Hilfe bei VPN Einrichtung



  • Hallo,

    ich möchte meine pfSense u.a. als einen VPN Client nutzen. Nun komme ich bei meinem Vorhaben gerade leider nicht weiter und hoffe auf eure Hilfe…

    Unter Rules => LAN habe ich eine Regel angelegt, wo bestimmt wird, welche Geräte über das eingerichtete OpenVPN Gateway geleitet werden sollen (alle anderen verbinden sich über das Standard WAN-Gateway mit dem Internet). Unter Source habe ich einen Alias angelegt und nun kann ich unter Aliases IP Adressen hinzufügen, welche über den VPN Tunnel surfen sollen. Soweit so gut.

    Nun würde ich gerne für einige Geräte die folgende Regel festlegen: das Gerät soll nur über das OpenVPN Interface ins Internet gehen können. Sprich, wenn die OpenVPN Verbindung meinerseits deaktiviert wird oder es eine serverseitige Störung gibt und generell keine OpenVPN Verbindung aufgebaut werden kann, dann soll das Gerät auch nicht über das WAN-Gateway (oder überhaupt ein anderes) ins Internet können - quasi entweder über VPN Tunnel oder gar nicht.

    Wie richte ich das nun am besten ein?


  • LAYER 8 Moderator

    Das sollte recht einfach zu machen sein. Unter die Allow Regel, die den Verkehr vom LAN via OpenVPN Gateway erlaubt, setzt du einfach eine Kopie der Regel mit Gateway auf default aber als BLOCK (oder REJECT) Regel, statt als Pass. Das verhindert dann, dass die im Alias definierten Geräte einen anderen Weg nehmen als das OpenVPN Gateway und statt dessen dann einfach geblockt werden. Das sollte IMHO den gewünschten Effekt bringen.



  • Ich muss zugeben, genau diese Idee habe ich gehabt, als ich dabei war diesen Thread zu erstellen. Leider funktioniert das bei mir so nicht. Auch habe ich versucht, statt "default" explizit das WAN Gateway zu definieren. Sobald ich die VPN Verbindung trenne, so kann ich sofort danach ganz normal über das WAN ins Internet, was ja eigentlich verhindert werden sollte…

    Kann ich evtl. etwas falsch gemacht haben, als ich den VPN Tunnel samt Firewall und NAT eingerichtet habe?


  • LAYER 8 Moderator

    Kann man so pauschal schlecht sagen. Du könntest aber explizit bei den Regeln das Logging Flag setzen und in den Filter Logs schauen, laut welcher Regel der Zugriff erlaubt wird (oder eben nicht). Dann wäre ggf. auch ein Block leichter möglich.



  • Ähm, mit dem Logging bin ich irgendwie nicht so wirklich klargekommen, aber ich habe durch probieren trotzdem etwas herausgefunden.

    Durch verändern der Regeln Reihenfolge konnte ich feststellen, dass die Block-Regel zuverlässig funktioniert. Denn schiebt man diese vor die Gateway-Regel, so habe ich keinen Internetzugang.
    Wenn diese sich diese aber hinter der Gateway-Regel befindet, dann kann ich VPN ein- und ausschalten wie ich will, so habe ich immer eine Internetverbindung (eben über den VPN Tunnel oder normal).

    Muss ja heißen, dass etwas damit nicht stimmt oder nicht "korrekt genug" eingestellt ist?



  • Mach doch mal Screenshots! Vielleicht sieht man da den "Denkfehler".

    Gruß
    Matthias


  • LAYER 8 Moderator

    Es gibt auch in den Advances Options noch die Einstellung Kill States on Gateway Failure etc. - das sind alles Dinge, die wir momentan nicht wissen, wie du sie eingestellt hast :)

    Edit: System / Advanced / Misc / Skip rules when gateway is down



  • Da solch ein Vorgehen hier schon oft besprochen wurde, verlinke ich mal https://www.infotechwerx.com/blog/Policy-Routing-Certain-Traffic-Through-OpenVPN-Client-Connection

    Das ist eine komplette Anleitung mit dem Zusatz, dass keine Verbindung über das WAN heraus geht. Geschrieben ist es von Derelict.



  • Danke euch beiden!

    @JeGr:

    Es gibt auch in den Advances Options noch die Einstellung Kill States on Gateway Failure etc. - das sind alles Dinge, die wir momentan nicht wissen, wie du sie eingestellt hast :)

    Edit: System / Advanced / Misc / Skip rules when gateway is down

    Das war tatsächlich so einfach ::) Darüber war ich auch schon mal gestolpert, habe aber den Sinn dieser Funktion nicht richtig verstanden.
    @Marvho:

    Da solch ein Vorgehen hier schon oft besprochen wurde, verlinke ich mal https://www.infotechwerx.com/blog/Policy-Routing-Certain-Traffic-Through-OpenVPN-Client-Connection

    Das ist eine komplette Anleitung mit dem Zusatz, dass keine Verbindung über das WAN heraus geht. Geschrieben ist es von Derelict.

    Danke für die schöne Anleitung!



  • Hallo,

    ich habe noch eine Frage bzgl. dieser Konfiguration. Ich kann die WebGUI des Modems nicht erreichen, sobald das VPN als Gateway genutzt wird. Wenn alles über WAN läuft, kann ich problemlos über 192.168.100.1 darauf zugreifen. Wenn ich aber über den VPN Tunnel online gehe, funktioniert das auf einmal nicht mehr. Muss ich da noch eine Regel beim entsprechenden VPN-Interface erstellen? Kann jemand weiterhelfen?



  • Eine Regel über der "VPN-Gateway" Regel erstellen, mit der Destination IP vom Modem und dem default Gateway sollte reichen.



  • Ach ok, das war ja wieder einfach. Danke!
    Ich habe versucht die gleiche Regel beim VPN-Interface zu erstellen…

    Kann mir evtl. noch jemand erklären, warum bei mir das "default Gateway" nicht funktioniert? Also auch bspw. bei der obigen Regel, wenn ich dort das Gateway auf "default" lasse, dann funktioniert die Regel nicht. Wenn ich dort aber explizit das WAN_Gateway auswähle (welches ja als default eingerichtet ist), dann geht es. ???



  • Schau mal oben unter dem Reiter "System" und dann "Routing" welches Gateway dort als default markiert ist. Falls das VPN-Gateway dies ist, einfach das WAN Gateway bearbeiten und bei```
    Default Gateway
    This will select the above gateway as the default gateway.



  • Ja, das kenne ich und wie gesagt - WAN ist als default Gateway definiert! Das ist ja auch irgendwie das Problem.

    Als default wird WAN angezeigt, aber wenn ich z.B. bei wieistmeineIP nachschaue, dann taucht dort die IP des VPN Tunnels auf.
    Nur hilft es auch nicht den default-Hacken bei einem anderen Gateway zu setzen und dann wieder auf WAN zurück… Auch wenn ich jetzt das VPN Gateway deaktiviere, dann habe ich trotzdem die VPN IP nach außen (mit default Gateway). Wo könnte der Fehler liegen? :o



  • Mal alle states zurückgesetzt? Wenn du den VPN-Client deaktivierst (anstatt das GW zu deaktivieren) ist es dann immer noch so?



  • States zurückgesetzt: alles beim alten. Wenn ich den VPN-Client deaktiviere, dann habe ich die WAN IP nach außen.



  • Magst du mal deine Regeln und Outbound NAT per Screenshot zeigen?



  • So sieht's aus:
    (Heimnetz [DHCP an] ist ein Bridge aus LAN+WLAN [DHCP bei beiden aus])



  • Die 192.77.1.100 ist dein PC womit du bei dem IP-test die VPN IP bekommst?

    Mit bridges kenne ich mich leider nicht aus und kann daher nicht viel zu den bridges sagen.

    Was genau ist der Alias für VPN DE1 GW und VPN DE2 GW?

    Hast du Regeln bei der Floating Sektion?



  • @Marvho:

    Die 192.77.1.100 ist dein PC womit du bei dem IP-test die VPN IP bekommst?

    Ganz genau.

    @Marvho:

    Was genau ist der Alias für VPN DE1 GW und VPN DE2 GW?

    Unter dem jeweiligen Alias sind bestimmte Geräte festgelegt, welche über den einen oder anderen VPN Tunnel sollen. So kann ich auch immer wieder weitere Geräte unter Aliases hinzufügen oder entfernen, ohne dabei etwas an den Regeln zu verändern.

    @Marvho:

    Hast du Regeln bei der Floating Sektion?

    Nein, dort sind keine Regeln eingerichtet.



  • Hast du beim VPN Client den Haken "Don't pull Routes" drin? Das könnte es eventuell sein.



  • Sorry für die längere Abwesenheit, hatte aber keine Zeit zum Testen.

    Tatsache, mit deiner Vermutung hattest du Recht, vielen Dank!

    Ich hätte da mal noch eine Frage zu VPN, diesmal aber zum IPSec Protokoll. Wenn ich es richtig verstehe, bietet pfSense an dieser Stelle keine wirkliche Trennung zwischen Client und Server wie bei OpenVPN? Folglich kann man die pfSense als Client auch nicht so einfach mit einem Server verbinden (wie man es bspw. vom Smartphone kennt), aber es soll ja nicht unmöglich sein. Was genau braucht man also dafür? Habe irgendwie keine brauchbaren Anleitungen gefunden…



  • Da ich mich mit dem Thema IPSec in Bezug auf PfSense noch nicht befasst habe, kann ich leider nicht helfen.
    Falls sich hier niemand melden sollte, würde ich im Englischen IPSec Bereich mal nachfragen.



  • Ok, danke für den Tipp, werde ich dann machen, wenn meine wichtigsten To-Do's abgearbeitet sind.

    Jetzt habe ich aber noch eine wichtige Frage zu den eingerichteten OpenVPN Tunneln: wie schützt man sich vor DNS Leaks bzw. macht der pfSense deutlich welche DNS Server von welchen Interfaces verwendet werden sollen? Ich dachte, man stellt es unter System => General Setup ein (dort eben den DNS Server und das entsprechende Gateway)? Aber das scheint nicht zu funktionieren, denn ein DNS Leaktest zeigt meine reale IP Adresse. Kann sein, dass noch irgendwo in den Einstellungen ein Haken gesetzt werden muss oder es evtl. in Kollision mit den zuvor getätigten Einstellungen geraten ist?

    *edit: ok, hat sich erledigt.



  • Ich mache das mit unbound, einfach als outgoing Interface das VPN nutzen. Hat natürlich den Nachteil, dass wenn der tunnel down ist, kann kein PC mehr DNS auflösen. Das kann man aber mit dem Service Watchdog am besten verhindern.



  • Ich habe die DNS Server im DHCP Server Bereich festgelegt und es scheint alles problemlos zu funktionieren.

    Ich bin gerade wieder einmal auf ein Problem gestoßen. Auf einem Mac brauche ich ab und zu für eine Anwendung eine IP aus dem Ausland. Daher dachte ich mir, ich richte mir mal einen OpenVPN Tunnel direkt auf dem Mac ein. Die Verbindung wird zwar aufgebaut, jedoch habe ich keinen Internetzugriff, muss ich dafür noch etwas in der Firewall freigeben?

    Ich habe 3 unterschiedliche Fälle, die mich noch mehr verwirren…
    1. Bei einem Tunnel wird der normale OpenVPN Port 1194 verwendet. Wenn ich diesen in der pfSense auf die private IP meines Mac's weiterleite, dann kann ich eine Internetverbindung aufbauen; sonst geht's nicht.
    2. Bei einem anderen Tunnel wird ein anderer Port verwendet. Wenn ich diesen freigebe, dann habe ich trotzdem keine Internetverbindung.
    3. Zum Ausprobieren habe ich auf dem iPhone die App OpenVPN installiert und dort genau die .ovpn Config aus Fall 2 eingerichtet => es funktioniert auf Anhieb, ohne irgendwelche Portfreigaben in der pfSense. Warum geht es also beim Mac nicht so einfach?



  • Zu dem Mac:

    Du brauchst bei OVPN keine Rules oder sonstiges einstellen. Habe selber keinen Mac, kann also nicht viel dazu sagen. Würde einfach mal die Standard Sachen nachgucken, funktioniert ein anderer (Kostenloser / Test) VPN? Bzw. funktioniert Ping, oder ist etwas an der Config eventuell falsch.

    Zu 1. Wie genau leitest du den zum Mac weiter?
    Zu 2. Also sind zwei Tunnel gleichzeitig (auf der PfSense?) am laufen. Wie gibst du diesen "frei"? Wechselst du das Gateway? Outbound-NAT Regel vorhanden?
    Zu 3. Siehe Punkt 2 -> Outbound-NAT für diesen internen IP-Bereich eingerichtet?



  • Ähm, irgendwie verstehe ich deine Fragen nicht bzw. mir kommt es so vor als ob du mich etwas missverstanden hast. Habe mich wohl nicht gut genug ausgedrückt, war schon spät…

    Ich versuche es nochmal, aber etwas detaillierter. Mir geht es nur darum auf dem Mac ab und zu eine IP aus einem anderen Land zu haben. So Sachen wie Verschlüsselung oder allgemeine Sicherheit sind mir an der Stelle egal, da der Mac standardmäßig über den auf der pfSense eingerichteten VPN Tunnel läuft. An der Stelle habe ich also zwei kostenlose VPN Anbieter ausprobiert, welche die o.g. Aufgabe erfüllen sollten.

    Ab hier läuft die Einrichtung nur auf dem Mac ab, hier hat pfSense nichts damit zu tun.
    1. Beim ersten Anbieter läuft es über den Port 1194. Wenn ich diesen Port in der pfSense freigebe, dann hat mein Mac eine Internetverbindung über den aufgebauten Tunnel. Erfolgt keine Portfreigabe meinerseits, so kommt zwar der Aufbau des Tunnels zustande, Internet ist aber tot - ich kann keine Seite aufrufen.
    2. Beim zweiten Anbieter läuft es über einen anderen Port und dann funktioniert die Portfreigabe auf der pfSense aus Punkt 1 (nur eben mit dem entsprechend geändertem Port) nicht mehr.
    3. Etwas irritiert war ich als ich den Tunnel aus Punkt 2 (also demselben .ovpn config File) problemlos auf dem iPhone aufbauen und erfolgreich nutzen konnte, ohne dabei irgendwelche Freigaben auf der pfSense einzurichten.

    Aus diesem Grund habe ich gefragt was nun richtig ist - muss ich auf der pfSense überhaupt etwas einrichten, damit die Geräte (in dem Fall mein Mac) im Heimnetz einen eigenständigen VPN Tunnel nach außen aufbauen können? Besser gesagt, ob die Firewall es standardmäßig blockt oder nicht? Weil ich halt kein eindeutiges Fehlerbild habe - auf dem Mac funktioniert es - wenn überhaupt - nur mit einer Freigabe, auf dem iPhone läuft alles auf Anhieb. Oder ist das nun definitiv ein Problem meines Mac's?



  • Wie genau sieht deine Freigabe (Firewall-Rule) aus? Standardmäßig musst du für OpenVPN nichts an der PfSense ändern. Hast du eventuell einen Windows Client, wo du das ganze testen kannst? Am besten auch am gleichen Interface der PfSense (wahrscheinlich WLAN?) testen.



  • Ähm, ich wollte pfSense jetzt mal komplett ausschließen und habe meinen Mac über den Hotspot des iPhones mit dem Internet verbunden. Die VPN Verbindung klappte sofort und ich konnte problemlos über den aufgebauten Tunnel surfen. Dann muss es doch irgendwo in der pfSense einen Hacken geben?

    Ob's mit Windows klappt, weiß ich noch nicht, aber evtl. kann ich es am Wochenende ja mal ausprobieren.

    So sieht die Rule aus (befindet sich entsprechend beim VPN Interface, welches als Gateway des Mac's definiert ist):




  • Falls ich dich nun richtig verstanden habe, hast du diese Regel auf dem VPN Interface angelegt?
    Eigentlich musst du keine Regeln auf dem VPN Interface anlegen, außer du möchtest vom VPN Tunnel aus auf dein LAN zugreifen. Ich habe auch keine angelegt.
    Da das VPN Interface ein internes Interface der PfSense ist (OVPNC1 wahrscheinlich), musst du deine Regel eher auf dem entsprechendem Interface wo dein Mac dran hängt (LAN/WLAN, wo du auch das VPN als Gateway bestimmt hast) anlegen.



  • Hmm, das ist schon lange her als ich die Regel erstellt habe (bzw. eine Portweiterleitung angelegt, die automatisch diese Regel erzeugt hat). Ich weiß nicht mehr aus welchem Grund ich darauf gekommen bin… wahrscheinlich bin ich davon ausgegangen, dass mein Mac ja die öffentliche IP des VPN Servers hat, nicht mehr die WAN IP und deswegen die Portweiterleitung auch entsprechend auf das VPN-Interface erfolgen soll, statt auf WAN.

    Jedenfalls habe ich am WE einige allgemeine Änderungen vorgenommen und nun funktioniert alles ohne irgendwelche Portweiterleitungen, so wie es soll. Keine Ahnung was die Ursache für das Scheitern war, aber zum Glück habe ich das erreicht, was ich wollte. Danke für die Beteiligung!



  • Würde mal gerne meinen alten Thread rauskramen und noch eine Frage zur VPN Geschichte stellen.

    Ich habe einen OpenVPN Server auf der pfSense laufen, womit sich die mobilen Geräte verbinden und es läuft auch nahezu alles, so wie ich es mir vorstelle.
    Nur verhalten sich die verbundenen Geräte trotzdem nicht so, als wären sie im Heimnetz. Also bspw. wird der AirPrint Drucker nicht gefunden oder ich kann nicht per FritzFon App auf die FritzBox Telefone zugreifen (ich muss dafür in der FritzBox den Zugriff aus dem Internet erlauben, damit es letztendlich funktioniert).
    Also es sieht so aus, als würden alle Geräte denken, es wird nicht aus dem Heimnetz auf sie zugegriffen, sondern aus dem Internet (vermutlich wegen dem anderen Subnetz?).

    Hat jemand eine Idee, wie ich das lösen kann?


  • LAYER 8 Moderator

    Nur verhalten sich die verbundenen Geräte trotzdem nicht so, als wären sie im Heimnetz.

    Was auch kein Wunder ist, denn sie sind es auch nicht.

    Also bspw. wird der AirPrint Drucker nicht gefunden oder ich kann nicht per FritzFon App auf die FritzBox Telefone zugreifen (ich muss dafür in der FritzBox den Zugriff aus dem Internet erlauben, damit es letztendlich funktioniert).

    Bei der FritzFon App bin ich nicht wirklich sicher, aber die AirPrint Geschichte bzw. der meiste AutoMagisch-Käse von Apple und Co. ist Bonjour/Avahi/Zeroconf. Und das basiert auf Broadcast etc. und wird IMHO nicht über OpenVPN geroutet. Deshalb haben die meisten solcher Geräte auch die Möglichkeit via IP o.ä. zu kommunizieren, weil man nicht weiß ob man direkt im gleichen Netz steht wie das Gerät. Wenn das Gerät mit der internen IP konfiguriert wird, sollte auch auch via VPN sauber funktionieren.

    Gruß



  • @JeGr:

    Nur verhalten sich die verbundenen Geräte trotzdem nicht so, als wären sie im Heimnetz.

    Was auch kein Wunder ist, denn sie sind es auch nicht.

    Ja, das stimmt schon. Aber der Sinn des VPN Tunnels ist ja u.a. den Heimnetzgeräten vorzutäuschen als wäre das per VPN angebundene Gerät eben bei mir zu Hause. Ist es nicht nur eine Sache der konkreten Einstellungen?

    @JeGr:

    Also bspw. wird der AirPrint Drucker nicht gefunden oder ich kann nicht per FritzFon App auf die FritzBox Telefone zugreifen (ich muss dafür in der FritzBox den Zugriff aus dem Internet erlauben, damit es letztendlich funktioniert).

    Bei der FritzFon App bin ich nicht wirklich sicher, aber die AirPrint Geschichte bzw. der meiste AutoMagisch-Käse von Apple und Co. ist Bonjour/Avahi/Zeroconf. Und das basiert auf Broadcast etc. und wird IMHO nicht über OpenVPN geroutet. Deshalb haben die meisten solcher Geräte auch die Möglichkeit via IP o.ä. zu kommunizieren, weil man nicht weiß ob man direkt im gleichen Netz steht wie das Gerät. Wenn das Gerät mit der internen IP konfiguriert wird, sollte auch auch via VPN sauber funktionieren.

    Gruß

    Zu Apple:
    Stimmt, ich erinnere mich jetzt auch irgendwo gelesen zu haben, dass deren hauseigene Dienste nicht über den VPN Tunnel laufen - wenn also AirPrint dazugehört (wird ja wohl nicht anders sein), dann kann man das wohl komplett vergessen… schade eigentlich.

    Ok, habe den Drucker auf dem MacBook als IP Gerät eingerichtet und konnte einen Druckvorgang per VPN starten - das geht schon mal gut. Für iOS bräuchte ich ja wohl eine App, die das umsetzen kann (Druckvorgang an einen IP Drucker weiterleiten)? Nicht zufällig jemand einen Tipp für mich?
    Ich habe Printer Pro seit längerer Zeit drauf, aber leider klappt das Drucken per VPN und IP Drucker nicht (obwohl die Testseite erfolgreich ausgedruckt werden konnte), müsste ich wohl noch ein bisschen experimentieren oder eben eine andere App suchen.

    Zur FritzBox:
    Kenne es von früher, wo die FritzBox selbst noch als Router lief und eben einen VPN Server bereitgestellt hat. Dort klappte es ja auch irgendwie, dass man von außerhalb per FritzFon App zugreifen konnte, ohne dass der Zugriff aus dem Internet erlaubt werden musste. Also müsste man das gleiche auch bei pfSense irgendwie einrichten können?
    Auch sieht man es anhand des Anmeldevorgangs im WebUI deutlich, dass die FritzBox per VPN angebundene Geräte als "Zugriff aus dem Internet" wertet. Im Heimnetz kann man den Benutzer aus der Liste auswählen, ansonsten muss der Nutzername manuell eingetippt werden.


  • LAYER 8 Moderator

    Ja, das stimmt schon. Aber der Sinn des VPN Tunnels ist ja u.a. den Heimnetzgeräten vorzutäuschen als wäre das per VPN angebundene Gerät eben bei mir zu Hause. Ist es nicht nur eine Sache der konkreten Einstellungen?

    Nein der Sinn eines VPNs ist ein Tunnel um dein aktuelles Netz (oder die einzelne IP vom Mobilgerät) über einen sicheren abgeschirmten Tunnel mit deinem Heimnetz zu verbinden. Nicht dein Gerät so da reinzuhängen als wäre es da. Du kannst soetwas teilweise erreichen, indem man bspw. OpenVPN nicht via Tunnel Interface, sondern via Bridging Device verbindest. Mit Bridging wäre es durchaus denkbar, dass dann auch Multicast oder Broadcast Krams wie Avahi/Zeroconf/Bonjour funktioniert. Aber die funktionieren eben nur innerhalb des gleichen Subnets, nicht außerhalb der Boundaries.

    als "Zugriff aus dem Internet" wertet.

    Hängt das evtl. damit zusammen, dass er das Gerät aus dem Netz "hinter" der FB erwartet und deshalb das Transfernetz des VPNs als extern wertet? Kann man das ggf. hinzufügen? Andernfalls könnte evtl ein NATting für das VPN Gerät in Richtung Fritzbox helfen (nur eine Mutmaßung) ;)



  • Das mit der Bridge ist tatsächlich sehr interessant, ich schaue es mir mal auf jeden Fall an und melde mich dann, wie es (und ob es so) läuft.



  • Nur stehe ich gerade ein wenig auf dem Schlauch. Bisher war für den OpenVPN Server kein Interface angelegt, wie soll ich da verfahren?



  • @un1que:

    Nur stehe ich gerade ein wenig auf dem Schlauch. Bisher war für den OpenVPN Server kein Interface angelegt, wie soll ich da verfahren?

    Ein Interface dafür einrichten. Interfaces > (assgin), unter "available network ports" den OpenVPN Server auswählen, daneben auf add klicken, auf das neue Interface klicken, Enable wählen, einen brauchbaren Namen vergeben und speichern.

    Aber, soweit ich weiß, findet Airprint die Geräte via Multicast. Könnte mir gut vorstellen, dass auch FritzFon dieses verwendet, weiß ich aber nicht.
    Um die Multicasts des (W)LANs ins VPN zu bringen, bietet pfSense allerdings schon ein Lösung: Services > IGMP Proxy.
    Wie man das konfiguriert, kann ich dir aber auch nicht sagen, hatte das vor Jahren nur probehalber mal gemacht. Ich glaube, das Interface von dem die Multicasts kommen, also (W)LAN, als Upstream setzen, das in welches sie gesendet werden als Downstream, ohne Garantie.  ;)
    Das VPN Interface ist dazu jedenfalls auch nötig.



  • Ja, wie man ein Interface anlegt und so - das wusste ich schon. Ich war nur irritiert, ob ich nicht evtl. noch sonstige Einstellungen unter Rules oder sonst wo tätigen muss. Aber das ist mittlerweile erledigt. Nun zum Thema mit Multicast…

    Danke für den Tipp mit IGMP Proxy. Das hat mich jetzt leider nicht weitergebracht (habe alle möglichen Varianten ausprobiert). Danach bin ich auf die Erweiterung Avahi für die pfSense gestoßen, welche ja wohl genau das tun soll - alle Multicasts auf allen bzw. ausgewählten Interfaces verfügbar machen.
    Also habe ich das Package installiert und ausprobiert, aber auch dieses bringt mich keinen Schritt weiter. Leider nach wie vor nichts über das OpenVPN Interface verfügbar.
    Generell scheint das Package aber seinen Dienst vorbildlich zu verrichten. Habe heute einen VLAN eingerichtet und von dort konnte ich problemlos solche Dienste wie Airprint oder Airplay erreichen, bis ich das entsprechende VLAN-Interface unter Avahi ausgeschlossen habe (warum läuft es eigentlich nach dem Ausschlussprinzip? :-).

    Idee, was ich noch versuchen könnte?


Log in to reply