WLAN Card compatible, but not showing up in pfsense?



  • Hey guys,

    I had a wlan card laying around that so happens to be compatible with pfsense "or google has lied" I wanted to pop it in my machine and make an AP. Popped it in last night, and I got absolutely nothing under interfaces. I KNOW the card works, because I just pulled it out of one of my machines that I was using it on. Its a belkin fsd7000.

    Please advise on what to do to get this wlan card working.

    Thank you so much guys!!!



  • Can you post the dmesg of this system?



  • I presume you mean Belkin f5d700 (digit "5" not letter "s").

    A number of manufacturers/suppliers of network cards use the same model name for cards with different chipsets. Each chipset needs its own driver. The table at http://linux-wless.passys.nl/query_part.php?brandname=Belkin
    lists five different chipsets used in the f5d7000. Off the top of my head I expect there to be drivers for the Atheros and two Ralink chipsets, maybe not the Realtek and probably not the Broadcom.

    As GruensFroeschli suggested, the dmesg output will help us determine what chipset is used in your card.

    You might like to try one of the recent 1.2.1 RC kits. They have a wider range of drivers and more up to date drivers than the 1.2 kits.



  • I am currently running 1.2.1. Please explain to me where I can find the dmesg at? I am very new to BSD and firewalls. But I know for sure its a fsd7000 as stated on the wlan card. Thanks for your help.



  • I pulled out the wlan card. Heres what I got

    Belkin Wireles Network Card FSD7000 VERSION 1233. Does this help any?



  • Sorry…. it is f5d7000.



  • http://yourpfSense.net/status.php
    –> the dmesg part



  • Belkin Wireles Network Card FSD7000 VERSION 1233. Does this help any?

    The quoted version number doesn't help me but it might help another reader. The dmseg data would be more helpful to me.

    Another way of getting the dmesg output is from the Diagnostics menu of the web GUI select Command and then type dmesg in the box tagged Command then click on the Execute button.



  • Here is my dmesg guys:

    $ dmesg
    Copyright © 1992-2008 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 7.0-RELEASE-p3 #0: Tue Aug 12 21:03:50 EDT 2008
        sullrich@freebsd7-releng_1_2.geekgod.com:/usr/obj.pfSense/usr/src/sys/pfSense_SMP.7
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: Intel Pentium III (863.87-MHz 686-class CPU)
      Origin = "GenuineIntel"  Id = 0x686  Stepping = 6
      Features=0x383f9ff <fpu,vme,de,pse,tsc,msr,pae,mce,cx8,sep,mtrr,pge,mca,cmov,pat,pse36,mmx,fxsr,sse>real memory  = 267124736 (254 MB)
    avail memory = 247357440 (235 MB)
    pnpbios: Bad PnP BIOS data checksum
    wlan: mac acl policy registered
    kbd1 at kbdmux0
    ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
    hptrr: HPT RocketRAID controller driver v1.1 (Aug 12 2008 21:03:31)
    cryptosoft0: <software crypto="">on motherboard
    acpi0: <dell mummy="">on motherboard
    acpi0: [ITHREAD]
    acpi0: Power Button (fixed)
    acpi0: reservation of 0, a0000 (3) failed
    acpi0: reservation of 100000, fe00000 (3) failed
    Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
    cpu0: <acpi cpu="">on acpi0
    pcib0: <acpi host-pci="" bridge="">port 0xcf8-0xcff on acpi0
    pci0: <acpi pci="" bus="">on pcib0
    vgapci0: <vga-compatible display="">mem 0xf8000000-0xfbffffff,0xffa80000-0xffafffff irq 11 at device 1.0 on pci0
    agp0: <intel 82810e="" (i810e="" gmch)="" svga="" controller="">on vgapci0
    pcib1: <acpi pci-pci="" bridge="">at device 30.0 on pci0
    pci1: <acpi pci="" bus="">on pcib1
    vr0: <via 10="" vt6105="" rhine="" iii="" 100basetx="">port 0xd000-0xd0ff mem 0xff8fd400-0xff8fd4ff irq 11 at device 8.0 on pci1
    vr0: Quirks: 0x0
    vr0: Revision: 0x86
    miibus0: <mii bus="">on vr0
    ukphy0: <generic ieee="" 802.3u="" media="" interface="">PHY 1 on miibus0
    ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    vr0: Ethernet address: 00:15:e9:ef:32:40
    vr0: [ITHREAD]
    dc0: <admtek 10="" an985="" 100basetx="">port 0xd400-0xd4ff mem 0xff8fd800-0xff8fdbff irq 6 at device 9.0 on pci1
    miibus1: <mii bus="">on dc0
    ukphy1: <generic ieee="" 802.3u="" media="" interface="">PHY 1 on miibus1
    ukphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    dc0: Ethernet address: 00:1a:70:13:01:29
    dc0: [ITHREAD]
    dc1: <admtek 10="" an985="" 100basetx="">port 0xd800-0xd8ff mem 0xff8fdc00-0xff8fdfff irq 9 at device 10.0 on pci1
    miibus2: <mii bus="">on dc1
    ukphy2: <generic ieee="" 802.3u="" media="" interface="">PHY 1 on miibus2
    ukphy2:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    dc1: Ethernet address: 00:14:bf:5f:4e:68
    dc1: [ITHREAD]
    pci1: <network>at device 11.0 (no driver attached)
    isab0: <pci-isa bridge="">at device 31.0 on pci0
    isa0: <isa bus="">on isab0
    atapci0: <intel ich="" udma66="" controller="">port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xffa0-0xffaf at device 31.1 on pci0
    ata0: <ata 0="" channel="">on atapci0
    ata0: [ITHREAD]
    ata1: <ata 1="" channel="">on atapci0
    ata1: [ITHREAD]
    uhci0: <intel 82801aa="" (ich)="" usb="" controller="">port 0xef80-0xef9f irq 10 at device 31.2 on pci0
    uhci0: [GIANT-LOCKED]
    uhci0: [ITHREAD]
    usb0: <intel 82801aa="" (ich)="" usb="" controller="">on uhci0
    usb0: USB revision 1.0
    uhub0: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb0
    uhub0: 2 ports with 2 removable, self powered
    pci0: <serial bus,="" smbus="">at device 31.3 (no driver attached)
    speaker0: <pc speaker="">port 0x61 on acpi0
    atkbdc0: <keyboard controller="" (i8042)="">port 0x60,0x64 irq 1 on acpi0
    atkbd0: <at keyboard="">irq 1 on atkbdc0
    kbd0 at atkbd0
    atkbd0: [GIANT-LOCKED]
    atkbd0: [ITHREAD]
    sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
    sio0: type 16550A
    sio0: [FILTER]
    pmtimer0 on isa0
    orm0: <isa option="" rom="">at iomem 0xc0000-0xc7fff pnpid ORM0000 on isa0
    ppc0: <parallel port="">at port 0x378-0x37f irq 7 on isa0
    ppc0: Generic chipset (EPP/NIBBLE) in COMPATIBLE mode
    ppbus0: <parallel port="" bus="">on ppc0
    ppbus0: [ITHREAD]
    plip0: <plip network="" interface="">on ppbus0
    lpt0: <printer>on ppbus0
    lpt0: Interrupt-driven port
    ppi0: <parallel i="" o="">on ppbus0
    ppc0: [GIANT-LOCKED]
    ppc0: [ITHREAD]
    sc0: <system console="">at flags 0x100 on isa0
    sc0: VGA <16 virtual consoles, flags=0x300>
    sio1: configured irq 3 not in bitmap of probed irqs 0
    sio1: port may not be enabled
    vga0: <generic isa="" vga="">at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
    Timecounter "TSC" frequency 863868489 Hz quality 800
    Timecounters tick every 1.000 msec
    Fast IPsec: Initialized Security Association Processing.
    hptrr: no controller detected.
    ad0: 19092MB <wdc wd200eb-11bhf0="" 15.15m15="">at ata0-master UDMA66
    WARNING: Expected rawoffset 0, found 63
    Trying to mount root from ufs:/dev/ad0s1a
    vr0: link state changed to UP
    dc0: link state changed to UP
    dc1: link state changed to UP
    pflog0: promiscuous mode enabled
    ipfw2 (+ipv6) initialized, divert loadable, rule-based forwarding enabled, default to accept, logging disabled

    Hmmm.. pci1: <network>at device 11.0 (no driver attached) Heres my prob. How do I load drivers for my device?</network></wdc></generic></system></parallel></printer></plip></parallel></parallel></isa></at></keyboard></pc></serial></intel></intel></intel></ata></ata></intel></isa></pci-isa></network></generic></mii></admtek></generic></mii></admtek></generic></mii></via></acpi></acpi></intel></vga-compatible></acpi></acpi></acpi></dell></software></fpu,vme,de,pse,tsc,msr,pae,mce,cx8,sep,mtrr,pge,mca,cmov,pat,pse36,mmx,fxsr,sse>



  • Hmmm.. pci1: <network>at device 11.0 (no driver attached) Heres my prob. How do I load drivers for my device?</network>

    My understanding is that the kernel is built with the drivers for all supported devices built in. Hence there is nothing to do to load drivers for your device, it is not supported.

    The dmesg output shows that the operating system detects the presence of the card - a prerequisite for getting it operational.

    If you want me to investigate a bit further you could post the output of the command "pciconf -r pci1:11:0 0:63" (my previous post on dmesg describes how to use the GUI to execute a command on the pfsense box) and I'll see if it tells me what chipset is on the card. Its just possible that the chipset is supported but none of the drivers recognise the way the chipset appears on your card. If thats the case, a small tweak to an existing driver might be enough to get you going, though this is fairly unlikely.

    If you want to have a working wireless interface the quickest route will be to get a card with known supported chipset. I can make a few suggestions. I expect you will be able to get a new card for well under US $40 (before shipping and taxes). There are probably a few more options if you are prepared to consider a USB NIC.



  • Also you could try to install the new 1.2.1 which is built upon FreeBSD 7.
    –> FreeBSD 7 supports more hardware than 6.2



  • Thank you so much for the reply. As soon as I get home I will try this command and post the output…... Is there any KNOWN name brand card I can pick up at CompUSA, Wal-Mart, or even radio shack that will be compatible with my machine?

    Thanks.

    I get home about 9:30EST, and I will post a reply asap!



  • @GruensFroeschli:

    Also you could try to install the new 1.2.1 which is built upon FreeBSD 7.
    –> FreeBSD 7 supports more hardware than 6.2

    I am currently running 1.2.1. I even did the new updated snapshot I believe was released 2 days ago.

    Thanks!!



  • I've been using a couple of TP-LINK TL-WN651G cards for the last nine months and they work well. They use the well regarded Atheros chipset. A quick scan of http://www.compusa.com shows them listed for $24.99.

    I can give you more options in about 12 hours.



  • Thank you sir! I will pick up this card in the next few hours. I wanted to go with wireless N, but hell you can't beat that price. So this card is working with BSD 7 pfsense 1.2.1 snapshot?



  • Well SCRATCH that… :( I just called CompUSA and they told me they do not have it in stock. I am wiring my whole house tomorrow, all bedrooms with ethernet, cat5, and coaxal, and I wanted to get my whole network up!!! arf.... anyone know of any supported cards that I can buy from CompUSA, Best Buy, Wal-Mart?

    Please advise.

    Thanks guys!



  • I'm pretty certain there are no compatible wireless n adapters for FreeBSD yet. I believe wireless N support is in FreeBSD 7 but last I heard there were no compatible drivers yet (Remember wireless N is pre N as N is not finalized yet).  If you wanted to do N you would need an external wireless N device connected to pfSense through ethernet.

    Most the time the supported cards are so specific you have to order them.



  • The cards here: http://pcengines.ch/order1.php?c=4 are all supported and work very well with pfSense.



  • The cards in the list at pcengines all look like mini-pci cards which would need an adapter to go into a regular PCI slot.

    mechanicalmetal: I presume you are after a card capable of acting as an access point (AP). The FreeBSD ath and ral drivers support that. The man page for ral (see http://www.freebsd.org/cgi/man.cgi?query=ral&apropos=0&sektion=0&manpath=FreeBSD+7.0-RELEASE&format=html
    lists a number of supported cards. I have no experience with the ral driver but have no reason to believe it wouldn't work well.

    The ath man page (http://www.freebsd.org/cgi/man.cgi?query=ath&apropos=0&sektion=0&manpath=FreeBSD+7.0-RELEASE&format=html) doesn't list supported cards but does list supported chipsets. If you explore vendor links on http://madwifi.org/wiki/Compatibility you will be able to find a number of PCI cards with a supported chipset. (madwifi is the Linux driver for Atheros PCI chipsets - their web site is a good source of information on chipsets and cards.)

    If you can wait a few days you could order the TP-LINK card (or its "little brother", the TP-LINK TL-WN550G) I mentioned earlier. If you are in a hurry you could call your preferred local computer shops, ask them what "wireless G" (or 802.11G) PCI cards they have in stock, get a list and see what cards match up against the list of cards supported by ral or ath.

    Warning: To minimise hassle avoid cards by Belkin, Dlink, Linksys or Netgear. All these suppliers (and quite possibly others as well) use the same model name for cards with a number of different chipsets. For most humans there is no way of telling what chipset is in one of those cards without plugging it into a computer, powering it on and seeing how the card identifies itself. This doesn't matter for Windows computers - they provide a CD with drivers for all the possible chipsets. However they rarely provide drivers for Open Source operating systems so you take your chances with getting such cards working on Open Source systems.

    Also, I don't know of any "wireless n" (802.11N) cards supported by FreeBSD.



  • Guys sorry I havent been back to reply to this thread. I did get wireless working! Prior to all of your wonderful posts, special thanks to mr. mcrane for personally walking me through card selections.

    It is confirmed that Linksys WMP54G Wireless G version 4.1 works and detects flawlessly with bsd7 pfsense v1.2.1.
    This card was purchased from CompUSA, and im pretty sure that your local walmart or bestbuy should carry it as well.

    Again, many thanks to all of your replies, and if anyone needs to PM me reguards to the WLAN card, please do so or feel free to msg me on AIM:mechanicalmetal or Yahoo:therealdank

    Take care!!!!



  • @wallabybob:

    I've been using a couple of TP-LINK TL-WN651G cards for the last nine months and they work well. They use the well regarded Atheros chipset. A quick scan of http://www.compusa.com shows them listed for $24.99.

    I can give you more options in about 12 hours.

    Just got one of these, version 1.5 and detects as AR5005GS in windows.

    Pfsense cannot detected this, I tried with 1.2,1.2.1-RC2,2.0-ALPHA

    No luck, any suggestions? I tried with in different pci-slots, putting static irq etc. My motherboard is P2B

    The only thing I get in dmesg related to this are:

    ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
    pci0: <bridge>at device 4.3 (no driver attached)

    EDIT: seems that my motherboard (P2B, v1.02, bios 1012) doesnt support pci 2.2v wich the card requires. So even tought the machine sees the card it cant use it. Problem solved, hopefully this ends up in google and some other poor soul doesnt waste an evening like I just did :)</bridge>



  • Pfsense cannot detected this, I tried with 1.2,1.2.1-RC2,2.0-ALPHA

    Interesting! I have a version 1.5 card in an older (but not as old as a P2B)  mini-ITX motherboard and it works fine on 1.2.1-RC2 and a number of older builds - in fact every build I tried from the 1.2 version based on FreeBSD 6.3. (I didn't try anything earlier.)

    On what evidence did you decide pfSense didn't detect the card? Here's how it shows up in my startup (I'm running 1.2.1-RC2):

    
    ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
     . . .
    ath0: <atheros 5212="">mem 0xee000000-0xee00ffff irq 12 at device 8.0 on pci0
    ath0: [ITHREAD]
    ath0: using obsoleted if_watchdog interface
    ath0: Ethernet address: 00:19:e0:68:31:4b
    ath0: mac 7.9 phy 4.5 radio 5.6</atheros> 
    

    I'm composing this message on a P2B based system. I'll try to check out my spare TL-WN651G on the P2B later today. I can't think of any reason whay the card wouldn't be detected by pfSense, at least to the point of being reported as a ath device during startup.



  • I tried the TL-WN651G in the spare slot of my P2B. The BIOS doesn't even report it. pfSense doesn't see it it any fashion - it was just as if nothing was plugged into that slot.

    I also have a Gigabyte GN-WPKG PCI card which has a Ralink 802.11G chipset. i plugged the Gigabyte card into the same slot I used for the TP-LINK card. The Gigabyte card was reported by the BIOS and the ral driver in pfSense 1.2.1-RC1. I didn't attempt to configure the Gigabyte card or use it. But there was something curious about this card as well. The system has a USB PCI card using a NEC USB 2.0 chipset. With this USB card in the system the startup would hang soon after reporting the NEC USB devices. When I removed the card with the NEC USB chipset the system started up and entered the usual configuration dialogue when booting from pfSense CD.

    I suspect you may need to choose carefully when it comes to getting a wireless PCI card for the P2B. I suspect the Gigabyte GN-WPKG card has been superseded. Based on this experience I would be cautious about assuming a card with a recent chipset will work on the P2B motherboard.


Log in to reply