Pfsense med fiber fra telenor og t-we fra canal digital (IPTV)


  • Jeg har prøvd å sette opp dette etter den samme opplegget, med Enable UPnP &NAT-PMP, med begge typene mapping . På WAN har jeg åpnet UDP-portene 5500, 1900, 5353 og 8000, med IGMP åpnet til alt og IGMP Proxy med LAN downstream 192.168.10.0/24 , og
    WAN upstream 224.0.0.0/4, 93.91.111.0/24. Men jeg prøver å søke på kanaler, og den stopper på 21 % uten å ha funnet noen og går ikke videre.

    Jeg har fire segmenter med et intel fireporters servernettverkskort, og jeg bruker ikke ruteren fra Telenor i det hele tatt. Jeg kjører direkte fra konverteringsboksen fra fiber til CAT6 og inn på nettverkskortet på hovedkortet på pfSense-boksen. Den er en Asus AT5IONT-I mini-ITX med Intel NM10 chipset.

    Er det noe jeg ikke har fått med meg? Må jeg adressere de åpnede portene i WAN til det 192.168.10.0-segmentet på en måte?


  • har du husket å gå under advanced på igmp reglen din og huket av for "ip options" (tar det etter hukommelse, muligen det heter noe annet)

    EDIT: Prøv å koble iptv tuneren rett i ont og se at du får opp kanaler da


  • Takk for svar! Ja, "Allow packets with IP options to pass." Den er satt.

    Edit: (Merkelig at jeg ikke så den editen din da jeg kom inn først, hvis vi ikke postet samtidig...) Det har jeg ikke, jeg leier ut deler av huset, så det betyr at jeg må bryte nettet for leietakerne, de har ett av de nevnte segmentene. Men jeg skal stikke ned i kjelleren og prøve det en dag de ikke er hjemme. Kanskje det er sånn at den trenger fri tilgang for kanalsøk og så klarer seg etterpå, mener du? En annen ting jeg kan prøve, er å sette opp et nytt segment fra grunnen av, med standardinnstillinger (det den sitter på nå, er litt modifisert), og så reservere det for tuneren.


  • Nei de skal ikke trenge det, er kun for å teste, skal ta bilde av mine instillinger når jeg kommer hjem senere i dag og legge de ut her

    Ja så jeg skrev min edit akkurat samtidig som du la ut

    Har du husket å lage "default allow all" rule på alle LAN?


  • @Exodus84 Tusen takk, så snilt! 👍


  • Litt forhåndsinfo, jeg har IPTV på et eget LAN interface kalt "IPTV" med adresse 192.168.3.0 osv

    Brannmur regler på WAN interfacet

    Husk å hukk av for IP Options under advanced her
    WAN IGMP.gif

    Portene er likt satt opp for hver gang
    WAN Port 1900.gif

    WAN Port 5353.gif

    WAN Port 5500.gif

    WAN Port 8000.gif

    LAN Rules (Interfacer heter "IPTV")
    IPTV (LAN) Default Allow All.gif

    IGMP Proxy
    IGMP Proxy.gif

    IGMP Proxy WAN Upstream.gif

    IGMP Proxy IPTV (LAN) Downstream.gif

    UPnP Service
    UPnP Settings.gif

    EDIT


  • Wow, mange tusen takk! :) Jeg skal prøve det neste gang jeg er innom huset (jeg bor stort sett på hytta nå), og så sier jeg fra om hvordan det gikk.


  • Da kom jeg meg endelig ned til huset og fikk sjekket. Jeg har satt opp et eget subnet med ip 192.168.3.1, og jeg tror jeg har fulgt alle skjermskuddene. Den får IP-adresse, men det gjorde jeg med det forrige forsøket også. Og nå får jeg "Plattformvalg feilet (E0171)" når jeg kjører kanalsøk. ☹


  • Jeg er en idiot! 😂 Jeg hadde et punktum for lite i IGMP proxy, så det sto 148.1227.125/32 istedenfor 148.122.7.125/32! Med det på plass funker det! Tusen takk for hjelpen!


  • Ikke noe problem :)


  • Hei, hadde problemer å bruke denne guiden men kom fram til en annen løsning for Telenor IPTV med PFSENSE, så for folk som ikkje får til, så kan dere prøve en guide eg laget som hvertfall fungerte for meg. https://technic-solder.eu-central-1.linodeobjects.com/PFSENSETelenorIPTV.pdf Hadde hvert greit om denne ble sjekket av noen men disse innstillingene fungerer bra for meg, merk at du trenger ikkje ha UPnP på. Dukumentet er en midlertidlig versjon, en med mer info kommer senere, som forklarer hva som gjør va. EDIT: ser i ittekant at den som er her skal fungere, eg hadde sikkert gjort noe feil men uansett min guide begrenser tilgangen mye meir og skal være sikrare.


  • Ett spørsmål litt på siden. Jeg har fiber fra Telenor inn i huset som terminerer i en boks med ethernet-grensesnitt (WAN) og coax, sannsynligvis det de kaller 'fiber med RF-Overlay'. T-We boksen kables med nevnte coax. Det jeg ønsker er å kvitte meg med hele coax-skiten. Er det noen som vet om IPTV går parallelt, slik at jeg kan benytte meg av nevnte løsninger eller må man ha "fiber med IPTV' hvor hele infrastrukturen i utgangspunktet er IP-basert slik at jeg kan benytte meg av PfSense m.m.


  • Vel, for oss som ikkje har Coax i konverteren så får vi IPTV sammen med resten og det er det eg vil tenke meg du og kan gjøre med den du har nå. Værstefall så er RJ45'en og coaxen skilt med vlans hos deg. Det eg ville ha gjort er å prøve T-WE gjennom RJ45 (uten pfsense) og sett ka som skjedde. Hviss ikkje kan
    du alltid ta en telefon til telenor.


  • Vist du har tv via koaks på fiber i dag, så kan det konverteres til IPTV ja, vi som montører kan gjøre dette via en nettside, men regner med at kundeservice kan gjøre det samme


  • @Exodus84 , da tok jeg i dag kontakt med 'kundeservice'. De påsto der at sentralen min ikke støttet IPTV og at de ikke kunne aktivere dette. Kan det stemme at dette er sentralavhengig?


  • This post is deleted!

  • det kan være utstyret du er koblet til på sentralen ikke støtter dette ja, men trodde de hadde byttet alt det gamle, men er nokk bare jeg som har hørt feil


  • Heisann - Vil bare sende en stor takk til dere i denne tråden. Oppe med pfSense og IPTV samme dag som fiber ble installert, takket være dere :-)


  • Slenger meg på dezibel, takk til denne tråden, etter bytte av switch så fungerte det endelig! Kan forøvrig legge til at jeg ikke fikk start forfra til å fungere uten å tillate port 5004 til dekoderen. Testet litt og for min del så det ut til at trafikk relatert til start forfra kun kom fra 148.123.61.140.

    Mao. så la jeg til en regel på wan som ble:

    ipv4 udp 148.123.61.140 * (statisk ip til dekoderen) 5004

    Edit: Det var forøvrig med upnp aktivert.


  • @kvalm oppdaget at eg heller fikk ikkje forfra til å fungere med gikk aldri mer inn i det siden bruker bare NRK appen uansett i de situasjonene. Takk for tipset! oppdaterer nok pdf dokumentet eg laga ved første anledning.