Traffic Graphs Broken in 2.4.0.b.20170512.1940?


  • Banned

    As stated, the traffic graphs on my dashboard stopped working on update to 2.4.0.b.20170512.1940. No issues before this update.



  • Same here…  Traffic & Interface are unpopulated thru todays 8am snap.



  • Yup.
    But they DO work on chrome on android…



  • Hi guys,

    I'm seeing the same blank traffic graph under both Chrome & Edge.

    I just updated from the May 6th build to the May 12th build.

    -Will



  • Mine are broken too on both Chrome and Safarri.  Clearing cache has no effect.
    Can't even remove the widget from the dashboard.



  • Seems related to updated d3pie.. https://redmine.pfsense.org/issues/7546


  • Developer Netgate

    Compatibility issue between d3.js and d3pie.js :(

    Change reverted



  • My Interface Statistic's, Installed Package's, Thermal Sensor's, or the Traffic Graph's widget work's the package manager still show's the installed package's though.

    I am on the 2.4.0.b.20170514.1010 and I am assuming it is similar to this problem.



  • @Steve_B:

    Compatibility issue between d3.js and d3pie.js :(

    Change reverted

    Thanks Steve for reverting it, I miss my stats!

    Looking at the changelog for d3pie, it seems the last version that supports d3 v3.x is 0.1.9, and he also changed a method in 0.1.7 that could break things.  Seems sticking to 0.1.6 is best until d3 is updated to v4.  If d3 is already v4, then the method he changed in 0.1.7 should be looked at I would think.

    I'm also curious as to how d3pie is used for dashboard stats, it's use would seem for the pie charts in the graphing areas, not the non-pie graphs.  I'm just curious here, that's all.



  • Besides d3 and d3pie, traffic graphs also use nvd3.

    https://github.com/novus/nvd3

    Do we support D3 v4.x?
    No, we do not...
    


  • Well, that settles that than…

    I'm glad I wasn't the one who wanted this to start with, I'd have even less friends..  :o



  • @Steve_B:

    Compatibility issue between d3.js and d3pie.js :(

    Change reverted

    Just updated to " built on Mon May 15 07:27:41 CDT 2017 ".  Should I see traffic graphs again?  I still see a blank widget and Traffic Graphs aren't listed under "Available Widgets" on the dashboard.



  • pfBlockerNB widget doesn't update download errors frame and it evens doesn't allow to remove the widget to reinstall it again to try to resolve the issue!



  • @Steve_B:

    Change reverted

    Forgot to revert it on 'master' branch? I do see its reverted on 2_3 branch (https://github.com/pfsense/pfsense/commit/2684f8d536501177839de9072a5006c1394ef09a)



  • Back to working with 2.4.0.b.20170516.1310



  • Working for me as well.



  • It`s working here as well but…
    See attached screen.
    Why on LAN traffic is doubled?




  • Updated to 2.4.0.b.20170520.1905, but traffic graph is still blank. Is there another step needed to fix?


  • Banned

    hmmmm, I'm on that version as well and traffic graphs are working fine for me.



  • Clear browser cache? Ctrl+F5 ?



  • @PiBa:

    Clear browser cache? Ctrl+F5 ?

    Thanks, that worked. Didn't think about it since I tried two different browsers, one of which hasn't been used to access pfSense in a long time. Figured cache would've expired or been cleared by now.



  • This issue still persists, i have 2.4.2 and Traffic Graph is blank and Retrieving CPU data wheel is spinning forever.

    Is there any fix for this ? :(




  • There is no fix as there isn't anything reproducible broken (that i know of anyhow).

    You will have to investigate a bit more to find why it is not working on your machine. Check browser developer network tab are there any javascript errors? Do requests for ifstat.php get a valid reply? Did already try to clear browser cache right?



  • I did clear browser cache, no java errors, tried on 3 different computers, tried on my iphone, macbook pro, windows pc, linux laptop, tired in incognito i don't think its a browser problem :(



  • Is the request for ifstats.php send by the timer in the browser? What interfaces are requested? And what does it return?



  • Can you help me identify this ifstat.php request ? where should i look for it ? in this scenarie no widget would refresh, i cannot move any widget or close any widget, only way to make things work again si to ingo Traffic Graphs config, and remove all the interfaces from being shown there, then everything starts to work again and Traffic Graphs is hidden.




  • In chrome you would press F12, then on network tab you could filter on the name ifstats and a new requests would show there. Possibly refresh the page with F5 to be sure everything gets shown.. Click one of those ifstats requests and you will be able to view the headers of the send request and also the response, make sure it looks valid from begin with a { until the end }.

    ![2018-01-30 00_26_29-pfSense.png](/public/imported_attachments/1/2018-01-30 00_26_29-pfSense.png)
    ![2018-01-30 00_26_29-pfSense.png_thumb](/public/imported_attachments/1/2018-01-30 00_26_29-pfSense.png_thumb)



  • Thank you very much for your help ! i did like you told me and there seems to be no response at all from ifstats, please check out the image.

    Let me know what you think.




  • @shimano:

    no java errors

    Perhaps no java error..
    But your screenshot shows at the bottom some 'red' text in the 'console' tab, that surely looks like a Javascript error ;). (p.s. Java is not related to Javascript..)

    Can you copy that text in full into a code # block here on the forum? It might help tell whats going on..



  • Sure thing ! that is what i noticed that are some errors there and why i did capture them in in the screenshot, here they are in all their glory !

    Uncaught SyntaxError: Invalid or unexpected token
    traffic-graphs.js?v=1510914901:162 Uncaught ReferenceError: nv is not defined
        at String. <anonymous>(traffic-graphs.js?v=1510914901:162)
        at Function.each (jquery-1.12.0.min.js?v=1510914902:2)
        at draw_graph (traffic-graphs.js?v=1510914901:141)
        at graph_init (traffic-graphs.js?v=1510914901:59)
        at (index):1120
        at HTMLDocument. <anonymous>(pfSense.js?v=1513000593:261)
        at i (jquery-1.12.0.min.js?v=1510914902:2)
        at Object.fireWith [as resolveWith] (jquery-1.12.0.min.js?v=1510914902:2)
        at Function.ready (jquery-1.12.0.min.js?v=1510914902:2)
        at HTMLDocument.K (jquery-1.12.0.min.js?v=1510914902:2)</anonymous></anonymous>
    


  • Is it possible to click on the "Uncaught SyntaxError: Invalid or unexpected token" line? Does it show some other file/script where that syntax error is present.?

    The second error where 'nv' is not defined is probably caused by the first syntax error skipping parts of code that is available..



  • No, i can only click on nv.d3.js:9656  right next to invalid or unexpected token and is shows this.




  • Any ideas what i should do so i can have a working traffic graph ?



  • What does line 9656 of that file look like?

    And a bit around it.



  •   function mouseover_line(evt) {
                    var yaxis = data[evt.seriesIndex].yAxis === 2 ? yAxis2 : yAxis1;
                    evt.value = evt.point.x;
                    evt.series = {
                        value: evt.point.y,
                        color: evt.point.color,
                        key: evt.series.key
                    };
                    tooltip
                        .duration(0)
                        .headerFormatter(function(d, i) {
                            return xAxis.tickFormat()(d, i);
                        })
                        .valueFormatter(function(d, i) {
                            return yaxis.tickFormat()(d, i);
                        })
                        .data(evt)
                        .hidden(false);
                }
    
                function mouseover_scatter(evt) {
                    var yaxis = data[evt.seriesIndex].yAxis === 2 ? yAxis2 : yAxis1;
                    evt.value = evt.point.x;
                    evt.series = {
                        value: evt.point.y,
                        color: evt.point.color,
                        key: evt.series.key
                    };
                    tooltip
                        .duration(100)
                        .headerFormatter(function(d, i) {
                            return xAxis.tickFormat()(d, i);
                        })
                        .valueFormatter(function(d, i) {
                            return yaxis.tickFormat()(d, i);
                        })
                        .data(evt)
                        .hidden(false);
                }
    
                function mouseover_stack(evt) {
                    var yaxis = data[evt.s[/code]
    
    ![a.JPG](/public/_imported_attachments_/1/a.JPG)
    ![a.JPG_thumb](/public/_imported_attachments_/1/a.JPG_thumb)
    


  • Not sure what happened there.. that line should be longer.:
    https://github.com/pfsense/pfsense/blob/ad1e294ce5a735b680aa9ef93f25906077c8812d/src/usr/local/www/vendor/nvd3/nv.d3.js#L9656 and should be still quite a few lines after it as well..

    Can you check with diagnostics\editfile or perhaps your favorite SCP client what the file "/usr/local/www/vendor/nvd3/nv.d3.js" on pfSense itself looks like? Is it complete?

    If the file is incomplete you could try and run:  pkg install -f pfSense-base    on the pfSense console or ssh connection to re-install it..



  • I don't know if its complete or not, but this is how it looks like, can you tell me if it is ok ?

    I added to a text file as i cannot paste it here to long.

    file.txt



  • Looks like its only 9656 lines, while there should be 14354 like in the link so definitely not ok.. https://github.com/pfsense/pfsense/blob/ad1e294ce5a735b680aa9ef93f25906077c8812d/src/usr/local/www/vendor/nvd3/nv.d3.js#L14354

    Can you run the pkg command mentioned, and check again.?



  • Thank you ever so much ! now it works perfectly !!

    Thanks so so much for your effort to help i so appreciate it you earn a lot of respect, if i can ever repay you for your help just le me know:

    
    [2.4.2-RELEASE][root@pfSense.shimano.home]/root: pkg install -f pfSense-base
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking integrity... done (0 conflicting)
    The following 1 package(s) will be affected (of 0 checked):
    
    Installed packages to be REINSTALLED:
            pfSense-base-2.4.2_1 [pfSense-core]
    
    Number of packages to be reinstalled: 1
    
    Proceed with this action? [y/N]: y
    [1/1] Reinstalling pfSense-base-2.4.2_1...
    [1/1] Extracting pfSense-base-2.4.2_1: 100%
    ===> Keeping a copy of current version mtree
    ===> Removing schg flag from base files
    ===> Extracting new base tarball
    ===> Removing static obsoleted files
    [2.4.2-RELEASE][root@pfSense.shimano.home]/root:
    
    




  • Ok great :).
    Next issue, please do fill in a different 'monitor ip' on your wan gateway, one that that responds to ping, so the gateway wont show as 'down' with 100% loss, and the quality monitoring rrd's will contain some better data ;). But well that should probably go into a different topic 8).