Проверка шлюза offline



  • @yarick123:

    а 87.250.250.242 - это тот же яндекс: ya.ru

    Да пигную я днс сервера яндекса.



  • @NegoroX:

    по моему 77.88.8.7 это днс яндекса "семейный"
    https://dns.yandex.ru/

    Так и есть  ;)



  • Ребята! Я не просил выяснять какие я IP адреса брал для отправки ping, хоть на всеми любимыми 8.8.8.8 и 8.8.4.4 какая разница…
    Я прошу помочь разобраться почему не идёт ping с моего шлюза до IP адресов в интернете. Выше всё чётко и наглядно представлено, в картинках.



  • Ты имеешь ввиду что
    gateway offline - ? а инет при этом у пользователей есть - так?.



  • @NegoroX:

    Ты имеешь ввиду что
    gateway offline - ? а инет при этом у пользователей есть - так?.

    Верно, интернет есть у пользователей.



  • @enman:

    @yarick123:

    Пока из всего написанного не видно, что шлюз вообще отвечает на пинг.

    Вот именно что не видно, не могу понять почему нет пинга.

    Другими словами, похоже на то, что сам шлюз не отвечает на пинг. Не любит он на ICMP вопросы отвечать. Игнорирует он их.

    @enman:

    Ребята! Я не просил выяснять какие я IP адреса брал для отправки ping, хоть на всеми любимыми 8.8.8.8 и 8.8.4.4 какая разница…
    Я прошу помочь разобраться почему не идёт ping с моего шлюза до IP адресов в интернете. Выше всё чётко и наглядно представлено, в картинках.

    Так дело в том, что Вы настолько туманно написали, что и как конкретно Вы проверяли, что ничего другого не оставалось.

    Где результаты хотя-бы одного пинга на шлюз?!



  • @enman:

    Я прошу помочь разобраться почему не идёт ping с моего шлюза до IP адресов в интернете.

    Ping может не работать если в правиле LAN в разделе Protocol указан TCP/UDP вместо any

    Можно конечно создать доп правило специально  для для пинга

    IPv4    ICMPany    LAN net * * * MultiWAN none   Default allow LAN to any rule

    P.S
    Встроенная в ПФ утилита ping  будет пинговать любой адрес в инете, а любая машина в сети нет !! без указания протокола any или ICMP



  • WAN1 icmp внешний IP адрес:7965 -> 8.8.8.8:7965 0:0 138.112 K / 0 3.69 MiB / 0 B

    Интерфейс WAN1
    Протокол icmp

    Пакет выходит с внешний IP адрес:7965 в google-public-dns-a.google.com ( ;D для знатоков)  8.8.8.8:7965

    Установлено соединений 0:0

    Передано байт 138.112 K / 0 3.69 MiB / 0 B

    Из этого следует, что PFsense отправляет пакет ICMP с внешнего ip адреса  к google-public-dns-a.google.com НО ответ на него не приходит от google-public-dns-a.google.com. В правилах разрешён весь трафик. Интернет с него приходит.



  • А вы узнайте у провайдера, не фильтруют ли они, кстати, я может пропустил, но все ли внешние IP не пингуются, или только какой то конкретный ?!



  • @Uranus:

    А вы узнайте у провайдера, не фильтруют ли они, кстати, я может пропустил, но все ли внешние IP не пингуются, или только какой то конкретный ?!

    Простите, вам эта картинка что либо говорит? Если нет, увы… Если говорит, то у провайдера есть проблемы с подачей интернета, блокирует он ICMP?



  • @enman:

    Простите, вам эта картинка что либо говорит? Если нет, увы… Если говорит, то у провайдера есть проблемы с подачей интернета, блокирует он ICMP?

    Ясно…, я с ночной смены, туплю понемногу... :)
    Другой вопрос, странно что у вас потери при пингах на первой картинке не 100%, а всего 94%, значит часть всё же проходит, или просто скрин был сделан когда потери не опустились до 100% ?



  • @Uranus:

    @enman:

    Простите, вам эта картинка что либо говорит? Если нет, увы… Если говорит, то у провайдера есть проблемы с подачей интернета, блокирует он ICMP?

    Ясно…, я с ночной смены, туплю понемногу... :)
    Другой вопрос, странно что у вас потери при пингах на первой картинке не 100%, а всего 94%, значит часть всё же проходит, или просто скрин был сделан когда потери не опустились до 100% ?

    Потери 100% скрин после перезагрузки PF



  • Ясно…
    Я бы конечно мог посоветовать провести тесты на свеже-установленном PF, потому как если из Диагностики пинги уходят, а так нет, то явно проблема в каких то настройках роутера, а вот что вы изменили можно только гадать.

    Сделать копию текущих настроек, затем заново установить PF, и ничего не меняя (ну кроме того чтобы выйти в инет) проверить как будет себя вести Gateway.
    Кстати у вас сразу начались такие проблемы или через некоторое время?
    Уж простите за банальные вопросы...



  • @Uranus:

    Ясно…
    Я бы конечно мог посоветовать провести тесты на свеже-установленном PF, потому как если из Диагностики пинги уходят, а так нет, то явно проблема в каких то настройках роутера, а вот что вы изменили можно только гадать.

    Сделать копию текущих настроек, затем заново установить PF, и ничего не меняя (ну кроме того чтобы выйти в инет) проверить как будет себя вести Gateway.
    Кстати у вас сразу начались такие проблемы или через некоторое время?
    Уж простите за банальные вопросы...

    Сразу после установки. Кажется я понял в чём проблема. 
    Есть интерфейсы WAN LAN OPT
    На WAN основной интернет. Переименован в WAN0
    На LAN локальная сеть
    На OPT резервный интернет Переименован в WAN1

    Проблема как раз получается с OPT=>WAN1
    Но интернет то с него есть. Пользователь выходит с него в интернет.
    А этот dpinger Gateway Monitoring Daemon показывает что либо 100% потери либо цифры прыгают.



  • в  Status / Services   перегрузите –-- dpinger Gateway Monitoring Daemon

    И в**  System / Routing / Gateways / Edit**

    Advanced

    Weight и Data Payload измените значение допустим на 5 –-- должно заработать



  • @enman:

    Сразу после установки. Кажется я понял в чём проблема. 
    Есть интерфейсы WAN LAN OPT
    На WAN основной интернет. Переименован в WAN0
    На LAN локальная сеть
    На OPT резервный интернет Переименован в WAN1

    Проблема как раз получается с OPT=>WAN1
    Но интернет то с него есть. Пользователь выходит с него в интернет.
    А этот dpinger Gateway Monitoring Daemon показывает что либо 100% потери либо цифры прыгают.

    Без обид, ну почему мы из вас должны вытягивать информацию, теперь у вас оказывается резервный канал есть, он в работе, то есть включен в настройках ?



  • @oleg1969:

    Weight и Data Payload

    А за что они отвечают эти два параметра?



  • @enman:

    @oleg1969:

    Weight и Data Payload

    А за что они отвечают эти два параметра?

    Weight в данном случае вообще не причем.
    https://doc.pfsense.org/index.php/Multi-WAN#Weight
    Не влияет на определение недоступности шлюза. Используйте для задания ширины каждого канала при балансировке.

    А вот payload может помочь:

    Some modems have a bug that makes them drop pings with 0 byte payloads. dpinger uses a 0 byte payload by default because there isn't a need to include one and unnecessarily chew up bandwidth. If you have such a buggy upstream device, you'll need to set the payload to something greater than 0. System>Routing, edit the gateway, go to Advanced, and set payload to 1. Save and apply changes.
    https://forum.pfsense.org/index.php?topic=110043.0

    Может (?) помочь и изменение Time Period



  • Добрый.
    А что в кач-ве ВАНов у вас ? Ethernet, adsl, 3g\4g etc. ?



  • @werter:

    Добрый.
    А что в кач-ве ВАНов у вас ? Ethernet, adsl, 3g\4g etc. ?

    Ethernet со статикой. PF в качестве роутера. Т.е. все каналы интернета входят в него и он же раздаёт интернет.



  • @pigbrother:

    @enman:

    @oleg1969:

    Weight и Data Payload

    А за что они отвечают эти два параметра?

    Weight в данном случае вообще не причем.
    https://doc.pfsense.org/index.php/Multi-WAN#Weight
    Не влияет на определение недоступности шлюза. Используйте для задания ширины каждого канала при балансировке.

    А вот payload может помочь:

    Some modems have a bug that makes them drop pings with 0 byte payloads. dpinger uses a 0 byte payload by default because there isn't a need to include one and unnecessarily chew up bandwidth. If you have such a buggy upstream device, you'll need to set the payload to something greater than 0. System>Routing, edit the gateway, go to Advanced, and set payload to 1. Save and apply changes.
    https://forum.pfsense.org/index.php?topic=110043.0

    Может (?) помочь и изменение Time Period

    Странно. Раньше такой проблемы не было. Это не первая установка, и не на первой машине. Всё равно спасибо. Вроде как заработало.



  • иногда вешается служба пингера, это "бывает". ребут службы решает проблему.



  • Тему закрываю, проблема решена.

    Отредактировал Weight и Data Payload эти параметры


Log in to reply