E2guardian5 kurulumu,squid entegrasyonu,SSL Man in the middle filtering ayarları



  • squid ve e2guardian da transparenti 2 taraftada seçmeye gerek yok
    trafiği gereksiz karıştırıyor ve cache stabil çalışmıyor

    • squidde transparent ssl proxy yi seçmeye yine gerek yok.


  • Susamlicubuk arkadaşımın dediğine katılıyorum, Squid üzerinde Transparent + SSL filtering özelliklerini açmanıza hiç gerek yok. Bu ayarları zaten E2guardian üzerinde yapıyorsunuz. Eğer ikisindede transparent + ssl ayarları yaparsanız stabil çalışmıyor, ben tecrübe ettim.)

    Squid üzerinde sadece squid servisini aktif edin " LAN ve Loopback" arabirimlerini seçin daha sonra ise aşağıdaki parametreleri Advanced altında Before Auth bölümüne ekleyin. Peki bunu neden ekliyorsunuz onuda söyliyeyim size, aşağıdaki parametreleri akıllı bir eleman elle proxy yazıp e2guardian servisini atlatmasın diye yapıyoruz. Yoksa direkt squid üzerinden internete çıkar ve filtrelemeye takılmaz.

    Parametreler:

    cache_peer 127.0.0.1 parent 8080 0 login=*:password
    always_direct deny all
    never_direct allow all

    Daha sonra ise zaten E2guardian servisini arkadaşımızın anlattığı gibi ayarlarsanız güzel bir şekilde çalışıyor.



  • E2guardian'ı tek başına kurdum ve test ediyorum. Her şey güzel çalışıyor. Gruplar oluşturup her bir gruba farklı siteleri yasaklayabildim.

    Fakat "ACLs > Extension List" alanını kullanarak bir dosya indirmeyi yasaklamayı yapmıyor. Örneğin ".exe" dosyaları vb.

    Acaba bu sorunla karşılaşıp çözebilen oldu mu?



  • Eski versiyonlarda uzantı engelleme çalışıyordu fakat yeni versiyonda malesef çalışmıyor
    Marcello nun bilgisi var müdahale edilmesini bekleyeceğiz.



  • Teşekkürler

    Bekleyeceğiz artık



  • marcellonun güncellemesinden sonra uzantı engelleme şuan çalışıyor



  • Malesef ben bir türlü beceremedim.
    Yasaklanan dosya uzantıları yinede indiriliyor.

    Acaba özel bir ayar mı var?



  • resimleri göremiyorum. güncellemeniz mümkün mü?



  • resimler görünmüyordu, yeniden yükledim.



  • pfsense 2.4.4 güncellemesi sonrası e2guardian sebebi ile bir süre sonra sistem donabiliyor.

    Verdiği hata aşağıda,
    e2guardian paketine de bu hatayı çözen bir güncelleme gelmedikçe, şimdilik bir çözüm yok. (ben logrotate'i disable ettim, neticesini bekliyorum.)
    e2guardian kullananların, bu sebeple 2.4.4'e güncellememelerini tavsiye ederim.

    PHP Errors:
    [02-Oct-2018 00:00:00 Europe/Istanbul] PHP Fatal error: Uncaught ArgumentCountError: Too few arguments to function service_control_stop(), 1 passed in /usr/local/www/e2guardian_logrotate.php on line 42 and exactly 2 expected in /etc/inc/service-utils.inc:668



  • 2.4.4 sürümünün direkt kurulumunda, fetch komutu ile e2guardian5 paketlere gelmiyor, Patch işlemi gerekiyor.

    https://forum.netgate.com/topic/128007/pacote-não-oficial-e2guardian-v5-para-software-pfsense/464



  • @tuzsuzdeli said in E2guardian5 kurulumu,squid entegrasyonu,SSL Man in the middle filtering ayarları:

    pfsense 2.4 ise :
    fetch -q -o /usr/local/etc/pkg/repos/Unofficial.conf https://raw.githubusercontent.com/marcelloc/Unofficial-pfSense-packages/master/Unofficial.conf

    Merhaba Anlatım için teşekkürler eline sağlık.
    pfSense 2.4.4 release yeni fiziki pc ye kurulum yaptım.
    Tam squid ve squidgoard kuracakken konuya takıldım e2guardian5 kurmaya karar verdim.
    SSH ile bağlandım 8 ile shell e giriş yaptım komutu verince herhangi bir işlem gerçekleşmedi service bölümde de bir şey yok.

    edit:
    konuyu araştırdım,
    http://knes1.github.io/blog/2015/2015-07-18-manually-installing-e2guardian-to-pfsense.html
    buradaki gibi
    pkg update
    pkg install e2guardian
    komutlarla kurdum o sitedeki sonraki ayarları yapmadım.
    sonra aşağıdaki videoda
    https://www.youtube.com/watch?v=7N7eIku3v98

    conf dosyası zaten oluşmuş
    bende System - Package Manager - Available Packages ler içinde e2guardian gözükmüyor.





  • Sonunda oldu, @plusbil verdiği link ile hallettim o linkteki yazıyı anlayana kadarda bayagı zaman harcadım.
    Önce eklentilerden System patch install yaptım.
    System / Patches / +Add new patch
    bölümden gerekli ayarı yapınca yüklenecek paketlerde listelendi. kurulumunu gerçekleştirdim umarım sonraki yapılandırma ayarlarda sorun olmaz. Resim ekledim.
    0_1541075668481_e2guardian.png



  • @tuzsuzdeli teşekkürler o linki şimdi fark ettim o sayfa bende de açıktı başka bir kaynaktan yönlenmiştim 900 küsür mesajdan yukarı doğru çıkıyordum ipin ucunu bir türlü yakalayamadım.



  • Özellikle link verdim, açıklamadım. Çünkü sadece balık yemeyi öğrenirsek, oltacıların nesli tükenir. Balık tutmayı öğrenmek olsun gayemiz...

    Bir de siz uğraşır yaparsanız, nasıl olduğunu bir daha unutmazsınız. Kopyala-Yapıştır yaparsanız, forumlara bağlı yaşarsınız. 😉



  • @plusbil çok haklısınız, anlatsanız da aklımda kalacağını sanmıyorum sağlık sorunlarımdan dolayı.
    pfSense uzun süredir kullanmıyorum bildiğimi de unutmuşum.
    O linkte takıldığım nokta google translate çeviriyi yapamadı şimdi yeni kurdum hatasız ilerlemek için bende kafama göre denemek istemedim. ID yerine link yazın diyormuş o kısmını anlamamıştım.

    @tuzsuzdeli hocam siz blacklist için download butona basın biraz bekleyin demişsiniz.
    Benim kurduğumda shallalist bölümü ekli geldi.
    Download diyorum sayfada hareketlilik yok, farklı tarayıcıdan da baktım aynı, umarım ters bir durum yoktur.

    Mantığı anlamak açından youtube daki anlatıma baktım diğerinden(squidguard) farklı daha stabil ve hızlı. İlk ayardan sonrası çok uğraştırmaz sanırım.
    youtube.com/watch?v=w7w8oZX8uJo

    Şimdilik engelleme yapmayacağım log lari takip edip ona göre işlemler yapacağım. Bana gerekli olan dışarıdan bu cihaza erişim, modem bridge mode olacak.
    WAN bölümden erişim riskli fakat depo ile aramızda 4-5km var. Bu konu için tavsiyeniz nedir.



  • @tuzsuzdeli Merhaba, bu konuyu yukarı sabitleseniz daha güzel olmaz mı?

    Edit:
    şu linkte link text
    Proxy için neden 127.0.0.1 8888 portunu yazmış?



  • 2.4.4 versiyonunda SSL enjeksiyon ile Whatsapp'ı gecikmesiz şekilde kullanan var mı? Ve ayrıca whatsapp üzerinden görüntülü görüşme yapabilen? Yahut hangi versiyonda Whatsapp'ı E2Guardian5 ile sıkıntısız kullanabiliyorsunuz?

    Bende mesajlar çoğu kez gecikmeli gidiyor. Arasıra whatsapp internete bağlı değil türü mesajlar veriyor. Görüntülü yahut sesli aramayı ise hiç yapmıyor. Loglara "TCP_DENIED/403 https://127.0.0.1" şeklinde blok düşüyor.



  • şu an aktif kullanmıyorum ancak birkaç hafta önce, 2.4.4 versiyon ile problemsiz şekilde görüntülü konuşma yapıyordum.
    ancak dediğiniz gibi, zaman zaman wi-fi'ya bağlı olmama rağmen mesajlar gelmiyordu. ya da web'den kullandığımda, telefon wi-fi ile bağlı ise, zaman zaman bağlı değil görünüyordu.