XG-7100 1U - Telekom VDSL auf VLAN 7 an einem 1 GigE-Port



  • Hallo zusammen,

    ich habe eine Frage zur XG-7100. Diese hat ja neben 2 SPF+ Ports, 8 1GigE Ports, die eigentlich ein 8 Port Switch sind der intern mit 2x 2,5Gig angeschlossen ist.

    Ich habe die XG-7100 so konfiguriert, das ich jeden der 8 Ports getrennt nutzen kann. Hier sind aktuell zwei alte ADSL Leitungen und einmal das LAN angeschlossen.

    Jetzt bekomme ich zwei neue VDSL 100 Leitungen. Diese benutzen bei der Telekom das VLAN 7. Bei anderen Installationen nutze ich eine apu2, lege hier das VLAN 7 an und erstelle ein Interface mit diesem VLAN 7. Anschließend hänge ich eine PPPoE Verbindung an und fertig ist das VDSL 100 bei der Telekom.

    Kann ich die XG 7100 dazu bewegen genauso zu funktionieren?

    PS: Ganz generell die Frage, wie ich auf diesen 8 Ports weitere VLANs nutzen kann. Es gibt ja in meiner Installation schon 8 VLANs eben weil das Produkt so die einen Switchports trennt.

    Viele Grüße


  • Moderator

    Wenn du die Ports nach offizieller Anleitung über den interen Switch getrennt hast, kannst du doch trotzdem nach wie vor auf dem dann getrennten Interface nach außen hin ein VLAN über den normalen pfSense Weg anlegen. Die interne VLAN Trennerei ist ja in dem Zusatzmenü des internen Switches verbaut?

    Gruß



  • Ich glaube, ich stelle mich nur etwas doof an. Ich hänge mal die aktuelle Konfig mit Screenshots an.

    0_1536129400898_switch-ports.PNG
    0_1536129410414_switch-vlans.PNG
    0_1536129417501_interfaces-vlans.PNG

    So habe ich aktuell die einzelnen Ports getrennt. Nach deinen Aussagen, bin ich aber gar nicht sicher, ob das so korrekt ist.

    Wenn ich unter Interfaces/VLANS nun ein VLAN 7 anlege und es auf das Interface lagg0 binde, woher weiß pfSense bzw. der Switch an welchem Port es ankommt. Muss ich es nun zusätzlich im Switch Menü anlegen (mit z.B. Port 5 untagged, Port 9/10 auf tagged) anlegen?

    Grüße


  • Moderator

    Du hast doch bei Interfaces nicht lagg0 sondern ETH1-8, sonst müsstest du den Spaß mit dem internen Switch ja gar nicht machen? Deine Screenshots sind ja alle von der Switch Verwaltung, nicht von der Interface Verwaltung?



  • Hallo,

    sorry für die späte Antwort. Die ersten beiden Screenshots sind aus der Switch Verwaltung und der dritte Screenshot ist aus der Interfaceverwaltung.

    Wenn ich ein VLAN in der Interfaceverwaltung anlege, kann ich ja als Parent Interface lediglich lagg0 oder die beiden Glasfaserinterfaces auswählen. Die einzelnen Switchports jedoch nicht.

    1_1536915201368_pfsense2.PNG

    So sehen aktuell meine zugewiesenen Interfaces aus:

    0_1536915345007_pfsense1.PNG

    Wie kann ich denn nun z.B. auf mein WAN2 oder WAN3 VLAN 7 legen?

    Grüße


  • Moderator

    Aaah stimmt. Das ist ja dieser doppelt gemoppelt gemogelte Durchgriff wegen der zwei Heads. Narf.

    Ich denke es könnte gehen, wenn du statt dem vorgeschlagenen 4081 bspw. einfach dein VLAN benutzt, aber da kann ich leider nur sagen ohne Gewähr. Eine Sache die mich massiv an der XG-7100 gestört hat ist genau das. Ich verstehe den technischen Unterbau, der das "erzwungen" hat, trotzdem halte ichs für ziemlich "unschön", es so zu lösen, genau weil man dann solches Schlamassel hat. Ansonsten würde ich aber einfach noch mal bei Netgate direkt nachfragen (oder im entsprechenden Unterforum), wie die sich das vorstellen. Das wird ja bei DSL noch witziger, da müsste man ja theoretisch erst ein PPPoE auf dem VLAN des LAGs legen und das dann wieder in VLAN7 oder so reinpacken... Ich sehe gerade VLAN Inceptions... 😳



  • @jegr said in XG-7100 1U - Telekom VDSL auf VLAN 7 an einem 1 GigE-Port:

    Das wird ja bei DSL noch witziger, da müsste man ja theoretisch erst ein PPPoE auf dem VLAN des LAGs legen und das dann wieder in VLAN7 oder so reinpacken... Ich sehe gerade VLAN Inceptions... 😳

    Genau an diesem Punkt habe ich mich auch stark gewundert. Ich werde nächste Woche noch mal ein bisschen Testen, wenn ich eine Lösung habe, poste ich sie.

    Ansonsten wende ich mich am besten mal an Netgate bzw. voleatech, wo wir gekauft haben. Danke schon mal für deinen Input, habe kurzzeitig gezweifelt, ob ich da irgendwas glasklares übersehe 👍



  • Hallo zusammen,

    ich hatte im englischen Forum noch einen Hinweis gefunden wie die Konfiguration aussehen sollte. Ich habe das jetzt für den Fall VLAN 7 mit der Telekom getestet und es läuft.

    Zuerst habe ich unter Interfaces VLAN das VLAN 7 mit lagg0 als Parent Interface angelegt.

    0_1537187525677_pfsense3.PNG

    Dann habe ich das VLAN 7 unter Interfaces/Switch/VLANs an dem entsprechenden Port und natürlich Port 9 und Port 10 auf tagged gesetzt.

    0_1537187590039_pfsense5.PNG

    Dann habe ich das Interface "VLAN 7 on lagg0 (Telekom VDSL)" hinzugefügt. Das Interface habe ich auf PPPoE gesetzt und mit meinen Zugangsdaten bestückt und schon kommt die Leitung hoch und läuft :)


  • Moderator

    OK das hatte ich zwar eigentlich gemeint, aber schön zu wissen, dass das auch genauso funktioniert ;) Trotzdem ein sehr friemeliges Gefummel was mich froh macht, dass wir da Alternativen haben was Hardware angeht :)



  • Ja, irgendwie etwas gewöhnungsbedürftig, aber wenn man weiß wie, dann funktioniert es gut :)

    Hätte ich mir vorher genauer anschauen sollen, aber jetzt muss ich damit leben. Wir haben noch einige alte Soekris 5501 zu ersetzen, wo ich mir jetzt die Frage stelle, welche Hardware ist dafür sinnvoll. Ich hatte immer mal auf die APUs geschielt, bin mir aber nicht sicher, ob das eine vernünftige Lösung ist.



  • @derchriis said in XG-7100 1U - Telekom VDSL auf VLAN 7 an einem 1 GigE-Port:

    Ich hatte immer mal auf die APUs geschielt, bin mir aber nicht sicher, ob das eine vernünftige Lösung ist.

    In den Tropen würden ich die Teile nicht einsetzen. Der Klimawandel auch hierzulande könnte eine
    unangenehme Rolle spielen. Nun, nach einem massiven Einsatz dieser Teile ist man
    (fast) immer schlauer.

    Ich habe ein Teil mit ausreichender Kühlung im Einsatz. Hoffe ich.


  • Moderator

    @derchriis Ich kenne die Soekris Teile noch von früher. Jammerschade, dass die sich erst so rar und dann komplett zurückgezogen haben. Gerade mit 4+ Interfaces waren die Teile eine Freude (ich hab über eine net4501 damals meine Diplomarbeit geschrieben ).

    Gerade da die Teile mehr als 3 Interfaces haben ist Ersatz wenn man die Ports benötigt nicht ganz so einfach. Kommt darauf an was ihr damit bedient und was abgelöst werden soll und natürlich wie groß die Budget Hausnummer ist. Evtl. kann man dann was empfehlen.

    Gruß



  • Ja, war auch immer sehr begeistert von den Geräten. Habe Installationen die fast 10 Jahre ohne Probleme laufen. Die Geräte hatten zwar ihren Preis, haben sich aber eindeutig bezahlt gemacht.

    In unseren Außenstellen reichen uns eigentlich 3 Interfaces. Ein viertes Interface wäre nice to have aber nicht zwingend notwendig. Wichtig ist für uns ein gutes Preis/Leistungsverhältnis (deshalb der Gedanke APU) und einfache Beschaffung. Für unsere Hauptstelle haben wir uns für die XG-7100 entschieden, da wir hier etwas mehr Power inkl. Reserve wollten (12 OpenVPN Site2Site Tunnel und ca. 40 Clients dahinter). In den Außenstellen haben wir 2 bis 16 Clients dahinter.


  • Moderator

    Unsere Kunden haben jetzt fast alle die APUs gegen scope7-1020er getauscht. Bisschen mehr Performance aber hauptsächlich wegen besserer Verarbeitung und Garantiezeiten. Kostet ein bisschen mehr, aber gerade ein Kunde, der schon 20 APU2 Kisten hatte und dem nun schon 3 ausgefallen sind durch Wärme und Stromversorgung, meinte dann auch "nee ich zahl jetzt nicht immer doppelt bei den Dingern, dann kann ich auch gleich die 1020er mit 3 Jahren Vorabtausch kaufen und hab Ruhe (und im Zweifelsfall am nächsten Tag ne neue Kiste statt umständliche RMA). Daher auch nix gegen die APUs, aber ich persönlich empfinde es gefühlt so, als wäre seit der APU Reihe die Qualität immer weiter gesunken (auch was BIOS und Stabilität angeht). WRAP und ALIX früher waren ja schon bombensicher, da war nie was. Daher auch: für daheim kein Thema, unsere Firmenkunden greifen inzwischen lieber zu anderen Alternativen.



  • Die kannte ich so noch nicht. Preise habe ich leider keine gefunden. Kannst du sagen wo die preislich liegen? Gibt es auch Geräte mit den Leistungsdaten die ich ins Rack schrauben kann?

    Habe bisher drei APUs im Einsatz und bis jetzt noch keine Probleme, aber vertraue da gerne auf Erfahrungen anderer. Was ich damit auf keinen Fall haben will ist Stress im laufenden Betrieb :-)





  • Hm okay, in etwa so wie die Soekris Geräte früher. Wenn ich 19" Hardware haben will kann ich also auch direkt die XG-7100 kaufen, oder muss drauf vertrauen das die APUs keinen Hitzetot sterben.



  • Was spricht bei euren Außenstellen denn gegen die SG-3100? ☺

    -Rico



  • Von Preis/Leistung nichts. Ich dachte nur es gibt vielleicht auch Hardware in der Preisklasse, die sich in eine HE auf 19" montieren lässt. So wie es das für die APUs gibt.


  • Moderator

    @derchriis said in XG-7100 1U - Telekom VDSL auf VLAN 7 an einem 1 GigE-Port:

    Wenn ich 19" Hardware haben will kann ich also auch direkt die XG-7100 kaufen, oder muss drauf vertrauen das die APUs keinen Hitzetot sterben.

    19" sind meistens schon größere Kisten. Je nach Bedarf sind das dann Kisten wie die 7525 bzw. bald deren Nachfolgerin die 1510 (bzw. eine mal wieder erstaunlich baugleiche SG-5100). Die kann man zumindest mit Winkeln ins Rack hängen. Aber Rackmount geht meistens bei Pi mal Daumen knapp unter nem Tausender los. Die Desktop/Einbaukit Hybriden mal abgesehen.

    Links zu den Kollegen von HRT bzw. mini-itx sind übrigens - da wiederhole ich mich auch - nicht so wirklich sinnvoll zielführend, da die genauso die Geräte teils neu anfragen müssen, da im Markt momentan (leider) viel Bewegung ist durch stetig steigende RAM und SSD Preise und sich auch die ein oder andere politische Ecke langsam im Preis niederschlägt. Deshalb geht da der Preis leider eher rauf denn runter. Allerdings wird es wohl auch seinen Grund haben, dass auch die Original SG-5100 urplötzlich wieder eine andere Bauart aufweist als die 3100 oder 7100 - und dabei wie ein Zwilling der Ur-Lanner 1510 gleicht ;)


  • Moderator

    @derchriis said in XG-7100 1U - Telekom VDSL auf VLAN 7 an einem 1 GigE-Port:

    Von Preis/Leistung nichts. Ich dachte nur es gibt vielleicht auch Hardware in der Preisklasse, die sich in eine HE auf 19" montieren lässt. So wie es das für die APUs gibt.

    BTW: Da arbeiten wir noch dran, die Jungs von Lanner bzw. deren Distris dazu zu kriegen, eine bspw. 1020 in ein 19" Gehäuse zu packen - ggf. mit der Option auch 2 davon reinzupacken als Cluster in 1HE Option. :)