Ntopng not showing country flags



  • Hello,
    I want to ask about some weird situation. I have 2 pfSense boxes, let's name them BOX-1 and BOX-2.
    BOX-1 is older installation, even before "Netgate", which I upgraded regulary and now it's on latest version 2.4.4 with installed ntopng current package version 0.8.13_3, which was installed today (ntopng was on this box for a long time). Now when I log into ntopng it still says that there is a new version 3.6.0 available (ntopng Community Edition v.3.4.180911). In package dependencies it shows "ntopng-3.6.d201800910,1". It's kind of the same problem which was in previous topic "[Help] ntopng not displaying Minute Interface Top Talkers". But the point is, that when I look in flows or other places, I can see country flags by public IPs.
    BOX-2 is newer insatallation, with Netgate ISO already. It's updated to same version 2.4.4, both are amd64 systems. Today I installed the newest ntopng package - version 0.8.13_3. When I log into ntopng, it shows I'm on Community Edition v.3.6.181102, which is OK. I also updated GeoIP data, but I can't see anywhere those country flags. Is it a bug or how can I get it there? It looks, that on older version it worked, but it's kind of reporting wrong version in ntopng but correct in pfsense package manager, and a fresh install on fresh pfsense install reports correct version in both places, but can't get work country flags. Any suggestions??



  • Hello,
    I am also seeing these symptoms. I have a fresh install of pfsense with ntopng as the first package installed. I cannot see any data in the geomap, hosts by country, or hosts by ASN, or the country flags as mentioned by the OP. I haven't found mention of similar issues within the last year other than this post. Is anyone experiencing similar issues?

    I have tried updating the geodata and even a full reinstall and default configuration of ntopng with the same result.



  • @networker2001 said in Ntopng not showing country flags:

    Hello,
    I am also seeing these symptoms. I have a fresh install of pfsense with ntopng as the first package installed. I cannot see any data in the geomap, hosts by country, or hosts by ASN, or the country flags as mentioned by the OP. I haven't found mention of similar issues within the last year other than this post. Is anyone experiencing similar issues?

    I have tried updating the geodata and even a full reinstall and default configuration of ntopng with the same result.

    I'm experiencing the exact same symptoms with the latest version of pfsense and ntopng (2.4.4 and 0.8.13_3).

    Ntopng does not show any country data nor any information about Autonomous Systems (showing ASN 0 only).
    I guess the new version does not work properly with Maxmind database.



  • I'm glad to hear that it's not just me. I have been looking to find if I missed a configuration step, or an error was logged. I haven't seen any related errors in the pfsense log or in the ntopng runtime log, so not sure where to start looking.



  • I have the same issue, and also I don't see the activity map on host pages that you'll see in the vide below, if you got to 4:20.

    https://www.youtube.com/watch?v=uGN6NYFkrh4



  • Has this been registered as a bug? It appears it is a bug, but haven't been able to find any confirmation. Is anyone successfully using the country flags, ASN, and country reporting in the current versions of ntopng and pfsense?



  • Just another +1. Country flags are gone and the only point I see on the geo map is my own. This used to work until the recent ntopng upgrade (or pfSense 2.4.4 -> 2.4.4p1 which was around the same time). Tried to "Update GeoIP Data" from the pfSense ntopng Settings interface but didn't seem to work.



  • @networker2001: I couldn't find anything on the bug tracker, so I opened an issue: https://redmine.pfsense.org/issues/9211



  • Seeing same issue here of no country flags w/ fresh install of pfSense 2.4.4p1 and ntopng pfSense package 0.8.13_3.

    Also ran /usr/local/bin/geoipupdate.sh which refreshed GeoIP database and then was able to use geoiplookup but still no country flags in ntopng.



  • Also having the same issue. Upgrade from 2.4.3 to 2.4.4p1.
    -no country flags or ASN info in ntopng 3.6
    -tried updating with "Update GeoIP Data" on Package > Diagnostics >ntopng Settings page.

    It was working previously in 2.4.3 and ntop 3.2



  • follow, same here
    fresh install of ntopng (never used it before) and location depending options not working for hosts.
    Only my own location shown on map



  • I'm seeing the same issue. Was this submitted as a bug? What's the estimated time to fix it?


  • Rebel Alliance Netgate Administrator

    Looks like a bug was filed:
    https://redmine.pfsense.org/issues/9211



  • @asterix_cz

    I'm new to pfSense and have the same problem. No GeoIP location, no country flags, no proper ASN just 0. I did some research and just wanted to share my findings.
    Using pfSense 2.4.4-RELEASE-p2 with Ntopng Community Edition v.3.6.181116

    I manually ran the /usr/local/bin/geoipupdate.sh script and got :
    fetch: http://geolite.maxmind.com/download/geoip/database/GeoLiteCountry/GeoIP.dat.gz: Not Found

    Then I went to Maxmind website and found this article:
    https://dev.maxmind.com/release-note/discontinuation-notice-for-geolite-legacy-databases/

    It looks for me that Maxmind has ended their support and download for the legacy GeoIP data.
    The only GeoIP data you can download are the GeoLite2 data. Not sure if Ntopng is compatible with that.

    Anyway, thanks for a great and free product! I hope the GeoIP feature will get fixed soon.

    Cheers!



  • ouch..