The firewall appears to be blocking outgoing text messages from my phone ...



  • @gweempose said in The firewall appears to be blocking outgoing text messages from my phone ...:

    @NogBadTheBad said in The firewall appears to be blocking outgoing text messages from my phone ...:

    Does the WAN interface have a RFC1918 address ?

    Sorry. I forgot to answer your question. No, the WAN interface does not have an RFC1918 address. It is a standard IP address assigned by Comcast via DHCP and it starts with "67".

    As others have stated, out-of-the-box pfSense blocks nothing outbound from your LAN. It only blocks unsolicited inbound traffic on the WAN side.

    Mostly likely what is going on is Comcast is providing you with an IPv6 address. They are one of the few ISPs in the U.S. that do that now by default. Android-based devices such as your Galaxy phone don't behave well yet with IPv6 on most LANs.

    Try this to see if it helps. Go to your LAN interface settings and be sure the IPv6 address box is set to "none". Do the same on the WAN interface settings. Apply the settings in both locations. Make sure any prefix delegation settings are also turned off for IPv6 on the WAN. Disconnect and reconnect your phone to WiFi and try things again. Your phone should now be forced to use IPv4.



  • @bmeeks said in The firewall appears to be blocking outgoing text messages from my phone ...:

    @gweempose said in The firewall appears to be blocking outgoing text messages from my phone ...:

    @NogBadTheBad said in The firewall appears to be blocking outgoing text messages from my phone ...:

    Does the WAN interface have a RFC1918 address ?

    Sorry. I forgot to answer your question. No, the WAN interface does not have an RFC1918 address. It is a standard IP address assigned by Comcast via DHCP and it starts with "67".

    As others have stated, out-of-the-box pfSense blocks nothing outbound from your LAN. It only blocks unsolicited inbound traffic on the WAN side.

    Mostly likely what is going on is Comcast is providing you with an IPv6 address. They are one of the few ISPs in the U.S. that do that now by default. Android-based devices such as your Galaxy phone don't behave well yet with IPv6 on most LANs.

    Try this to see if it helps. Go to your LAN interface settings and be sure the IPv6 address box is set to "none". Do the same on the WAN interface settings. Apply the settings in both locations. Make sure any prefix delegation settings are also turned off for IPv6 on the WAN. Disconnect and reconnect your phone to WiFi and try things again. Your phone should now be forced to use IPv4.

    I will give this a try when I get home.



  • Okay, I'm not 100% sure, but it seems like turning off IPv6 solved the problem. The reason I'm a bit uncertain is because some texts actually went through before I made the change. They all seem to be going through after the change, though, so I think we found the solution.

    So are there any downsides to having IPv6 disabled for my entire network? Would it perhaps make more sense to create rules that block IPv6 traffic only from my family's cell phones?



  • @gweempose said in The firewall appears to be blocking outgoing text messages from my phone ...:

    Okay, I'm not 100% sure, but it seems like turning off IPv6 solved the problem. The reason I'm a bit uncertain is because some texts actually went through before I made the change. They all seem to be going through after the change, though, so I think we found the solution.

    So are there any downsides to having IPv6 disabled for my entire network? Would it perhaps make more sense to create rules that block IPv6 traffic only from my family's cell phones?

    There are no downsides for now to disabling IPv6 on your LAN. One day in the distant future there may exist websites that have only an IPv6 address, but that day seems to keep getting pushed into the future.

    Do not put IPv6 block rules in the firewall, though. Simply removing the ability for devices to get a routable IPv6 address on your LAN is enough.


  • Galactic Empire

    http://ipv6-test.com/ << do you get a pass here ?

    If you do I'd be tempted to keep IPv6 enabled.

    System -> Advanced -> Networking , try ticking the Prefer IPv4 over IPv6 option



  • I have IPv6 on my cell network, as well as at home. In fact, my phone is IPv6 only and uses 464XLAT to support IPv4. The problem is not IPv6. Fire up Wireshark or Packet Capture to see what's happening. If you don't know what's happening, you can't fix it.



  • @NogBadTheBad said in The firewall appears to be blocking outgoing text messages from my phone ...:

    System -> Advanced -> Networking , try ticking the Prefer IPv4 over IPv6 option

    That is only for pfSense, not for clients connected to it.

    And yes Android versions before 7 do have problems with IPv6, these are mostly related to PMTU discovery not working correct and the default MTU being to high. That also explains why connections sometimes work and sometimes not.

    So personally I would put those old Android devices on a separate VLAN without IPv6, and use IPv6 for all other LANs. But first make sure IPv6 is actually working.


  • Galactic Empire

    @Grimson said in The firewall appears to be blocking outgoing text messages from my phone ...:

    @NogBadTheBad said in The firewall appears to be blocking outgoing text messages from my phone ...:

    System -> Advanced -> Networking , try ticking the Prefer IPv4 over IPv6 option

    That is only for pfSense, not for clients connected to it.

    And yes Android versions before 7 do have problems with IPv6, these are mostly related to PMTU discovery not working correct and the default MTU being to high. That also explains why connections sometimes work and sometimes not.

    So personally I would put those old Android devices on a separate VLAN without IPv6, and use IPv6 for all other LANs. But first make sure IPv6 is actually working.

    Oh didn't realise that :)



  • @Grimson said in The firewall appears to be blocking outgoing text messages from my phone ...:

    So personally I would put those old Android devices on a separate VLAN without IPv6, and use IPv6 for all other LANs.

    This sounds like a good solution. Unfortunately, I don't have any experience with VLANs. Will my cell phones still be able to communicate with devices on the other VLAN?



  • My ISP does not offer IPv6, so I was using a Hurricane Electric tunnel for a couple of years to put IPv6 on my LAN. My Apple iOS devices worked fine with it after I got Ubiquiti WAPs that fully supported IPv6. I initially had some old hand-me-down corporate WAPs from a manufacturer I can't remember, but they did not work correctly with IPv6.

    But because of the geo-fencing stuff done by Netflix and others, and because some of my streaming devices were wanting to use IPv6, I was encountering difficulties sometimes with streaming content on my LAN. This is because many of the big streaming providers block Hurricane Electric's IP blocks because of the geo-fencing stuff. So I have, for now, disabled my IPv6 HE tunnel.



  • @bmeeks said in The firewall appears to be blocking outgoing text messages from my phone ...:

    My ISP does not offer IPv6, so I was using a Hurricane Electric tunnel for a couple of years to put IPv6 on my LAN. My Apple iOS devices worked fine with it after I got Ubiquiti WAPs that fully supported IPv6. I initially had some old hand-me-down corporate WAPs from a manufacturer I can't remember, but they did not work correctly with IPv6.

    But because of the geo-fencing stuff done by Netflix and others, and because some of my streaming devices were wanting to use IPv6, I was encountering difficulties sometimes with streaming content on my LAN. This is because many of the big streaming providers block Hurricane Electric's IP blocks because of the geo-fencing stuff. So I have, for now, disabled my IPv6 HE tunnel.

    That's exactly my story.
    WAP, IPv6, iPhone's, all of it.

    Notable difference : I did not disable he.net because I need (an IPv6) it. I'm using their access point in Paris - I'm connecting from France.
    I disabled Netflix .... and will come back when they changed their access politics. I know, this might take a while.



  • @Gertjan said in The firewall appears to be blocking outgoing text messages from my phone ...:

    @bmeeks said in The firewall appears to be blocking outgoing text messages from my phone ...:

    My ISP does not offer IPv6, so I was using a Hurricane Electric tunnel for a couple of years to put IPv6 on my LAN. My Apple iOS devices worked fine with it after I got Ubiquiti WAPs that fully supported IPv6. I initially had some old hand-me-down corporate WAPs from a manufacturer I can't remember, but they did not work correctly with IPv6.

    But because of the geo-fencing stuff done by Netflix and others, and because some of my streaming devices were wanting to use IPv6, I was encountering difficulties sometimes with streaming content on my LAN. This is because many of the big streaming providers block Hurricane Electric's IP blocks because of the geo-fencing stuff. So I have, for now, disabled my IPv6 HE tunnel.

    That's exactly my story.
    WAP, IPv6, iPhone's, all of it.

    Notable difference : I did not disable he.net because I need (an IPv6) it. I'm using their access point in Paris - I'm connecting from France.
    I disabled Netflix .... and will come back when they changed their access politics. I know, this might take a while.

    I still have my Hurricane Electric tunnel configured. I've just disabled the gif0 interface on my firewall for now and removed the IPv6 DHCPv6 scopes from my DHCP server so my local devices don't grab routable IPv6 addresses. I did not disable the protocol itself on my devices.

    The only real issue I had was a rare occasion when some dual-stack web site would not work with IPv6 but would with IPv4 (hello US Social Security site a couple of years ago ... ☹ ). Truth be told the main streaming client issues were with my grandkids trying watch Netflix cartoons on their iPads. When they wanted to watch their favorite cartoon and Netflix blocked my Hurricane Electric IPv6 network, then something had to give and that something was my IPv6 setup ... ☺ .



  • @bmeeks : You saw https://forum.netgate.com/topic/118566/netflix-and-he-net-tunnel-fixed-using-unbound-python-module ? I'm using that feature. No AAAA for netflix sites forces IPv4 access.

    @gweempose sorry for the thread jacking.



  • Funny that I found this thread because I have had the same thing at my house. My step-son's older Samsung Galaxy could not send text messages when at home on the WIFI. My wife's new Galaxy could. My Pixel could and my old Moto could as well. I never did figure out why. Maybe it is time for a second look. If it was my phone I would be going crazy trying to figure it out...but the kid? He'll survive.



  • Still, a real SMS goes over the 2G/3G/4G carrier - even is if the phone is connectioned to some second Internet source (Wifi, Bluetooth, whatever)

    edit : after the Whatapp / Telegram / Messenger : who's using SMS these days ?



  • @Gertjan said in The firewall appears to be blocking outgoing text messages from my phone ...:

    Still, a real SMS goes over the 2G/3G/4G carrier - even is if the phone is connectioned to some second Internet source (Wifi, Bluetooth, whatever)

    SMS uses WiFi, if WiFi calling is enabled.

    edit : after the Whatapp / Telegram / Messenger : who's using SMS these days ?

    What's Whatapp/Telegram/Messenger? 😉



  • @JKnott said in The firewall appears to be blocking outgoing text messages from my phone ...:

    SMS uses WiFi, if WiFi calling is enabled.

    Not every phone has wifi calling. If the OP of a thread is using wifi calling I for one would suggest that they mention that in the first post.

    I myself carry a Sonim basic 4G phone which does not have WIFI calling.. but also a tablet that gets all my sms along with my phone as a 4G only device and does get SMS over wifi. Verified yesterday in a no cell coverage basement of a building. :)



  • @chpalmer said in The firewall appears to be blocking outgoing text messages from my phone ...:

    Not every phone has wifi calling. If the OP of a thread is using wifi calling I for one would suggest that they mention that in the first post.

    I mentioned it in the second post as soon as I realized it was pertinent.



  • @gweempose said in The firewall appears to be blocking outgoing text messages from my phone ...:

    I mentioned it in the second post as soon as I realized it was pertinent.

    I see that now. And my post is in a generalization kind of way and not directed at you totally. Others that come by might benefit.

    :)

    Im wondering though if you looked at your state table to see what your phone is trying to connect to??

    Could you try static port on that particular connection to see if that helps.. My tablet seems to work out of the box on my Verizon account.



  • @chpalmer You are right


Log in to reply