Vodafone Kabel bekomme keine ipv6 auf WAN



  • Hallo, ich nutze seit Monaten PFSense und bin mega zufrieden. Leider bekomme ich vom vorgeschalteten Arris Router (natürlich Bridge) keine ipv6 an den WAN Port.

    In den Settings der WAN-Schnittstelle steht unter "IPv6 Konfigurationstyp" DHCP6. Auch das "LAN-Interface" habe ich bei "IPv6 Konfigurationstyp" auf "Ermittle Schnittstelle". Weiter unten wurde auch WAN als ipv6 Schnittstelle angegeben.

    Unter Dienste/DHCPv6 Server & RA/HEIMNETZ/Router Werbung steht der Routermodus auf Zustandloser DHCP RA- flags etc.

    Was mache ich hier falsch? Ich möchte doch nur dass meine Clients IPv6 Adressen bekommen. Ob diese jetzt nun per DHCPv6 der PFSense verwaltet werden ist mir eigentlich egal, wäre schön,- aber kein Muss.

    Danke!


  • Rebel Alliance Moderator

    @dwoderso said in Vodafone Kabel bekomme keine ipv6 auf WAN:

    Unter Dienste/DHCPv6 Server & RA/HEIMNETZ/Router Werbung steht der Routermodus auf Zustandloser DHCP RA- flags etc.

    OK kleine Seitennotiz: Teilweise ist die deutsche Übersetzung wirklich freakin' gruselig. Router Werbung? Ernsthaft?

    Was mache ich hier falsch? Ich möchte doch nur dass meine Clients IPv6 Adressen bekommen. Ob diese jetzt nun per DHCPv6 der PFSense verwaltet werden ist mir eigentlich egal, wäre schön,- aber kein Muss.

    Du bist schon viel weiter als du eigentlich erstmal checken solltest. Aller interner Kram mit LAN auf Tracking Interface und DHCP6 Server etc. blabla ist schon überflüssig, wenn auf dem WAN kein v6 ankommt. Daher erstmal:

    1. Kommt auf WAN überhaupt eine v6 Verbindung zustande?
    2. Wenn ja, gibt es eine entsprechende v6 Adresse mit - wahrscheinlich - /64er Prefix
    3. Wenn ja, gibt es ein zugewiesenes Prefix zum Weiterrouten? Meist /56
    4. Wie ist die WAN Schnittstelle für v6 konfiguriert?
    5. Geht ein Diagnostic/Ping via v6 auf ipv6.google.com?

    Bevor das nicht alles passt, brauchst du dir wegen Clients noch überhaupt keinen Kopf zerbrechen, die werden vorher nicht funktionieren. Verwaltet werden die Adressen dann aber meistens eh nicht auf der pfSense. Du wirst lediglich ein /64er Prefix durch Tracking auf dein LAN bekommen, mit Stateless Assisted DHCP6 gibst du DNS und NTP noch an Clients raus und ansonsten machen das die Clients mit SLAAC automatisch und autonom, sobald die ein v6 Prefix im Netz annonciert bekommen. Aber erstmal die WAN Seite lauffähig bekommen.

    Gruß Jens



  • Danke für die ausführliche Antwort.

    Ich denke es ist besser am Anfang anzufangen wie du bereits geschrieben hast.

    Zu 1. Nein auf dem Interface kommt vom Bridge-Router nicht einmal eine IPv6 Adresse rein. Dort gibt es nur eine IPv4.

    Wie kann ich das erzwingen? Ich hatte mal gelesen, dass WAN keine IPv6 annimmt wenn der Rest im LAN nicht konfiguriert ist.


  • Rebel Alliance Moderator

    @dwoderso said in Vodafone Kabel bekomme keine ipv6 auf WAN:

    Zu 1. Nein auf dem Interface kommt vom Bridge-Router nicht einmal eine IPv6 Adresse rein. Dort gibt es nur eine IPv4.

    Dann ist das schonmal der Knackpunkt.

    Wie kann ich das erzwingen? Ich hatte mal gelesen, dass WAN keine IPv6 annimmt wenn der Rest im LAN nicht konfiguriert ist.

    Davon ist mir nichts bekannt, das halte ich für quatsch. WAN bekommt entweder v6 oder nicht. Ob und was da auf dem LAN konfiguriert ist, ist völlig schnuppe. Dein WAN mit v4 juckt es ja auch primär nicht ob du da schon dein LAN dran hast oder nicht. Er wählt sich ein und gut.

    Bitte wie gesagt mal WAN v6 Konfiguration zeigen (Interface Einstellung).



  • Hier die komplette WAN-Konfig

    1.JPG

    Dort steht DHCP6 schon drin. Mehr kann man doch da gar nicht einstellen oder? ;-)


  • Rebel Alliance Moderator

    @dwoderso said in Vodafone Kabel bekomme keine ipv6 auf WAN:

    Dort steht DHCP6 schon drin. Mehr kann man doch da gar nicht einstellen oder? ;-)

    Natürlich. Alles was unten bei "DHCP6 Client Konfiguration" steht sind Optionen, die je nach Hersteller, ISP oder Verbindung gesetzt oder nicht werden müssen. Da ist schonmal der erste Fehler drin, denn im Normalfall geben DSL und Kabelanbieter ein 56er Prefix raus, kein 64er, damit der Kunde intern genug Netze adressieren kann. Da wäre also mein Tipp eher auf 60 oder 56 einzustellen. Dazu den Prefix Hint senden, ist OK, ich würde aber den RA Haken erstmal rausnehmen, nicht jeder braucht den und bislang arbeiteten alle ISPs ohne den ganz OK. Somit mal wie gesagt mit /56 Delegation Size und Send Prefix Hint speichern und testen.

    Der ARIS ist definitiv im Bridge Mode?



  • Erstmal DANKE für die Hilfe!!!

    Ich habe nun also den Präfix auf 56 gestellt und bei " Warte nicht auf ein RA" den Hacken entfernt.

    Ja der Arris ist defenitiv im Bridge-Modus. Bekomme ja auf IPv4 an PFSense eine öffentliche IP statt eine lokale. Auch im Kundencenter von Vodafone ist dies so konfiguriert.

    Bisher ist noch keine IPv6 da. Ich werd mal den ganzen Schmuh hier runterfahren und auch den Arris komplett Neustarten,

    Ich werde berichten, obs geklappt hat.



  • Leider auch nach komplettem Neustart keine ipv6 Adresse an der WAN Schnittstelle ;-(


  • Rebel Alliance Moderator

    Evtl. könnte das bei Vodafone notwendig sein:

    Hake mal den "IPv6 über IPv4 beziehen" Haken mit an, speichern und dann mal auf Status/Interfaces den Output des WANs beobachten (anderer Tab ggf. geht schneller). Wenn nicht, den mal wieder raus und den darunter "Nur Prefix anfordern aber keine Adresse" rein und nochmal speichern und versuchen. Mitunter ists nicht ganz klar, welcher ISP was gerne möchte, man bekommt es aber "rausgespielt". Evtl. ist ja ein KD/Vodafone Kabel Kunde unter uns und kann da helfen. Bei Unitymedia genügt die Einstellung von weiter oben, die ich beschrieben hatte um das ans Laufen zu bekommen.



  • Ok habe das auch mal mit den Häckchen probiert. Leider auch keine Besserung.

    Hier mal ein Screenshot von dem 6 über 4 Beziehen:
    1.JPG

    Hier ein Screenshot von dem "Nur Präfix keine Adresse":
    2.JPG

    Bei beidem gibt es nur fe80 zu sehen, leider keine hübsche ipv6 ;-)

    Ich hoffe das geht irgendwann. Wäre dankbar wenn evtl. ein Vodafonekunde mal seine Konfig posten könnte. Evtl ist ja noch irgend ein Hackchen falsch ;-(



  • So wirst Du auch keine IPv6 Adresse bei Vodafone im Kabelnetz bekommen. Entweder Du besorgst Dir ein "richtiges" Modem (TC4400) oder musst die Option feste IP buchen. Dann gibt's auch erst IPv6.



  • Das wäre mir ja komplett neu

    1. Vodafone verteilt ipv6 wo es nur geht und ipv4 nur wenn man bettelt.
      Wieso bei mit aufeinmal komplett andersrum?!?

    2. Was hat die Adressvergabe mit dem Modem zu tun?

    3. Habe schon mehrfach im „inoffiziellen Kabelforum“ gelesen, dass die Leute dort mit dem Arris auch ipv6 bekommen haben, allerdings im Routermodus statt Bridge. Wo ist da denn der Unterschied in der Adressvergabe?

    Deine Antwort kann ich so also überhaupt nicht nachvollziehen. Wenn dem so ist, kann man das irgendwo nachlesen/erfragen? Ich lern ja gern dazu ;-)



  • @Elektronick

    Leider stimmt deine Aussage ;-) Auch wenn das für mich absolut keinen Sinn ergibt ;-)

    Hier der Link zum offiziellen Vodafone Forum wo mir diese Infos so bestätigt wurden:
    https://forum.vodafone.de/t5/Internet-Geräte/Erhalte-keine-ipv6-über-Bridge-Modus-an-PFSense-mit-Arris-Router/m-p/1948863/highlight/false#M98405

    Ergibt zwar keinen Sinn, denn alle Kunden werden DS-Lite zwangsversorgt um mit der ipv4 Knappheit klarzukommen. Aber wenn ich freiwillig zusätzlich zu der "netterweise" zugeordneten ipv4 auch das (verramschte) ipv6 haben will dann gehts nicht -weil ist einfach so ;-)

    Schwache Nummer von Vodafone! Danke trotzdem für eure Hilfe und Danke an @Elektronick an die "doofe" aber leider richtige Antwort ;-)



  • @dwoderso
    Ich verstehe Dein Unverständnis und Ärger über die IP-Vergabe bei Vodafone. Wenn Du echtes DS haben möchtest, gibt es für Dich zwei Optionen. Entweder in einen Business Tarif wechseln und für 5 Euro extra die Option feste IP buchen oder eins der wenigen freien Modems, die es am Markt gibt, kaufen.


Log in to reply