tercera interface



  • Hola, tengo un pfsense montado en un host ESXi. Tengo configuradas dos tarjetas de red ( una para WAN y otra para LAN) y funciona correctamente. El problema es que quiero añdir otra tarjeta de red con la idea de redirigir todo el trafico VPN. Si la VPN va por el puerto XX pues redirigir todo a una interfaz y si va por YY redirigirlo a otra interface.
    El problema es que en la maquina virtual le añado la interface sin problemas, pero pfsense no me reconoce la tercera interfaz, y no se si me falta algun paso o es una limitacion de la version community.

    Gracias!



  • Menu Interfaces -> Assignements, ahi seleccionas las tarjetas reconocidas.



  • @trasher-mx El problema es que no me aparece la interface



  • Revisa el driver que le estas enviando, posiblemente este emulando un driver que pfsense no soporta, revisa las demas interfaces que tienes y ser si son los mismo drivers.

    Saludos.



  • @periko los tres drivers son VMXNET3



  • @atreyumu en tu consola ejecuta: pciconf -l muestra la pantalla que te arroja, ahi te dice todas las interfaces que pfsense detecta, saludos.



  • Hola, esto es lo que me arroja.
    comando.PNG



  • @atreyumu segun veo pfsense solo esta reconociendo 2 interfaces? vmx0 y vmx1.
    No logro ver la 3ra, los demas drivers creo que no son interfaces de red, aun asi los puedes buscar.

    En la pantalla de pfsense donde estas las interfaces el pone a u lado que driver detecta para cada tarjeta, de las que reconoce asi las ve realmente el kernel.

    foro1.png

    Recuerda que viene de freebsd, si tienes dudas de algun driver como mi ejemplo, mis interfaces son igb, en google si busco que es: freebsd man pages igb

    Y me arrojara la info de ese controlador y es una tarjeta de red Intel Pro 1000(1GB).

    Mas info:

    freebsd man pages

    En resumen no parece que el host no le esta enviando la 3er interfaz a esta vm, quedamos a la espero para ver si logras ver por donde esta el enbotellamiento, saludos.



  • Puede que lo que te escriba, no aplique en tu caso, pero utilizo para mis pruebas ProxMox y cuando creo una interfaz virtual, debo activarla, de lo contrario, va a ser como que no existe.

    Es algo sencillo, pero puede que en ESXi sea similar. Revisa en la creación de la interfaz a ver que opciones te aparecen y las comparas con las ya creadas y reconocidas.



  • gracias.
    Esto es lo que tengo, tanto en el pfsense como en el vmare. El driver es el mismo.
    interf pfsense.PNG VMware1.PNG VMware2.PNG



  • @atreyumu vmware tiene mas drivers disponibles, creo que tiene e1000, prueba con otros que tengas a la mano, saludos.!!!



  • @periko Es lo primero que hice, y tengo el mismo resultado. Entiendo que la versión comunity no tiene restricción de interfaces ,¿ no?



  • @atreyumu desconzco, ahi ya es alguien que ejecute pfsense bajo vmware o bien checar en los foros de ellos si tiene limitantes.

    Lo que veo en otros post es que cuando hacen esos cambios, apagan la vm, no la reinician, no se si sea tu caso, saludos.



  • @periko he reiniciado y apagado la máquina, pero sigo igual.
    He estado buscando pero no he encontrado nada en la documentación al respecto.



  • @atreyumu te recomendaria entrar a el foro de vmware y exponer tu caso, al menos que alguien mas aqui tenga experiencia con esta aplicacion, saludos.


Log in to reply