Wireless interface iwm0 not showing in GUI?

  • With the pandemic making me work from home and some recent outages I have been trying to find a way to get failover internet...the obvious thing (to me) is my travel cellular MiFi/Jetpack gets a little signal in one particular window and if I could connect the WiFi card in my pfSense router to the MiFi I could have a 2nd WAN and do failover.

    After the 2.4.5_p1 update adding the kernel modules the Intel(R) Dual Band Wireless AC 8260 card now shows as iwm0 in the terminal (a step forward!) but iwm0 is not listed in the GUI to pick for setting up a wireless device.

    From dmesg:

    iwm0: <Intel(R) Dual Band Wireless AC 8260> mem 0xfe900000-0xfe901fff irq 40 at device 0.0 on pci3
    iwm0: SecBoot CPU1 Status: 0x3090001, CPU2 Status: 0x0
    iwm0: Failed to start INIT ucode: 35

    pciconf -lv tells me:

    iwm0@pci0:3:0:0:	class=0x028000 card=0x10108086 chip=0x24f38086 rev=0x3a hdr=0x00
        vendor     = 'Intel Corporation'
        device     = 'Wireless 8260'
        class      = network

    But trying to add iwm0 I don't see it were I expect:

    Anyone have suggestions how to troubleshoot this?

  • I have exactly the same issue.

    iwm0: <Intel(R) Dual Band Wireless AC 8260> mem 0xdf000000-0xdf001fff irq 17 at device 0.0 on pci4
    iwm0: SecBoot CPU1 Status: 0x3090001, CPU2 Status: 0x0
    iwm0: Failed to start INIT ucode: 35

    Tried to load the firmware through rc.conf.local and loader.conf.local. But that did nothing.


  • LAYER 8

    the problem is
    iwm0: Failed to start INIT ucode: 35

    for some reason is not loading the firmware

    but they have built it into the kernel

    imho it would have been better to compile them out as modules instead

    nothing else on dmesg ?

  • No nothing else. I've checked the /var/log files as well, but nothing there either.

  • LAYER 8

  • Netgate Administrator

    Hmm, odd that it doesn't appear in the list in the gui even though it does appear as an interface and is present here:

    That initialisation error looks like a show stopper but...

    Have you tried configuring or querying the interface directly?

    Does it show in the output of sysctl net.wlan.devices?


  • No it does not show....


  • Netgate Administrator

    @Cypher87 said in Wireless interface iwm0 not showing in GUI?:

    iwm0: Failed to start INIT ucode: 35

    Hmm, the iwm8000 firmware is the last one to load I wonder if that is failing? Testing....

  • Netgate Administrator

    Nope looks OK in 2.4.5p1:

    Jun 20 22:22:48 	kernel 		firmware: 'iwm3160fw' version 0: 918268 bytes loaded at 0xffffffff82026e90
    Jun 20 22:22:48 	kernel 		firmware: 'iwm7260fw' version 0: 1049340 bytes loaded at 0xffffffff82107240
    Jun 20 22:22:48 	kernel 		firmware: 'iwm7265fw' version 0: 1180412 bytes loaded at 0xffffffff822075f0
    Jun 20 22:22:48 	kernel 		firmware: 'iwm7265Dfw' version 0: 1383604 bytes loaded at 0xffffffff823279a0
    Jun 20 22:22:48 	kernel 		firmware: 'iwm8000Cfw' version 0: 2390316 bytes loaded at 0xffffffff82479708
    Jun 20 22:22:48 	kernel 		firmware: 'iwm8265fw' version 0: 1811984 bytes loaded at 0xffffffff826c10e8 

  • Anything else I can do to help diagnose this issue?

  • @stephenw10
    what command were you running to get that list?

    Still in the same boat here...about the only thing I haven't done is a total reinstall from scratch. I've rebooted and powered fully off and reseated stuff...

  • I did just notice something on my prompt...is there a way to 100% verify that it's booted the new/current kernel and not a previous one when it reboots after the install?

    While the homepage says 2.4.5-p1 doing uname -a just says 2.4.5, I'm unsure if this is expected or not.

    [2.4.5-RELEASE][root@pfSense.apt]/root: uname -a
    FreeBSD pfSense.apt 11.3-STABLE FreeBSD 11.3-STABLE #243 abf8cba50ce(RELENG_2_4_5): Tue Jun  2 17:53:37 EDT 2020     root@buildbot1-nyi.netgate.com:/build/ce-crossbuild-245/obj/amd64/YNx4Qq3j/build/ce-crossbuild-245/sources/FreeBSD-src/sys/pfSense  amd64


  • Netgate Administrator

    Yeah, uname -a reports the June 2nd build. That is correct.

    I booted in verbose mode to see the firmware load list. Add boot_verbose="YES" to /boot/loader.conf.local.


  • Ok, booting with that I see those but still no joy.

    [2.4.5-RELEASE][root@pfSense.apt]/root: grep iwm /var/log/*
    /var/log/dmesg.boot:firmware: 'iwm7265Dfw' version 0: 1383604 bytes loaded at 0xffffffff823279a0
    /var/log/dmesg.boot:firmware: 'iwm8000Cfw' version 0: 2390316 bytes loaded at 0xffffffff82479708
    /var/log/dmesg.boot:firmware: 'iwm8265fw' version 0: 1811984 bytes loaded at 0xffffffff826c10e8
    /var/log/dmesg.boot:firmware: 'iwm3160fw' version 0: 918268 bytes loaded at 0xffffffff82026e90
    /var/log/dmesg.boot:firmware: 'iwm7260fw' version 0: 1049340 bytes loaded at 0xffffffff82107240
    /var/log/dmesg.boot:firmware: 'iwm7265fw' version 0: 1180412 bytes loaded at 0xffffffff822075f0
    /var/log/dmesg.boot:iwm0: <Intel(R) Dual Band Wireless AC 8260> mem 0xfe900000-0xfe901fff irq 40 at device 0.0 on pci3
    /var/log/dmesg.boot:iwm0: attempting to allocate 1 MSI vectors (1 supported)
    /var/log/dmesg.boot:iwm0: using IRQ 271 for MSI
    /var/log/dmesg.boot:random: harvesting attach, 8 bytes (4 bits) from iwm0
    /var/log/dmesg.boot:iwm0: SecBoot CPU1 Status: 0x3090001, CPU2 Status: 0x0
    /var/log/dmesg.boot:iwm0: Failed to start INIT ucode: 35

    Any ideas what else to try? I was reminded to check back when my ISP went out for a few hours again in another storm...

  • Netgate Administrator

    Hmm, it sure looks like this: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=229138

    Are you able to test FreeBSD 11.3 directly? It looks like an upstream bug.

    If not maybe try pfSense 2.5 which is built on FreeBSD 12.1 currently.


  • @stephenw10 Hmmm, I'll have to see if there is a FreeBSD LiveCD to try (never looked before) if so I could do a test.

    I've actually seen that bug report in my searches but was unsure if it still applied with my understanding that pfSense 2.4.5-p1 was based on FreeBSD 11.3 (I think I read that somewhere?).

    I'll see what I can do to test FreeBSD 11.3 and 12.1 to see if the wireless card will initialize properly and report back. May be a bit, can't afford to take the router offline while I'm work from home and my roomate doesn't like when I break the whole-home-lab when they are trying to surf the web...but I do want to do anything possible to figure this out, just takes longer if I have to dismantle more stuff and swap disks out.

  • Netgate Administrator

    I'll see if I can get hold of one to test with.

  • It does look like the FreeBSD DVD download offers a LiveCD option after selecting single/multi user mode when I tested a VM just now. I'll download a few versions and see if I can test to see what happens and report back. I'm downloading 11.3, 11.4, 12.1 DVD ISO versions to try. A 9AM meeting I had was cancelled so I may be able to do a quick reboot this morning and try stuff, I'm reasonably confident a LiveCD can't hurt anything and pfSense has proven reliable booting back up as long as I don't have to unhook or change hardware.

    If there are any specific commands that would be especially helpful for me to run and capture output of let me know and I'll try to do that, otherwise I think I'm just looking to see that the wireless card is "alive" and initialized.

  • Small update, I did a few tests but I'm apparently not sufficiently educated in FreeBSD command line operation yet, have to read up more and try again. My initial test was inconclusive/inconsistent on 11.x and looked like it was going to work on 12.1.

    I ran out of time to do any more experimenting with 11.x this morning, probably not the rest of today (I'll see).

    11.3...was not showing iwm0 when I checked dmesg or logs, didn't show anything in net.wlan.devices.
    11.4...showed iwm0 in the dmesg (but not logs?) didn't show anything in net.wlan.devices. Another reboot it did show iwm0 in dmesg. Unsure what I did different, I need to make a script or something to be consistent in what I do.
    12.1...showed iwm0 in dmesg and logs. Revisited after more research and it was showing iwm0 in net.wlan.devices. Once I manually ran ifconfig wlan0 create wlandev iwm0 it showed wlan0 in ifconfig but I don't yet know the command to scan for networks to prove it's alive.

    I think I'd like to try and come up with a list (or script) of commands to run and capture the output to a textfile on removable media so I can report back more accurate findings. Maybe also run it twice each version to prove it's repeatable.

    I'm open to suggestions of commands to dump any logs/information you think might be useful...

  • Netgate Administrator

    Yeah just check that it appears and is seen as a wireless device.
    So sysctl net.wlan.devices

    Check the boot log for something like the line shown in that bug report:

    iwm0: hw rev 0x200, fw ver 22.361476.0, address  b8:8a:60:xx:xx:xx

    Which I assume shows if you don't get that error.

    You may need to kldload the driver and/or firmware. pfSense has it all in-kernel but FreeBSD usually doesn't.


  • @stephenw10 Gave it a few tries during lunch and got consistent results this time multiple boots in a row.

    FreeBSD 11.3/11.4 do the exact same thing pfSense 2.4.5-p1 is doing.
    FreeBSD 12.1 appears to work properly.

    I did not attempt to "sideload" anything, just booted up livecd, got to a root shell, and typed the commands. I think my prior inconsistency was some glitch with the USB CD-ROM I was using to boot from or cycling power too fast.

    I've attempted to attach photos of the terminal for each (with my finger pointing at the uname line showing which version is booted)


  • Netgate Administrator

    Huh, well that's interesting. Still shows those errors even when it works.

    Try a pfSense 2.5 snapshot then, that should also work.


    Hmm, that page needs updating, snapshots are built on 12.1-stable now.


  • Good catch - I'm glad I posted the pictures (was debating) because I missed that the suspect error message showed even on 12.1 where it appears to work properly.

    I'll have to read a bit on the snapshots and pfSense 2.5, see how hard it would be to "roll back" if needed and what potential issues I may run into unless there's a way to do a "live boot" test that I am unaware of without affecting the installed version. Or maybe I can try to do the install on a USB thumbdrive and change the boot order so if it goes badly I can just yank the thumbdrive and reboot to get online.

  • Netgate Administrator

    Yup you would need to reinstall to go back to 2.4.5.

    Yes, you can install from one usb drive to another one and boot from that. Boot time will be less that stellar but it will work as test. You might want to enable ram disks after boot to cut down writes to the drive.


  • @stephenw10 Is there any way to get an ISO for the 2.5.0 builds?

    I've tried a few times to use the memstick install but it keeps hanging when it tries to load the installer...I know I've had a lot of issues in general with USB booting. Somehow even a USB DVD-ROM is far more reliable.

  • Ah, ok - got that to work, and after installing on a USB drive it's seeing the wireless card on the GUI.

    And after it finished setting up the new install, I added the new interface, set up the WiFi options, and it worked. Only "gotya" is I forgot to tick the box for enabling WPA so it wasn't connecting...but once I corrected my mistake it came right up with 2.5.0-Development snapshot.

    And without going to the trouble of reconfiguring everything, here's a quicky test from command line showing the interface status and PING over the pfSense WLAN interface to my cellular data card...

    Still no idea why 2.4.5-p1 doesn't behave with my Intel 8000 Wireless card with the drivers built into it but it's good to know it will likely work fine on 2.5.0 unless something changes. Now I guess I'll have to think long and hard if I want to risk moving the whole home network up to development/experimental builds or accept that my redundant WiFi WAN probably can't work until 2.5.0 comes out stable.

Log in to reply