Latest 1.2.3-20091106-2354 Randomly reboots



  • hello,

    I am not sure which update this issue started, but the last couple of snapshots is causing my system to reboot periodically. Would someone help me track down the problem to figure why this is happening?  What log files should I be looking at?  Thanks!

    Copyright © 1992-2009 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
            The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 7.2-RELEASE-p4 #0: Fri Nov  6 23:04:46 EST 2009
        sullrich@FreeBSD_7.2_pfSense_1.2.3_snaps.pfsense.org:/usr/obj.pfSense/usr/pfSensesrc/src/sys/pfSense_SMP.7
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: VIA Nehemiah (1333.39-MHz 686-class CPU)
      Origin = "CentaurHauls"  Id = 0x698  Stepping = 8
      Features=0x381b83f <fpu,vme,de,pse,tsc,msr,sep,mtrr,pge,cmov,pat,mmx,fxsr,sse>VIA Padlock Features=0xdd <rng,aes>real memory  = 469696512 (447 MB)
    avail memory = 445509632 (424 MB)
    wlan: mac acl policy registered
    kbd1 at kbdmux0
    ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
    cryptosoft0: <software crypto="">on motherboard
    padlock0: <aes-cbc>on motherboard
    acpi0: <cn400 awrdacpi="">on motherboard
    acpi0: [ITHREAD]
    acpi0: Power Button (fixed)
    acpi0: reservation of 0, a0000 (3) failed
    acpi0: reservation of 100000, 1bef0000 (3) failed
    Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
    acpi_button0: <power button="">on acpi0
    acpi_button1: <sleep button="">on acpi0
    pcib0: <acpi host-pci="" bridge="">port 0xcf8-0xcff on acpi0
    pci0: <acpi pci="" bus="">on pcib0
    agp0: <via pm800="" pn800="" pm880="" pn880="" host="" to="" pci="" bridge="">on hostb0
    agp0: aperture size is 128M
    pcib1: <pci-pci bridge="">at device 1.0 on pci0
    pci1: <pci bus="">on pcib1
    vgapci0: <vga-compatible display="">mem 0xe8000000-0xebffffff,0xec000000-0xecffffff irq 12 at device 0.0 on pci1
    fwohci0: <via fire="" ii="" (vt6306)="">port 0xec00-0xec7f mem 0xee102000-0xee1027ff irq 10 at device 13.0 on pci0
    fwohci0: [FILTER]
    fwohci0: OHCI version 1.0 (ROM=1)
    fwohci0: No. of Isochronous channels is 4.
    fwohci0: EUI64 00:40:63:50:00:05:10:a2
    fwohci0: Phy 1394a available S400, 2 ports.
    fwohci0: Link S400, max_rec 2048 bytes.
    firewire0: <ieee1394(firewire) bus="">on fwohci0
    fwe0: <ethernet over="" firewire="">on firewire0
    if_fwe0: Fake Ethernet address: 02:40:63:05:10:a2
    fwe0: Ethernet address: 02:40:63:05:10:a2
    fwip0: <ip over="" firewire="">on firewire0
    fwip0: Firewire address: 00:40:63:50:00:05:10:a2 @ 0xfffe00000000, S400, maxrec 2048
    sbp0: <sbp-2 scsi="" over="" firewire="">on firewire0
    dcons_crom0: <dcons configuration="" rom="">on firewire0
    dcons_crom0: bus_addr 0x1150000
    fwohci0: Initiate bus reset
    fwohci0: BUS reset
    fwohci0: node_id=0xc800ffc0, gen=1, CYCLEMASTER mode
    atapci0: <via 8237="" udma133="" controller="">port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xd000-0xd00f at device 15.0 on pci0
    ata0: <ata 0="" channel="">on atapci0
    ata0: [ITHREAD]
    ata1: <ata 1="" channel="">on atapci0
    ata1: [ITHREAD]
    uhci0: <via 83c572="" usb="" controller="">port 0xd400-0xd41f irq 12 at device 16.0 on pci0
    uhci0: [GIANT-LOCKED]
    uhci0: [ITHREAD]
    usb0: <via 83c572="" usb="" controller="">on uhci0
    usb0: USB revision 1.0
    uhub0: <via 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb0
    uhub0: 2 ports with 2 removable, self powered
    uhci1: <via 83c572="" usb="" controller="">port 0xd800-0xd81f irq 12 at device 16.1 on pci0
    uhci1: [GIANT-LOCKED]
    uhci1: [ITHREAD]
    usb1: <via 83c572="" usb="" controller="">on uhci1
    usb1: USB revision 1.0
    uhub1: <via 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb1
    uhub1: 2 ports with 2 removable, self powered
    uhci2: <via 83c572="" usb="" controller="">port 0xdc00-0xdc1f irq 10 at device 16.2 on pci0
    uhci2: [GIANT-LOCKED]
    uhci2: [ITHREAD]
    usb2: <via 83c572="" usb="" controller="">on uhci2
    usb2: USB revision 1.0
    uhub2: <via 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb2
    uhub2: 2 ports with 2 removable, self powered
    uhci3: <via 83c572="" usb="" controller="">port 0xe000-0xe01f irq 10 at device 16.3 on pci0
    uhci3: [GIANT-LOCKED]
    uhci3: [ITHREAD]
    usb3: <via 83c572="" usb="" controller="">on uhci3
    usb3: USB revision 1.0
    uhub3: <via 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb3
    uhub3: 2 ports with 2 removable, self powered
    ehci0: <via vt6202="" usb="" 2.0="" controller="">mem 0xee100000-0xee1000ff irq 11 at device 16.4 on pci0
    ehci0: [GIANT-LOCKED]
    ehci0: [ITHREAD]
    usb4: EHCI version 1.0
    usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3
    usb4: <via vt6202="" usb="" 2.0="" controller="">on ehci0
    usb4: USB revision 2.0
    uhub4: <via 1="" 9="" ehci="" root="" hub,="" class="" 0,="" rev="" 2.00="" 1.00,="" addr="">on usb4
    uhub4: 8 ports with 8 removable, self powered
    isab0: <pci-isa bridge="">at device 17.0 on pci0
    isa0: <isa bus="">on isab0
    vr0: <via 10="" vt6102="" rhine="" ii="" 100basetx="">port 0xe800-0xe8ff mem 0xee101000-0xee1010ff irq 12 at device 18.0 on pci0
    vr0: Quirks: 0x0
    vr0: Revision: 0x78
    miibus0: <mii bus="">on vr0
    ukphy0: <generic ieee="" 802.3u="" media="" interface="">PHY 1 on miibus0
    ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    vr0: Ethernet address: 00:40:63:df:04:12
    vr0: [ITHREAD]
    pcib2: <pci-pci bridge="">at device 20.0 on pci0
    pci2: <pci bus="">on pcib2
    sis0: <natsemi 10="" dp8381[56]="" 100basetx="">port 0xc000-0xc0ff mem 0xee010000-0xee010fff irq 10 at device 0.0 on pci2
    sis0: Silicon Revision: DP83816A
    miibus1: <mii bus="">on sis0
    nsphyter0: <dp83815 10="" 100="" media="" interface="">PHY 0 on miibus1
    nsphyter0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    sis0: Ethernet address: 00:00:24:c4:5c:20
    sis0: [ITHREAD]
    sis1: <natsemi 10="" dp8381[56]="" 100basetx="">port 0xc400-0xc4ff mem 0xee011000-0xee011fff irq 11 at device 1.0 on pci2
    sis1: Silicon Revision: DP83816A
    miibus2: <mii bus="">on sis1
    nsphyter1: <dp83815 10="" 100="" media="" interface="">PHY 0 on miibus2
    nsphyter1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    sis1: Ethernet address: 00:00:24:c4:5c:21
    sis1: [ITHREAD]
    acpi_tz0: <thermal zone="">on acpi0
    speaker0: <pc speaker="">port 0x61 on acpi0
    sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
    sio0: type 16550A
    sio0: [FILTER]
    sio1: <16550A-compatible COM port> port 0x2f8-0x2ff irq 3 on acpi0
    sio1: type 16550A
    sio1: [FILTER]
    atkbdc0: <keyboard controller="" (i8042)="">port 0x60,0x64 irq 1 on acpi0
    atkbd0: <at keyboard="">irq 1 on atkbdc0
    kbd0 at atkbd0
    atkbd0: [GIANT-LOCKED]
    atkbd0: [ITHREAD]
    cpu0: <acpi cpu="">on acpi0
    acpi_throttle0: <acpi cpu="" throttling="">on cpu0
    pmtimer0 on isa0
    ppc0: parallel port not found.
    sc0: <system console="">at flags 0x100 on isa0
    sc0: VGA <16 virtual consoles, flags=0x300>
    vga0: <generic isa="" vga="">at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
    Timecounter "TSC" frequency 1333392585 Hz quality 800
    Timecounters tick every 1.000 msec
    IPsec: Initialized Security Association Processing.
    firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
    firewire0: bus manager 0 (me)
    acpi_tz0: _TMP value is absurd, ignored (-247.7C)
    acpi_tz0: _TMP value is absurd, ignored (-247.7C)
    acpi_tz0: _TMP value is absurd, ignored (-247.7C)
    acpi_tz0: _TMP value is absurd, ignored (-247.7C)
    acpi_tz0: _TMP value is absurd, ignored (-247.7C)
    ad0: DMA limited to UDMA33, device found non-ATA66 cable
    ad0: 57220MB <ic35l060avv207 0="" v22oa66a="">at ata0-master UDMA33
    Trying to mount root from ufs:/dev/ad0s1a
    WARNING: / was not properly dismounted
    WARNING: R/W mount of / denied.  Filesystem is not clean - run fsck
    WARNING: R/W mount of / denied.  Filesystem is not clean - run fsck
    acpi_tz0: _TMP value is absurd, ignored (-247.7C)
    acpi_tz0: _TMP value is absurd, ignored (-247.7C)
    sis0: link state changed to UP
    vr0: link state changed to UP
    sis1: link state changed to UP
    bridge0: Ethernet address: 66:5f:de:63:e7:2d
    vr0: promiscuous mode enabled
    acpi_tz0: _TMP value is absurd, ignored (-247.7C)
    pflog0: promiscuous mode enabled</ic35l060avv207></generic></system></acpi></acpi></at></keyboard></pc></thermal></dp83815></mii></natsemi></dp83815></mii></natsemi></pci></pci-pci></generic></mii></via></isa></pci-isa></via></via></via></via></via></via></via></via></via></via></via></via></via></via></via></ata></ata></via></dcons></sbp-2></ip></ethernet></ieee1394(firewire)></via></vga-compatible></pci></pci-pci></via></acpi></acpi></sleep></power></cn400></aes-cbc></software></rng,aes></fpu,vme,de,pse,tsc,msr,sep,mtrr,pge,cmov,pat,mmx,fxsr,sse>



  • Upgrade the BIOS first, there is an update available for that platform that gets rid of the BIOS bug that causes the "tmp value absurd" message. I'm not sure what else that might fix, but it could be related.



  • Thanks for the reply.  This is a Via C3 SP13000.  The bios is revision 1.04 - although I updated with 1.07, the issue persists with the acpi hardware polling.  Last update was 2005 - so I doubt I'll get anything newer at this point.

    I've appended this to sysctrl.conf:

    hw.acpi.thermal.polling_rate=0

    To disable that feature.  The system still reboots though.



  • I have had this problem and rolled back to RC1 which has fixed the issue. I am using http://linitx.com/viewproduct.php?prodid=11714. At first I thought is was bad memory as I got paging errors but mem test came clean, and a roll back sorted.

    I haven't gone back to RC3 as yet test test it again.



  • Is it possible that the re-introduction of the padlock driver is causing this?

    http://forum.pfsense.org/index.php/topic,19818.0.html

    Whatever it is, I rather suspect that it is related to the Via platform - I follow the snapshots closely with other systems, and only the Via C3 box is rebooting.  Snapshots from 2 months ago were stable.


  • Rebel Alliance Developer Netgate

    If you're curious, I have an image up that only differs from RC3 in that it has padlock enabled.

    http://pingle.org/files/pfSense-Full-Update-1.2.3-RC3-padlock.tgz

    I don't have an equivalent without padlock though.



  • Its beautiful now - no reboots in the last 12 hours (it was happening every 2 hours approx). It makes me wonder what has changed  - was it at all related to padlock, or just a coincidence?


  • Rebel Alliance Developer Netgate

    No reboots with the same image you had? Or with the image I posted?



  • No reboots with your RC3 + padlock you posted - thanks


  • Rebel Alliance Developer Netgate

    Ok, so it's probably not padlock then. Perhaps some other change since I built that one, or a bad builder run of some kind.



  • As a side note - Are there any plans to have padlock enabled (package added) to 1.2.3-Release?


  • Rebel Alliance Developer Netgate

    Padlock should already be back in current snapshots of 1.2.3. It was added back a week or so ago.



  • I will do some tests with my system but I ran kldstat and I don't see the padlock driver being list although I am a novice so not sure if this is right.

    I am running 1.2.3 RC3 so I will see if the reboot kicks back in.



  • 1.2.3-RC3 build 7/11/09 still reboots.



  • @Jonb:

    I ran kldstat and I don't see the padlock driver being list  . . ..

    I expect that, in common with other drivers, the padlock driver is built into the kernel.



  • I have put the firmware listed above and it works fine but the latest snapshot doesn't.



  • Yes but not to sure on the build differences to cause a reboot.



  • Does any of the Devs know what is causing this.


  • Rebel Alliance Developer Netgate

    I'm not sure anyone has even reproduced it, let alone knows what is causing it on your hardware.



  • I was wondering if there has been a driver change.


  • Rebel Alliance Developer Netgate

    The only changes to drivers have been for Atheros wireless cards (ath0), and even then the change is simply reverting something that changed between RC2 and RC3.



  • Do you know what the difference is between the firmware listed above and the latest snapshot.

    The RC1 works fine the firmware listed above work but the latest snapshot doesn't.


  • Rebel Alliance Developer Netgate

    There are a lot of changes. Too many to list. Changes to pfSense code, patches, tools repo changes, etc. Hundreds of changes at least, maybe more.

    Unless you can pinpoint with a little more accuracy what might actually be causing the reboots, it will be impossible to track. There should be a debugging kernel on the CD, available as an option when you install. (There are ways to switch kernels live, if you know how, the kernels are in /kernels/) If you switch to a debug kernel it should stop with an error instead of rebooting.



  • Ok I will have to have a look at this then.

    Is anyone else seeing this problem?



  • Well, obviously I am.  Its common to my VIA cpu based systems.  I don't seem to have any issues with other platforms at the moment, using the latest snapshots.



  • I have the exact some only and issue with VIA boxes. Guess need to find a keyboard and mouse then to try and diag.


Log in to reply