Slow/Poor Performance on Wifi



  • Hi all,

    I just switched over to pfSense from a Linksys WRV54G router. I've used pfSense at work but I wanted to use it at home as well.

    I'm currently running 1.0-SNAPSHOT-09-21-06 on a Celeron 1ghz box with 384mb of RAM and an 80gb HDD. I am using a 3C905, some DEC Tulip card, and a Netgear WG311T (Atheros based chipset).

    It seems that my wifi performance is sub par. I will get 2-5ms ping times to my pfSense's LAN ip, and some web pages will come up slowly or even only partially.

    Here are my settings for the wifi interface.

    Bridged to LAN
    802.11g standard
    Mode: Access Point
    Protection Mode Off
    Allow Intra-BBS - on
    Channel: auto
    WPA
    Pre-Shared Key
    Open System Auth
    (all other options left at defaults)

    Ideas? Let me know if there is something useful that I can do to provide more information.



  • Do you see a lot of errors for the wireless interface at status>interfaces?



  • check the WAN interface for colissions, if that's the case there's a duplex mismatch.



  • @hoba:

    Do you see a lot of errors for the wireless interface at status>interfaces?

    Yeah, seems like there are a lot of errors:

    Wireless interface (ath0)
    Status associated
    MAC address 00:14:6c:89:3a:0c
    Media autoselect mode 11g <hostap>Channel 2
    SSID CT
    In/out packets 22415/40270 (2.51 MB/24.28 MB)
    In/out errors 252657/3
    Collisions 0
    Bridge (bridge0) learning</hostap>



  • Sounds like you have some kind of wrong antenna setup as the errors are only incoming. See http://forum.pfsense.org/index.php/topic,1007.msg6968.html#msg6968 for a possible solution.



  • @hoba:

    Sounds like you have some kind of wrong antenna setup as the errors are only incoming. See http://forum.pfsense.org/index.php/topic,1007.msg6968.html#msg6968 for a possible solution.

    Ok, I went through that thread and managed to get my antenna configured (presumably) correctly. The card only has one antenna. I added the following to my config.xml:

    <shellcmd>sysctl dev.ath.0.rxantenna=2;sysctl dev.ath.0.txantenna=1;sysctl dev.ath.0.diversity=0</shellcmd>
                  <afterfilterchangeshellcmd>sysctl dev.ath.0.rxantenna=2;sysctl dev.ath.0.txantenna=1;sysctl dev.ath.0.diversity=0</afterfilterchangeshellcmd>

    I had tried setting both rx and txantenna to = 1 and it seemed from my very unscientific testing that I was getting more errors.

    I am still getting a ton of incoming errors, no matter what changes I make to config.xml.

    I also set it to 802.11g only, distance to 30, and 802.11g OFDM Protection Mode to RTS/CTS.

    Web surfing seems a little quicker, but I am still seeing pages half-load on occasion. I should also say that this does NOT happen with a wired NIC, so I am positive that it's the wireless that's doing it.



  • make sure the channel you selected is free of other accesspoints,babyfoons,wireless musicboxes ,wireless video transmitters etc etc



  • @jeroen234:

    make sure the channel you selected is free of other accesspoints,babyfoons,wireless musicboxes ,wireless video transmitters etc etc

    Right now it's set to auto.

    Wouldn't a congested channel give me both tx and rx errors?



  • Well, I had to give up and go back to my crap-tastic Linksys WRV54G. I'll give it another shot in a few more releases. :(



  • I have serious performance problems as well. I read all of the above suggestions and changed my config accordingly. The number of I/O errors is now almost zero. Sadly it didn't improve my wireless performance. I have quite steady pings of about 2.5 - 4.0 ms, which I think is ok. But the data rate is limited to about 200kb/s which is far from what I'm used to. I use my wifi connection to transmit tv-feeds and for that to work I need a lot more bandwidth. With my old AP this was no problem at all.
    I use a WRAP board with two AR5006XS based miniPCI adapters. One of them is configured for 11a and one for 11b/g. I have one antenna per card but I made sure the driver uses the right connector.
    One thing I noticed is that during a file transfer over wireless, the web frontend is responding very slowly even on the wired lan interface. From my point of view this leads to the conclusion that the WRAP board is working at its limit. I'm using WEP128 and PPTP with 128bit encryption at the same time. Is this too much for this board? Should I handle the VPN from another machine?



  • Sounds like you are running out of resources yes. You might want to try stopping some services, and also try to enable only one card.
    Top will tell you what is using all your CPU.
    Please report back your findings.

    PS. I never tried to use the wraps with 2 cards, i only use two cards with p4 machines, and that works just fine.



  • Yep, sounds like your bringing it to it's knees.  I would move the VPN to another box as MPD has to do its crypto without any type of hardware help.



  • I disabled the PPTP and used pure WEP. The result is a data rate of 1.500kb/s. Much better ;) I will move the VPN server to another machine. Thanks.



  • i am experiencing also a poor performance regarding the wireless functionality - the throughput from OPT1 (running on 11g) interface to LAN is limited to a max of 5.8 Mbit/s, regardless what i try i can't achieve more…

    • tested with two different laptops, one equipped with 802.11g the other with a 802.11b PCMCIA - same result...

    • using sinkgen (very slim and prooven as effective) as a traffic generator... / in every case the magic 5.8 Mbit/s is the max (nice flat graph on the top)

    all LAN intefaces that take part are running 100-full (pfsense, switch, receiving PC - same test between 2 PC at the same Switch reaches up to 90Mbit/s)

    fxp0: flags=8843 <up,broadcast,running,simplex,multicast>mtu 1500
            options=8 <vlan_mtu>inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
            inet6 fe80::202:b3ff:fe12:3180%fxp0 prefixlen 64 scopeid 0x3
            ether 00:02:b3:12:31:80
            media: Ethernet autoselect (100baseTX <full-duplex>)
            status: active

    ath0: flags=8843 <up,broadcast,running,simplex,multicast>mtu 2290
            inet6 fe80::20f:b5ff:fefa:84de%ath0 prefixlen 64 scopeid 0x4
            inet 172.16.1.1 netmask 0xfffffff8 broadcast 172.16.1.7
            ether aa:aa:aa:aa:aa:aa
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: associated
            ssid xxxxxxxx channel 3 bssid xx:xx:xx:xx:xx:xx
            authmode WPA privacy MIXED deftxkey 3 TKIP 2:128-bit TKIP 3:128-bit
            txpowmax 37 protmode OFF burst -apbridge dtimperiod 1 bintval 100

    is there some throughput limitation? during the test the CPU (AMD K7 Duron 800Mhz) is at around 15% load... filetransfers are very boring that way - currently still grabbing my patchcable for this ;-)</hostap></up,broadcast,running,simplex,multicast></full-duplex></vlan_mtu></up,broadcast,running,simplex,multicast>



  • If you stations run in 11b mode the 6 mbit/s is a rather "normal" value, however if they run in 11g you should expect more. On my WRAPs with CM9's I can push up to 25 mbit/s in turbo a mode (and a wrap is much slower than the hardware you are using). Check if your g client is actually using 54 mbit/s mode doesn'T fall back to 11b.



  • I've experienced a few diferent hardware setups in outdoor enviroment all at the same distance (700 meters), and I seem to achieve the top speed at 3,3MBytes/sec on 802.11g and 5.5MBytes/sec on 802.11a Turbo on a Pentium III 500Mhz with fxp and ath nics. With a Pentium III 800Mhz the 802.11a link gave me about 6MBytes/sec. Both motherboards are based on Intel chipsets. Same distance with a WRAP gave me 2,8Mbytes/sec. The wifi cards used were CM9's and the setup was with routing, not bridging.



  • the card is really operating at 54Mbit/s - 802.11g… made the test again but this time the reverse way (the PC sends and the Laptop receives)
    the Laptop can recieve 28Mbit/s from the LAN interface - but it can send 5.8 Mbit/s only



  • Looks like antennasetup problems. Like if the card is set to diversity but only one antenna is connected. Search the forum. This has been discussed before somewhere.



  • I've also got a throughput problem. But I'm starting to wonder if it's a driver problem…

    I first configured the network to use WPA-PSK, and I only got ~300KB/s transfer speed.
    I disabled it and I got about 600-700KB/s.

    Then I searched the forums and found various threads mentioning the sysctl switch for setting the rx/tx antennae manually.

    I used the following settings (since the antennae was connected to the main antennae connector):

    dev.ath.0.rxantenna: 0
    dev.ath.0.txantenna: 0
    dev.ath.0.diversity: 0

    I also had a look at the interfaces page:

    Status  associated
    MAC address 00:16:cf:22:2a:5d
    Media autoselect mode 11a <hostap>Channel 132
    SSID lustitia
    In/out packets 419682/750021 (25.95 MB/1017.81 MB)
    In/out errors 3917/80
    Collisions 0
    Bridge (bridge0) learning

    athstats

    752148 tx management frames
    284 tx frames discarded prior to association
    1 tx stopped 'cuz no xmit buffer
    473 tx discarded empty frame
    9075 tx failed 'cuz FIFO underrun
    175568 tx failed 'cuz bogus xmit rate
    190 tx frames with rts enabled
    14091 tx frames with 11g protection
    4727 rx failed 'cuz of FIFO overrun
    421753 rx management frames
    99845 beacon setup failed 'cuz no mbuf
    6169 beacons transmitted
    404 periodic calibration failures
    6 rate control checks
    1 tx used alternate antenna
    Antenna profile:
    [2] tx  743351 rx  429624
    [3] tx        3 rx        0

    I see a few erronous packets inbound. Dispite the changes in sysctl settings.

    I don't know what to do… 700KB/s is simply not acceptable.

    My WRT54G can perform 2200KB/s with WPA-PSK. And I definitely think the soekris has the hardware to outperform a regular AP.

    My Setup:

    Soekris 4801
    PfSense 1.0.1 embedded
    IBM Wireless a/b/g AR5212

    settings:
    bridge with LAN
    accesspoint
    802.11a
    channel auto
    prot mode cts and rts.
    no encryption.

    Does anyone have any thoughts?

    And another question: What is the highest thoughput people have gotten with wlan cards using the ath driver? Are there any benchmarks available?</hostap>



  • 1, You should not see performance drops due to WPA with AES on atheros, as this is done in the chip itself.
    2. Protmode is for b/g mixed environment, should be disabled for A (i'll note that if system is set to A then this should be automagically disabled in newer versions.)
    3. If you can get me access to this setup, I can have a look at whats going on. Normally it's easily fixed as long as pfsense is to blame, if it's driver and or client issues there is not a lot we can do about it.



  • Email me, and I'll give you the ip and passwd.



  • I've sent you the ip/pwd.

    Test's:

    http://pr0n.se/wireless-pfsense/

    Evidently very shaky when transferring from the soekris.


Locked