Performans ayarı önerisi



  • pfsense ve/veya Squid çalıştırdığınız bilgisayarda
    /boot/loader.conf dosyasında
    kern.ipc.nmbclusters="0"
    satırını, aşağıdaki şekilde değiştirirseniz, daha yüksek performans alırsınız.
    kern.ipc.nmbclusters="32768"

    network buffer'ını arttıran bir parametredir.



  • @tuzsuzdeli:

    pfsense ve/veya Squid çalıştırdığınız bilgisayarda
    /boot/loader.conf dosyasında
    kern.ipc.nmbclusters="0"
    satırını, aşağıdaki şekilde değiştirirseniz, daha yüksek performans alırsınız.
    kern.ipc.nmbclusters="32768"

    network buffer'ını arttıran bir parametredir.

    tuzsuzdeli kardeş teşekkür ederim paylaştığın için konuyu açtığın gün gördüm denedim hissedilir derecede Squid üzerinde ciddi bir performans artışı gördüm teşekkürler tekrardan ;)



  • @Ntldr_missing:

    @tuzsuzdeli:

    pfsense ve/veya Squid çalıştırdığınız bilgisayarda
    /boot/loader.conf dosyasında
    kern.ipc.nmbclusters="0"
    satırını, aşağıdaki şekilde değiştirirseniz, daha yüksek performans alırsınız.
    kern.ipc.nmbclusters="32768"

    network buffer'ını arttıran bir parametredir.

    tuzsuzdeli kardeş teşekkür ederim paylaştığın için konuyu açtığın gün gördüm denedim hissedilir derecede Squid üzerinde ciddi bir performans artışı gördüm teşekkürler tekrardan ;)

    Rica ederim, ne demek.



  • teşekkürler. Performans önemli bir konu.



  • bahsettiğiniz dosyanın içi boş ama ben elle ekledim inşAllah bi sorun çıkmaz.



  • arkadaşlar o dosya sanırım /boot/default/loader.conf yolu bu



  • değil
    benim yazdığım yerde olmalı :)



  • /boot altındaki dosya boş içi



  • boş dosyaya şunları yazabilirsiniz

    autoboot_delay="3"
    vm.kmem_size="435544320"
    vm.kmem_size_max="535544320"
    kern.ipc.nmbclusters="32768"

    eğer makine sanal makine ise Vmware üzerinde çalışıyorsa da şu şekilde olmalı
    autoboot_delay="1"
    vm.kmem_size="435544320"
    vm.kmem_size_max="535544320"
    #kern.ipc.nmbclusters="0"
    hint.apic.0.disabled=1
    kern.hz=100
    #for squid
    kern.ipc.nmbclusters="32768"
    kern.maxfiles="65536"
    kern.maxfilesperproc="32768"
    net.inet.ip.portrange.last="65535"



  • Bende denedim sonuç mükemmel , Teşekkürler tuzsuzdeli



  • Huh! bu kadarmı farkeder.. Enteresan.. Teşekkürler Tuzsuzdeli.. ;)



  • @tuzsuzdeli:

    pfsense ve/veya Squid çalıştırdığınız bilgisayarda
    /boot/loader.conf dosyasında
    kern.ipc.nmbclusters="0"
    satırını, aşağıdaki şekilde değiştirirseniz, daha yüksek performans alırsınız.
    kern.ipc.nmbclusters="32768"

    network buffer'ını arttıran bir parametredir.

    Tuzsuz kardeş paylaştığın bu bilgi performans hissedilir derecede anlaşılıyor bir önerim var hatta şuan deniyeceğim kern.ipc.nmbclusters="32768"  değeri maximum değermidir yoksa daha çok arttırılabilirmi siz daha önce değerleri değiştirip deedinizmi ben şimdi 32768 değerini 75623 şeklinde değiştireceğim sonucu yazarım buraya ama şuan networte aktikf olarak 5 sunucu 4 istemci 9bağlantı var ayarı değiştirdim bi kaç gün test edeyim networke bütün cihazlar bağlansın pfnin üzerinde yük oluşsün belli bir trafik oluşsun sonucu buraya yazarın ;) mesai başlasın haftaiçi belli olur yazarım buraya hatta belli aralıklarla değerleri değiştiririm. görüşmek üzere.



  • bu parametrenin alabileceği maximum değer = 65536

    Ancak çoğu dökümanda hep benim ilk yazdığım konfigürasyondaki değer önerilmiş. O yüzden bende daha yüksek bişey yazıp denemedim.

    Bu değerin, sistemde takibini yapmak istiyorsanız, shell'de
    netstat -m
    yazıp, o an ne kadarının kullanıldığını görebilirsiniz.



  • @tuzsuzdeli:

    pfsense ve/veya Squid çalıştırdığınız bilgisayarda
    /boot/loader.conf dosyasında
    kern.ipc.nmbclusters="0"
    satırını, aşağıdaki şekilde değiştirirseniz, daha yüksek performans alırsınız.
    kern.ipc.nmbclusters="32768"

    network buffer'ını arttıran bir parametredir.

    bu değişikliği nasıl yapacağım konusunda yardımcı olurmusun. şimdiden teşekkürler



  • Bu değişikliği nerden yapabiliriz acaba?



  • /boot/loader.conf



  • @tuzsuzdeli:

    pfsense ve/veya Squid çalıştırdığınız bilgisayarda
    /boot/loader.conf dosyasında
    kern.ipc.nmbclusters="0"
    satırını, aşağıdaki şekilde değiştirirseniz, daha yüksek performans alırsınız.
    kern.ipc.nmbclusters="32768"

    network buffer'ını arttıran bir parametredir.

    Pfsense kurulu bilgisayarınıza winSCP veya putty ile bağlanın /boot dizini altındaki loader.conf dosyasını açın 0 olan değeri 32768 değiştirin bu kadar.

    Kolay gelsin ..



  • @tuzsuzdeli:

    pfsense ve/veya Squid çalıştırdığınız bilgisayarda
    /boot/loader.conf dosyasında
    kern.ipc.nmbclusters="0"
    satırını, aşağıdaki şekilde değiştirirseniz, daha yüksek performans alırsınız.
    kern.ipc.nmbclusters="32768"

    network buffer'ını arttıran bir parametredir.

    ciddi bir performans artisi oldu. bu faydalı bilgi icin tesekkürler



  • ben putty ile bağlanıyorum ancak Shell diyip /boot dediğim de erişim engellendi gibi bir hata alıyorum neden acaba bilen var mı ??



  • /boot demeyeceksiniz
    /boot/loader.conf dosyasını edit edeceksiniz.
    ben bu işler için winscp kullandığımdan putty ile nasıl edit edileceği konusunda yardımcı olamayacağım.
    ama winscp ile başka bir bilgisayardan bağlanırsanız, iş çok kolay.
    windows ortamında edit edebilirsiniz.

    winscp'yi kurun
    aynı putty'de olduğu gibi pfsense bağlanın
    file explorerda ilgili dosyayı bulup "edit" i seçin
    kaydedip çıkın



  • hocam çok teşekkür ederiz harika bir performans artışı oldu.



  • Çok yararlı bilgiler, emeği geçenlere teşekkür ederim.



  • squid için de şöyle bir performans ayarı var. Ben de biraz farkedilir bir değişklik oldu, ama bir ölçüm metodu olmadığından, fark psikolojik de olabilir :) Bir deneyin derim.

    Services - Proxy server - Cache management - Hard disk cache system : Ufs
    sonrasında
    System -> Advanced -> Sytem Tunables altındaki vfs.read_max=32 default değerini vfs.read_max=128 yapın.



  • @tuzsuzdeli:

    squid için de şöyle bir performans ayarı var. Ben de biraz farkedilir bir değişklik oldu, ama bir ölçüm metodu olmadığından, fark psikolojik de olabilir :) Bir deneyin derim.

    Services - Proxy server - Cache management - Hard disk cache system : Ufs
    sonrasında
    System -> Advanced -> Sytem Tunables altındaki vfs.read_max=32 default değerini vfs.read_max=128 yapın.

    vohooo :) güzel gayet başarılı gözle görülür bir performans var ;) teşekkürler tuzsuz kardeş ;)



  • Merhaba yardımlarınız için çok teşekkür ederim sorunlarımı tek tek sayenizde çözüyorum sayın tuzsuzdeli birşey dikkatimi çekti proxy server: Cache management altındaki Level 1 subdirectories altındaki bu not
    "Each level-1 directory contains 256 subdirectories, so a value of 256 level-1 directories will use a total of 65536 directories for the hard disk cache. This will significantly slow down the startup process of the proxy service, but can speed up the caching under certain conditions. "

    performans ayarında ilk senin dediğini yaptım gayet uzun zamadır sorunsuz çalıyor şimdi verdiğin en yüksek değeri yaptım yani 65536 yı..Level 1 subdirectories "16" olarak kullanıyorum 32 yapınca yada hardsik size 10000 yapınca squid ve squidguard stop ediyor bu Level 1 subdirectories ne işe yarıyor neden 32 yapınca yada daha yüksek yapınca servisler duruyor ? Eski haline yani 6000 ve 16 yapınca tekrar çalışıyor sistem

    ram - 2 gb
    harddisk - 500gb 5400 rpm
    kullanıcı sayısı en az 85 en fazla 95  okulda kullanıyorum bu sistemi



  • Durduğunu zannetmiyorum
    Açılış süresi aşırı derecede uzuyor.
    Belki bi 20-30 dakika belki 1 saat beklemeyi deneyin.

    Ya da loglara bakın, eğer başka bir problem var ise loglarda yazar.



  • teşekkürler birde öle deneyeyim bu ayarlar network buffer başka ne işe yarıyor yani amacı ne ve sen hangi ayarları kullanıyorsun şuan ekran görüntüsü atabilirsen çok iyi olur :) yada bu donanım için önerilerin ne acaba ?



  • Eternetimki sorundan dolayı yanlış bir geri bildirim yapmışım. Silerek düzeltiyorum.



  • @tuzsuzdeli:

    /boot demeyeceksiniz
    /boot/loader.conf dosyasını edit edeceksiniz.
    ben bu işler için winscp kullandığımdan putty ile nasıl edit edileceği konusunda yardımcı olamayacağım.
    ama winscp ile başka bir bilgisayardan bağlanırsanız, iş çok kolay.
    windows ortamında edit edebilirsiniz.

    winscp'yi kurun
    aynı putty'de olduğu gibi pfsense bağlanın
    file explorerda ilgili dosyayı bulup "edit" i seçin
    kaydedip çıkın

    abicim ben windows üzerinden tarayıcı ile bağlannıyorum bulamadım dediğin ayarı tam adres verirmisin ?



  • Daha açık nasıl yazılır bilemiyorum.
    Windows üzerinden tarayıcı ile bağlanmayın, winscp kurup öyle bağlanın.

    Ya da
    pfsense için "file manager package" kurup onunla yapabilirsiniz. (system packages altından paketi kurup, diagnostics menüsünden file manager'ı seçerek devam edebilirsiniz)



  • @tuzsuzdeli:

    Daha açık nasıl yazılır bilemiyorum.
    Windows üzerinden tarayıcı ile bağlanmayın, winscp kurup öyle bağlanın.

    Ya da
    pfsense için "file manager package" kurup onunla yapabilirsiniz. (system packages altından paketi kurup, diagnostics menüsünden file manager'ı seçerek devam edebilirsiniz)

    ayrı makinadan windowstan tarayıcıdan girdiğim için göremiyordum demekki
    şimdi dediğini yaptım file manager package ini yükledim paketlerden.dediğini buldum yaptım.teşekkürler ilgine sağol.ALLAH razı olsun.iyi çalışmalar



  • Merhaba,

    WinSCP ile bağlantı yapmayı denediğimde; çok genir bir sftp paketi algılandı hatası veriyor bağlantı kurmuyor ?

    yardımcı olursanız çok sevinirim



  • @tuzsuzdeli:

    boş dosyaya şunları yazabilirsiniz

    autoboot_delay="3"
    vm.kmem_size="435544320"
    vm.kmem_size_max="535544320"
    kern.ipc.nmbclusters="32768"

    eğer makine sanal makine ise Vmware üzerinde çalışıyorsa da şu şekilde olmalı
    autoboot_delay="1"
    vm.kmem_size="435544320"
    vm.kmem_size_max="535544320"
    #kern.ipc.nmbclusters="0"
    hint.apic.0.disabled=1
    kern.hz=100
    #for squid
    kern.ipc.nmbclusters="32768"
    kern.maxfiles="65536"
    kern.maxfilesperproc="32768"
    net.inet.ip.portrange.last="65535"

    merhaba bu hız ayarını 8 ay önce yapmış ve sorunsuz kullanıyordum ancak yazınızdaki "Vmware üzerinde çalışıyorsa da şu şekilde olmalı"

    satırına göre configi güncelledim ve pfsense bir daha ACILMADI !

    yeniden kurdum hiç bir şey yapmadan sizin ayarı yaptım gene açılmadı.
    sorunu bulmak için bir daha kurdum
    hint.apic.0.disabled=1  satırı olunca bu sorunun meydana geldiğini gördüm.

    tabi buda bana pahalıya patladı sabahlamak gibi :)

    iyi çalışmalar.



  • vfs.read_max Increase UFS read-ahead speeds to match current state of hard drives and NCQ. More information here: http://ivoras.sharanet.org/blog/tree/2010-11-19.ufs-read-ahead.html 128

    sura değilmi arkadaşlar? en altaki yere 128 yazdım.teşekkür ederim bilgilendiğiniz için…



  • @linux42:

    @tuzsuzdeli:

    boş dosyaya şunları yazabilirsiniz

    autoboot_delay="3"
    vm.kmem_size="435544320"
    vm.kmem_size_max="535544320"
    kern.ipc.nmbclusters="32768"

    eğer makine sanal makine ise Vmware üzerinde çalışıyorsa da şu şekilde olmalı
    autoboot_delay="1"
    vm.kmem_size="435544320"
    vm.kmem_size_max="535544320"
    #kern.ipc.nmbclusters="0"
    hint.apic.0.disabled=1
    kern.hz=100
    #for squid
    kern.ipc.nmbclusters="32768"
    kern.maxfiles="65536"
    kern.maxfilesperproc="32768"
    net.inet.ip.portrange.last="65535"

    merhaba bu hız ayarını 8 ay önce yapmış ve sorunsuz kullanıyordum ancak yazınızdaki "Vmware üzerinde çalışıyorsa da şu şekilde olmalı"

    satırına göre configi güncelledim ve pfsense bir daha ACILMADI !

    yeniden kurdum hiç bir şey yapmadan sizin ayarı yaptım gene açılmadı.
    sorunu bulmak için bir daha kurdum
    hint.apic.0.disabled=1   satırı olunca bu sorunun meydana geldiğini gördüm.

    tabi buda bana pahalıya patladı sabahlamak gibi :)

    iyi çalışmalar.

    Kullandığınız Vmware hangisi acaba ? versiyonu filan ?



  • @tuzsuzdeli:

    @linux42:

    @tuzsuzdeli:

    boş dosyaya şunları yazabilirsiniz

    autoboot_delay="3"
    vm.kmem_size="435544320"
    vm.kmem_size_max="535544320"
    kern.ipc.nmbclusters="32768"

    eğer makine sanal makine ise Vmware üzerinde çalışıyorsa da şu şekilde olmalı
    autoboot_delay="1"
    vm.kmem_size="435544320"
    vm.kmem_size_max="535544320"
    #kern.ipc.nmbclusters="0"
    hint.apic.0.disabled=1
    kern.hz=100
    #for squid
    kern.ipc.nmbclusters="32768"
    kern.maxfiles="65536"
    kern.maxfilesperproc="32768"
    net.inet.ip.portrange.last="65535"

    merhaba bu hız ayarını 8 ay önce yapmış ve sorunsuz kullanıyordum ancak yazınızdaki "Vmware üzerinde çalışıyorsa da şu şekilde olmalı"

    satırına göre configi güncelledim ve pfsense bir daha ACILMADI !

    yeniden kurdum hiç bir şey yapmadan sizin ayarı yaptım gene açılmadı.
    sorunu bulmak için bir daha kurdum
    hint.apic.0.disabled=1   satırı olunca bu sorunun meydana geldiğini gördüm.

    tabi buda bana pahalıya patladı sabahlamak gibi :)

    iyi çalışmalar.

    Kullandığınız Vmware hangisi acaba ? versiyonu filan ?

    Workstation 9 du ama şuan esxi 5.1 yükledim ama denemeye tırsıom :)
    satede hint.apic.0.disabled=1  satırı hariç diğerlerini ekliyom.



  • yapın bi tane klon makine
    birini öyle birini diğer türlü çalıştırıp bakın



  • 2.3.x versiyonlarında da işe yararmı acaba ?



  • @nefsim:

    2.3.x versiyonlarında da işe yararmı acaba ?

    merhaba,
    referans adreslerde performans önerileri mevcut, inceleyebilirsiniz.
    https://doc.pfsense.org/index.php/Low_Throughput_Troubleshooting
    https://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards



  • @tuzsuzdeli:

    pfsense ve/veya Squid çalıştırdığınız bilgisayarda
    /boot/loader.conf dosyasında
    kern.ipc.nmbclusters="0"
    satırını, aşağıdaki şekilde değiştirirseniz, daha yüksek performans alırsınız.
    kern.ipc.nmbclusters="32768"

    network buffer'ını arttıran bir parametredir.

    üstad 2.4.2 içinde geçerli midir bu ayar? zira benim loader.conf dosyasında sadece aşağıda yazan satırlar var.

    autoboot_delay="3"
    comconsole_speed="115200"
    hw.usb.no_pf="1"