PFsense 2.0 не настраивается PPPoE и доступ на модем



  • Роутер с 3-я сетевухами, WAN , LAN (192.168.11.0/24), WIFI (192.168.12.0/24).
    Версия ОС - PFsense 2.0 Beta1

    Есть Adsl модем в режиме Bridge, его локальный адрес 192.168.10.1 - он доступен если к модему подключать компьютер обычным проводом и настраивать IP адрес например 192.168.10.2 , при этом в Windows можно создать PPPoE соединение, при этом работает и интернет и доступ на сам модем по адресу 192.168.10.1.

    Установил роутер PFsense 2.0,  маршрут как я понял в ней не прописать если нет интерфейса, пробовал настроить дополнительный интерфейс 2-я способами..

    1. ставил на WAN интерфейсе адрес такой же как на компьютере, то есть 192.168.10.2 (при этом связь с модемом была нормальная), потом добавлял Vlan к этому интерфейсу, включал его, выбирал на нем PPPoE прописывал настройки соединения.. оно получалось с состоянием - down..
    2. пробовал по другому, на WAN интерфейсе ставил - PPPoE, потом добавлял аналогично Vlan с адресом 192.168.10.2 , потом добавлял этот шлюз, затем маршрут на 192.168.10.0 через шлюз 192.168.10.2 , результат - ничего вообще не работает, помогла только переустановка роутера..
    3. ставил на WAN интерфейсе PPPoE, нажимал в назначении интерфейсов "+" , появлялся PPPoe0 интерфейс, выбираю в нем Static IP, пишу IP адрес 192.168.10.2, применяю, но в свойствах интерфейса у него оставался такой же адрес как ина WAN, то есть ещё 1 внешний IP, доступа к 192.168.10.1 соответственно не было, маршрут не добавить т.к. идет ошибка, сообщающая что 192.168.10.1 не лежит в подсети интерфейса.

    на Monowall всё настроилось за минуту.. (тот же комп с 3-я сетевухами) вот что получилось:

    WAN interface
    Status up
    PPPoE up  
    IPv4 address 78.37.200.74/255.255.255.255
    IPv4 gateway 78.37.192.1  
    IPv6 address fe80::219:5bff:fe3e:3c12%ng0/64
    ISP DNS servers 213.158.7.2
    212.48.193.37
    In/out packets 188084/163145 (201.16 MB/10.09 MB)
    In/out errors 0/0
    Wifi interface
    Status up
    MAC address 00:80:48:42:8c:9b
    IPv4 address 192.168.12.1/255.255.255.0
    IPv6 address fe80::280:48ff:fe42:8c9b%rl1/64
    Media 100baseTX <full-duplex>In/out packets 89178/130484 (7.23 MB/174.55 MB)
    In/out errors 0/0
    Collisions 0
    WAN eth interface
    Status up
    MAC address 00:e0:52:01:02:50
    IPv4 address 192.168.10.2/255.255.255.0
    IPv6 address fe80::2e0:52ff:fe01:250%rl0/64
    Media 100baseTX <full-duplex>In/out packets 189262/164293 (205.19 MB/13.60 MB)
    In/out errors 0/0
    Collisions 0
    LAN interface
    Status up
    MAC address 00:19:5b:3e:3c:12
    IPv4 address 192.168.11.1/255.255.255.0
    IPv6 address fe80::219:5bff:fe3e:3c12%vr0/64
    Media 100baseTX <full-duplex>In/out packets 83480/103966 (6.56 MB/36.67 MB)
    In/out errors 0/0
    Collisions 0

    результат команды ifconfig

    $ ifconfig -a
    vr0: flags=8843 <up,broadcast,running,simplex,multicast>mtu 1500
    options=8 <vlan_mtu>inet 192.168.11.1 netmask 0xffffff00 broadcast 192.168.11.255
    inet6 fe80::219:5bff:fe3e:3c12%vr0 prefixlen 64 scopeid 0x1
    ether 00:19:5b:3e:3c:12
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    rl0: flags=8843 <up,broadcast,running,simplex,multicast>mtu 1500
    options=8 <vlan_mtu>inet 192.168.10.2 netmask 0xffffff00 broadcast 192.168.10.255
    inet6 fe80::2e0:52ff:fe01:250%rl0 prefixlen 64 scopeid 0x2
    ether 00:e0:52:01:02:50
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    rl1: flags=8843 <up,broadcast,running,simplex,multicast>mtu 1500
    options=8 <vlan_mtu>inet 192.168.12.1 netmask 0xffffff00 broadcast 192.168.12.255
    inet6 fe80::280:48ff:fe42:8c9b%rl1 prefixlen 64 scopeid 0x3
    ether 00:80:48:42:8c:9b
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    enc0: flags=41 <up,running>mtu 1536
    lo0: flags=8049 <up,loopback,running,multicast>mtu 16384
    inet 127.0.0.1 netmask 0xff000000
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
    ng0: flags=88d1 <up,pointopoint,running,noarp,simplex,multicast>mtu 1492
    inet6 fe80::219:5bff:fe3e:3c12%ng0 prefixlen 64 scopeid 0x6
    inet 78.37.200.74 –> 78.37.192.1 netmask 0xffffffff

    ===============================================================================

    Как то же самое сделать на PFsense 2.0 ?? Нужен интернет по PPPoE и доступ на адрес модема (модем в режиме моста) его адрес 192.168.10.1</up,pointopoint,running,noarp,simplex,multicast></up,loopback,running,multicast></up,running></full-duplex></vlan_mtu></up,broadcast,running,simplex,multicast></full-duplex></vlan_mtu></up,broadcast,running,simplex,multicast></full-duplex></vlan_mtu></up,broadcast,running,simplex,multicast></full-duplex></full-duplex></full-duplex>



  • ifconfig с pfSense - для какого случая (ты три ситуации описал)?



  • @Eugene:

    ifconfig с pfSense - для какого случая (ты три ситуации описал)?

    ни для какого, это ifconfig и "status\interfaces" с другого роутера (monowall) на котором всё настроилось как надо.. нужен точно такой же результат на "PFsense 2.0 Beta1" честно говоря, я даже не знаю с чего начинать..

    может кто объяснит, как правильно настраивается подобная конфигурация на PFsense 2.0 BETA1 ?



  • аффтору топа: а Вас не смущает, что у Вас пфсайнс и модем в разных подсетях?



  • @aleksvolgin:

    аффтору топа: а Вас не смущает, что у Вас пфсайнс и модем в разных подсетях?

    Роутер был соединен с модемом проводом..

    пробовал добавлять Vlan из 10-й подсети (та же подсеть что и локальный IP модема), пробовал ставить на интерфейсе 192.168.10.2 , и в VLAN интерфейсе добавлять PPPoE (соединение не поднималось), пробовал добавлять интерфейс кнопкой "Add" рядом с PPPoE интерфейсом, то же безрезультатно, он становился 1 в 1 одинаковый с WAN интерфейсом..

    в общем сейчас опять буду ставить PFsense, скоро выложу IFconfig-и и прочее..



  • в общем сейчас опять буду ставить PFsense, скоро выложу IFconfig-и и прочее..

    Позволю себе дать Вам последний совет: налейте себе чашечку чая, сядте за стол, возьмите лист бумаги и карандаш, нарисуйте подробную схему вашей сети с указанием имён железок и их ип адресов, и я уверен, Вы очень быстро найдёте ответ на Ваш вопрос.



  • Вот схема:

    интернет работает, но нужен доступ на модем 192.168.10.1 с локальной сети 192.168.11.0 или 192.168.12.0, если модем не переведен в режим моста, доступ на его адрес есть, но мне нужен внешний IP на роутере а не на модеме.. при переключении модема в Bridge, на 192.168.10.1 доступ пропадает..
    как можно это настроить ?
    (в 1-м сообщении есть конфигурация интерфейсов роутера monowall на том же самом железе, с тем же самым провайдером, там доступ на модем работает.. нужно то же самое настроить теперь на PFsense)

    вот что сейчас в интерфейсах на PFsense

    WAN interface (rl0)
    Status   up
    PPPoE up  
    IP address 78.37.222.115  
    Subnet mask 255.255.255.255
    Gateway 78.37.192.1
    ISP DNS servers 213.158.7.2
    212.48.193.37
    LAN interface (vr0)
    Status up
    MAC address 00:19:5b:3e:3c:12
    IP address 192.168.11.1  
    Subnet mask 255.255.255.0
    Media 100baseTX <full-duplex>WIFI interface (rl1)
    Status up
    MAC address 00:80:48:42:8c:9b
    IP address 192.168.12.1  
    Subnet mask 255.255.255.0
    Media 100baseTX</full-duplex>



  • Модем переведите в режим брижда, назначте модему адрес из подсети .11, например 192.168.11.11, в пфсайнсе в настройках WAN переведите его в режим PPPoE - соответственно настройте (логин/пароль и др.).

    Так-же неплохо везде назначить пфсенс шлюзом по умолчанию.

    Фсё  ;)



  • @aleksvolgin:

    Модем переведите в режим брижда, назначте модему адрес из подсети .11, например 192.168.11.11, в пфсайнсе в настройках WAN переведите его в режим PPPoE - соответственно настройте (логин/пароль и др.).

    Так-же неплохо везде назначить пфсенс шлюзом по умолчанию.

    Фсё  ;)

    В общем сейчас у компьютера адрес 192.168.11.2, у шлюза PFsense (локальный интерфейс) 192.168.11.1, у LAN интерфейса модема переведенного в мост - 192.168.11.11 ,  через PFsense связи с модемом нет, если провод от компьютерв полключать напрямую в LAN порт модема то доступ на 192.168.11.11 работает нормально, пробовал пинговать модем с самого роутера PFsense результат - 100% потерь пакетов.

    При этом интернет работает, на WAN интерфейсе PFsense внешний IP.



  • Да. Не будет работать такая схема. Ошибся я.



  • В общем в mono я добавлял интерфейс.. наверное и тут нужен 4-й интерфейс, когда на WAN настроено PPPoE, в разделе назначения интерфейсов рядом с WAN появляется кнопочка "+", можно добавить ещё 1 интерфейс (PPPoE), вот скрин:

    Потом значит я захожу в этот интерфейс и пишу ему статический IP, 192.168.11.10 например..  
    скрин:

    сразу ничего вообще не срабатывает, после перезагрузки роутера получается вот это:

    результат Ifconfig:

    $ ifconfig -a
    vr0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=2808 <vlan_mtu,wol_ucast,wol_magic>ether 00:19:5b:3e:3c:12
    inet 192.168.11.1 netmask 0xffffff00 broadcast 192.168.11.255
    inet6 fe80::219:5bff:fe3e:3c12%vr0 prefixlen 64 scopeid 0x1
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    rl0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=8 <vlan_mtu>ether 00:e0:52:01:02:50
    inet6 fe80::2e0:52ff:fe01:250%rl0 prefixlen 64 scopeid 0x2
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    rl1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=8 <vlan_mtu>ether 00:80:48:42:8c:9b
    inet 192.168.12.1 netmask 0xffffff00 broadcast 192.168.12.255
    inet6 fe80::280:48ff:fe42:8c9b%rl1 prefixlen 64 scopeid 0x3
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    pflog0: flags=100 <promisc>metric 0 mtu 33200
    enc0: flags=0<> metric 0 mtu 1536
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
    options=3 <rxcsum,txcsum>inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x6
    inet 127.0.0.1 netmask 0xff000000
    nd6 options=3 <performnud,accept_rtadv>pfsync0: flags=0<> metric 0 mtu 1460
    syncpeer: 224.0.0.240 maxupd: 128
    pppoe0: flags=88d1 <up,pointopoint,running,noarp,simplex,multicast>metric 0 mtu 1492
    inet6 fe80::219:5bff:fe3e:3c12%pppoe0 prefixlen 64 scopeid 0x8
    inet 91.122.190.194 –> 78.37.192.1 netmask 0xffffffff
    nd6 options=3 <performnud,accept_rtadv>---------------------------------------------------------------------

    пробовал заходить на этот адрес, то есть на 91.122.190.194, и попадаю на сайт PFsense :)

    Кстати при этом результаты IFconfig-а между monowall (1-е сообщение темы) и pfsense (это сообщение) очень похожи, но в PFsense как вижу нет 1-й строчки "inet" на интерфейсе "rl0", может можно как то вручную подправить ?</performnud,accept_rtadv></up,pointopoint,running,noarp,simplex,multicast></performnud,accept_rtadv></rxcsum,txcsum></up,loopback,running,multicast></promisc></full-duplex></performnud,accept_rtadv></vlan_mtu></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></vlan_mtu></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></vlan_mtu,wol_ucast,wol_magic></up,broadcast,running,simplex,multicast>



  • Давайте базироваться на этой диаграмме:
    @onega122:

    Вот схема:

    интернет работает, но нужен доступ на модем 192.168.10.1 с локальной сети 192.168.11.0 или 192.168.12.0, если модем не переведен в режим моста, доступ на его адрес есть, но мне нужен внешний IP на роутере а не на модеме.. при переключении модема в Bridge, на 192.168.10.1 доступ пропадает..
    как можно это настроить ?
    (в 1-м сообщении есть конфигурация интерфейсов роутера monowall на том же самом железе, с тем же самым провайдером, там доступ на модем работает.. нужно то же самое настроить теперь на PFsense)

    вот что сейчас в интерфейсах на PFsense

    WAN interface (rl0)
    Status   up
    PPPoE up  
    IP address 78.37.222.115  
    Subnet mask 255.255.255.255
    Gateway 78.37.192.1
    ISP DNS servers 213.158.7.2
    212.48.193.37
    LAN interface (vr0)
    Status up
    MAC address 00:19:5b:3e:3c:12
    IP address 192.168.11.1  
    Subnet mask 255.255.255.0
    Media 100baseTX <full-duplex>WIFI interface (rl1)
    Status up
    MAC address 00:80:48:42:8c:9b
    IP address 192.168.12.1  
    Subnet mask 255.255.255.0
    Media 100baseTX</full-duplex>

    До сих пор всё правильно. На WAN (rl0) можно сконфигурировать 192.168.10.2/24 gateway 192.168.10.1 ?



  • @Eugene:

    До сих пор всё правильно. На WAN (rl0) можно сконфигурировать 192.168.10.2/24 gateway 192.168.10.1 ?

    Можно так сделать, и при этом доступ на модем 192.168.10.1 работает.. но что делать с PPPoE, модем то в режиме моста..
    именно так пробовал делать, то есть назначал статику на WAN 192.168.10.2 с шлюзом на 192.168.10.1, добавлял VLAN для rl0, получался новый интерфейс, ставил на нем тип подключения PPPoE но безрезультатно, PPPoE не поднималось..



  • А если наоборот? Wan PPPoE, а статику на Opt ?



  • @dvserg:

    А если наоборот? Wan PPPoE, а статику на Opt ?

    Я это вобщем-то и имел ввиду. Нам нужно получить два логических интерфейса (на одной физике) с возможностью создавать правила для обоих. Не знаю, как это реализовано (и закончена ли реализация) в 2.0, но знаю планы были.



  • @dvserg:

    А если наоборот? Wan PPPoE, а статику на Opt ?

    ну вот результат:
    http://forum.pfsense.org/index.php/topic,23071.msg118796.html#msg118796

    то есть пишу статику и адрес 192.168.10.2, а получается внешний адрес, как бы второе PPPoE  :(

    Я это вобщем-то и имел ввиду. Нам нужно получить два логических интерфейса (на одной физике) с возможностью создавать правила для обоих. Не знаю, как это реализовано (и закончена ли реализация) в 2.0, но знаю планы были.

    То есть проблема может быть в версии 2.0 ?
    А в версии 1.2.3 такое дело нормально работает ?



  • Значит в 2.0 не доделали ещё.
    В 1.2.3 добавить PPPoE в параллель с WAN нельзя.
    Я никогда не имел и не имею ни PPPoE, ни PPTP интернет-подключения, с отладкой этого дела помочь не могу -(



  • Отцы русской американской демократии говорят pppoe вообще возможно не должен появляться в Assign. Однако вот какой хак существует, чтобы достучаться до модема http://doc.pfsense.org/index.php/How_can_i_access_my_PPPoE_Modem_on_WAN



  • @Eugene:

    Отцы русской американской демократии говорят pppoe вообще возможно не должен появляться в Assign. Однако вот какой хак существует, чтобы достучаться до модема http://doc.pfsense.org/index.php/How_can_i_access_my_PPPoE_Modem_on_WAN

    Жесть! Костыль на костыле и костылем костыляет…
    но как вариант доступа к модему думаю заработает



  • Господа чем окончилась эта увлекательная история?
    Как раз пытаюсь сделать почти тоже самое под 1.2.3.
    к провайдеру подключаюсь через PPPoe , на входе имею шнурок RJ-45 , который воткнул в WAN порт  вторая сетевая смотрит в локалку.

    Проблема с настройкой клиента PPPoE. Смог кто нибудь это сделать?



  • Начни лучше новую ветку с описанием конкретной проблемы, тем более на другой версии.


Log in to reply