Как поднять PPPoE server на LAN



  • Доброго времени суток!
    Оч нужна помощь!!!! Форумчане, родненькие - помогите!!!! или ткните носом в нужный топик!!!

    Нужно поднять pppoe server в локалке, что бы user-ы коннектились к нему и получаби инет.
    Не получается поднять ppoe server. Находил парочку мануалов… делал все как сказано, но фиг(((
    клиент не видит сервера, хотя lan интерфейс ПФ пингуется. Что делать?



  • Что значит не видит? купите клиенту веб-камеру и покажите ему сервер



  • Убедиться что сервер стартовал, проверить правила на LAN, прописать pfsense гейтвеем у клиентов.



  • @dvserg:

    Убедиться что сервер стартовал, проверить правила на LAN, прописать pfsense гейтвеем у клиентов.

    Сервер, по всей видимости не стартует, в Status -> Services находятся только три службы DNS Forward, NTP clock sync, DHCP Service (если не там смотрю - поправте)
    Что же касается правил, то на LAN у меня их вообще нет, а вот в Firewall -> Rules -> PPPoE VPN создал одно - Pass/PPPoE/TCP/PPPoE clients/any.
    Все делал по статье http://genmed-root.blogspot.com/2008/07/pfsense-pppoe.html

    Lan => 192.168.2.1/24

    PPPoE server => Interface = lan
                                netmask = 25
                      server address = 172.30.10.254
                      address range = 172.30.10.0



  • @M@kcumk@:

    PPPoE server => Interface = lan
                                netmask = 25
                      server address = 172.30.10.254
                       address range = 172.30.10.0

    сделать netmask = 24 ??



  • @rubic:

    @M@kcumk@:

    PPPoE server => Interface = lan
                                netmask = 25
                      server address = 172.30.10.254
                       address range = 172.30.10.0

    сделать netmask = 24 ??

    иииии? толку от того что он маску сети на большую поставит?



  • у него клиенты c IP < 172.30.10.128 сейчас не в одной подсети с сервером



  • Сделал как сказали, но результат от этого не изменился.
    Мне кажется проблема в том что сервер не стартует, т.к. в Status Cervices отсутстует данная служба! Почему так?? Может ли это зависеть от правил в фаерволе? (по всем законам логики не должно)




  • Только что интереса ради проделал все как написано. zar0ku1 как всегда прав))) маска не решает…
    Что у вас конкретно не получается? Клиенты к серверу коннектятся по PPPoE?
    Если да, но нет инета, то в Outbound NAT надо еще добавить записи для 172.16.0.0/12 на WAN интерфейсе.



  • Кстати в Status - Services и не должно ничего появляться при поднятии PPPoE сервера
    Все работает.



  • Таки мне казалось что PPPoE туннелирует IP протокол, поэтому непонятна возня с IP адресами.
    как будет видно в логах, что PPPoE отрабатывает соединение, так дальше и думать.



  • Туннелирует, до pfSense. А дальше - как обычно - routing table и т.д. Выражение "клиент не видит сервера" ведь всяко-разно толковать можно))



  • собсна проверил на
    Version 2.0-BETA5 (i386)
    built on Thu Jan 6 17:09:33 EST 2011
    под virtualBox все работает на обычных виртуальных адаптерах.
    (только на vlan-ах PPPoe отказался соединяться, ну да отнесем это к тонкостям виртуализации виртуального  ;D).

    ![pfSense.localdomain - Status- System logs- VPN_1294410615382.jpg](/public/imported_attachments/1/pfSense.localdomain - Status- System logs- VPN_1294410615382.jpg)
    ![pfSense.localdomain - Status- System logs- VPN_1294410615382.jpg_thumb](/public/imported_attachments/1/pfSense.localdomain - Status- System logs- VPN_1294410615382.jpg_thumb)



  • Всем спасибо за столь активное участие!!!
    В ходе непрерывных экспериментов результат остался прежним((( PPPoE server не пингуется(с учетом предыдущих настроек 172.30.10.254), клиент не коннектится((( или может я чего не так делаю?!

    ЗЫ как проверить что pppoe server поднялся???



  • А еще лучше! если Вас, много уважаемые форумчане, не затруднит дать подробные инструкции по созданию маршрутизатора с характеристиками описанных в указанном мною мануале выше. или же подробно прокомментировать его! плиз!!! оч надо!!! за ранее благодарю!



  • Расскажите лучше что вы делаете на клиенте (настройка соединения, по шагам) чтобы подключить его к серверу.



  • Настройка клиента Windows:
    Пуск -> Сетевые подключения -> Создание нового подключения  -> Подключение к сети на рабочем столе (VPN) -> Подключение к виртуальным частым сетям -> Организация "Пипец" -> IP-адрес - 172.30.10.254  -> Ввожу логин и расс.
    Вроде бы так это все должно выглядеть!



  • а вид впн не выбирайте?



  • А разве в винде есть возможность выбора вида VPN??? что для PPTP, что для PPPoE - однотипное подключение! или если я заблуждаюсь поправте.



  • есть.



  • сделайте:
    Пуск -> Сетевые подключения -> Создание нового подключения  -> Подключить к Интернету -> Установить подключение вручную -> Через высокоскоростное подключение, запрашивающее имя пользователя и пароль -> Имя поставщика услуг: "Пипец" -> для всех пользователей.
    Имя пользователя PPPoE сервера, пароль, подтверждение, Готово.



  • УУУУУУРРРРРРРРААААА!!!! Наконец-то!!!! Получилось)))
    Всем большое спасибо!!!!! Все заработало!!!)))
    Нужно было только лишь корректно создать подключение на клиенте!!!



  • Да, видимо имя поставщика сыграло роль.
    Очень плохо, что визард винды не спрашивает про тип впн.



  • M@kcumk@ а на какой версии работаем? В новых сборках в файерволе появляется раздел для прописывания правил pppoe?
    А то начиная примерно с сентября вкладка users ушла в низ страницы с настройками pppoe сервера (было как в pptp, кому интересно - посмотрите) и исчезла вкладка с правилами файервола для pppoe.


Locked