FAQ по настройке wireless (wi-fi) access piont и bridge pfsense 2.0



  • @aleksvolgin:

    Рулятся как совершенно разные интерфейсы..

    это вы тонко намекаете, что таки возможно создание на сенсе virtual AP?

    Ну не то что-бы тонко.. А прямо так, в лоб. :)
    У меня сейчас крутятся 2 AP:
    1. Для офиса
    2. Для гостей

    Карта TP-Link на Atheros… модельку сейчас не скажу.. железки нет под рукой.



  • @Grant:

    неужели тема никому не интересна, никто не настраивает wi-fi на pf?

    Нужна, нужна. Спасибо за статью! :-)  Задача "висела" давно, да руки не доходили. Настроил все гут.

    Если кому надо, все в картинках. Может есть ошибки, не судите строго копипостера. :-)

    http://thin.kiev.ua/index.php?option=com_content&view=article&id=398:access-piont-bridge-pfsense-20&catid=50:pfsense&Itemid=81



  • @dr.gopher:

    @Grant:

    неужели тема никому не интересна, никто не настраивает wi-fi на pf?

    Нужна, нужна. Спасибо за статью! :-)  Задача "висела" давно, да руки не доходили. Настроил все гут.

    Если кому надо, все в картинках. Может есть ошибки, не судите строго копипостера. :-)

    http://thin.kiev.ua/index.php?option=com_content&view=article&id=398:access-piont-bridge-pfsense-20&catid=50:pfsense&Itemid=81

    Гут. Мне нравится.



  • @Grant:

    1. вариант
    Простой бридж между интерфейсами

    Настроил.  А потом обратил внимание на проблемку. Локальная сеть и вайфай в одной подсети и получаtт айпи с одного ДХЦП сервера. Вот только, не видят компы друг друга.

    Пинг с компа с Wi-fi не проходит на подключенный к LAN. Таже ситуация и из LAN к WI-FI
    Может каки правила добавить надобно?

    Включение опции Allow intra-BSS communication - не помогло.
    P.S. Помогло - добавление разрешающих правил в огненной стене.



  • @dr.gopher:

    @Grant:

    1. вариант
    Простой бридж между интерфейсами

    Настроил.  А потом обратил внимание на проблемку. Локальная сеть и вайфай в одной подсети и получаtт айпи с одного ДХЦП сервера. Вот только, не видят компы друг друга.

    Пинг с компа с Wi-fi не проходит на подключенный к LAN. Таже ситуация и из LAN к WI-FI

    настроил именно по первому варианту. всё работает, всё пингается.
    но столкнулся с проблемкой другой - как добавить Mac filtering с Captive portal ? он отказывается работать с интефейсом LAN, который bridge0…



  • Доброго времени суток!

    Это третья попытка внедрения PfSense. Первые две дальше стенда не пошли. Давненько я пытался создать бридж из нескольких сетевых интерфейсов PfSense 1.2.3-RC3
    http://thin.kiev.ua/index.php?option=com_content&view=article&id=347:brige&catid=50:pfsense&Itemid=81
    И тогда была проблемка с ДХЦП.

    Посему прошу не пинать. Опишу проблему с которой я столкнулся. Надеюсь всезнающий ALL ткнет меня носом в мои ошибки.

    Исходные данные:
    1. PfSense 2.03
    2. Celeron 633
    3. ОЗУ 512 мб

    4. Сетевые:  Intel® PRO/100 S Desktop Adapter (2 шт) разного года выпуска.
    http://www.intel.com/products/desktop/adapters/pro100s/pro100s-overview.htm

    5. WIFI:  DINK dwl-g510
    http://www.dlink.ru/ru/products/2/473.html

    WAN fxp0: 92.60.189.1/28
    LAN fxp1: 192.168.5.1/24
    WAFI opt1:  none

    Скриншоты всех или почти всех настроек:
    http://thin.kiev.ua/download/pf/forum/

    Проблемка:
    Клиенты WIFI не видят друг друга. Пришлось подключить два клиента WIFI и дескотоп.

    Включаю Allow intra-BSS communication в WIFI ( http://thin.kiev.ua/download/pf/forum/10.JPG  )

    Все работает. Интернет и пинги между всем и вся.

    WIFi > WIFI
    WIFi > LAN
    WIFi > ip в интернете

    LAN > WIFI
    LAN> ip в интернете

    Через 10-20 минут перестают идти пинги  (и SMB) между WIFI > WIFI
    А вот LAN > WIFI   работает!

    Выключаю, включаю - Allow intra-BSS communication, все начинает работать
    Через 10-20 минут все повторяется.



  • @sashka:

    настроил именно по первому варианту. всё работает, всё пингается.
    но столкнулся с проблемкой другой - как добавить Mac filtering с Captive portal ? он отказывается работать с интефейсом LAN, который bridge0…

    А можно скрины настроек интерфейсов и rules глянуть?
    Возможно это проблема самого WIFI или ошибка моей ДНК.



  • @dr.gopher:

    1. вариант
    Простой бридж между интерфейсами
    Настроил.  А потом обратил внимание на проблемку. Локальная сеть и вайфай в одной подсети и получаtт айпи с одного ДХЦП сервера. Вот только, не видят компы друг друга.

    Пинг с компа с Wi-fi не проходит на подключенный к LAN. Таже ситуация и из LAN к WI-FI
    Может каки правила добавить надобно?

    Включение опции Allow intra-BSS communication - не помогло.
    P.S. Помогло - добавление разрешающих правил в огненной стене.

    Подскажите, какие правила и для каких интерфесов настраивать?



  • @kozovoy:

    Подскажите, какие правила и для каких интерфесов настраивать?

    Читаем начало топика:

    2. вариант
    делаем бридж lan-opt1
    в рулезах в opt1 добавляем

    • 0.0.0.0 * 255.255.255.255 * * none –для работы DHCP
    • LAN net * * * * none  - разрешающее правило как на lan
      Либо
                • разрешать все, dhcp тоже работает


  • У меня после таких настроек не то что инета не стало, а перестал откликаться pfsense по webgui.
    Подключил монитор и клаву, сделал резет. Что и думать не знаю.



  • Привет всем помогите, не пойму где туплю!
    Использую мини гайд в начале темы начал попытки настройки wifi access point.
    Начал с метода 2 как показалось проще и доступней.
    описываю действия:
    У меня стандартная конфа с изменениями для l2tp для билайна, имеем:
    wan - fxp1- dhcp
    lan - fxp0 - 10.10.10.1
    opt1 - l2tp - connect
    Wifi ctntde[f djnryenf (ral0)
    (как бы внешняя сетка отношения не имеет к настройке, это для примера)
    1 Начинаем настройку по методу 2
    interface - (assign) - нажимаем "+" - получаем "opt2 (ral0)" - жмем "save"
    interface - opt2 - ставим "enable" - из стандарта добавляем -mtu "1500" - standart "802.11g" -mode "access point" - ssid "MyHomeNet" - Allow intra-BSS communication "yes" - жмем "save" и "apply"
    interface - (assign) - bridges -жмем "+" - выбираем через "ctrl" lan и opt2 - жмем "save"
    interface - (assign) - нажимаем "+" - получаем "opt3 (bridges0)" - жмем "save"
    interface - opt3 - ставим "enable" - жмем "save" и "apply"
    firewall - rules - opt2 - нажимаем "+" - жмем "save" (получаем правило "разрешено все")
    на всякий случай
    firewall - rules - opt3 - нажимаем "+" - жмем "save" (получаем правило "разрешено все")
    DHCP server поднят(на интерфейсе lan 10.10.10.100-10.10.10.199 gateway 10.10.10.1 dns 8.8.8.8), по шнурку ip получают, по wifi связь есть но ip не получают, но даже ручками забитый 10.10.10.88 не пингует 10.10.10.1
    2 Забил, думаю подниму по методу 1:)
    На этапе
    Меняем lan на bridge0, opt2 на nfe0
    В итоге должно получиться
    Wan- rl0
    Lan – bridge0
    Opt1 – ral0
    Opt2 – nfe0
    Нажать “save” , при этом соединение не разорвется и никаких правил добавлять и переделывать ненужно. Можно добавлять любое количество интерфейсов. DHCP работает на всех интерфейсах.
    лезу в interface - (assign) - в lan меняю на bridge0 - opt2 на fxp0 - жму "save" пишет 2 bridge0 интерфейса , ошибка
    Вот такой лол



  • Товарищи, есть ли у кого то настроенный роутер который нормально работает? :) Не могли бы вы выложить скрины настроек, под WAN / LAN / Wi-Fi AP (Intel PRO/Wireless 3945ABG).

    Интересуют:
    1. Interface (assign - bridges)
    2. Service \ DHCP Server (wifi - opt)
    3. Ну и все сопутствующие настройки
    4. Дашборд

    $ dmesg
    wpi0: <intel(r) pro="" wireless="" 3945abg="">mem 0xe0200000-0xe0200fff irq 17 at device 0.0 on pci2
    wpi0: Driver Revision 20071127
    wpi0: Hardware Revision (0x1)
    wpi0: Regulatory Domain: MoW2
    wpi0: Hardware Type: B
    wpi0: Hardware Revision: ?
    wpi0: SKU does support 802.11a
    wpi0: [ITHREAD]
    wpi0: HOSTAP mode not supported
    wpi0: timeout resetting Tx ring 1
    wpi0: timeout resetting Tx ring 3
    wpi0: timeout resetting Tx ring 4</intel(r)>

    $ ifconfig
    wpi0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
    ether 00:1c:bf:34:f4:fe
    media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
    status: no carrier</up,broadcast,running,simplex,multicast>

    Ага, видимо мой косяк в HOSTAP mode not supported. Нужно будет попробовать с другой сетевой…



  • @art13:

    У меня после таких настроек не то что инета не стало, а перестал откликаться pfsense по webgui.
    Подключил монитор и клаву, сделал резет. Что и думать не знаю.

    Так и есть. В ситуации когда неправильно внесены изменения. Сам раза три делал все с начала.

    Добавил два скриншота в статью.

    Теперь стало понятнее и мне самому.
    http://thin.kiev.ua/index.php?option=com_content&view=article&id=398:access-piont-bridge-pfsense-20&catid=50:pfsense&Itemid=81



  • @gig:

    Товарищи, есть ли у кого то настроенный роутер который нормально работает? :) Не могли бы вы выложить скрины настроек, под WAN / LAN / Wi-Fi AP (Intel PRO/Wireless 3945ABG).

    Скриншоты  http://thin.kiev.ua/download/pf/forum/    актуальны и правильны.
    Настроил всё с нуля на тоже железе. Проблема пингов WI-Fi клиенты <=> LAN  и  WI-Fi клиенты <=> WI-Fi клиенты УШЛА.



  • Доброго времени суток!
    Решил то же я pfsens на Wi-Fi "попытать"..Карточка у меня Atheros 5212 (DWA 520 , в микротике пашет без проблем)
    Так вот как только устанавливаю режим "Adhoc(IBSS)" pfsense уходит в полный "ступор" ???
    Ни Reset ни default не помогает….
    Печально.... :'(



  • А можно задать глупый вопрос: какую смысловую нагрузку несёт VLAN на fxp1 (WAN)?

    Добавил два скриншота в статью.

    второй скин, вероятно должен быть с подписью "После изменений".



  • @aleksvolgin:

    второй скин, вероятно должен быть с подписью После изменений".

    Извиняюсь. Исправил.



  • Карточка у меня Atheros 5212 (DWA 520 , в микротике пашет без проблем)

    версия микрота какая?



  • @aleksvolgin:

    версия микрота какая?

    2.9.27



  • Блин, друзья, а USB Wi-Fi карточку можно присобачить к Сенсу?
    Вот такая у меня http://zyxel.ru/g-202-ee
    Главно при запущеном сенсе воткнул, он увидел её, написал типа воткнута такая то модель, а дальше нифига.. Перезагрузил - нет её нигде((


Log in to reply