DHCP+PPOE(WAN)+static routing



  • Добрый день!
    прошу помощи у знатоков. не бейте сразу… необходимо организовать вход в локальную сеть провайдера.. на длинке все работало вот так. + включить мультикаст. установлен pfs 2.0.1.



  • попытался в рулеас прописать, но после любых изменений pfs теряет инет. и не находит его даже после удаления рулесов… неужели ни кто не сталкивался с такой проблемой...? может более старую версию поставить?



  • @crazy_user:

    неужели ни кто не сталкивался с такой проблемой…?

    Вопрос сформулируйте.
    Реквизиты сетей ваши, провайдера, статик, дхцп и т.п. ?
    А еще есть поиск по форуму.



  • @dr.gopher:

    @crazy_user:

    неужели ни кто не сталкивался с такой проблемой…?

    Вопрос сформулируйте.
    Реквизиты сетей ваши, провайдера, статик, дхцп и т.п. ?
    А еще есть поиск по форуму.

    поиском я уже воспользовался.. даже в доку посмотрел… может не туда или не так...

    инет приходит по кабелю получается адрес по дшсп+потом подымается PPOe к провайдеру. локальная сеть прова 10.10.x.x маршрутизация через 78.137.1.128/25 подсети 255.255.252.0 сеть внутри офисa 192.168.0.хх 255,255,255,0 адреса раздает pfs. сервер который вещает телевидение 10.10.184.5.
    задача входить на локальные ресурсы 10.10.х.х + смотреть IPTV



  • @crazy_user:

    инет приходит по кабелю получается адрес по дшсп+потом подымается PPOe к провайдеру. локальная сеть прова 10.10.x.x маршрутизация через 78.137.1.128/25 подсети 255.255.252.0 сеть внутри офисa 192.168.0.хх 255,255,255,0 адреса раздает pfs. сервер который вещает телевидение 10.10.184.5.
    задача входить на локальные ресурсы 10.10.х.х + смотреть IPTV

    Имхо, вам достаточно прописать статический маршрут в сеть провайдера.



  • @dr.gopher:

    @crazy_user:

    инет приходит по кабелю получается адрес по дшсп+потом подымается PPOe к провайдеру. локальная сеть прова 10.10.x.x маршрутизация через 78.137.1.128/25 подсети 255.255.252.0 сеть внутри офисa 192.168.0.хх 255,255,255,0 адреса раздает pfs. сервер который вещает телевидение 10.10.184.5.
    задача входить на локальные ресурсы 10.10.х.х + смотреть IPTV

    Имхо, вам достаточно прописать статический маршрут в сеть провайдера.

    c этого я и начал.. даже сабж так назвал.. но при вводе гейтвея выдается
    The following input errors were detected:

    The gateway address 10.10.184.5 does not lie within the chosen interface's subnet.

    такое же было на старом линксисе..



  • @crazy_user:

    c этого я и начал.. даже сабж так назвал.. но при вводе гейтвея выдается
    The following input errors were detected:

    http://thin.kiev.ua/router-os/50-pfsense/565-pfsense-20.html
    Возможно необходимо будет прописать стат. маршрут на локальной машине.



  • @dr.gopher:

    @crazy_user:

    c этого я и начал.. даже сабж так назвал.. но при вводе гейтвея выдается
    The following input errors were detected:

    http://thin.kiev.ua/router-os/50-pfsense/565-pfsense-20.html
    Возможно необходимо будет прописать стат. маршрут на локальной машине.

    у меня 10 машин с разными осями… прописать конечно возможно, но геморно как то... может дело именно в PPPOe ?



  • The gateway address 10.10.184.5 does not lie within the chosen interface's subnet.
    такое же было на старом линксисе..

    С pppoe проблема маловероятна. Подключение ведь идет на L2 и не маршрутизируется
    Скорее всего проблема с масками сетей. Посмотрите маску на wan интерфейсе. У вас получается, что шлюз не находиться в подсети интерфейса.
    Потом делаете этот шлюз используемым по умолчанию, добавляете правило NAT (на pppoe интерфейсе) и все должно работать.
    Ну и читаете про тонкости настройки iptv.

    10.10.x.x маршрутизация через 78.137.1.128/25 подсети 255.255.252.0

    10.10.x.x  - 16
    78.137.1.128  - 25
    255.255.252.0 - 22
    192.168.0.хх - 24
    Сетей по описанию три, а масок я уже четыре насчитал



  • @nomeron:

    The gateway address 10.10.184.5 does not lie within the chosen interface's subnet.
    такое же было на старом линксисе..

    С pppoe проблема маловероятна. Подключение ведь идет на L2 и не маршрутизируется
    Скорее всего проблема с масками сетей. Посмотрите маску на wan интерфейсе. У вас получается, что шлюз не находиться в подсети интерфейса.
    Потом делаете этот шлюз используемым по умолчанию, добавляете правило NAT (на pppoe интерфейсе) и все должно работать.
    Ну и читаете про тонкости настройки iptv.

    10.10.x.x маршрутизация через 78.137.1.128/25 подсети 255.255.252.0

    10.10.x.x  - 16
    78.137.1.128  - 25
    255.255.252.0 - 22
    192.168.0.хх - 24
    Сетей по описанию три, а масок я уже четыре насчитал

    Спасибо! сегодня попробую, а то как в анекдоте- "…ну вот нутром чувствую? что 0.5 + 0.5 = литр.. а объяснить не могу..." так и я понимаю... что дело в масках... а все равно головой об стену... настройка IPTV не пугает.. тут бы попасть к прову в сетку, а там уже по месту разберусь :)



  • у меня ваще крыша уехала.. динамический шлюз, который появляется на wan интерфейсе, и используется по умолчанию, ваще другой(109.227.70.1 ).. и понятное дело в абсолютно другой подсети отличной от описанных выше..:( даже вот это http://ru.doc.pfsense.org/index.php/PPPoE_или_PPTP_на_WAN_c_DHCP попробовал… инет пропал.. буду копать...



  • поставил версию 1.2.3 + пакет РСlientWAN настроил интерфейс ОТР1+static routing. инет поднялся.. в сетку провайдера попасть не могу.. подскажите, плиз, что не так делаю…?

    PS На фре все работало... :(




  • Правило NAT  скорее всего затрагивает и диапазон сети провайдера.
    Оно применяется первым до маршрутизации. Попробуйте в него записать !сеть провайдера в destination



  • @nomeron:

    Правило NAT  скорее всего затрагивает и диапазон сети провайдера.
    Оно применяется первым до маршрутизации. Попробуйте в него записать !сеть провайдера в destination

    Пробовал. при вводе в destination сети провайдера инет пропадает, а сеть провайдера не появляется. :( сейчас в NAT вот так:




  • после перезагруза pfs появилась сетка провайдера, но пропал инет.. жив остался только скайп.. мистика… на версии 2.0.1 ваще не работает.. на этой почти не работает, squid тоже не завелся... :( не хочу опять фрю подымать... уж очень сильно обленился :)



  • вернул пока все назад. убрал ОТР.. инет - ОК. локальных ресурсов прова нет.. если у кого будут какие идеи поделитесь, плиз…
    PS ставить фрю, плиз, не предлагать...



  • Вы на WAN что повесили - pppoe или получение dhcp от пров-ра ?



  • @werter:

    Вы на WAN что повесили - pppoe или получение dhcp от пров-ра ?

    получение от прова DHCP. у меня примерно по такой схеме http://ru.doc.pfsense.org/images/8/89/PclientWAN_assign.jpg



  • Ок. А pppoe-линк в Interfaces: PPP в Interface(s)/Port(s) висит на физической сетевой или на имени интрефейса (WAN, OPT1 etc.) ? У меня он на "физику" повешен.



  • @werter:

    Ок. А pppoe-линк в Interfaces: PPP в Interface(s)/Port(s) висит на физической сетевой или на имени интрефейса (WAN, OPT1 etc.) ? У меня он на "физику" повешен.

    не совсем понял вопроса. кроме этого, ничего не нашел






  • У меня версия pf 2.0.1!




  • @werter:

    У меня версия pf 2.0.1!

    на этой версии у меня вообще не поднялся ОТР.. завтра попробую еще раз.. может у провайдера чтото…



  • Пробовал. при вводе в destination сети провайдера инет пропадает, а сеть провайдера не появляется. Sad сейчас в NAT вот так:

    Смотрите на текст внимательно. Символ - ! означает отрицание.
    Оставьте правила NAT как у вас на слайде.
    Т.к сеть провайдера не маршрутизируется с вашей локальной подсетью, то NAT нужно использовать в обоих случаях
    И в правилах интерфейса LAN пропишите 2 правила
    1. Если адрес назначения не сеть провайдера (подсеть отобразиться со знаком ! - т.е  !10.10.0.0  ) то использовать шлюз pppoe
    2. Если адрес назначения сеть провайдера - использовать шлюз wan (шлюз в доп параметрах)



  • @nomeron:

    Пробовал. при вводе в destination сети провайдера инет пропадает, а сеть провайдера не появляется. Sad сейчас в NAT вот так:

    Смотрите на текст внимательно. Символ - ! означает отрицание.
    Оставьте правила NAT как у вас на слайде.
    Т.к сеть провайдера не маршрутизируется с вашей локальной подсетью, то NAT нужно использовать в обоих случаях
    И в правилах интерфейса LAN пропишите 2 правила
    1. Если адрес назначения не сеть провайдера (подсеть отобразиться со знаком ! - т.е  !10.10.0.0  ) то использовать шлюз pppoe
    2. Если адрес назначения сеть провайдера - использовать шлюз wan (шлюз в доп параметрах)

    если я Вас правильно понял, то при этих настройках работает только скайп…




  • Конечно, только скайп и будет работать. Ну и соединение на любой IP.
    Включите DNS. Ему нужен протокол udp и порт 53.
    Т.е правило
    tcp\udp  * * * 53 * *



  • @nomeron:

    Конечно, только скайп и будет работать. Ну и соединение на любой IP.
    Включите DNS. Ему нужен протокол udp и порт 53.
    Т.е правило
    tcp\udp  * * * 53 * *

    Спасибо! помогло! осталось до конца с сетями провайдера разобраться. :( у прова есть веб-сервера с внешними ай-пи типа 78.137.0.0, заходя на них через ОТР1 я получаю отказ. нужно правило типа если "пункт назначения" 78.137.0.0 использовать подсеть 255.255.252.0 гейтвей 10.10.0.0… помогите советом, пожалуйста. где его организовать?



  • Routing + для верности правила в fw с явным указанием gw



  • @werter:

    Routing + для верности правила в fw с явным указанием gw

    в версии 1,2,3 локальные ресурсы повились при настройке роутинга как на картинке. в 2,0,1 не могу прописать на ОТР1 нужный гейтвей.. может я чет не то делаю?




  • Добавляйте правила выше созданных ранее (т.е выше отрицания 10.10.0.0)
    tcp/udp  * 78.137.0.0  opt1



  • @nomeron:

    Добавляйте правила выше созданных ранее (т.е выше отрицания 10.10.0.0)
    tcp/udp  * 78.137.0.0   opt1

    добавил. не работает. :(




  • придется водружать фрю… не могу поднять раздельный вход по сетям...


Locked