Servico internet demasiado lento



  • Buen día, saludos a todos.

    En días pasados me propuse instalar un firewall para la empresa para la cual trabajo actualmente. Y opte por pfsense.

    Actualmente cuentan con un balanceador de carga, TP-link que hace las funciones de balanceo de carga, dhcp server gateway en fin, un router etc.

    La Instalación se hizo sin problemas,

    El problema es a la hora de implementarlo, internet muy lento.. desconexiones, paginas tardan mucho abrir y en fin un largo etcetera.

    El hardware que utilizo es un cpu con procesador doble nucleo, 2gb de RAM y 2 tarjetas de red.

    Alguna idea ?

    Es una red de máximo 50 usuarios.

    La empresa cuenta con un 1 enlace a 50mb y 2 enlaces a 4mb. Segun mis calculos y debido a la carga de trabajo el solo enlace a 50mb seria mas que suficiente.

    Saludos de antemano.



  • Que servicios  prendistes en tu pfsense?



  • Que tal periko,

    squid + squidguard… un rato use dansguardian.

    Me da que el problema viene con algo de configuracion de squid..

    Segui las instrucciones en tu blog sobre instlacion de cero.

    Ahorita lo tengo apagado, pq la oficina se puso histerica.

    Pero por donde empezaria a buscar una solucion ? El hardware esta bien para las necesidades ?



  • Un paso a la vez.

    Yo haria lo siguiente, tienes un router operando, entonces tu red esta trabajando sin el pfsense correcto?

    Yo prenderia el pfsense, pero solo agregaria mi maquina que cruzara por ahi, prenderia solo el squid.

    Puro fw y probar como se desempena, una atraves de tu router y sobre pfsense y tomaria notas de desempeno, sin nigun servicio simple fw.

    Si no hay diferencia,  optaria por squid3, ya la rama 2 no por que te reganan en la lista de squid si preguntas(se los juro), sin squidguard por el momento.

    Ahora revisaria mi hw, cuanto espacio le dijistes a squid que usara de cache en disco duro y cuanta memoria le asignastes?

    De ahi haria los cambios y probaria, con tu equipo, esto lleva su tiempo, luego si todo sigue operando igual me voy por squidguard claro si deseas implementarlo.

    Solo espero tengas la habilidad de cuando salga las paginas bloqueadas poder restrear y re-configurar rapido por que la gente se enoja.

    Como comentario, para squid con tu hw, yo le asignaria 800MB, no has mencionado si tu disco es sata o ide, pero me voy x sata, y le crearia una particion chica, squid no requiere mucho espacio mucho menos un fiewall.

    20 GB  y con iniciaria, mientras mas chica sea la particion la cabeza del disco se mueve menos para llegar a el dato, y sobre todo tu swap lo haria de 512MB la idea es que no uses la swap eee.

    monta / con noatime.

    Espero te sirva de algo todo esto, saludos.



  • Le di un factory reset.

    ahorita acabo de instalar squid3 con 60gb de cache y 1024 de memoria.

    Es un sata de 160 gb.



  • Repito, squid  no requiere tanto espacio, al menos que seas un ISP y tengas clusters de squid, 8-16GB suficiente.



  • Enterado, 16GB de cache.



  • yo tengo 500M de cache y la verdad la navegacion esta genial.. el asunto de tener tanto espacio para cache es que en algun momento se podra muuuuuy lento todo ya que el acceso a disco es mas lento.. creo que 16GB es mucho.. es mi opinion



  • Correcto juancho, los algoritmos de squid dicen que con 8-16GB es mas que suficiente, aqui tengo uno con 70 usuarios y sin problemas y cerca de 9GB de cache.

    Vamos viendo como le funciona.

    La cosa es que pruebe, ya sabes que squid no puedes cantar victoria hasta los 3 dias corriendo…



  • jajaja cierto.!! ese squid se las trae..



  • @trasher:

    Le di un factory reset.

    ahorita acabo de instalar squid3 con 60gb de cache y 1024 de memoria.

    Es un sata de 160 gb.

    squid3 no esta en beta? no le he usado por eso, me estoy perdiendo entre otras cosas poder filtrar https



  • Hay 2, 3 y 3-dev.



  • Entonces por lo que veo…

    Squid solamente utiliza la memoria RAM.

    El cache, lo accesa muy poco.

    Ahorita, con una sola computadora no me da ningun problema, intentare mas tarde meter varias computadoras a la red y les cuento como me fue.



  • Squid usa la red y cuando un objeto es mas nuevo, manda los viejos a disco, cachea tanto en memoria como disco duro, asi es por default el algoritmo que usa, pero tiene mas.



  • Para agregar solamente, recuerda que tienes 2GB, de ahi estas dando 1GB a squid, si vas a querer integrar squidguard te vas a dar de topes, ya que ese servicio crear hilos, y cada hilo tiene un peso en memoria, para mantenerlo en memoria, creo que por default levanta 5 hilos, esto incrementa el uso de memoria, para tu red vas a necesitar mas memoria.

    Te lo comento que es lo mas seguro que te paso, se saturo tu pfsense.

    Te dejo este enlace, saludos.

    http://pheriko.blogspot.mx/2013/10/pfsense-2x-squidguard-redirector-warning.html





  • Y por otro lado,

    le dejare 512 mb a ver que pasa…



  • Comprueba bien la resolución DNS en tu instalación. Es una causa frecuente de ralentización de las conexiones.



  • Que tal, no entendí tu consejo.



  • Diagnostics / DNS Lookup

    Tiempos de resolución que obtengas…

    Y en las estaciones de los clientes

    Linux

    $ dig www.google.com | grep time
    

    Windows, http://samsclass.info/40/proj/digwin.htm



  • :) hola…

    te recomiendo quites de la instalación el squid... no he visto la primera prueba con pfsense que funcione bien con squid, siempre empieza bien y al poco tiempo se vuelve inestable y lento



  • Que tal a todos,

    Muchas gracias por los consejos.

    Ayer en la noche hize los cambios necesarios para tener funcionando el pfsense, hoy voy llegando a la oficina y nadie se ha quejado, parece que esta bien.

    Configs: 512 RAM 8Gb Cache.

    Esperemos que siga asi.

    Ah si, por cierto, solo esta activo squid3 en modo transparente, SquidGuard de momento inactivo.

    Esperemos que siga asi todo el dia.

    Saludos!



  • Los problemas ahora son con outlook,

    No puedo enviar correos…

    Imagino que es por firewall, alguien me pueda hechar una mano ?



  • Trasher un leve comentario.

    Instalastes un software que de entrada es sencillo, pero para poder agarrar este carrito tienes que entenderlo, no solo es prendelo y listo, te habia comentado que lo pusieras en tu red bajo tu maquina y sobre entendieras que lo pusieras a prueba.

    En tu equipo corrieras todo lo que ahi en tu red usan y asi pudieras pulirlo, muchas veces la gente o empresarios les queda una mala imagen por que se hace esto, se implementa y no se tiene el conocimiento adecuado para poder administrarlo, claro ahi que ponerlo a trabajar para entenderlo estoy totalmente de acuerdo, pero no en una red de 50 usuarios que ellos quieren poder realizar su trabajo sin problemas.

    Ahora ya pusiste squid, ahora tienes problemas con el firewall, tienes que entender como leer los logs como abrir los puertos adecuados en tu LAN para que pueda salir hacia fuera sin problemas, aqui ya te di un norte.

    Espero tomes este comentario de una manera positiva, solo imaginate cuando tengas squid+squiguard+firewall bloqueando alguna pagina? no tendras la habilidad de leer los logs y poder hacer la modificacion rapida, que es lo que la empresa espera de tu parte, se pierde esa confianza hacia ti y tus sistemas.

    Te voy hacer una recomendacion, regresa, prendelo, entiendelo y de nuevo a la carga, si le hechas los kilos en pocos dias podras manejarlo a un nivel donde esto que estas pasando te dara risa.

    Por el momento te puedo decir que tienes que abrir los puertos para que tus clientes puedan ir y accesar los servidores de correo, me imagino que los tienes externos a tu red o sea en Internet, ahora que puertos necesitas? es pop, imap, pops, imaps…?

    LAN->any ==> WAN->25,465,110, etc, etc...

    Saludos.



  • Que tal,

    Estoy acoplándome al pfsense.

    No pensé que fuera a complicarse tanto la situacion… imaginaba que el FW estaria configurado, bloqueando todas las entradas... pero permitiendo todas las salidas.

    Sondee un poco la red recien llegue en la mañana y se quejaban algunos usuarios de lentitud...

    A veces esto me desespera...

    Pero bueno, esta apagado... sigo con el balanceador que estaba originalmente.

    Y periko, gracias por el comentario.. a tener muy en cuenta.

    Saludos!



  • Estan seguro como tu quieras hacerlo, puede ser tan liberar como paranoico, segun tu sabor, asi que hechale los kilos, si podemos ayudarte mas aqui tienes este gran foro, siempre hay alguien con deseos de ayudar, saludos.



  • Todo parece indicar que la "lentitud" era un problema de HW.

    No estaba funcionando bien el ventilador del procesador ocasionando sobrecalentamiento.

    Acabo de corregir el problema y estoy reinstalando pFsense de nueva cuenta.



  • De cualquier manera, compre mas memoria RAM.

    Ahorita lo tengo funcionando con 4gb y sin problemas.

    Gracias atodos por los consejos.

    Saludos!°



  • Saludos mi estimado excelente las consideraciones que te ha dado periko en mi experiencia he optado por usar squid fuera de pfsense y dejar este solo como enrutador y firewall. Va excelente ademas uso haarpcache para cache dinamico ya que mis clientes son alto consumidores de youtube, facebook, entre otros. Como bien te ha dicho periko debes estudiar tu red de servicios haciendo las pruebas necesarias para que las inversiones que hagan sean 100 % fructiferas siendo o no el dueño de la empresa de la red de servicios. Estamos a tu orden



  • entonces que fue se pudo o no supo, tengo una red similar y quisiera sabe si mejor compro un router/firewall



  • @mkhakk pfsense ha cambiado mucho en 5 años y ahora es mas facil que antes


Log in to reply