[SOLUCIONADO] PfSense e Imagenio



  • He conseguido hacer el bridge entre los dos puertos y pasar la voip al router, tengo linea y puedo hacer llamadas, basicamente es hacer un bridge entre dos vlan 3 una en cada puerto, si a alguien le interesa puedo poner la configuracion detallada.

    Por otro lado me ha dado por trastear con el IPV6 y me he encontrado con que Movistar me da una ip publica, no sabia que movistar ya tenia IPv6 funcionando?

    No he probado si hay conectividad pero por lo menos la WAN recibe una ip publica…



  • Alguno de vosotros tiene la VOIP funcionando con Movistar ???, no consigo que me funcione… Como haceis el NAT en pfsense?

    Gracias Por adelantado



  • Es posible hacer funcionar el VOD en el decodificador sin hacer un NAT 1:1? Esto es lo mismo que un full-cone nat?
    Por otro lado alguien ha comentado lo de poner el deco en una Red separada, entiendo que para eso es necesario partir la lan normal que tengo ahora en dos vlan, pero si debajo del pfsense tengo 2 routers wifi (funcionando como meros puntos de acceso) entiendo que tendría que definir las vlans en cada uno de ellos también…
    Alguien que tenga el deco en un Res separada puede poner un ejemplo de como lo tiene configurado?



  • Yo tengo un problema con los canales de Canal+, fútbol, motos, etc..

    Pasado unos segundos el video se congela y el audio desaparece - la única forma de ver estos canales es en diferido.

    ¿Alguna sugerencia sobre como arreglarlo?



  • Es por igmpproxy a veces se queda como tostado con algunos canales, reinicia el igmpproxy y arreglado. Con la version 2.3 no me ha pasado.

    Otra causa puede ser el ancho de banda, por las pruebas que he realizado el ancho de banda de la vlan de imagenio es de 25Mb si estas viendo muchos canales simultáneos y llegas a mas de 25Mb hace cosas raras como congelar canales.



  • Saludos,

    Necesito algún consejo y ayuda. Voy a ver si me explico.

    Tengo un Pfsense recién actualizado a 2.3. La wan está conectada a la fibra pero sin la VLANS (están configuradas pero no activas), de momento no puedo prescindir del router de Movistar. Voy siguiendo el foro y el manual de Donizt.

    Resultado de lo hecho hasta ahora:
    VOIP sin problemas, Udpxy sin problemas, Multicast sin problema con IGMP entre la WAN y la LAN. En el servidor DHCP de la LAN tengo la opción de 240 para que el Desco tenga la opción del multicast y  DNS  172.26.23.3

    Veo la tele por VLC o Kodi sin problemas en Unicast y Multicast. Veo la tele en el Desco e incluso veo la guía de programas PERO, aquí está el PERO, los menús del desco no están o salen las opciones entre corchetes en inglés. ¿De dónde toma está información?

    Si hago un bridge entre wan y opt1 para separar la Tv del resto de la red el Desco funciona perfecto, aunque mi problema está en el switch que es compartido entre LAN y Opt1 y de no puedo separarlas (Solo da ip por DHCP  la red LAN) y la privada con la opción 240 de la WAN que llega a los Descos. (tengo multiroom con dos desco aunque en plantas diferentes del edificio la opción de intentar un puente por wifi no me funciona)

    Entiendo que esto no es bueno pues provocará colisiones en el switch.
    Donizt y/o Bellera comentaban en el manual al final tras la parte de udpxy poner una tarjeta distinta para el Desco pero supongo que es para conectar el Desco directamente no a través de toda la trama de red.

    WAN ip: 192.168.200.2/24 El Gateway es el router de telefónica 192.168.200.1
    LAN ip: 192.168.1.1/24
    OPT1 ip: 192.168.101.0/24
    (Tengo otra WAN y otras redes internas en el Pfsense pero no afectan al tema que comento)

    Por tanto:

    1. ¿Por qué el Desco no tiene los menús en castellano o en simple inglés sino corchetes con las opciones? ¿Cómo hago para que el Desco tenga esa información?

    2. Si la opción anterior no es posible y hago un bridge entre la WAN y lOPT1(sería para dejar pasar tal cual la wan hacia opt1) ¿Cómo configuro mi red sin que haya conflicto entre LAN y OPT1? ¿Es posible? ¿Valdría hacer que LAN fuera 192.168.0.0/16 para abarcar a la opt1? ¿Podría mediante reglas evitar multicast fuera de las ips de los Descos sin que haya conflicto entre redes?

    Mientras sigo investigando si alguien puede aportarte ideas o soluciones se lo agradecería.



  • Por lo que lei en un foto, el deco de imagenio cuando enciende pilla el firnware mas actualizado de sus servidores.

    Entiendo que tienes 2 decos, son los dos los que te aparecen en ingles o solo 1?

    En la configuracion del NAT 1:1 que deco tienes configurado el que te sale en ingles o el otro?

    En el IGMProxy que ips tienes
    yo tengo esto ahora mismo

    IMAGENIO upstream 172.26.0.0/16, 239.0.0.0/8, 10.0.0.0/8, 239.0.0.0/16, 172.0.0.0/8 multicast imagenio
    TV downstream 192.168.1.0/24 Multicast TV

    Lo de tener dos redes una para los decos y otra para la lan es evitar el trafico multicast en la red LAN. pero en principio no hay ningún problema en dejarlo todo el LAN, salvo si es por WIfI.

    Yo en mi caso tengo una maquina virtual con un linux (ubuntu) corriendo el udpxy y el tvheanded (puedes encontrar mas info en la pagina de www.luispa.com). Y las otras tv las conecto al tvheanded con una rapsberry y el openelec ( si la tele lo soporte se puede manejar la rpasberry con el mando de la tele por el hdmi).

    El problema del pfsense con imageneio con 2 decos lo veo en el nat 1:1 realmente hace falta full-cone nat pero el pfsense no lo hace (logicamente) y se apaña con el nat 1:1 pero claro…. solo vale para un deco.

    Para los dos decos otra opción ( para mi la mejor en tu caso ) es hacer un híbrido entre lo que hace luispa y el pfsense. Consiste en tner el pfsense con la vlan de internet y voip y la vlan de imageneio tratarla con el gentoo y con su parche si se puede hacer full cone nat.

    Si puedes mira lo del nat 1:1, a ver si el que tiene ese mapeo es el que esta en castellano y el otro.

    un saludo y ya me contaras como evoluciona esto.

    Por otro lado una de las ventajas del tvhended es que si tienes una vpn entre dos imagenios distintos puedes compartir canales entre unos y otros



  • ¿Me sabéis decir porqué el MTU de los interfaces para las VLAN de VoIP e Imagenio debe ser 1594?.

    Por más que busco veo que todo el mundo lo aconseja pero no encuentro el porqué y si miro con ifconfig cómo está configurado el router de Movistar veo que ellos las ponen a 1500.

    ¿Qué MTU se debe poner al interfaz físico sobre el que van las VLAN?.

    Muchas gracias.



  • Hola
    @regne:

    ¿Me sabéis decir porqué el MTU de los interfaces para las VLAN de VoIP e Imagenio debe ser 1594?.

    Por más que busco veo que todo el mundo lo aconseja pero no encuentro el porqué y si miro con ifconfig cómo está configurado el router de Movistar veo que ellos las ponen a 1500.

    ¿Qué MTU se debe poner al interfaz físico sobre el que van las VLAN?.

    Muchas gracias.

    El MTU es la Máxima Unidad de Transferencia o el tamaño del paquete IP más grande que acepta un medio de Transmisión sin tener que ser fragmentado para su envío. Para Ethernet suele ser 1500 (1500 Bytes el tamaño del paquete incluyendo los 28 bytes de la cabecera ip). Para PPPoE suele ser 1492.

    Un script para calcular MTU: https://www.javcasta.com/bash-script-getmtuv2-sh-calcular-mtu-en-pfsense-version-2/

    En cuanto a la problemática del MTU para VoIP

    ref:  http://www.voiptroubleshooter.com/problems/mtu.html

    The maximum delay introduced by a packet is equivalent to the MTU size divided by the link speed

    El máximo retardo (delay) introducido por un paquete es equivalente al tamaño del MTU dividido por la velocidad del enlace.
    Para un MTU de 1500 en un enlace T1, el retardo seria de 8msg, para enlaces de velocidades menores el retardo se incrementa y puede causar jitter ( http://www.voiptroubleshooter.com/problems/jitter.html , congestión de la red por descarte de paquetes, problemática en VoIP).

    Conclusión: Lo ideal es poner el MTU óptimo, ya que si retardo=MTU/velocidad, a mayor MTU menor retardo y mejor calidad en la Tx de audio (no se percibe el delay). Pero si se pone un MTU mayor que el que acepta el medio, los paquetes se deberán fragmentar y habria problemas tb.

    Salu2



  • Pero porqué 1594 exactamente. En los enlaces que has puesto no veo que lo aclare, ni siquiera aparece ese número.

    El cálculo de porqué el MTU para PPPoE es 1492 es archiconocido, pero porqué para VoIP e imagenio tiene que ser 1594 si las entradas y salidas al router pfSense son sobre ethernet que tiene un MTU máximo de 1500. ¿Tener un MTU a 1594 no causa fragmentación?.

    Gracias de nuevo.



  • Hola

    Me ciño a lo que es un MTU y lo que se recomienda para VoIP. (Poner MTU óptimo, y que no fragmente obviamente)

    El MTU 1594 no es para medio Ethernet ni PPPoE, es para FFTH, otro medio de transmisión otro MTU, no entiendo la duda.

    Calcula tu MTU y aplica lo que te sea óptimo. No hay nada mejor que el ensayo error en tu propia infraestructura :)

    Si con 1594 te va bien estupendo, sino prueba a bajarlo (en múltiplos de 2)

    https://www.voipnovatos.es/2015/02/26/como-configurar-un-mikrotik-para-usar-la-vlan3-de-voip-de-movistar-ffth/

    Salu2



  • Ese tamaño de mtu surgio despues de mirar linea a linea la configuracion del router de telefonica. Los valores que puse en la guia era los que tenia el router.

    De todas formas hay cosas que han cambiadod ede que escribi la guia, no muchas pero no hay nada como trastearlo uno mismo



  • @donizt:

    De todas formas hay cosas que han cambiadod ede que escribi la guia, no muchas pero no hay nada como trastearlo uno mismo

    Por eso me surgió la duda:

    # ifconfig
    [...]
    gpon0     [...] UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
    ppp0.1    [...] UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
    veip0     [...] UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
    veip0.1   [...] UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
    veip0.2   [...] UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
    veip0.3   [...] UP BROADCAST RUNNING ALLMULTI MULTICAST  MTU:1500  Metric:1
    [...]
    # 
    

    Tengo el GPT-2541GNAC y todas las interfaces físicas y virtuales tienen el MTU a 1500 menos, lógicamente, la de PPPoE.

    He estado buscando tanto el porqué de los 1592 que incluso he encontrado un documento histórico: la única que vez que han contestado algo técnico con sentido en los foros.  ;D

    Es broma, bastante bien lo hacen los pobres con los medios y la formación que les deben dar.

    Estoy esperando que me llegue la tarjeta con doble puerto. Ya os comentaré lo que encuentre cuando me llegue.

    Muchas gracias a los dos.



  • Hola

    El MTU es un parámetro para un medio (capa 2) entre 2 interfaces (capa 3), tiene su lógica, si el router se conecta al convertidor Ethernet/Fibra vía Ethernet, el MTU debe ser 1500

    Salu2



  • ya solo me queda configurar la IPTV. De momento no he logrado configurarlo correctamente segun los mensajes de este post.

    En MTU de la interfaz de IPTV, el máximo valor que me deja poner es 1500, si sobrepaso ese valor me indica que el MTU es superior al parent. Si subo el parent (WAN) me da problemas despues en el pppoe. Supongo porque es wan /vlan 6 y al pppoe no le hace mucha gracia el valor de 1594 como se indica en el manual.

    Os comparto algunos pantallazos por si veis ago que debo corregir. Gracias.

    Dashboard:

    Interfaz IPTV:

    Configuración IGMP-Proxy:

    Rutas RIP:

    Rules Wan:

    Rules Lan:

    Rules IPTV:

    Log General:

    Log Firewall:

    Me llama especialmente la atención los logs pero desconozco aun a qué puede ser debido…

    Tambien me da que el manual hace referencia a la configuracion de Imagenio antigua con direccionamiento en el deco 10.xxx.xxx.xxx.
    La que lleva ahora, la IP asignada al deco es del segmento de red de la LAN.



  • Estoy intentado instalar uppxy tal y como indica el manual de @donizt :

    pkg_add -r ftp-archive.freebsd.org/pub/FreeBSD-Archive/old-releases/amd64/8.3-
    RELEASE/packages/Latest/udpxy.tbz

    A partir de la versión 2.3 el comando cambia a pkg add. El comando que ejecuto añadiendo ftp:// a la URL es el siguiente:

    pkg add ftp://ftp-archive.freebsd.org/pub/FreeBSD-Archive/old-releases/amd64/8.3-RELEASE/packages/Latest/udpxy.tbz
    Fetching udpxy.tbz

    el resultado que me muestra es el siguiente:

    Fetching udpxy.tbz: 100%   35 KiB  35.9kB/s    00:01
    pkg: /tmp/udpxy.tbz.XXXXX is not a valid package: no manifest found
    
    Failed to install the following 1 package(s): ftp://ftp-archive.freebsd.org/pub/FreeBSD-Archive/old-releases/amd64/8.3-RELEASE/packages/Latest/udpxy.tbz
    

    sabéis como podría instalar el paquete udpxy en esta versión?

    La versión de pkg es:

    #pkg info pkg

    
    pkg-1.8.7_3
    Name           : pkg
    Version        : 1.8.7_3
    Installed on   : Sat Nov  5 10:34:53 2016 CET
    Origin         : ports-mgmt/pkg
    Architecture   : freebsd:10:x86:64
    Prefix         : /usr/local
    Categories     : ports-mgmt
    Licenses       : BSD2CLAUSE
    Maintainer     : pkg@FreeBSD.org
    WWW            : http://wiki.freebsd.org/pkgng
    Comment        : Package manager
    Shared Libs provided:
            libpkg.so.3
    Annotations    :
            repo_type      : binary
            repository     : FreeBSD
    Flat size      : 10.2MiB
    Description    :
    Package management tool
    
    


  • pfSense 2.3 –-> FreeBSD 10.3

    Un binario de la rama 8.x no te funcionará en la rama 10.x

    En https://forum.pfsense.org/index.php?topic=120509.msg666599#msg666599 se explicó hace poco como nanejar pkg

    Y arriba, en Documentación, también está este enlace y este otro, https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/pkgng-intro.html

    Más…

    https://doc.pfsense.org/index.php/Installing_FreeBSD_Packages#pfSense_2.3

    https://www.digitalocean.com/community/tutorials/how-to-manage-packages-on-freebsd-10-1-with-pkg



  • Gracias @Bellera, ya he podido.

    he probado lo que comentan en los links y he logrado instalar el udpxy.
    Siguiendo los links que comentas y realizado lo que indica @javcasta.

    https://forum.pfsense.org/index.php?topic=120509.msg666599#msg666599

    a diferencia de instalar putty como se indica en el link se ejecutaría:

    #pkg update

    #pkg install udpxy

    pkg install udpxy
    Updating FreeBSD repository catalogue...
    FreeBSD repository is up-to-date.
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    The following 1 package(s) will be affected (of 0 checked):
    
    New packages to be INSTALLED:
            udpxy: 1.0.23 [FreeBSD]
    
    Number of packages to be installed: 1
    
    30 KiB to be downloaded.
    
    Proceed with this action? [y/N]: y
    Fetching udpxy-1.0.23.txz: 100%   30 KiB  31.0kB/s    00:01
    Checking integrity... done (0 conflicting)
    [1/1] Installing udpxy-1.0.23...
    [1/1] Extracting udpxy-1.0.23: 100%
    
    

    Para las modificaciones de los ficheros utilizo filezilla por SSH.

    La verdad, un lujo de foro y toda su gente.



  • Después de instalar udpxy sigo sin ver imagenio.
    Revisando los logs, me sigue saliendo este mensaje que me trae por el camino de la amargura:

    Log General:

    he visto este link pero sigue sin resolver el problema:

    https://forum.pfsense.org/index.php?topic=30983.0.

    Me he quedado atascado…



  • Hola,

    yo tenia todo funcionando perfectamente pero hoy no tengo la guia. Me sale en blanco.

    ¿Que puedo hacer?

    Saludos



  • Yo de momento no te puedo ayudar porque la guia me sale en negro  :( . Es decir que aun no he conseguido configurar con PFsense.

    Si te sirve de ayuda, yo de momento hasta que esto funcione, lo tengo conectado a un ASUS ac-56u y la guia funciona correctamente, por lo que no es un problema de Movistar.



  • Ya he conseguido quitar este error, he vuelto a revisar la configuración y en vez de tener 172.26.0.0 tenia 176.26.0.0

    Pero ahora me sale esto:  :'(

    
    Nov 5 21:17:46 	igmpproxy 	62042 	select() failure; Errno(4): Interrupted system call
    Nov 5 21:17:46 	igmpproxy 	62042 	MRT_DEL_MFC; Errno(49): Can't assign requested address
    Nov 5 21:17:46 	igmpproxy 	62042 	MRT_DEL_MFC; Errno(49): Can't assign requested address
    Nov 5 21:17:46 	igmpproxy 	62042 	MRT_DEL_MFC; Errno(49): Can't assign requested address
    Nov 5 21:17:46 	php-fpm 	79582 	/services_igmpproxy.php: Started IGMP proxy service. 
    

    Y esto:

    
    Nov 5 21:19:26 	kernel 		arp: aa:bb:cc:dd:ee:ff is using my IP address 10.80.xxx.xxx on re0_vlan2! 
    

    Moderador
    Corregida la MAC a aa:bb:cc:dd:ee:ff a fin de no desvelar datos particulares



  • Comento el problema por si le pasa a alguien aunque no creo que sea muy frecuente que esto suceda.

    El error que comentaba de la IP en uso por otro equipo con MAC aa:bb:cc:dd:ee:ff es del otro router que tengo en paralelo.
    osea que tenia la solución delante de mis narices!!  ;D ;D

    De la ONT he puesto un Switch al cual he conectado el Pfsense y el router neutro Asus para trabajar en paralelo. De esta manera no corto el servicio de Internet IPTV y VoIP en casa. La mac a la que hacia referencia es la del Asus. Tenía un conflicto IP de imagenio.
    He apagado un momento el Asus e imagenio tira sin problemas.

    PPoE+ VoIP + IPTV funcionando.

    Muchas gracias por vuestra ayuda.



  • Hola

    PPoE+ VoIP + IPTV funcionando.

    Me alegro, parecia que estabas radiando un partido contra el router pfSense :)

    Salu2



  • Moderador
    Corregida la MAC a aa:bb:cc:dd:ee:ff a fin de no desvelar datos particulares

    La mac,  capa 2, no trasciende de un dispositivo de capa 3, que abre el paquete al recibirlo y al difundirlo inserta la mac de su interface por donde lo retransmita . La mac es un dato que para obtenerlo hay que estar en el mismo dominio de broadcast, dentro de su red



  • Es lo que se llama, encapsulación y desencapsulación, al atravesar un paquete una red (modelo osi) :)

    Salu2




  • @iplost:

    La mac,  capa 2, no trasciende de un dispositivo de capa 3, que abre el paquete al recibirlo y al difundirlo inserta la mac de su interface por donde lo retransmita . La mac es un dato que para obtenerlo hay que estar en el mismo dominio de broadcast, dentro de su red

    Ya… pero no creo que sea conveniente poner identificadores (supuestamente) únicos de tus equipos en el foro.

    https://es.wikipedia.org/wiki/Dirección_MAC

    Digo "supuestamente" por el hecho de que puede cambiarse, https://es.wikipedia.org/wiki/MAC_spoofing



  • Ok, pues no tenía idea de lo del identificador de la mac. Mejor no desvelar informacion de equipos personales. Gracias!.

    @javcasta, ya te digo, menudo monólogo que me he liado !!  ;D ;D.



  • Hola

    La mac de una interfaz no es un dato que se pueda obtener en remoto, ya que al atravesar dispositivos de capa 3 (routers, firewalls, etc), como decia iplost, esta solo indica cual es el último interfaz de capa 3 que ha difundido el paquete. Otra cosa es "publicitar" IP públicas, expuestas a scaneos y pruebas de los bad boys no deseadas en Inet.

    Y efectivamente es un identificador único, a no ser que se haga spoof de mac (pfSense lo permite en su página de configuración de interfaces)

    E indica el fabricante también. Por ejemplo, todas las que empiecen por 00:50:56:xx:xx:xx son de VMware: http://aruljohn.com/mac/005056

    Salu2



  • Hola,

    Tras intentantar resetear el desco varias veces sigo sin poder ver la guía de programas. He comprobado que el desco tiene conexión internet - de hecho puedo ver el menu de Movistar plus y acceder a mis grabaciones.

    ¿Alguien sabe de que dirección viene la guia para el desco? Como tengo la TV en una VLAN quiero comprobar que puedo conectar, desde un PC en la misma VLAN puedo conectar a la guide de Movistar Plus pero no se si es la misma que utiliza el desco.

    @themaninspain:

    Hola,

    yo tenia todo funcionando perfectamente pero hoy no tengo la guia. Me sale en blanco.

    ¿Que puedo hacer?

    Saludos



  • Bueno,

    tengo avances y retrocesos.

    Ya he conseguido que salga la guía pero ya no me funciona los menus de Movistar (grabaciones, etc…) y tampoco me salen los detalles de la programación.

    Esta es mi configración

    Tengo una LAN separada para la TV, tengo definidos TVWAN y TVLAN.

    En TVWAN tengo reglas para pasar trafico IGMP y UDP - con la opción de pasar paquetes con IP options
    En TVLAN tengo las mismas reglas para IGMP y UDP más otra regla para pasar tráfico de cualquier red
    IGMP proxy esta configurado para pasar tráfico a TVLAN - me da que he puesto más redes de los que haga falta
    (172.0.0.0/8, 172.26.0.0/16, 224.0.0.0/4, 239.0.0.0/4, 239.0.0.0/8, 239.0.0.0/16, 10.0.0.0/8, 240.0.0.0/4, 192.168.2.0/24)

    Hay un NAT 1:1 de la IP de TVWAN al IP del desco (el desco tiene la opción DHCP 240 configurado y el DNS 172.26.23.3)

    Con esta configuracion puedo ver todos los canales contratados y la guia, pero no puedo ver la información de los programas ni iniciar una grabación ni entrar en la parte de Movistar TV (boton azul en mi mando) Me sale un mensaje cuando intento acceder a estos servicios que no puede conectar.

    ¿Asi que la pregunta es que me falta?



  • Algo raro tienes que tener, lo unico raro que ha pasado ultimamente es uqe han cambiado muchas direcciones de los canales pero si no usas tvheanded o silimar no te afecta.

    Ver los canales y que no te funcione la guia del todo, mas concretamente que la guia funcione lentisima me paso cunado estaba haciendo las primera pruebas, y fue por culpa del dns. Prueba algunas cosas a ver si das con el problema

    Haz un ping desde el pfsense al 172.26.23.3 y comprueba que te sale por el interface de la vlan de imagenio.
    Entra en el deco en el menu de inicio, me parece recordar que era dando a menu varias veces mientras inicia despues de un reseto. En ese menu hay una funcion para poner ip statica. Prueba a poner todos los valores manualmente.

    Hay un scritp en python que te descarga la guia automaticamente, buscalo y ejecutalo para ver si te funciona. (descartarmos que el deco sea problema)



  • Echando un vistazo a las rutas, encuentro esto:

    172.26.22.0/26 10.64.0.1 UG 0 1594 em0_vlan2
    172.26.22.23 10.64.0.1 UGH 0 1594 em0_vlan2
    172.26.22.56/29 10.64.0.1 UG 0 1594 em0_vlan2
    172.26.23.0/27 10.64.0.1 UG 0 1594 em0_vlan2
    172.26.23.3 192.168.144.1 UGHS 0 1492 pppoe3 <- en otros posts he visto que esta ruta iba por vlan2
    172.26.23.4 10.64.0.1 UGH 0 1594 em0_vlan2
    172.26.23.5 10.64.0.1 UGH 0 1594 em0_vlan2
    172.26.23.23 10.64.0.1 UGH 0 1594 em0_vlan2
    172.26.23.24 10.64.0.1 UGH 0 1594 em0_vlan2
    172.26.23.30 10.64.0.1 UGH 19 1594 em0_vlan2
    172.26.80.0/21 10.64.0.1 UG 0 1594 em0_vlan2

    ¿Es significativo que la ruta hacia 172.26.23.3 va por la WAN y no por vlan2?



  • Ese es el fallo, te tiene que salir por 10.64.0.1
    ¿ de donde ha salido que salga por 192.168.144.1?
    LA "S" es de estatica https://doc.pfsense.org/index.php/What_do_the_flags_on_the_routing_table_mean
    Mira a ver donde la has puesto



  • Gracias,

    He borrado la ruta y ya funciona. El único tema es que no definí esa ruta estática y no se como se generó.
    Vigilare la tabla de rutas por si acaso.



  • Pues tengo un problema, esta mañana la tabla de rutas estaba bien, al comprobarlo a mediodia otra vez estaba la ruta estática.

    ¿Que puede estar modificando la ruta?



  • Yo tengo el mismo problema que tu, tampoco me carga la guia y no puedo ver las series del videoclub , yomvi o como se llame.

    a mí me aparece lo siguiente

    default             192.168.144.1 UGS     61862     1492     pppoe0
    10.64.0.0/10     link#9                 U       14909     1492     re0_vlan2
    80.58.61.250     192.168.144.1 UGHS 1318     1492     pppoe0
    80.58.61.254     192.168.144.1 UGHS       0    1492     pppoe0
    172.26.22.0/26     10.64.0.1         UG           449     1492     re0_vlan2
    172.26.22.23     10.64.0.1         UGH           121      1492     re0_vlan2
    172.26.22.56/29    10.64.0.1         UG                 0    1492     re0_vlan2
    172.26.23.0/27     10.64.0.1         UG               48    1492     re0_vlan2
    172.26.23.4     10.64.0.1         UGH               10    1492     re0_vlan2
    172.26.23.5     10.64.0.1         UGH                 0    1492     re0_vlan2
    172.26.23.23     10.64.0.1         UGH               13    1492     re0_vlan2
    172.26.23.24     10.64.0.1         UGH               15    1492     re0_vlan2
    172.26.23.30     10.64.0.1         UGH                 8    1492     re0_vlan2

    172.26.80.0/21     10.64.0.1         UG               22    1492     re0_vlan2
    192.168.144.1     link#10         UH         16383    1492     pppoe0



  • No dije nada, ya carga la guia. Supongo que habrá que esperar. Lo dejé asi sin cargar la guia y despues de unos minutos veo que la guia la carga.

    Lo que no puedo ver son las series o peliculas del yomvi, se queda cargando el anuncio previo antes de ver del capitulo o pelicula.



  • Otra vez se ha modificado la ruta, esta vez estaba viendo la tele cuando paso, estoy mirando los logs y veo que a las 22:00 se inicio un proceso de renovación de DHCP en el interfaz de VOIP.

    Esto es lo que he sacado de log pero no se interpretarlo, he resaltado una linea que me llama la atención sobre el interfaz de TV (ImagenioWAN en mi config).
    Por el momento he añadido una ruta estatica para 172.26.23.3 y espero que no se modifique, pero me gustaría saber que esta pasando.

    Nov 15 22:00:19 firewall dhclient: EXPIRE
    Nov 15 22:00:19 firewall dhclient: Deleting old routes
    Nov 15 22:00:19 firewall dhclient: PREINIT
    Nov 15 22:00:19 firewall dhclient: ARPSEND
    Nov 15 22:00:19 firewall kernel: arpresolve: can't allocate llinfo for 10.26.x.x on em0_vlan3
    Nov 15 22:00:21 firewall dhclient: ARPCHECK
    Nov 15 22:00:21 firewall dhclient: BOUND
    Nov 15 22:00:21 firewall kernel: arpresolve: can't allocate llinfo for 10.26.x.x on em0_vlan3
    Nov 15 22:00:21 firewall dhclient: Starting add_new_address()
    Nov 15 22:00:21 firewall dhclient: ifconfig em0_vlan3 inet 10.26.x.x netmask 255.255.224.0 broadcast 10.26.31.255
    Nov 15 22:00:21 firewall dhclient: New IP Address (em0_vlan3): 10.26.x.x
    Nov 15 22:00:21 firewall dhclient: New Subnet Mask (em0_vlan3): 255.255.224.0
    Nov 15 22:00:21 firewall dhclient: New Broadcast Address (em0_vlan3): 10.26.31.255
    Nov 15 22:00:21 firewall dhclient: New Routers (em0_vlan3): 10.26.x.x
    Nov 15 22:00:21 firewall dhclient: Adding new routes to interface: em0_vlan3
    Nov 15 22:00:21 firewall dhclient: Creating resolv.conf
    Nov 15 22:00:21 firewall check_reload_status: rc.newwanip starting em0_vlan3
    Nov 15 22:00:22 firewall php-fpm[6377]: /rc.newwanip: rc.newwanip: Info: starting on em0_vlan3.
    Nov 15 22:00:22 firewall php-fpm[6377]: /rc.newwanip: rc.newwanip: on (IP address: 10.26.x.x) (interface: VOIPWAN[opt3]) (real interface: em0_vlan3).
    Nov 15 22:00:23 firewall xinetd[25854]: Starting reconfiguration
    Nov 15 22:00:23 firewall xinetd[25854]: Swapping defaults
    Nov 15 22:00:23 firewall xinetd[25854]: readjusting service 6969-udp
    Nov 15 22:00:23 firewall xinetd[25854]: Reconfigured: new=0 old=1 dropped=0 (services)
    Nov 15 22:00:26 firewall dpinger: send_interval 500ms  loss_interval 2000ms  time_period 60000ms  report_interval 0ms  data_len 0  alert_interval 1000ms  latency_alarm 500ms  loss_alarm 20%  dest_addr 10.64.y.y  bind_addr
    10.64.e.e  identifier "ImagenioGW "
    Nov 15 22:00:26 firewall dpinger: send_interval 500ms  loss_interval 2000ms  time_period 60000ms  report_interval 0ms  data_len 0  alert_interval 1000ms  latency_alarm 500ms  loss_alarm 20%  dest_addr 192.168.144.1  bind_
    addr 80.39.51.77  identifier "WAN_PPPOE "
    Nov 15 22:00:26 firewall dpinger: send_interval 500ms  loss_interval 2000ms  time_period 60000ms  report_interval 0ms  data_len 0  alert_interval 1000ms  latency_alarm 500ms  loss_alarm 20%  dest_addr 10.26.x.x  bind_addr
    10.26.8.44  identifier "VOIPWAN_DHCP "
    Nov 15 22:00:27 firewall dhcpd: Internet Systems Consortium DHCP Server 4.3.4
    Nov 15 22:00:27 firewall dhcpd: Copyright 2004-2016 Internet Systems Consortium.
    Nov 15 22:00:27 firewall dhcpd: All rights reserved.
    Nov 15 22:00:27 firewall dhcpd: For info, please visit https://www.isc.org/software/dhcp/
    Nov 15 22:00:27 firewall dhcpd: Config file: /etc/dhcpd.conf
    Nov 15 22:00:27 firewall dhcpd: Database file: /var/db/dhcpd.leases
    Nov 15 22:00:27 firewall dhcpd: Internet Systems Consortium DHCP Server 4.3.4
    Nov 15 22:00:27 firewall dhcpd: PID file: /var/run/dhcpd.pid
    Nov 15 22:00:27 firewall dhcpd: Copyright 2004-2016 Internet Systems Consortium.
    Nov 15 22:00:27 firewall dhcpd: All rights reserved.
    Nov 15 22:00:27 firewall dhcpd: For info, please visit https://www.isc.org/software/dhcp/
    Nov 15 22:00:27 firewall dhcpd: Wrote 0 deleted host decls to leases file.
    Nov 15 22:00:27 firewall dhcpd: Wrote 0 new dynamic host decls to leases file.
    Nov 15 22:00:27 firewall dhcpd: Wrote 64 leases to leases file.
    Nov 15 22:00:27 firewall dhcpd: Listening on BPF/re1_vlan104/
    Nov 15 22:00:27 firewall dhcpd: Sending on  BPF/re1_vlan104/
    Nov 15 22:00:27 firewall dhcpd: Listening on BPF/re0/
    Nov 15 22:00:27 firewall dhcpd: Sending on  BPF/re0/
    Nov 15 22:00:27 firewall dhcpd: Listening on BPF/em1/
    Nov 15 22:00:27 firewall dhcpd: Sending on  BPF/em1/
    Nov 15 22:00:27 firewall dhcpd: Sending on  Socket/fallback/fallback-net
    Nov 15 22:00:27 firewall dhcpd: Server starting service.
    Nov 15 22:00:28 firewall php-fpm[6377]: /rc.newwanip: Resyncing OpenVPN instances for interface VOIPWAN.
    Nov 15 22:00:28 firewall php-fpm[6377]: /rc.newwanip: Creating rrd update script
    Nov 15 22:00:28 firewall igmpproxy[46120]: select() failure; Errno(4): Interrupted system call
    Nov 15 22:00:28 firewall php-fpm[6377]: /rc.newwanip: Started IGMP proxy service.
    Nov 15 22:00:29 firewall dpinger: ImagenioGW 10.64.0.1: Alarm latency 0us stddev 0us loss 100%
    Nov 15 22:00:29 firewall check_reload_status: updating dyndns ImagenioGW
    Nov 15 22:00:29 firewall check_reload_status: Restarting ipsec tunnels
    Nov 15 22:00:29 firewall check_reload_status: Restarting OpenVPN tunnels/interfaces
    Nov 15 22:00:29 firewall check_reload_status: Reloading filter
    Nov 15 22:00:29 firewall dpinger: VOIPWAN_DHCP 10.26.x.x: Alarm latency 0us stddev 0us loss 100%
    Nov 15 22:00:29 firewall dpinger: WAN_PPPOE 192.168.144.1: Alarm latency 0us stddev 0us loss 100%
    Nov 15 22:00:29 firewall check_reload_status: updating dyndns WAN_PPPOE
    Nov 15 22:00:29 firewall check_reload_status: Restarting ipsec tunnels
    Nov 15 22:00:29 firewall check_reload_status: Restarting OpenVPN tunnels/interfaces
    Nov 15 22:00:29 firewall check_reload_status: Reloading filter
    Nov 15 22:00:30 firewall php-fpm[23634]: /rc.openvpn: OpenVPN: One or more OpenVPN tunnel endpoints may have changed its IP. Reloading endpoints that may use ImagenioGW.
    Nov 15 22:00:30 firewall xinetd[25854]: Starting reconfiguration
    Nov 15 22:00:30 firewall xinetd[25854]: Swapping defaults
    Nov 15 22:00:30 firewall xinetd[25854]: readjusting service 6969-udp
    Nov 15 22:00:30 firewall xinetd[25854]: Reconfigured: new=0 old=1 dropped=0 (services)
    Nov 15 22:00:30 firewall php-fpm[6377]: /rc.newwanip: pfSense package system has detected an IP change or dynamic WAN reconnection - 10.26.y.y ->  10.26.y.y - Restarting packages.
    Nov 15 22:00:30 firewall check_reload_status: Starting packages
    Nov 15 22:00:30 firewall php-fpm[6377]: /rc.dyndns.update: phpDynDNS (asterix.mydomain.net): No change in my IP address and/or 25 days has not passed. Not updating dynamic DNS entry.
    Nov 15 22:00:30 firewall snmpd[10820]: disk_OS_get_disks: adding device 'ada0' to device list
    Nov 15 22:00:31 firewall php-fpm[12394]: /rc.openvpn: OpenVPN: One or more OpenVPN tunnel endpoints may have changed its IP. Reloading endpoints that may use WAN_PPPOE.
    Nov 15 22:00:34 firewall xinetd[25854]: Starting reconfiguration
    Nov 15 22:00:34 firewall xinetd[25854]: Swapping defaults
    Nov 15 22:00:34 firewall xinetd[25854]: readjusting service 6969-udp
    Nov 15 22:00:34 firewall xinetd[25854]: Reconfigured: new=0 old=1 dropped=0 (services)
    Nov 15 22:00:35 firewall php-fpm[12461]: [pfBlockerNG] Starting cron process.

    esto es mi crontab:

    minute hour mday month wday who command Add
    1,31 0-5 * * * root /usr/bin/nice -n20 adjkerntz -a
    1 3 1 * * root /usr/bin/nice -n20 /etc/rc.update_bogons.sh
    */60 * * * * root /usr/bin/nice -n20 /usr/local/sbin/expiretable -v -t 3600 sshlockout
    */60 * * * * root /usr/bin/nice -n20 /usr/local/sbin/expiretable -v -t 3600 webConfiguratorlockout
    1 1 * * * root /usr/bin/nice -n20 /etc/rc.dyndns.update
    */60 * * * * root /usr/bin/nice -n20 /usr/local/sbin/expiretable -v -t 3600 virusprot
    30 12 * * * root /usr/bin/nice -n20 /etc/rc.update_urltables
    */5 * * * * root /usr/bin/nice -n20 /usr/local/bin/php -f /usr/local/pkg/snort/snort_check_cron_misc.inc
    */5 * * * * root /usr/bin/nice -n20 /sbin/pfctl -q -t snort2c -T expire 3600
    39 0,12 * * * root /usr/bin/nice -n20 /usr/local/bin/php -f /usr/local/pkg/snort/snort_check_for_rule_updates.php
    15 0 * * * root /usr/local/pkg/swapstate_check.php
    0 * * * * root /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php cron >> /var/log/pfblockerng/pfblockerng.log 2>&1
    0 8 1-7 * * root /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php dcc >> /var/log/pfblockerng/extras.log 2>&1



  • Mediante DHCP se puede poner una ruta estatica con la opcion 121. ¿Que mediante el interface de voip te este forzando la ruta? Es posible pero me aprece muy heavy. Mete un wireshak hay filtrando los paquetes dhcp a ver que encuntras. No conozco a nadie que le pase esto pero todo es posible.

    Si tu pones una ruta estatica manual en principio tiene preferencia sobre las otras. Pero desconozco si las staticas tienen preferencia sobrea las de la opcion 121. Prueba lode wireshark a ver si localizas algo y salimos de dudas


Log in to reply