Firewall stops talking to wireless after short time



  • I have a Vista 32bit laptop connecting to a PCI card in a PC running PFsense. After a certain amount of time I loose connection to the internet but not to the the rest off the network. It seems as though PFSense has forgotten about the route to the internet. It does seem as though it can be triggared by heavy traffic. If you try and ping the firewall it no long is contactable.

    I cannot control the PfSesne box at all from the wireless machine at all and the only thing I can do is remote control a PC on cable the control the PFSense box and reapply the wireless settings. (I do this by clicking save of the interface page)

    I do not make any change to the PFsense during thins time before it cuts off.

    I am out of idears and I was wondering if anyone else has one.  Thanks



  • Try running ifconfig ath0 down ; ifconfig ath0 up from a shell/console option 8 when this happens.



  • Sounds like a similar problem i have with my wireless. From the wireless machine, do a ping -t <lan ip="">continuous and when the connection cuts off, it should take around 10 seconds before it can ping back the interface.

    It does not seem to be a routing issue.

    Also, from another lan machine, ssh into the box and when connection cuts off, type athstats at shell and tell me if the tx failed because of underrun goes up in numbers.</lan>



  • It is a Ralink card so shall I put in ral in place of ath?



  • I tried
    ifconfig ral0 down
    then
    ifconfig ral0 up

    and that didn't sort the problem. The athstats and ralstats didn't work. After the interface went down then up I still have no access to the internet.



  • Wireless config:

    <opt1><descr>Wireless</descr>
    <if>ral0</if>
    <wireless><standard>11g</standard>
    <mode>hostap</mode>
    <protmode>cts</protmode>
    <ssid>Main22</ssid>
    <channel>3</channel>
    <authmode><txpower>99</txpower>
    <distance><wpa><macaddr_acl><auth_algs>1</auth_algs>
    <wpa_mode>2</wpa_mode>
    <wpa_key_mgmt>WPA-PSK</wpa_key_mgmt>
    <wpa_pairwise>CCMP</wpa_pairwise>
    <wpa_group_rekey>60</wpa_group_rekey>
    <wpa_gmk_rekey>3600</wpa_gmk_rekey>
    <passphrase>key</passphrase>
    <ext_wpa_sw><enable></enable></ext_wpa_sw></macaddr_acl></wpa></distance></authmode></wireless>
    <bridge>lan</bridge>
    <ipaddr><subnet>32</subnet>
    <gateway><spoofmac><mtu><enable></enable></mtu></spoofmac></gateway></ipaddr></opt1>



  • After playing a bit more if I update anything that causes the filters to refresh that fixes the problem. When I loose internet I canot ping the pfsense box at all.

    I am still very confused on what is doing this.

    note:

    I have snort instatalled and squid (although wireless is not used).



  • Is there no fix for this??



  • I have also run into the same problem.    I have a Windows XP laptop with a wireless D-Link card that I used to connect to a wireless access point in my network.  At times I can see the pfsense (v1.2) firewall and at other times I cannot.  My laptop can see the rest of my LAN regardless.  I thought that my wireless AP was the cause (it is actually a wireless D-Link router configured as an access point) so I just activated the wireless card in pfsense thinking that the problem would go away but it did not.

    Any suggestions?

    Thanks,
    Steve



  • Seems like heavy traffic is the cause of this. Is that what you peeps are seeing as well?

    I'm hoping Freebsd 7 with newer atheros drivers will cure everything! Bring it on!



  • Not heavy traffic for me.  In fact, sometimes the laptop is the only computer trying to get to the internet.  The problem manifests itself when the laptop hops onto the LAN via a wireless access point or through the OPT1 interface.



  • I guess if you are doing transfers to and from wan, that's considered high traffic for the access point…



  • Whether it is through the access point or through OPT1, the results are the same.  My wireless laptop can access any part of the LAN, it just will not see the pfSense gateway whereas wired computers can see the gateway.  I suspect it is how the packets are created from my wireless laptop that is somehow causing FreeBSD to not like them and acknowledge them.

    I recently added pfSense as my gateway from a Linux gateway that I had cobbled together via scripts and I did not have these troubles in this scenario so I doubt that heavy traffic is the cause.



  • I also had this problem on a brand new ALIX.3 setup with Atheros card.  I set the LAN and WIFI to be bridged.  Everything would work find but after about 10-20 minutes I could no longer connect on the Internet from the Wifi.  I could access anything local and could even access the PFSense admin page.  Reboot resolved it everytime.

    I just re-installed and didn't enable the WIFI.  I am running pings over it for a few hours and if that goes well then I will turn the WIFI back on and see how that goes.



  • Hey

    I have a similar problem with my Atheros WIFI card (configured as an Access Point).  When I first enable it, everything works fine.  After a few hours of inactivity, the access point disappears.  When ever it disappears, I can make it re-appear by going to "Interfaces: OPT1" and hitting the save button (at the bottom).

    It's nice that I can get the access point back up with very little effort, but having to visit a desktop every time I want to use a laptop is getting a little annoying … has anyone found a resolution to this problem?

    RC



  • I actually found two possible cause's to this problem (although there maybe more).

    1. Power saving options on the wireless card.
          Fix for this is go into device manager and switch off power saving mode on the nic. I found this even with my new wireless N laptop.

    2. Snort
            I found that even in bridge mode and snort only having the wan interface selected it banned my internal IP and the only way I found to get around this was to put the Internal LAN in the white list.



  • Hello,

    I have the same issue that my wireless connection drops when there is 'heavy traffic' going from WAN -> Wireless
    I can start downloading at 2MB/s but after 5 minutes or so, the connection drops. I can still see my wireless access point, but i can't connect to it. The only thing I can do to solve this is accessing the webgui and reapply the wireless settings using a wired connection. When I restart the download again, after 5 minutes the connection drops again.

    I'm running 1.2 on a Linksys Ralink card. My laptop is the only wireless client in my network.

    I think somehow this must be driver related? I tried 1.2.1 and 1.3, then I can configure my wireless but I get 'no carrier' on the interface status page so I presume the Ralink drivers are not mature yet on freebsd7?

    I tried with another wireless NIC (also ralink) to eliminate a faulty wireless card, but I have the exact same issues with that card.

    I hope there will be a solution to this rather soon, because in this state I can't put Pfsense into production.

    Best regards,
    Jan



  • Have you tryied both possible fixes that are posted above



  • I am not sure that this is an issue with power saving in the user end… I am having the same issue but a bit different...
    I think is at the OS level with pfsense...
    I have notice that when the wireless idles and pfsense marks it offline the wireless drops your connection...
    In some instances I have set some static dhcp entries and the old dhcp entrie lingers arround... When the system at the user end renews the lease it gets the new IP but the old dhcp entries lingers around and it gets marked off line and it drops your connection...



  • If Pfsense is marking the nic as offline then this will be a prob with Pfsense and maybe worth rasing a ticket



  • I might have spoken to soon when I posted my comment…
    But it seem to be a BSD issue... pfsense 1.2 FreeBSD 6.3 took care of the disconnect problems... Also the pfsense full version (not embedded) does not seem to act this way....



  • You may want to try out pfSense 1.2.1 which uses FreeBSD7. For me it has fixed the disconnect issues.
    Link to download pfSense 1.2.1 can be found here http://blog.pfsense.org/?p=207


Log in to reply