PfSense 2.2-RELEASE Now Available! [временная]



  • Ура, товарищи !!!
    Дождались таки. Огромная благодарность разработчикам и всем принимающим участие в "жизни" этого действительно
    замечательного продукта.

    https://blog.pfsense.org/?p=1546



  • Кто нибудь обновился уже?



  • Кто нибудь обновился уже?

    Обновился для чего? если для работы сыроват.



  • @NegoroX:

    Кто нибудь обновился уже?

    Обновился для чего? если для работы сыроват.

    Может нашлись смельчаки…



  • Обновил 2 машины
    LightSquid отвилился сразу (потерял свио конфили и Perl),поравил вручную,
    тоже самое с Bandwidthd
    также стал показывать меньше температуру процесора в среднем на 4-5 градусов(толи брешет, толи првда - незнаю)
    Web интерфейс стала дольше открываться
    вместо pkg-add теперь pkg install и прочих родственных (фря новая всётаки)
    пока вроде всё.



  • странно Вы написали в заголовке pfSense 2.2-RELEASE Now Available! [временная] при обновления я этого не заметил что она временная  :-\

    было на 2.1.5

    1-Squid3-dev
    2-SquidGuard
    3-HAVP
    4-Snort
    5-Lightsquid
    6-openVPN
    7-Nut
    8-freeRadius2
    9-Captive portal

    из них перестало работать SquidGuard, HAVP, Lightsquid,freeRadius2, а в Squid3 не запускается c-icap . Captive portal перестал функционировать должным образом
    так что с c-icap_ом и Captive portal-ом в стадии разбирательства.
    может и еще что но я еще не глядел… обновлялся поздней ночью  :-[
    думаю как вернутся на 2.1.5, бэкап не делал перед обновлением, так как предыдущая обновления была супер успешна с 2.1.4 на 2.1.5...



  • перестали подниматься межсайтовые OpenVPN туннели, причём 50/50
    В чём дело не знаю, уже всю репу исчесал. Вроде бы туннель есть, а вот траффик то ходит - то не ходит.
    OSPF на этих тачках через туннель перестал работать впринципе. Даже в снифере его нету. Ну и конечно в логах тишина.
    Какое то бородатое обновление, благо не весь парк успел перевести.



  • Хмм,  у меня везде ипсеки натыканы и немного другая ситуация, пингуется все,  кроме кластерных ип которые на нлб весят.Но понять  чего это она не погу. Вот сейчас со снифером в зубах пытаюсь понять как это так, но пока как баран на новые ворота. Вот поспешил с обновлениями конечно. А так вроде все норм, переживал за сурикату, но встало  без проблем. Из косяков пока только что ипсек чудит.



  • @gar2k:

    Хмм,  у меня везде ипсеки натыканы и немного другая ситуация, пингуется все,  кроме кластерных ип которые на нлб весят.Но понять  чего это она не погу. Вот сейчас со снифером в зубах пытаюсь понять как это так, но пока как баран на новые ворота. Вот поспешил с обновлениями конечно. А так вроде все норм, переживал за сурикату, но встало  без проблем. Из косяков пока только что ипсек чудит.

    IPSec сменил платформу с racoon на strongswan. Это серъезное изменение. Попробуйте удалить туннели и создать их заново.

    P.s. Такое ощущение, что changelogs читаю только я.



  • Спасибо! чет проморгал! Есть куда рыть теперь.



  • .del
    Проблема OSPF решилась обновлением вручную пакета quagga
    В веб интерфейсе было сообщение в разделе пакетов:

    Available: 0.99.22.3.1_2 v0.6.2
    Installed: 0.99.22.3 v0.6.2



  • 2 All
    Исходя из вышесказанного, для тех , кто все же решился обновиться до 2.2  - обновите так же все свои пакеты до самых актуальных версий.



  • В общем итоге оказалось что дело не в ипсеках, дело в таблице арп.  Если кто затупит  как я , может ему подскажет.

    В логах светится строка:

    kernel: arp: <mac_nlb> is multicast</mac_nlb>
    

    При старте в syslog- е или так:

    arp -a |grep 250
    ? (xxx.xxx.xxx.250) at (incomplete) on em1 expired [ethernet]
    

    Быстрое действие - добавить пару мак руками:

    arp -s mm.mm.mm.mm.mm.mm   xxx.xxx.xxx.xxx
    

    Счастья привалило как оказалось еще в 9-ке , настраивается по традиции через

    echo net.link.ether.inet.allow_multicast=1 >> /etc/sysctl.conf
    

    Имхо для рутерной сборки должно стоять по  умолчанию, так как кластеры сейчас массовое  увлечение.



  • Приветствую!

    Даже не знаю как сказать, но словил повторяющуюся багу - если ставить на ProLiant DL320e Gen8 внутрь ESXi 5.5 pfsense 2.2 либо обновляться с 2.1.5 - разваливается raid на самой железке, как ни дико это звучит. Лечится перезагрузкой, 2.2 так и не удалось поставить. Порадовало, что сервер пока не боевой

    Вот такие пироги…



  • @taras.melnik:

    Приветствую!

    Даже не знаю как сказать, но словил повторяющуюся багу - если ставить на ProLiant DL320e Gen8 внутрь ESXi 5.5 pfsense 2.2 либо обновляться с 2.1.5 - разваливается raid на самой железке, как ни дико это звучит. Лечится перезагрузкой, 2.2 так и не удалось поставить. Порадовало, что сервер пока не боевой

    Вот такие пироги…

    Там же вроде для виртуалок специальная версия pfSense была. Ее брали?



  • @taras.melnik:

    Приветствую!

    Даже не знаю как сказать, но словил повторяющуюся багу - если ставить на ProLiant DL320e Gen8 внутрь ESXi 5.5 pfsense 2.2 либо обновляться с 2.1.5 - разваливается raid на самой железке, как ни дико это звучит. Лечится перезагрузкой, 2.2 так и не удалось поставить. Порадовало, что сервер пока не боевой

    Вот такие пироги…

    Виртуалка, которая рушит рейд на гипервизоре??? Пруфы будут?



  • Как говорила моя учительница математики :" Этого не может быть, потому что этого не может быть НИКОГДА!" (с) Дорошенко Л.В. Заслуженный преподаватель СССР.

    Обновите BIOS сервера\контроллера.
    В настройках ВМ выставите в кач-ве сетевой E1000
    В кач-ве контроллера HDD исп. LSI.



  • стандартная еще при запуске отметила, что она внутри вмвари и добавила модули. потом все :)=





  • Всем доброго дня!

    При обновлении до 2.2 у меня появились указанные проблемы тоже, переустановил  Package,  перестал запускаться Squid3, squidGuard-squid3 не могу пере установить выдает ошибку, появились сервисы clamd, c-icap которые не запускаются.

    @werter:

    IPSec сменил платформу с racoon на strongswan. Это серъезное изменение. Попробуйте удалить туннели и создать их заново.

    После обновления один из туннелей IPSEC пингуется только в одном направлении, удалил его, заново поднял, не помогло! Куда копать, что делать, неужели откатываться назад?






  • Куда копать, что делать, неужели откатываться назад?

    Да откатываться - однозначно, обидно но факт.



  • После обновления один из туннелей IPSEC пингуется только в одном направлении, удалил его, заново поднял, не помогло! Куда копать, что делать, неужели откатываться назад?

    ВО во! У меня тоже самое с OpenVPN! Избирательно!



  • Приветствую всех,
    поставил 2.2. на новый сервачок - полдня убил на то, чтобы понять, почему не ходит межсайтовый трафик по GRE-туннелям.
    Оказывается, в этом релизе правила NAT автоматом создаются и для GRE-интерфейсов. Это баг или фича?
    Также, оные GRE-интерфейсы не поднимаются при старте системы, пришлось сделать типа rc.local и прописать туда для них down/up…
    Впрочем, последняя грабля еще на 2.1 началась...



  • Обновился до 2.2. Трафик по L3 туннелям не ходил, хотя туннели поднимались. Работал только L2 туннель. Попробовал поставить чистую 2.2 - после установки не загружается. Пришлось ставить 2.1.4.



  • @Jetberry:

    Обновился до 2.2. Трафик по L3 туннелям не ходил, хотя туннели поднимались. Работал только L2 туннель. Попробовал поставить чистую 2.2 - после установки не загружается. Пришлось ставить 2.1.4.

    Вы OpenVPN или IPsec имеете ввиду ?
    Версию какой разрядности 2.2 ставили ? Какие ошибки при этом появились (листинг) ? На чем крутится pf - реальное железо\виртуалка ?



  • OpenVPN. 32-bit. ставил с флешки. на железо (сейчас точно не скажу какое, т.к. не на работе). После чистой установки 2.2 перезагружается -  выводит стандартную надпись про F1 (раньше как правило сам начинает загружаться дальше, а тут хоть жми F1 хоть жди - уходит в перезагрузку). Никаких ошибок. Были-бы ошибки - знал бы куда копать.



  • @Jetberry:

    OpenVPN. 32-bit. ставил с флешки. на железо (сейчас точно не скажу какое, т.к. не на работе). После чистой установки 2.2 перезагружается -  выводит стандартную надпись про F1 (раньше как правило сам начинает загружаться дальше, а тут хоть жми F1 хоть жди - уходит в перезагрузку). Никаких ошибок. Были-бы ошибки - знал бы куда копать.

    Ранее на этом же железе крутился пф ? Попробуйте др. флешку или с СД поставиться. Попробуйте исп. др. разрядность пф.



  • Да, на этом же железе и стоял pfSense. Он и сейчас стоит на нем, только версия 2.1.4. Видимо придется экспериментировать с 2.2 в свободное от работы время. Ну да ничего, главное что проект развивается и он хорош.
    P.S. С проблемой хождения трафика по L3-тунелям ovpn вроде как начало прояснятся. дело в том, что связки pfSense-pfSense, pfSense-Linux, pfSense-Android - работают как надо, а вот с Win-клиентами проблема выше описанная. И появление её не связано с обновлением pfSense, а скорее всего это связано с обновлением OpenVPN клиента для Windows.



  • vnstat2 опять не работает, пересоздавал базу, как советовал иностранный товарищ - не помогло.
    squid3+squidguard3 завёлся через сильные пинки, может стартует медленнее. lightsquid с ними отказался работать.
    После установки, пока не включил dns forwarder инет работал медленно, в старых версиях не помню уже, но для себя отметил, что надо включать его.



  • @DasTieRR:

    vnstat2 опять не работает, пересоздавал базу, как советовал иностранный товарищ - не помогло.
    squid3+squidguard3 завёлся через сильные пинки, может стартует медленнее. lightsquid с ними отказался работать.
    После установки, пока не включил dns forwarder инет работал медленно, в старых версиях не помню уже, но для себя отметил, что надо включать его.

    По лайтсквиду - https://forum.pfsense.org/index.php?topic=87648.msg482653#msg482653