LightSquid Report has blank page after upgrading to version 2.2



  • Dear guys,

    After upgrading to 2.2 pfsense version the LightSquid began to return a "blank page" in the LightSquid Report tab. The proxy state tab works fine..

    Someone has the same error?

    Thanks,



  • Not surprising at all to me anyway.

    I've had to un-install squid and lightsquid after updates before and clear and recreat the squid cache also to make it work.





  • Dear Cino,

    Thanks for your help, but now i have the new error:

    Software error:

    Can't locate /usr/local/etc/lightsquid/lightsquid.cfg in @INC (@INC contains: /usr/local/lib/perl5/site_perl/mach/5.18 /usr/local/lib/perl5/site_perl /usr/local/lib/perl5/5.18/mach /usr/local/lib/perl5/5.18 /usr/local/lib/perl5/site_perl/5.18 /usr/local/lib/perl5/site_perl/5.18/mach . /usr/local/www/lightsquid/) at /usr/local/www/lightsquid/index.cgi line 17.
    For help, please send mail to this site's webmaster, giving this error message and the time and date of the error.

    Maybe you can help me?

    Thanks



  • have you setup lightsquid and refresh report?



  • Dear,

    Yes, I've removed and installed squid and lightsquid again.

    The error persists

    Thanks,



  • yeah but do you have any data in your access.log then in lightsquid you need to refresh full for the first report to be created



  • Dear,

    I've deleted all files from:

    -/var/squid/logs
    -/var/squid/cache

    Restart squid services and refresh full squidlight, the error persists



  • once you can confirm you have data in /var/squid/logs/access.log; then goto lightsquid click refresh full… give it a minute and see if a report is created.



  • Dear,

    Unfortunatly does not work, i've tryed the command:

    /usr/bin/perl /usr/pbi/lightsquid-amd64/www/lightsquid/lightparser.pl today

    Look the return:

    Can't locate /usr/local/etc/lightsquid/lightsquid.cfg in @INC (@INC contains: /usr/local/lib/perl5/site_perl/mach/5.18 /usr/local/lib/perl5/site_perl /usr/local/lib/perl5/5.18/mach /usr/local/lib/perl5/5.18 /usr/local/lib/perl5/site_perl/5.18 /usr/local/lib/perl5/site_perl/5.18/mach . /usr/pbi/lightsquid-amd64/www/lightsquid/) at /usr/pbi/lightsquid-amd64/www/lightsquid/lightparser.pl line 35.

    Thanks,



  • the issue is the link for /usr/local/etc/lightsquid/lightsquid.cfg

    did you run this?

    
    amd64
    ln -s /usr/pbi/lightsquid-amd64/local/www/lightsquid /usr/local/www/lightsquid
    ln -s /usr/pbi/lightsquid-amd64/local/etc/lightsquid /usr/local/etc/lightsquid
    
    i386
    ln -s /usr/pbi/lightsquid-i386/local/www/lightsquid /usr/local/www/lightsquid
    ln -s /usr/pbi/lightsquid-i386/local/etc/lightsquid /usr/local/etc/lightsquid
    
    


  • Dear,

    yes, look:

    [2.2-RELEASE][root@firewall]/usr/local/etc/lightsquid: ln -s /usr/pbi/lightsquid-amd64/local/www/lightsquid /usr/local/www/lightsquid
    ln: /usr/local/www/lightsquid/lightsquid: File exists
    [2.2-RELEASE][root@firewall]/usr/local/etc/lightsquid: ln -s /usr/pbi/lightsquid-amd64/local/etc/lightsquid /usr/local/etc/lightsquid
    ln: /usr/local/etc/lightsquid/lightsquid: File exists
    [2.2-RELEASE][root@firewall]/usr/local/etc/lightsquid:



  • i see your in /usr/local/etc/lightsquid

    try this

    
    cd ..
    rm -f /usr/local/etc/lightsquid
    ln -s /usr/pbi/lightsquid-amd64/local/etc/lightsquid /usr/local/etc/lightsquid
    
    

    then run

    
    /usr/bin/perl /usr/pbi/lightsquid-amd64/www/lightsquid/lightparser.pl today
    
    


  • Dear,

    Nice one!!! Sounds perfect!

    Thank you!

    Cheers



  • great!! Hopefully the package will be updated so we wont have to use this workaround anymore.



  • Dear,

    Yes !! your tip was wonderfull, thank you !!

    cheers



  • =D glad you got it working!



  • Thanks too ! I had the same problem since upgrade and your solution worked perfectly.
    Just had indeed to remove first the imbedded dir /lightsquid/lightsquid via rm -d.

    For me, the command that worked was

    ln -s /usr/pbi/lightsquid-i386/local/etc/lightsquid /usr/local/etc/  …and first like I said, to remove the /usr/local/etc/lightsquid directory

    Thanks again

    Thierry



  • Caro Thylroi,

    Aonde dou esse comando! Pode me ajudar?



  • $ /usr/bin/perl /usr/pbi/lightsquid-amd64/www/lightsquid/lightparser.pl today
    /usr/bin/perl: lrwxr-xr-x:: not found

    How can I do ? Please help



  • $ /usr/bin/perl /usr/pbi/lightsquid-amd64/www/lightsquid/lightparser.pl today
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LC_ALL = (unset),
    LANG = "en_US.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").

    How can I do ? Please help


  • Banned

    There is no need to do any similar nonsense, the reports work perfectly fine from the GUI in the current package. No idea what are you trying to do.



  • "lightsquid.cfg "change at line 17:

    wrong path "/usr/pbi/lightsquid-amd64/www/lightsquid/tpl""
    right path: "/usr/local/www/lightsquid/tpl"

    now everything is working.