Squid no funciona con la actualización a 2.2



  • Estimados actualice a la ultima version de pfsense, 2.2 y no puedo arrancar el squid, por consola me falta un archivo q termina en so.. instale el squid3 y funciona correctamente, pero no puedo hacer funcionar ningun tipo de reporte, el Lightsquid pero me da error 404 cuando entro al reporte, instale tambien Sarg, y tampoco muestra nada en el reporte…

    Será q es muy nueva, las versiones..


  • Rebel Alliance



  • solo tengo squid3 sin squidguardian…



  • A mi me pasa lo mismo, actualice a 2.2-RELEASE (amd64); y SARG y LIGHSQUID  dejaron de funcionar; reinstalé ambos y sigue sin funcionar!



  • Al parecer todos en las mismas… sin funcionar, ojala salga una pronta solución..



  • a mi tampoco me funciono al principio, y luego me di cuenta que no se actualizaron los blacklist, los descargue de nuevo y reinicie el servicio del squid y funciono de manera perfecta.
    Espero te sirva!
    Saludos



  • Yo solo tengo squid3, nada de squidguardian,…



  • Gente, de entrada por algún motivo, cuando actualice de version a la 2.2, no se me actualizo correctamente Squid. No iniciaba y al intentar iniciarlo desde la consola me encontre con que daba error por no encontrar la librería libssl.so.6. Reinicie pfsense (para poder acceder desde el entorno gráfico al administrador de paquetes), y luego reinstale Squid, y el inconveniente se soluciono.
    A aquellos que reinstalarlo no se los ha solucionado, ¿que error les da?.
    Saludos



  • A mi me daba el mismo error q tu, pero con la reinstalacion y renicio, no soluciones nada…tuve q instalar squid3, el bloqueo funciona,,pero el reporte no..



  • Saludos Señores.
    Tuve un problema similar con Squid y SquidGuard. Al final quite ambos Paquetes y elimine desde consola los directorios squid ubicados en /var/squid y tambien /var/db/squidGuard Reinicie y instale de nuevo ambos paquetes y comenzaron a funcionar de forma normal.



  • Desde la linea de comandos

    pw useradd clamav -G wheel
    pw usermod clamav -G wheel

    mkdir /var/log/clamav
    chmod 775 /var/log/clamav
    mkdir /var/db/clamav
    chmod 775 /var/db/clamav
    mkdir /var/run/clamav
    chmod 775 /var/run/clamav

    freshclam

    Luego y por el menu Proxy Server a la Solapa antivirus poner el tilde en Enable hacer clic en el boton Save

    Wala Anivirus y proxy start :-)



  • Buen dia;

    Estimados, presento el mismo problema, tengo instalados los paquestes de Squid y SquidGuard, para lo cual ya reistale los paquete por medio del la opcion de reistalacion, y el problema persiste, me parece interesate la opcion que menciona #hatchivana, pero no tengo idea de como hacerlo, soy usuario avanzado pero la verdad en pfsense no tengo tanta experiencia, les pido su ayuda para poder realizar la eliminacion de los directorios implicados desde consola, y proceder con la reinstalacion, apelo a su gran esperitu colaborador  :) ;D ;D. saludos desde Perú  ;D :D.



  • @hatchivana:

    Saludos Señores.
    Tuve un problema similar con Squid y SquidGuard. Al final quite ambos Paquetes y elimine desde consola los directorios squid ubicados en /var/squid y tambien /var/db/squidGuard Reinicie y instale de nuevo ambos paquetes y comenzaron a funcionar de forma normal.

    Si es lo que dice…

    rm -R /var/squid
    rm -R /var/db/squidGuard

    reiniciar e instalar de nuevo los paquetes.



  • Buenas tardes;

    Estimado y como ejecutos esos comandos, como lo puedo hacer?. gracias por la ayuda. saludos.



  • Desde consola.

    O desde Diagnostics / Command Prompt



  • Estimados, para expresarles que no tengo noticias favorables, el problema persiste y la verdad no se que mas hacer, les ruego que comuniquen el problema las personas que puedan y nos ayuden a darle una pronta solucion, se que la union hace la fuerza y juntos lograremos el conseguir la ayuda y solucion del caso.

    saludos



  • Si mirando logs no ves causa de porque se para tu squid…

    Guarda tu config.xml en lugar seguro, descarga última versión. Haz una instalación desde cero, mínima para poder cargar tu config.xml. Carga tu config.xml.

    Con ello probarás si una instalación limpia funciona.



  • La mia es desde cero y es el mismo problema…



  • A mi me sucede lo mismo al realizar los  procedimientos indicados el error persiste, pues el tema apunta a unas librerias. " php-fpm[10228]: /pkg_mgr_install.php: The command '/usr/pbi/squid-i386/sbin/squid -D' returned exit code '1', the output was 'Shared object "libz.so.5" not found, required by "libmd5.so.1"
    Al buscar la libreria por consola "find / -name libz.so.5" no arroja resultados. En la version de pfsense 2.1.5 si encuentra la lñibreria en la ruta /lib/libz.so.5
    Al parecer estas librerias fueron deprecadas en esta version. Opcion hasta el momento instalar squid3 pero no funciona en modo transparente ni con squidguard.



  • ¡Por fin alguien posteó el error que le sale!

    Google Shared object libz.so.5 not found required by libmd5.so.1 squid

    Efectivamente para 32 bit…

    https://forum.pfsense.org/index.php?topic=87283.0

    El problema se debe a que el binario de squid está apuntando a librerías anteriores.

    En https://redmine.pfsense.org/issues/4293 proponen hacer enlaces simbólicos para salir del paso.

    A ver si alguien puede probarlo y decir si le funcionó.

    Seguramente irá. Cuando sólo hay binarios a veces hay que tirar de estar solución, como en la mayoría de Linux. En un FreeBSD "puro" normalmente se bajan las fuentes y se compilan sobre el equipo pero en pfSense (FreeBSD tuneado) todo viene hecho.

    Otra solución sería hacerse con un FreeBSD 10.1 32 bit y compilar squid con las opciones necesarias...





  • Incluye en lo que hay que eliminar
    rm -R /var/squidGuard

    después instala los paquetes de nuevo y todo funciona de nuevo.

    @bellera:

    @hatchivana:

    Saludos Señores.
    Tuve un problema similar con Squid y SquidGuard. Al final quite ambos Paquetes y elimine desde consola los directorios squid ubicados en /var/squid y tambien /var/db/squidGuard Reinicie y instale de nuevo ambos paquetes y comenzaron a funcionar de forma normal.

    Si es lo que dice…

    rm -R /var/squid
    rm -R /var/db/squidGuard

    reiniciar e instalar de nuevo los paquetes.


Log in to reply