Wierd console loader issue on nanobsd alix



  • i have this issue since 2.2.2 and so far now on 2.2.3 it still persists. When the alix boots, the loader provides the option to select slice and then the 5 second counter to press enter or goto shell, for me during those 2 stages my serial console will just display the info but wont let me input anything, i have tried almost 4 different serial to usb adapters and 2 serial cables but nothing helps, the console starts taking inputs once its booted completely after which there r no such input issues at all. I even tried a clean install thinking the loader might be broken during upgrade but that too doesnt help making the slice selection impossible to use



  • This the same ancient ALIX you've had serial console issues with forever? IIRC it seemed like that ALIX was just broken, or else your client's serial console was.



  • ys same issue but i suffer the same on multiple alixes so it cant be all broke and that too y just the slice selection and press enter to boot only, rest everything works fine.

    the reboot hang issue was a due to a fake Chinese chip in the adapter which was leaking signal back from transmit to receive lines so i found another adapter with a genuine chip and that reboot hang issue resolved



  • In that case, likely the latter - your serial console isn't working. Which specific ALIX is this?



  • alix 2d3 and 2d13.

    y is it that multiple alix broke all at the same time all at different locations and using different serial to usb adapters to connect to PC



  • bear in mind, the reboot hang issue was resolved using a genuine chip and its just those 2 portions when it doesnt take input, other than that the display and rest all functions operate normally once booted



  • I'm out of town at the moment without an ALIX handy. Will double check when I get home, but this doesn't appear to be a general problem. If anyone else can confirm or deny, it'd be appreciated.



  • to add to that, kindly check using a serial to usb adapter as most of my PCs dont have a serial port so i commonly use these adapters only and issue happens there


  • Banned

    Is that still the same nonsense where you daisy-chained about 4 adapters and it did not work?

    https://redmine.pfsense.org/issues/4571#note-13



  • nope, just a plain and simple serial to usb adapter and bytheway serial to tll to usb is same as a serial to usb and it works exactly the same because alix just needs the tx and rx lines connected, rest of the lines r inactive



  • @xbipin:

    to add to that, kindly check using a serial to usb adapter as most of my PCs dont have a serial port so i commonly use these adapters only and issue happens there

    That's generally all I use, as none of the machines I routinely use as desktops/laptops have a serial port. FTDI chipsets are your best bet in my experience, the common Prolific chipset ones are often unstable or otherwise poorly behaved.



  • i have all sorts of adapters with different chipset, if it was the cause i wouldnt have opened this thread and i believe there is something else to it.

    Regarding chipset brands, alix just uses the tx and rx lines only so other than that no other lines r active so as long as the tx and rx lines work without any voltage loop or interference, anything should be fine


  • Banned

    @xbipin:

    anything should be fine

    Well, this was already excluded by your daisy-chained powered madness experiment. Some of the Prolific shit even makes this unbootable: https://forum.pfsense.org/index.php?topic=62220.0



  • true but like i said, that crash on boot issue is due to fake chips which insert rouge voltages from the rx to tx lines and this caused the bootloader to receive unknown characters causing the crash and windows filters such data where as linux etc OS dont so that crash issue is solved for me with a genuine chip now, i did the voltage tests and all seems fine now but still alix doesnt take any input during slice selection whereas going to alix bios works perfectly fine which happens before the boot loader kicks in


  • Rebel Alliance Developer Netgate

    It works fine here, even with a Prolific USB serial adapter.

    There was a change to the loader between 2.1.x and 2.2.x but that part would only change for new images, not upgrades.

    Make certain that your BIOS serial speed is set to match the pfSense serial speed before doing anything else.



  • earlier it went dead when i upgraded and it messed some other things which was resulting in totally skipping the slice selection menu so i did a clean install and it solved that but since then, all the display etc all appears good, bios speed matches that too of the pfsense, 115200, i can goto bios and it works well, just slice selection and press enter to continue in 5s dont take any input, after that everything works normal



  • is there any way to revert to the older boot loader just to test it out and make sure its not something else affecting it.

    i have tried many different chipset adapters but same result, they work fine on 2.1


  • Rebel Alliance Developer Netgate

    There is no way to revert that.



  • @jimp:

    There is no way to revert that.

    is there any way to fix this?


  • Rebel Alliance Developer Netgate

    Without being able to prove anything is actually broken, probably not.

    In the meantime, check your serial client and try some other settings, especially important is to try changing flow control. For example, disable hardware flow control, use XON/XOFF or disable flow control entirely.



  • Works fine here too.



  • my serial client i upgraded that to latest version, played with all the possible flow control settings but still same.

    if u say the alix is dead or the adapter is dead then in those cases nothing should be working at all on serial at all but then y is it that just those 2 sections input is not accepted and everywhere else it works fine, how can it not be broken when 2.1.x versions work fine with same alix and adapter?


Log in to reply