• Всем доброго утречка.
    Прошу помощи.
    В пятницу установил сие чудо.
    Все выходные потратил на то чтоб включить статистику, но никак мне это неудвлось.
    в раздеде где должна быть статистика высвечивается вот такая штука:
    LigthSquid diagnostic.
    Error : report folder '/var/lightsquid/report' not contain any valid data! Please run lightparser.pl (and check 'report' folder content)
    Please check config file !
    что делать незнаю.


  • @vasya:

    LigthSquid diagnostic.
    Error : report folder '/var/lightsquid/report' not contain any valid data! Please run lightparser.pl (and check 'report' folder content)
    Please check config file !

    /var/lightsquid/report - такой путь вообще существует?
    Вообще стоит посмотреть файл конфигурации и внимательно проверить все пути. Часто бывают незначительные изменения. Например в системе /var/squid/logs для логов сквида, а в конфиге парсера /var/squid/log


  • Как что сделать подскажите….ПЛИЗЗ!!!!


  • Версия Pfsense? squid установлен?


  • версия 2.2.4-RELEASE
    да squid стоит и lightsquid стоит


  • @vasya:

    версия 2.2.4-RELEASE
    да squid стоит и lightsquid стоит

    На этом сайте где-то уже обсуждалась настройка этого дела.
    К сожалению, после установки и обновления pfSense приходится начинать танцы с бубном.  :D

    На одном украинском сайте давалась инструкция по запуску SQUID3 на 2.2,
    Но симптомы такие же но на просто SQUID.
    Ссылка:
    https://it-community.in.ua/2014/11/pfsense-2-2-beta-squid-https.html/

    В коммандной строке выполнить команды из вышеназваноной ссылки.
    (Можно в Diagnostics - Command Prompt)
    Создаём Symlink:

    ln -s /lib/libmd.so.6 /usr/lib/libmd5.so.1

    Конфиги лежат в /usr/pbi/squid-i386/local/etc/squid/ Symlink на них. (у меня платформа i386, у кого amd64, соответственно /usr/pbi/squid-amd64/local/etc/squid/)

    ln -s /usr/pbi/squid-i386/local/etc/squid /usr/local/etc/squid

    Снова Symlink на них:

    ln -s /usr/pbi/squid-i386/local/libexec/squid /usr/local/libexec/squid

    Перезапустил SQUID.
    Вроде бы как заработало.

    Поставил Lightsquid.
    Но он, зараза, на закладке Lightsquid Report выдаёт
    "500 - Internal Server Error", а на вкладке "Proxy State"
    информацию в онлайне выдаёт кто и куда ломится.
    Проблема после установки Lightsquid в версии pfsense 2.2.x
    На закладке Lightsquid Report выдаёт "500 - Internal Server Error",

    LightSquid лечится также - исправление сылок на Perl

    ln -s /lib/libutil.so.9 /lib/libutil.so.8

    и поправить ссылки на конфиги (/usr/local/etc/lightsquid/)
    ln -s /usr/pbi/lightsquid-i386/local/libexec/lightsquid /usr/local/etc/lightsquid

    Как-то так.


  • сейчас буду пробывать.


  • https://forum.pfsense.org/index.php?topic=49872.0 вот эта тема. Запустить надо lightparser.pl Погугли ли бы сначала. Самая первая ссылка на решение проблемы.


  • делал уже всё по этой ссылке….. ничего неполучается...


  • а  Log store directory  как править???


  • при вводе команды cd /usr/local/www/lightsquid/ && ./lightparser.pl
    через браузер выдаёт:

    $ cd /usr/local/www/lightsquid/ && ./lightparser.pl
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LC_ALL = (unset),
    LANG = "en_US.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").


  • в squid  Enabled logging  галка стоит?


  • стоит.
    Когда смотришь Status: Traffic Graph ,движения есть…
    а вот статистики нет..... :'(


  • а другой сквид для установки доступен? если да то снеси сквид3 поставь сквид и Lightsquid  реинсталлируй.


  • так у меня и стоит сквид и Lightsquid….


  • посмотри в  System: Package Manager  там должен быть еще squid, не  squid3 а просто squid,
    вот третий удалит а другой поставить.


  • А перезагрузить pfSense не пробовали?


  • стоит обычный скуид.
    уже и перегружал и переставлял ничего…. :'(


  • народ подскажите как поменять с конфиге /var/lightsquid/report на  /var/squid/logs???


  • @vasya:

    народ подскажите как поменять с конфиге /var/lightsquid/report на  /var/squid/logs???

    Снесите lightsquid и поставьте заново.
    Выполните в командной строке (Diagnostics: Execute command) две команды:

    ln -s /lib/libutil.so.9 /lib/libutil.so.8
    ln -s /usr/pbi/lightsquid-i386/local/libexec/lightsquid /usr/local/etc/lightsquid

    (если система 64-разрядная - то lightsquid-amd64/ )
    На вкладке Services: Proxy Reports (LightSquid, SQStat) -> Settings нажмите кнопку  "Refresh now".

    /var/squid/logs - это куда squid валит логи, а /var/lightsquid/report - это где lightsquid создаёт отчёты,
    две разные вещи.


  • Дружище сделал всё как ты написал….  всеравно такая байда.
    Может залезешь ко мне на машинку по тиму. глянешь.... а то у меня уже за целый день башку сносит.....
    буду очень благодарен...


  • В долгу неостанусь….


  • Похоже ситуация прояснилась.
    Пока через Squid не ходят в интернет пользователи, файл /var/squid/logs/access.log
    не обновляется и соответственно для LightSquid нет работы, парсить нечего, вылетает эта
    ошибка.
    После того, как пошёл трафик через pfSense и Squid, access.log начинает заполняться
    и LightSquid начинает парсить и создавать отчёты.


  • Через squid ходит моя машинка…...  уже второй день.
    я специально открывал сайты все подряд... но в статистике нет ничего.... :'(


  • @vasya:

    Через squid ходит моя машинка…...  уже второй день.
    я специально открывал сайты все подряд... но в статистике нет ничего.... :'(

    А посмотрите содержимое файла /var/squid/logs/access.log
    Такое ощущение, что ваш комп в обход прокси ходит.
    А кстати, Squid-то у вас запустился, горит зелёным в WEB-интерфейсе?
    Попробуйте в браузере, ради интереса, выставить "использовать прокси" - ip вашего pfSense и порт 3128.


  • а как глянуть запустился или нет???
    у меня в свойствах обозревателя стоит моя прокся и порт 1328


  • @vasya:

    а как глянуть запустился или нет???
    у меня в свойствах обозревателя стоит моя прокся и порт 1328

    https://ip-pfSense, принять сертификат.
    На главной странице Status: Dashboard добавить "Services Status"
    Смотреть "squid Proxy server Service" - зелёный, значит запущен, красный, значит не запущен.


  • @vasya:

    а как глянуть запустился или нет???
    у меня в свойствах обозревателя стоит моя прокся и порт 1328

    Порт должен быть не 1328 а 3128!
    А лучше вообще поставить в настройках Squid галочку на "Transparent proxy",
    тогда точно через проксю будет ходить и в браузере можно удбрать "использовать прокси".


  • он и есть 3128 опечатался прошу прощения.
    статус горит зелёным
    Тут наткнулся на интересную штуку.
    полез  через файл менеджер с папку /var/squid/logs там есть логи по компу который подцеплен на проксю,
    дальше полез в /var/lightsquid/report посметреть есть ли что там.
    И оказалось что так есть ещё две папки название которых (20150824, 201508 25) как я понял эти папке создаются каждый день. В папочках есть файлики название которых соответствуют IP адресам компов которые подключены через проксю, и данные там есть.
    Но вот непоказывает из и всё…


  • @vasya:

    он и есть 3128 опечатался прошу прощения.
    статус горит зелёным
    Тут наткнулся на интересную штуку.
    полез  через файл менеджер с папку /var/squid/logs там есть логи по компу который подцеплен на проксю,
    дальше полез в /var/lightsquid/report посметреть есть ли что там.
    И оказалось что так есть ещё две папки название которых (20150824, 201508 25) как я понял эти папке создаются каждый день. В папочках есть файлики название которых соответствуют IP адресам компов которые подключены через проксю, и данные там есть.
    Но вот непоказывает из и всё…

    Значит всё работает.
    А не пробовали из командной строки запуск команды /usr/local/www/lightsquid/lightparser.pl?
    И потом посмотреть статистику.


  • $ cd /usr/local/www/lightsquid/ && ./lightparser.pl
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
      LC_ALL = (unset),
      LANG = "en_US.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").

    вот такую байду выдает


  • @vasya:

    $ cd /usr/local/www/lightsquid/ && ./lightparser.pl
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
      LC_ALL = (unset),
      LANG = "en_US.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").

    вот такую байду выдает

    А через WEB-интерфейс в Diagnostic-Command prompt просто запустить /usr/local/www/lightsquid/lightparser.pl?
    А в настройках lightsquid Lang=ru.
    В какой-то мелочи проблема.


  • тоже самое.
    $ /usr/local/www/lightsquid/lightparser.pl
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LC_ALL = (unset),
    LANG = "en_US.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").

    я уже ради эксперемента поставил sarg
    так он тоже невыдаёт статистики хотя в реальном времени всё видит.
    МИСТИКАА!!!! :o


  • @vasya:

    тоже самое.
    $ /usr/local/www/lightsquid/lightparser.pl
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LC_ALL = (unset),
    LANG = "en_US.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").

    я уже ради эксперемента поставил sarg
    так он тоже невыдаёт статистики хотя в реальном времени всё видит.
    МИСТИКАА!!!! :o

    С  Sarg тоже танцы с бубном, но и он начинает работать.
    Поставьте назад Lightsquid.
    Может по удалёнке Ammyy Admin как-то подключиться, напишите в личку, попробуем вдвоём поизвращаться.  :D


  • есть тимвьювер…


  • @vasya:

    есть тимвьювер…

    Давайте.
    Пишите данные на 3vs@mail.ru


  • Всё вопрос решился благодаря  3vs (Василию)
    Большое ему человеческое СПАСИБО.
    Весь косяк был в фаерфоксе. как только открыли в ИЕ всё пошло…