Pfsense als Router mit Telekom Magenta L / Entertain



  • Hallo erstmal  :).
    Ich steh vor einem problem ich habe einen internet anschluss von der Telekom (Magenta L 100dow/40up) mit entertain nun wollte ich umsteigen von einem Telekom Router auf einen Pfsense Router habe alles wie in dieser Anleitung gemacht: http://tuxi-test.blogspot.de/2009/03/pfsense-als-vdsl-router.html
    Aber der Pfsense Router hat sich nicht verbunden, meine vermutung ist das er eine ipv6 verbindung aufbauen will aber dort sind ja keine anmeldedaten hinterlegt (Mein Telekom Router verbindet sich mit einer Ipv6 adresse).
    Dort steht ja bei der Wan einstellung nur dhcp6 drin.
    Was mach ich da Falsch liegt es an ipv6 oder an etwas anderem?
    Dazu kommt dann noch Entertain habe da an diese Anleitung gedacht: https://blog.tausys.de/2014/10/16/telekom-iptv-mit-pfsense/

    Schonmal danke im voraus


  • Moderator

    Suche mal in diesem Forum nach Entertain etc. da findest du garantiert mehr/aktuellere Informationen als in einem 6(!) Jahre alten Blogartikel über eine völlig veraltete pfSense Version. Zumal wie du hier ebenfalls findest, inzwischen die Telekom Entertain und Co. auch anders überträgt/übertragen kann als vorher mit VLANs etc. üblich.

    Beispiel: https://forum.pfsense.org/index.php?topic=103508.0

    Grüße



  • Was für ein Modem hast Du? In dem angegebenen Artikel wird das VDSL-Modem Speedport 300HS verwendet. Benutzt Du das?

    Ich würde empfehlen zuallererst mit einem Rechner direkt eine PPPoE Einwahl mit dem Modem zu machen. Dann kannst Du prüfen, ob die DSL-Verbindung überhaupt klappt. Das Modem könnte nämlich auch defekt oder mit dem Anschluß inkompatibel sein. Das 300HS sollte wohl auch an VDSL2 funktionieren, aber ich bin mir da nicht so sicher.

    Erst wenn das geht, solltest Du die pfSense an das Modem anschließen. Entertain kannst Du zunächst ignorieren. Schau erstmal, daß die pfSense Kontakt bekommt. Du mußt auf dem WAN interface ein VLAN7 einrichten, auf diesem Interface dann PPPoE, hier kommen die Telekom-Einwahldaten rein. Dann müßte das schon klappen.

    Entertain fügst Du dann hinzu, wenn das Internet geht. Das ist nicht kompliziert.

    -flo-



  • Das Speedport 300HS geht für VDSL2 Vectoring nicht!

    VDSL 100 gibt es nur mit Vectoring.



  • Als Modem kann ich das DrayTek Vigor130 empfehlen. Dort setzte ich auch das VLAN7 also muss ich das nicht unter pfSense machen (Entertainment habe ich nicht).

    Hier meine Einstellungen, damit auch IPv6 funktioniert (allerdings erst mit 2.2.5 ohne Probleme).










  • @Wonko:

    Das Speedport 300HS geht für VDSL2 Vectoring nicht!

    VDSL 100 gibt es nur mit Vectoring.

    Das ist eine wichtige Info, danke dafür!

    -flo-



  • @mrpink:

    Als Modem kann ich das DrayTek Vigor130 empfehlen. Dort setzte ich auch das VLAN7 also muss ich das nicht unter pfSense machen (Entertainment habe ich nicht).

    DrayTek Vigor 130 kann ich ebenfalls empfehlen, das funktioniert sehr gut. Wie bereits in einem anderen thread erwähnt: Entertain kommt bei mir mit VDSL100 nicht mehr in einem separaten VLAN, man kann also das Modem das VLAN-Tag entfernen lassen, und Entertain funktioniert trotzdem.

    Der Tipp zu IPv6 hat mich heute eine Stunde gekostet. Als ich das so eingestellt habe, hatte ich zwar sofort eine IPv6-Adresse, aber keine IPv4-Adresse mehr.  :-[ Internet war damit "weg". Nach Rückbau der Konfiguration ging es auch nicht, da ist irgendwas verrutscht. Am Ende habe ich auf ein Backup einer älteren Konfiguration zurückgegriffen.

    Kriegst Du mit Deinem Setup eine IPv4 [b]UND eine IPv6-Adresse?

    -flo-



  • Ja ich bekomme IPv4 und IPv6. Bin aber nicht direkt bei der Telekom sondern 1und1.
    Sollte aber bei der Telekom auch genau so funktionieren.



  • Mit ADSL2+ nutze ich derzeit ein ALLNET ALL126AS2, was jedoch kein Vectoring kann.

    Habe gerade nachgescheut, nun gibt es auch:
    ALLNET ALL-BM100VDSL2 / VDSL2 Bridge Modem mit Vectoring & "ADSL-Backward"

    VDSL2 Plug and Play Bridge Modem für Provider VDSL Anschlüsse wie z.B. Telekom, Vodafone, QSC etc.

    Bridge-Modem nach VDSL2-Standard für hohen Datendurchsatz und ADSL abwärtskompatibilität
    Integrierter 4-Port Ethernet 10/100/1000Mbps Switch für WAN Verbindung
    Automatische Geschwindigkeitseinstellung für VDSL2-Port
    Zukunftssichere VDSL2-Technik bis 100Mbps
    Vordefinierter Tonemode B43
    Vectoring kompatibel

    Das ALLNET ALL-BM100VDSL2V ist ein VDSL2 Bridge Modem, welches Ihnen auf schnelle und einfache Weise Zugang zum VDSL2 Internet ermöglicht.
    Das Modem wird einfach mit einem Breitband-Router, Firewall PC oder MAC verbunden, weitere Einstellungen sind nicht nötig.
    Am LAN Port/Anschluss muss nur noch ihr Router/Firewall/PC etc. angeschlossen werden.

    Kennt das zufällig schon jemand?
    Allerdings ist es mit UVP Netto: 150,42 €  (brutto 179,- Euro) auch teurer als das als funktionierend bekannte Vigor130.



  • Wie bereits erwähnt ist das Vigor 130 ein gutes Modem, das alle erforderlichen Profile,etc. unterstützt.
    Schau doch mal bei ebay Kleinanzeigen, da wird gerade eines für 75€ angeboten.



  • @epionier:

    … ebay Kleinanzeigen ...

    Ich brauche Neuware mit Rechnung und das wird erfahrungsgemäß beim Kleinanzeiger schwer…  ;D

    Klar kann ich einfach das Vigor nehmen. Mir gefällt zumindest der Gedanke, eine Alternative zu haben. Darum fragte ich, ob das jemand kennt.  ;)



  • Habe das Zyxel VMG1312-B30A an einem Entertain Anschluss im Einsatz.

    VLAN Konfiguration läuft direkt über die Pfsense. Wir machen durchaus größere Scans damit. Der vorher als Modem genutzte Speedport machte immer bei 50.000 States die Grätsche. Das Zyxel läuft auch mit über 130.000 ohne Probleme.

    VG
    Andreas



  • Servus,
    ein paar Infos:

    VMG1312-B10A ( die eigentliche Annex A-Version) läuft an einem echten Vectoring-Anschluss einwandfrei. Was ADSL nach Annex J macht, geht damit nicht. Das Modem ist in D 40 - 50 Euro günstiger als das B30A (Annex B) zu haben.

    Am Montag verbaue ich ein Draytek Vigor 130 - ich bin gespannt.

    Heute hatte ich übrigens erstmals echte Probleme mit dem VOIP und weiß keinen Rat. Vielleicht einer von Euch. Ist ein Telekom BNG-DSL-Anschluss (AllIP Data-S). Ich habe mich an die Porteinstellungen der Telekom gehalten, bekomme aber ums Verrecken keine Sprachdaten rüber, wohl aber die Signalisierung. Auf der FritzBox an demselben Anschluss gehts aber. Momentan also doppeltes NAT, pfS aber als expoded host an der Fritte konfiguriert.

    Liegts am doppelten NAT? Normalerweise muss ich doch nur die RTP-Ports zur TK-Anlage eingehend NATten und sonst nix, oder ??? Jedenfalls habe ich das bisher immer so gemacht. Ist mehr eh alles suspekt, Telekom gibt hier UDP 30000 - 31000 und noch andere Ports an. http://klaus-rossteuscher.de/beschreibungen/voip-einrichtung-telekom-fremdrouter.html

    Grüße



  • Sooooooo. Es lies mir einfach keine Ruhe, habe deshalb an meinem T-Online-Anschluss daheim gewerkelt. Soweit ich das beurteilen kann muss, so wie bisher immer gemacht, eigentlich nur WAN-IP NAT -> PBX eingestellt werden. Entgegen aller Informationen der Telekom ,hat mich echt Nerven gekostet, kommen meine Gespräche auf UDP 20XXX an und nicht etwa auf 30000 - 31000 oder gar 40000 - 41000. Sipgate nutz ja z.B. 10000 - 20000.

    Also Rule für 10000 - 30000 gebaut und, Sackzement(!), es läuft. Und zwar auch ohne manual outbound NAT.



  • Erstmal wollte ich mich entschuldigen dass ich mich nicht mehr gemeldet habe, aber die Familie hat vorrang ;) .
    Aber nun kann ich mich wieder um den Pfsense Router kümmern.
    Erstmal danke für die ganzen atworten.
    Also ich habe eigentlich vor meinen jetztigen Router als moden zu konfigurieren das wäre dann der Speedport W921V.
    Nun soweit ich noch weis hatte ich probleme meine Nutzerdaten der Telekom richtig in die Pfsense einzutragen, da sich pfsense nicht verbinden wollte.
    Hab mich dann im Netzt etwas schlau gemacht und hab dann diese seite gefunden http://www.its05.de/computerwissen-computerhilfe/dsl_dfue_Internet/dsl_zugang_einrichten_01/dsl_zugang_einrichten_01.html und wie es bei Alte Teilnehmernummer steht müste ich das dann auch bei der Pfsense eintragen? Stimmt das soweit?

    Benedikt



  • @Benob:

    […]und wie es bei Alte Teilnehmernummer steht müste ich das dann auch bei der Pfsense eintragen?

    So habe ich das hier auch (ohne das '#').

    -flo-



  • @Benob:

    …wie es bei Alte Teilnehmernummer steht müste ich das dann auch bei der Pfsense eintragen?...

    Du hast von den Daten her einen VDSL-Anschluss mit Vectoring.
    Benutze dafür mal die "neue" Schreibweise, die Teilnehmerdaten werden IMHO bei er Umstellung auch angepasst oder der Server akzeptiert diese Version zumindest.



  • Hi,

    @tpf: Ist es für eine Firewall nicht etwas ungeschickt, so einen großen Range an Ports zu vergeben? Bei mir läuft das wie in den Anhängen aufgezeigt.

    pfsense auf APU1D4 mit Vigor 130 als Modem für VDSL100/40, VLAN7 Tagging auf pfsense, kein Entertain. Wobei ich behaupte, dass Entertain immernoch VLAN8 ist…

    Gruß
    Matthias



    ![pfsense nat.JPG](/public/imported_attachments/1/pfsense nat.JPG)
    ![pfsense nat.JPG_thumb](/public/imported_attachments/1/pfsense nat.JPG_thumb)
    ![Voip Ports.JPG](/public/imported_attachments/1/Voip Ports.JPG)
    ![Voip Ports.JPG_thumb](/public/imported_attachments/1/Voip Ports.JPG_thumb)
    ![stun telekom.JPG](/public/imported_attachments/1/stun telekom.JPG)
    ![stun telekom.JPG_thumb](/public/imported_attachments/1/stun telekom.JPG_thumb)



  • @mrpink:

    Als Modem kann ich das DrayTek Vigor130 empfehlen. Dort setzte ich auch das VLAN7 also muss ich das nicht unter pfSense machen (Entertainment habe ich nicht).

    Hier meine Einstellungen, damit auch IPv6 funktioniert (allerdings erst mit 2.2.5 ohne Probleme).

    Danke, das hat mir geholfen und ich bin recht schnell mit dem Vigor online gegangen.
    Ich habe nur ein Problem, das meine WAN Gateways als down markiert sind, obwohl ich die vom Client aus Pingen kann und ich auch Online bin.
    Die PFSense kann das WAN GW nicht pingen. Woran liegt das ?

    Irgendwelche FW Regeln ?

    ![2016-12-03 13_14_10-pfSense.localdomain - Status_ Dashboard.png](/public/imported_attachments/1/2016-12-03 13_14_10-pfSense.localdomain - Status_ Dashboard.png)
    ![2016-12-03 13_14_10-pfSense.localdomain - Status_ Dashboard.png_thumb](/public/imported_attachments/1/2016-12-03 13_14_10-pfSense.localdomain - Status_ Dashboard.png_thumb)
    ![2016-12-03 13_15_11-pfSense.localdomain - Status_ Dashboard.png](/public/imported_attachments/1/2016-12-03 13_15_11-pfSense.localdomain - Status_ Dashboard.png)
    ![2016-12-03 13_15_11-pfSense.localdomain - Status_ Dashboard.png_thumb](/public/imported_attachments/1/2016-12-03 13_15_11-pfSense.localdomain - Status_ Dashboard.png_thumb)



  • Zu erwähnen wäre vielleicht noch, dass ich die PFSense bislang hinter einer FB laufen hatte und dort gab es keine Probleme. Erst seit die PFSense hinter dem Vigor 130 Modem hängt und die Einwahl selber macht, habe ich das Problem.  :-\


  • Moderator

    Die PFSense kann das WAN GW nicht pingen. Woran liegt das ?

    Da das Telekom ist: Die Telekom hat meistens WAN Gateways (also next-hops) bei DSL, die nicht pingbar sind. Dass du das vorher mit der FB nicht hattest ist klar, hier war dein next-hop ja die FritzBox die ganz normal greifbar ist (und eigentlich sinnlos als Gateway Check, da sie bei dir steht). Gib für die DSL Gateways einfach eine alternative Monitoring Adresse ein, bspw. einen deiner DNS Server extern (oder 8.8.4.4 bspw.) und dann wirst du auch einen sauberen Online Status angezeigt bekommen.

    Grüße



  • Ok, danke.
    Das verwundert mich nur, weil die IP von Extern (also aus dem VPN) ja zu pingen ist.