In/Out errors :(



  • OPT1 interface
    Status associated
    MAC address 00:02:6f:3f:3c:29
    Channel 6
    SSID wireless
    In/out packets 3283680/4783188 (509.98 MB/149.32 MB)
    In/out errors 55033733/46
    Collisions 0

    configuration

    $ ifconfig
    sis0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>mtu 1500
    options=8 <vlan_mtu>inet6 fe80::20d:b9ff:fe03:a294%sis0 prefixlen 64 scopeid 0x1
    inet 192.168.0.1 netmask 0xffffff00 broadcast 192.168.0.255
    ether 00:0d:b9:03:a2:94
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    sis1: flags=8843 <up,broadcast,running,simplex,multicast>mtu 1500
    options=8 <vlan_mtu>inet6 fe80::20d:b9ff:fe03:a295%sis1 prefixlen 64 scopeid 0x2
    ether 00:0d:b9:03:a2:95
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    ath0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>mtu 1500
    inet6 fe80::202:6fff:fe3f:3c29%ath0 prefixlen 64 scopeid 0x3
    ether 00:02:6f:3f:3c:29
    media: IEEE 802.11 Wireless Ethernet autoselect mode 11b <hostap>status: associated
    ssid wireless channel 6 bssid 00:02:6f:3f:3c:29
    authmode OPEN privacy OFF txpowmax 38 protmode OFF burst -apbridge
    dtimperiod 1 bintval 100
    pfsync0: flags=41 <up,running>mtu 2020
    pfsync: syncdev: lo0 maxupd: 128
    lo0: flags=8049 <up,loopback,running,multicast>mtu 16384
    inet 127.0.0.1 netmask 0xff000000
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
    pflog0: flags=100 <promisc>mtu 33208
    bridge0: flags=8043 <up,broadcast,running,multicast>mtu 1500
    ether ac🇩🇪48:3d:db:38
    priority 32768 hellotime 2 fwddelay 15 maxage 20
    member: sis0 flags=3 <learning,discover>member: ath0 flags=3 <learning,discover>ng0: flags=88d1 <up,pointopoint,running,noarp,simplex,multicast>mtu 1492
    inet6 fe80::20d:b9ff:fe03:a294%ng0 prefixlen 64 scopeid 0x7
    inet 201.255.9.94 –> 200.51.241.237 netmask 0xffffffff

    WARP: 1 LAN 1 WAN
    MINIPCI: senao 8602 400 mw

    That is the problem? please help me.</up,pointopoint,running,noarp,simplex,multicast></learning,discover></learning,discover></up,broadcast,running,multicast></promisc></up,loopback,running,multicast></up,running></hostap></up,broadcast,running,promisc,simplex,multicast></full-duplex></vlan_mtu></up,broadcast,running,simplex,multicast></full-duplex></vlan_mtu></up,broadcast,running,promisc,simplex,multicast>



  • Noise. Stop polluting the air with highpower cards.
    I have a 82 mile (about 132 KM) shot with CM-9's and parabolic antennas.



  • Could he try turning down the Power using the drop-down box in pfSense?



  • That should work.



  • I too get lots of In/Out errors :
    In/out errors 38660/7513

    this is my conf :

    ifconfig -v ath0

    ath0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>mtu 1500
            inet6 fe80::20b:6bff:fe4d:4e0f%ath0 prefixlen 64 scopeid 0x1
            ether 00:0b:6b:4d:4e:0f
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: associated
            ssid "Omega Netwrok" channel 11 (2462) bssid 00:0b:6b:4d:4e:0f
            authmode WPA privacy MIXED deftxkey 3
            AES-CCM 2:128-bit
            AES-CCM 3:128-bit powersavemode OFF powersavesleep 100 txpowmax 20
            txpower 20 rtsthreshold 2346 mcastrate 1 fragthreshold 2346 -pureg
            protmode OFF -wme burst ssid SHOW -apbridge dtimperiod 1 bintval 100
            -countermeasures

    I tried to lower Transmit power, adjust the "Distance setting" to 30, and tried diffrent Channel, but still get the same in/out error.

    Any recomendation ?</hostap></up,broadcast,running,promisc,simplex,multicast>



  • When I use the command :
    sysctl dev.ath.0.rxantenna
    I get this answer :
    dev.ath.0.rxantenna: 2

    Can this be the problem, I only have one Antenna connected to my CM9 card ?

    If so, How can I change rxantenna,txantenna,diversity from shell ?



  • You should soon be able to select the Tx & Rx Antennas (for ath) from the GUI :
    http://forum.pfsense.org/index.php?topic=1172.0



  • I am also having problems with errors, but only on the "IN" side not the out.  I checked my config, and I have two antennas, tx on antenna 1, and rx on antenna 2 using deiversity.

    I'll play around with the power on my CM9 card and see if I can get some of the errors to go away.  My channel settings are now on auto as well, so I can play with channels as well.

    Is there a way from the command line to reset the error counters without rebooting the box?



  • When running in G mode you might want to turn on Prot mode and set it to CTS/RTS. also if you have G only clients you might want to turn on "pureg". but really there is not much you can do about noise in 802.11b/g, only 3 channels are non overlapping. This basically means that "everyone" should stick to channel 1/6/11 and leave the rest unused. I know this is utopia, but still. Some "semi hideing" from noise by using the middle channels only creates problems in the long run, both for the ones that  use the ovelapping channels and for those who stick to 1/6/11. Also, so called "TX power overdrive/override" will cause a lot of sideband noise.

    What ppl essentially do is trying to scream higher then the person next to them, all in hopes of beeing the one that is heard. Everyone understands that this isn't going to work in the long run.

    Only way to get rid of some noise is to use RF channel filters. But those probably cost more then your whole wireless setup.

    as for the sysctls, they will be available in 1.1. you can offcource set them manually in the shell.
    normal uasge should be diversity disabled, and RX/tx antenna should be the same if you have a single antenna setup. if you have two antennas then you should set one to TX and the other to RX.



  • " How can I change rxantenna,txantenna,diversity from shell [for Atheros] ? "
    I would also like to know how to do this.  Plus, how/where to put the commands so they run on boot up of pfSense Imbedded version.
    Also, is it not wise to turn on receive diversity, even with two antennas?  Is it not worth using unless you have 3 antenna ports (2Rx, 1Tx)?
    Thanks, -Pete



  • Use the force luke, ahm, the search: http://forum.pfsense.org/index.php?topic=1149.msg6765#msg6765  ;D



  • Hi lsf,

    I ask my question again :

    How can I change rxantenna,txantenna,diversity from shell ?

    Hoba,
    Your link point out to how "find out" which rxantenna,txantenna,diversity you use, it dosn't tell you how to change those values.



  • You can change the values using the sysctl command from shell:

    Example:
    "sysctl dev.ath.0.txantenna" will list the value that is in use atm
    "sysctl dev.ath.0.txantenna=1" will set the value to 1

    If you want to make these changes static add these commands to your "/etc/sysctl.conf" so they will be set at bootup. You can do that easily by using diagnostics>edit file from the webgui.



  • Thanks for the help Hoba, using the following command eliminated my in/out error :

    sysctl dev.ath.0.rxantenna=1
    sysctl dev.ath.0.txantenna=1
    sysctl dev.ath.0.diversity=0

    However, I can't make it work on statup, I put these command inside /etc/sysctl.conf and reboot the router :
    dev.ath.0.rxantenna=1
    dev.ath.0.txantenna=1
    dev.ath.0.diversity=0

    But after reboot, If I do sysct, It show the old figures.

    inside /etc/rc.bootup, I noticed that functions interfaces_wan_configure()  interfaces_lan_configure()  interfaces_vlan_configure(); are called after system_setup_sysctl()
    Can those function overwrite my sysctl command.

    I also noticed the function system_do_shell_commands() (/* run any shell commands specified in config.xml */)
    Where inside config.xml file I can put my shell command ?
    Maybe puting my sysctl command there would help.



  • Maybe http://pfsense.blogspot.com/2005/06/new-xml-system-tag-introduced.html (another of our hidden xml options: http://faq.pfsense.com/index.php?action=artikel&cat=10&id=38&artlang=en&highlight=hidden ) would be a good option to put it as this then will also be run after you changed wireless settings from the gui. Please try and report back.
    Btw, we are working on getting these advanced options in the gui for pfSense 1.1.



  • Hoba thank you very much for all help.

    I now manage to reduce my In/Out Error to 3 figures instead of 6 figures.
    In my configuration, I have only one antenna connected to CM9 card.

    1. Based on lsf recomendation,the first thing I did was changing my pfsense config trough webGUI to :
    Standard = 802.11g
    Mode = Access Point
    802.11g OFDM Protection Mode = Protection mode RTS and CTS
    802.11g only = Check
    Transmit power = 20
    Channel = Auto
    Distance setting = 30

    2. Based on Hobas help, I changed my Antenna configuration trough shell :
    sysctl dev.ath.0.rxantenna=1
    sysctl dev.ath.0.txantenna=1
    sysctl dev.ath.0.diversity=0

    3. Again, based on Hobas Help, I modify my /cf/conf/config.xml :
    Find the tag :

    Change it to :
    <shellcmd>sysctl dev.ath.0.rxantenna=1;sysctl dev.ath.0.txantenna=1;sysctl dev.ath.0.diversity=0</shellcmd>

    4.Reboot

    Hoba, maybe you should update WIKI for Wirless and explain how to change sysctl command and put it on startup (Number 2 and 3)



  • Maybe we should hardcode these settings for pfSense 1.0. This way it will work for people regardless if they have 1 antenna or 2 (one of them then would simply not be used though present unless you change the sysctl's). Like written in my earlier post the next pfSense version should have settings for these values at the webgui. Updating the wiki won't hurt. I'll do that later (unless lsf does this before I find the time  ;) ).



  • Right now I am using BETA3-PLUS-11548-PLUS-11567

    I changed /cf/conf/config.xml from :

    To :
    <afterfilterchangeshellcmd>sysctl dev.ath.0.rxantenna=1;sysctl dev.ath.0.txantenna=1;sysctl dev.ath.0.diversity=0</afterfilterchangeshellcmd>

    and save the file.

    But when I changed some configuration in WebGui for my WLAN, the <afterfilterchangeshellcmd>inside config.xml had been removed automaticly.</afterfilterchangeshellcmd>



  • Hoba,

    I did some more testing and now I fiugre out what should be done.
    Whenever, you change the /cf/conf/config.xml  file, you need to reboot the router immediately once .

    So this is how I make it work :

    1.Search /cf/conf/config.xml for

    Replace it with :
    <afterfilterchangeshellcmd>sysctl dev.ath.0.rxantenna=1;sysctl dev.ath.0.txantenna=1;sysctl dev.ath.0.diversity=0</afterfilterchangeshellcmd>

    2.Reboot

    3.Now, Whenever you change config for interfaces inside WebGUI, you don't loose the wirless parameters.



  • You have to remove /tmp/rules.debug as well after changing config.xml as its the cached version and will simply overwrite config.xml on the next filter reload operation.

    So technically the reboot is not needed.



  • @sullrich:

    You have to remove /tmp/rules.debug as well after changing config.xml as its the cached version and will simply overwrite config.xml on the next filter reload operation.

    So technically the reboot is not needed.

    close… /tmp/config.cache :)

    --Bill



  • @billm:

    @sullrich:

    You have to remove /tmp/rules.debug as well after changing config.xml as its the cached version and will simply overwrite config.xml on the next filter reload operation.

    So technically the reboot is not needed.

    close… /tmp/config.cache :)

    --Bill

    Grr.  Bill is absolutely right.  This head cold is driving me ape shit.



  • My Tx was set to 0, and Rx to 1 (on Atheros).
    Is 0 or 1 the First antenna?  And, what does it mean when set to "2".
    Thank you,
    -Pete



  • The second time I link to http://forum.pfsense.org/index.php?topic=1149.msg6765#msg6765 in this thread  :P



  • Thanks hoba!
    Although it's fairly obvious, I was just hoping to see it spelled out in no uncertain terms that 0=Main and 1=Aux.
    I was careful to read the card's docs to be sure I put the First pigtail (labeled "Antenna#1") on Main,
    and the Second pigtail (labeled "Antenna#2") on Aux.  -Pete



  • 2 means Auto.

    What I did was to set both antenna to 0 fisrt and check the in/out errror, then set both to 1 and check the errors again.
    Do the same and see when you get less error, then you know which antenna port you should use.



  • nima.m, is it possible that you plugged your single pigtail into the card's Aux antenna port, and that is why you had to set it to 1?



  • @pcatiprodotnet:

    Thanks hoba!
    Although it's fairly obvious, I was just hoping to see it spelled out in no uncertain terms that 0=Main and 1=Aux. -Pete

    I think that is related to the hardwarelayout. I have even seen cards with no label on either of the antennaoutputs. I recommend doing what nima.m suggested. Try to see what gives you the best results. Generate some traffic (try to load it) and you should see errors increasing rather fast with the wrong setting. Closing the case might help finding the wrong setting too, so you get some noise reflections inside the case with the non hooked up output.



  • I have no idea :-)

    I bought one of those Lintex 6 Nic router and told them to install a CM9 minipci and a external antenna and send it to me.
    And they did that, And I havn't open my case for checking it.



  • I just tried the above procedure on beta4, deleted /tmp/config.cache, rebooted for good measure, and it didn't change.
    I loaded up /cf/conf/config.xml , and re-checked it…
    <maximumstates><afterfilterchangeshellcmd>sysctl dev.ath.0.rxantenna=0;sysctl dev.ath.0.txantenna=0;sysctl dev.ath.0.diversity=0</afterfilterchangeshellcmd>

    but in shell it still reports...

    sysctl dev.ath.0.diversity

    dev.ath.0.diversity: 1

    sysctl dev.ath.0.rxantenna

    dev.ath.0.rxantenna: 1

    sysctl dev.ath.0.txantenna

    dev.ath.0.txantenna: 0</maximumstates>



  • Change it to :

    <shellcmd>sysctl dev.ath.0.rxantenna=1;sysctl dev.ath.0.txantenna=1;sysctl dev.ath.0.diversity=0</shellcmd>
    <afterfilterchangeshellcmd>sysctl dev.ath.0.rxantenna=1;sysctl dev.ath.0.txantenna=1;sysctl dev.ath.0.diversity=0</afterfilterchangeshellcmd>

    then reboot and check

    sysctl dev.ath.0.diversity



  • It's still unchanged. -Pete



  • Is there a way to simply run a shell script after pfsense finishes booting?  If so, I could put the sysctl commands there.
    This problem with the antennas is causing us quite a bit of hassle.
    Also, I wouldn't recommend pfSense pre-determining the antenna settings because people will often attach a single pigtail on the "wrong" mini-pci U.FL connector or transpose two connectors for main/aux.  If you must, perhaps setting both Tx & Rx to Auto would be the most generally helpful; but, having the ability to set them in the GUI is golden.
    Thank you, -Pete



  • This is not something we controll, it's controlled by the freebsd driver/HAL. One of the reasons i haven't added these settings are just because of that. What should be defaults ? should I first up the card and enable it, and then allow the values to be changed ? if not, how should i get the defaults ? (the defaults "change" based on what settings it found "sensible" when the interface was up'ed and configured).
    Basically what i'm trying to say is that the driver does not behave the same on every HW combo/user setup. So it's hard to pick any default. I know the driver does not do this perfectly, but it probably does a better job then us presetting/hardcoding this.



  • @pcatiprodotnet:

    Is there a way to simply run a shell script after pfsense finishes booting?  If so, I could put the sysctl commands there.

    Thats what shellcmd tag do,

    Lets try this
    1.Change your config file in this way :
      <shellcmd>echo 1 > /beforeShell;sysctl dev.ath.0.rxantenna=1;sysctl dev.ath.0.txantenna=1;sysctl dev.ath.0.diversity=0;echo 1 > /afterShell</shellcmd>
      <afterfilterchangeshellcmd>echo 1 > /beforeFilter;sysctl dev.ath.0.rxantenna=1;sysctl dev.ath.0.txantenna=1;sysctl dev.ath.0.diversity=0;echo 1 > /afterFilter;</afterfilterchangeshellcmd>

    2.Reboot

    3.SSH to your router

    4.Run this command one by one and see the result :

    ls /beforeShell
    ls /afterShell
    ls /beforeFilter
    ls /afterFilter



  • After some investigation, I discovered that boot commands are working; however, after a little time, the old settings get put back. I'm not quite sure what to make of this.  Perhaps with Diversity is On, the wireless card is changing the Rx antenna setting based on what it thinks is best at the moment?

    Another handy command: athstats

    Although information is sparse, it appears that for tx/rxantenna setting: 0=auto, 1=antenna1, 2=antenna2.

    -Pete



  • @pcatiprodotnet:

    After some investigation, I discovered that boot commands are working; however, after a little time, the old settings get put back. I'm not quite sure what to make of this.
    -Pete

    Yeah, I believe some of that is the ATH driver.  It's annoying.  FWIW, I have a machine with two antenna's attached and I constantly get errors - it doesn't seem to impact the performance of the unit, so I've just learned to ignore it.

    –Bill



  • @pcatiprodotnet:

    Although information is sparse, it appears that for tx/rxantenna setting: 0=auto, 1=antenna1, 2=antenna2.

    To be honest i haven't checked this in a while, so it might have changed in the ath driver, however madwifi also seems to have what I stated earlier, and it used to be the defautls of the HAL.
    So this might be some weirdness with athstats as well (i'll check this out later)
    BTW: both=auto

    If diversity is on then it should change antennas whenever it needs to (autosense), however if diversity is off then it should stick to what you set it to. And diversity should not turn on again unless you change the interface settings or up/down the interface.



  • Another question..  If I enable TPC via sysctl commands, it seems to turn on both antennas, and diversity.  Does TPC require the use of two antennas?  I have searched on this, but I cant find anything?  (I'm using a CM9)



  • That really depends on the implemetation, to be honest I'm not sure how this is controlled in sams HAL.
    Normally it should not require diversity and/or two antennas.


Log in to reply