Openvpn bahnhof



  • Ok, jag har en lite kraftigare fyrkärnig stationär PC med. Jag skall göra en installation på den med och testa skillnaden. Även kolla att jag har full hastighet i uttaget med såklart.



  • Jämför också med/utan OpenVPN-klienten igång, det är själva krypteringen som kan vara tung för CPUn. Snabbt kollat utan att dra om sladdar menar jag.



  • Ska kolla det med.
    Samt ringa Bahnhof, TP direkt i uttaget gav bara 66mbit/s



  • Lite snabbtest i morse gav 100/10 direkt i uttaget via PFSense utan VPN.
    PFSens med VPN var fortfarande ca 10 upp och 20 ner. CPU-belastningen låg på mellan 18 och 24% under TP-Testet.

    Skall fortfarande testa med andra burken med men funderar redan på alternativ VPN-tjänst.

    OVPN är ett alternativ, NordVPN ett annat.

    Förslag? Stabilitet är ju ett prio.



  • Jag har bara provat OVPN i några veckor men än så länge har det fungerat bra. Du kan prova gratis 5 timmar har jag för mig. Dom har en bra guide för pfSense där du kan se vilka saker du behöver ändra. Om jag inte minns helt fel är det förutom det självklara också port och några custom options att lägga till. Fixat på några minuter. Glöm inte att byta CA  ;) Känner inte till NordVPN.



  • @StarkJohan:

    Jag har bara provat OVPN i några veckor men än så länge har det fungerat bra. Du kan prova gratis 5 timmar har jag för mig. Dom har en bra guide för pfSense där du kan se vilka saker du behöver ändra. Om jag inte minns helt fel är det förutom det självklara också port och några custom options att lägga till. Fixat på några minuter. Glöm inte att byta CA  ;) Känner inte till NordVPN.

    Japp, jag har spanat lite på deras guide och mailat dom i försöket att tigga till mig lite längre testtid än 5h :)



  • Jo det tyckte jag också var lite snålt… Något dygn kunde dom åtminstone tillåtit.



  • Så, kundtjänst på OVPN var väldigt tillmötesgående så nu har jag några dagar på mig att testa istället för några timmar.
    Inte nog med det så sticker sambon och lillgrabben några timmar ikväll så med lite tur så kan jag testa lite.

    PLANEN är att först installera Integrity på den andra enheten och testa om hastigheten blir lika kass.
    Efter det så blir det installation av OVPN och testa på den första igen.

    Det sagt, kan jag skifta USB-minnet till en annan dator och bara uppdatera nätverkskorten eller behöver jag göra en ren installation?
    Om ren installation, kan jag använda de sparade konfigurationsfilerna på den nya "routern"?



  • Det vet jag tyvärr inte.



  • Ok, det här var ju mindre kul.
    Min PC med Q8300 processor gav ca 37 upp och 10 ner, så ca 10 högre än den med ion.
    Jag gick tillbaks till ion och ställde in OVPN, vilket gick smidigt.
    Tptest 3 och tptest5 gav bara 10 upp och 17 ner medan brebandskollens webbaserade gav 45 upp och 45 ner.
    Märk väl att linan är 100/10.

    Så jag är lite av ett frågetecken nu.

    Tillägg 20170308 07:10
    Jag körde Speedtest.net i morse med 75 ner och 10 upp.

    Om man nu drar den obekräftade slutsatsen att webbaserade mätningar ger korrekt resultat och de nedladdade TPTesten ger felaktigt så verkar det funka fint. Dock verkar OVPN variera med tiden på dygnet.

    Jag skall göra ett test till med Integrity och köra webbaserade med den med för att kunna jämföra bättre.



  • Varje gång du mäter bör du nog också mäta utanför tunneln så att det inte är grannarnas surf som ställer till det för dig just vid den tidpunkten, för säkerhets skull.

    Jag kör pfSense och OpenVPN-klient på en sån här utan att tappa hastighet: https://forum.pfsense.org/index.php?topic=114202
    Min Macbook Air (Mid 2013; 1,7 GHz Intel Core i7; 8 GB 1600 MHz DDR3) klarar helt utan problem att köra 100/100 över OpenVPN också så borde knappast vara din PC som inte hänger med.

    Jag har valt "pool.prd.se.malmo.ovpn.se" eftersom jag bor ganska nära Malmö. Se till att välja en server eller serverpool nära dig.

    Mina resultat är väldigt lika med TPTest5 och BBK generellt men BBK brukar visa något högre hastighet nedströms. Jag har 100/100 öppen fiber.

    10 ner låter inte så kul på en 100MBit lina…



  • @StarkJohan:

    Varje gång du mäter bör du nog också mäta utanför tunneln så att det inte är grannarnas surf som ställer till det för dig just vid den tidpunkten, för säkerhets skull.

    Jag kör pfSense och OpenVPN-klient på en sån här utan att tappa hastighet: https://forum.pfsense.org/index.php?topic=114202
    Min Macbook Air (Mid 2013; 1,7 GHz Intel Core i7; 8 GB 1600 MHz DDR3) klarar helt utan problem att köra 100/100 över OpenVPN också så borde knappast vara din PC som inte hänger med.

    Jag har valt "pool.prd.se.malmo.ovpn.se" eftersom jag bor ganska nära Malmö. Se till att välja en server eller serverpool nära dig.

    Mina resultat är väldigt lika med TPTest5 och BBK generellt men BBK brukar visa något högre hastighet nedströms. Jag har 100/100 öppen fiber.

    10 ner låter inte så kul på en 100MBit lina…

    Jag har hittills mätt utan tunnel med för att få en referens, det har varit full hastighet med ett undantag.
    Imorse fick jag ca 75/10 på speedtest.net mot stockholm via VPN så bättre än igår eftermiddag.
    Jag skall köra ett test med din inställning mot malmö. I nuläget kör jag bara mot det första alternativet (Sweden).
    Sen skall jag göra samma sak med Integrity igen.

    Frågan är bara varför det blir sån skillnad mellan TP-test och webbaserad tjänst.



  • Jag har inte så bra koll på exakt vad som skiljer TPTest mot BBK. Jag tror att BBK är HTML5-baserad multisession medan TPTest kör en enda TCP-session.

    Har inte tillräckligt bra koll för att kunna upplysa dig mer tyvärr…



  • Lite mer testat.

    Angående alla olika testsystem så ringde jag Bahnhof och rådfrågade dom. Deras svar var helt enkelt att vi använder alltid Bredbandskollens avancerade mätning mot Stockholm och med "sockets" vald.
    Detta tog jag till mig och kopplade in min PFSense EFTER min första router, detta för att slippa bryta kopplingen varje gång jag testar nått.

    Jag använde mig av min Asus at3ion i samtliga fall och började med OVPN, min uppkoppling är 100/10. Klockan runt 17.00.
    1. Utan OVPN gav 100/30
    2. Med OVPN mot "Sverige" gav 90/30
    3. Med OVPN mot Malmö gav 70/30
    4: Med OVPN mot Stockholm gav 50-60/30
    5. Skiftade tillbaks till Sverige och fick då fortfarande 50-60/30

    6. Utan VPN gav 100/10
    7. Med Integrity gav 40/10

    OVPN fick jag ett högre värde på uppströms, vilket tydligen inte är ovanligt pga något med kompressionen. OVPN skiftade också väldigt från mätning till mätning.
    Integrity gav ett lägre värde nedströms men ett stabilt sådant. Jag testade detta ett flertal gånger under kvällen och morgonen och det varierade med max 2mbit.

    Utan att kunna så mycket om detta så känns det som att AES-NI är viktigare än ren processorstyrka för att få upp hastigheten på OpenVPN så jag funderar på att bara köra med min befintliga setup och begränsa vilka enheter som går via VPN tills jag finner nån lämplig enhet att uppgradera med.

    Tankarna går spontant till en APU-enhet.

    Kommentarer, tankar, sågningar?



  • Hårdvarustöd för krypteringen är såklart att föredra om man har valet. Min pfSenseburk har inte stöd för det tyvärr men det fungerar bra ändå.

    OVPN-valet "Sverige" väljer nog "närmaste" eller "mest lediga" server vilket såklart också är bra.



  • @StarkJohan:

    Hårdvarustöd för krypteringen är såklart att föredra om man har valet. Min pfSenseburk har inte stöd för det tyvärr men det fungerar bra ändå.

    OVPN-valet "Sverige" väljer nog "närmaste" eller "mest lediga" server vilket såklart också är bra.

    Ja, jag hoppades att min lilla atom skulle klarat det ändå men det var nog att hoppas på lite väl mycket.
    Oavsett känner jag att jag kommit till vägs ände med detta med den hårdvara jag har. Jag kommer att hålla ögonen öppna för lite annan hårdvara. Jag är inte sugen på att lägga ut en massa (läs helst inga alls) pengar på detta så det stå mellan begagnade delar, APU-enhet eller ett liknande koncept jag har nu fast med AES-Stöd.



  • Good times!
    Strax efter mitt förra inlägg havererade en pc på jobbet och den kasserades.
    Moderkortet var dött men jag räddade processorn, kylare, psu och minne.

    Processorn är en I3-4130 med stöd för AES och jag fick tag i ett billigt moderkort från Asus och en ny kylare då den befintliga inte var kompatibel med det nya moderkortet.
    Samtidigt hittade jag en gammal E8600 processor för en dryg hundring till min andra PC.

    Så nu har jag följande:
    Asus P5PKL
    Intel E8600
    4GB RAM

    Och
    Asus H81M-K
    Intel I3-4130
    4GB RAM

    Jag funderar på att sätta I3:an som VPN och överklocka E8600 så gott det går och ha den till media/lek.
    Till I3:an har jag även en picopsu med 90W extern nätadapter



  • I3an installerad och integrity ger  fullt blås. 100mb ner och 10 upp.



  • Hej, om någon har hastighetsproblem med OpenVPN så rekommenderar jag att kolla MTU setting.

    Den står på 1500 per default, men efter att ha kört kommandot:

    ping -n 1 -l 1500 -f www.di.se

    där man gradvis stegar ner "1500" med 10, dvs 1490, 1480… så hittar man en setting där man inte förlorar paket.

    Jag kör OpenVPN (Integrity.st) med kryptering på en Core2 Duo E8400 (passmark ca 2100) utan AES-NI på en 250Mb ner och 100Mbit upp lina.

    Utan MTU inställningen fick jag 53Mbit ner och 88Mbit upp.
    Processorlast på ca 25%

    Med MTU inställningen fick jag 200Mbit ner och 100Mbit upp.
    Processorlast på ca 45%

    Här är en länk till MTU inställning:
    https://www.sonassi.com/help/troubleshooting/setting-correct-mtu-for-openvpn

    Hoppas att det hjälper någon :-)

    /MrIster
    PS. nu får man jaga de där sista 50Mbiten....inte så relevant nu men om man någon gång skulle gå upp i hastighet alternativt kan det ju ge lite störningar man inte vet om ännu ;-)


  • Banned

    This post is deleted!