Problema trafico de salida en PfSense 2.2.6



  • Muy buenas.
    Tenemos un PfSense que nos hace de proxy transparente cache, y aun ni siquiera hemos empezado a bloquear nada (hay intencion de usar alguna lista de shallalist o similar, peor aun no esta hecho
    Recientemente hemos empezado a tener problemas de envio con Outlook, y despues de mucho rompernos la cabeza, hemos visto que no solo es outlook, si no casi todo el trafico "saliente"

    Tenemos dos interfaces WAN (DHCP connectado a router Fibra Optica dentro del rango 192.168.2.0/24) y la LAN (IP FIJA 192.168.1.101)

    Algunas capturas:

    Dashboard

    Gateways definidas :

    Reglas del firewall :

    Y el que creo que es "el turron" …..logs donde se ven cientos de bloqueos por el siguiente motivo : block drop in log inet all label "Default deny rule IPv4"

    La cuestion es que si deshabilito el firewall mediante shell (pfctl -d) todo funciona perfectamente, enviamos correo y podemos hacer pruebas de velocidad en cualquiera de las webs , que nos da una velocidad de bajada de 100Mb y de 10Mb de subida), o sea todo correcto

    En el momento que hacemos un pfctl -e (habilitamos de nuevo firewall), outlook deja de funcionar , y en las webs de pruebas tan solo podemos hacer el test de bajada , que nos da 100Mb correctamente, pero el de subida nos da un error de timeout.

    Podeis ayudarnos ??

    P.D.: Sorry si no he hecho presentacion, pero estamos en un aprieto y llevo muy poquito con PFSense


  • Rebel Alliance



  • @ptt:

    Por qué / para qué el GW en la LAN  ???

    https://doc.pfsense.org/index.php/Connectivity_Troubleshooting#LAN_Interface

    Porque si quitamos el GW de la LAN la velocidad de descarga nos disminuye a 30Mb en lugar de 100Mb…..  :-[ :-[

    Como digo soy totalmente novato en PFSense, y puede que por ahí venga el problema, pero fué poner el GW en la LAN y voila, la velocidad de la conexion fué de 100Mb de golpe.


  • Rebel Alliance

    Las interfaces "tipo LAN" NO "llevan" GW  (revisa el link a la documentación oficial que dejé en el post anterior).

    Estás corriendo pfSense "virtualizado" ?

    Adjunta un Diagrama/Esquema de la Red



  • @ptt:

    Por qué / para qué el GW en la LAN  ???

    https://doc.pfsense.org/index.php/Connectivity_Troubleshooting#LAN_Interface

    Por probar he quitado el GW 192.168.1.1 y he visto dos cosas :

    1 - He recuperado la "subida" y ahoira puedo hacer el test de velocidad y vuelvo a enviar mails
    2 - la velocidad de conexion, como te decia antes, ha bajado de nuevo a 30Mb en lugar de 100Mb de nuestra fibra y que poniendo el GW de 192.168.1.1 recuperamos

    adjunto captura de velocidad quitando el GW de LAN

    Insisto, si pongo el GW de LAN este mismo test nos da la velocidad completa de la Fibra (100Mb) , pero da un error cuando intenta hacer el test de subida, así como que dejamos de poder enviar correos.



  • @ptt:

    Las interfaces "tipo LAN" NO "llevan" GW  (revisa el link a la documentación oficial que dejé en el post anterior).

    Estás corriendo pfSense "virtualizado" ?

    Adjunta un Diagrama/Esquema de la Red

    Si, está dentro de un ESXI 5.1 (192.168.1.5), que a su vez ejecuta un Win 2008 server haciendo de DC (192.168.1.210)

    No se que herramienta usar para haceros un diagrama de la red  :'( :'( :'(



  • Hola.

    Si tienes 2 gateways, debes de segmentar la red y que los 2 gateways sean accesibles solo desde la interfaz WAN:

    red local - siwtch A – interfaz lan pfsense -PFsense --- interfaz wan1 pfsense --cable directo- Gateway1
                                                                            |---- interfaz wan2 pfsense - cabel directo-- Gateway2

    Debes de configurar multiwan en System > routing > Groups (creas uno) .. y luego en las reglas del tráfico lan a Inet usas como gateway ese grupo multiwan creado

    doc multiwan: https://doc.pfsense.org/index.php/Multi-WAN

    Salu2

    –-añadido ---

    Lo ideal para tu caso seria que tu pfSense tuviera 3 nics (1 para la lan, 2 para las wan), ----

    pero para una sola interfaz wan en tu pfsense: seria la topología:

    red local - siwtch A -- interfaz lan pfsense -PFsense --- interfaz wan pfsense --siwtch B- Gateway1
                                                                                                                      --switch B-- Gateway2



  • @javcasta:

    Hola.

    Si tienes 2 gateways, debes de segmentar la red y que los 2 gateways sean accesibles solo desde la interfaz WAN:

    red local - siwtch A – interfaz lan pfsense -PFsense --- interfaz wan1 pfsense --cable directo- Gateway1
                                                                            |---- interfaz wan2 pfsense - cabel directo-- Gateway2

    Debes de configurar multiwan en System > routing > Groups (creas uno) .. y luego en las reglas del tráfico lan a Inet usas como gateway ese grupo multiwan creado

    doc multiwan: https://doc.pfsense.org/index.php/Multi-WAN

    Salu2

    –-añadido ---

    Lo ideal para tu caso seria que tu pfSense tuviera 3 nics (1 para la lan, 2 para las wan), ----

    pero para una sola interfaz wan en tu pfsense: seria la topología:

    red local - siwtch A -- interfaz lan pfsense -PFsense --- interfaz wan pfsense --siwtch B- Gateway1
                                                                                                                      --switch B-- Gateway2

    OSt***…..te lo agardezco, pero.......no he entendido un pimiento.....como hago todo eso ??

    Y a parte....El hecho de tener dos gateway fué porque en medio de un ensayo y error vimos que haciendo eso la bajada en los test de velocidad de la fibra optica era completa , eso es, los 100Mb......no porque nosotros lo necesitamos, que de eso ni idea, no sabemos si lo necesitamos o no.

    Tenemos en la empresa un ESXi que hasta ahora era el DC y un ZENTYAL....de repente hacve unos meses ZENTYAL deja de ofrecer el servicio proxy de filtrado de WEBS y de chache y nos recomendaron PFSense, pero nunca lo habia tocado hasta ese momento.

    Y ahí estamos.....



  • Añado estructura que he sacado del ESXi



  • Hola.

    Mira, para este escenario multiwan

    Un procedimiento que he hecho para pfSense 2.2.6 amd64 como

    -Firewall
        – Proxy caché (squid3)
        – Filtro de contenidos (squidGuard)
        – Antivirus para tráfico http (clamAV, incluido en paquete squid3)
        – Gestión de tráfico: histórico de consumo de ancho de banda por usuario (IP) (Sarg)
        – Balanceo de carga
        – Servidor DHCP con WDAP y servidor DNS para la red local

    En https://www.javcasta.com/procedimiento-pfsense-2-2-6-amd64-con-squid-en-entorno-multiwan/

    (Lo de Multiwan y balanceo de carga se configura al final)

    Salu2



  • Si entendí esta frase:

    "Tenemos dos interfaces WAN (DHCP connectado a router Fibra Optica dentro del rango 192.168.2.0/24) y la LAN (IP FIJA 192.168.1.101)"

    ¿Significa que consideras tu interfaz LAN como una de tus dos WAN?.

    De ser así sólo corrige la topología de tu red y el problema de velocidad se resolverá solo.

    En tu anfitrión deberás configurar dos interfaces físicas (WAN y WAN2) y una interfaz LAN puenteada a tus máquinas virtuales huéspedes.

    Saludos.



  • Hola.

    Sí, para 2 interfaces wan en el pfsense la topología:

    red local - siwtch A – interfaz lan pfsense -PFsense --- interfaz wan1 pfsense --cable directo- Gateway1
                                                                            |---- interfaz wan2 pfsense - cable directo-- Gateway2

    Para una sola interfaz wan en el pfsense la topología:

    red local - siwtch A -- interfaz lan pfsense -PFsense --- interfaz wan pfsense --siwtch B- Gateway1
                                                                                                                      --switch B-- Gateway2
    Y pondría direccionamiento estático en la wan de pfsense:

    wan ipv4: 192.168.4.2/23
    máscara 255.255.254.0

    ip red 192.168.4.0
    ip broadcast 192.168.5.255
    1º ip utilizable 192.168.4.1
    última ip utilizable 192.168.5.254

    definiria los 2 gateways en el pfSense

    ( GW1 con ip 192.168.4.1/24, GW2 con ip 192.168.5.1/24)

    gw1 192.168.4.1
    gw2 192.168.5.1

    Crearia un grupo de gateways en system > routing > groups, llamado balanceo1 (com mismo tier tier1 y disparador de evento perdidas de paquetes y alta latencia)

    (En System: Advanced: Miscellaneous > marcaria: Load Balancing Enable default gateway switching)

    Definiria como gateway balanceo1 en las reglas que lo precisen del firewall en lan

    Y en la LAN

    interfaz lan del pfsense : 192.168.1.101/24

    para clientes lan:

    ip (o por dhcp del pfsense o fijas en la red 192.168.1.0/24)
    gateway 192.168.1.101
    dns 192.168.1.101

    Salu2



  • @maaraujo:

    Si entendí esta frase:

    "Tenemos dos interfaces WAN (DHCP connectado a router Fibra Optica dentro del rango 192.168.2.0/24) y la LAN (IP FIJA 192.168.1.101)"

    ¿Significa que consideras tu interfaz LAN como una de tus dos WAN?.

    De ser así sólo corrige la topología de tu red y el problema de velocidad se resolverá solo.

    En tu anfitrión deberás configurar dos interfaces físicas (WAN y WAN2) y una interfaz LAN puenteada a tus máquinas virtuales huéspedes.

    Saludos.

    Culpa mia, está mal escrita esa frase y es cierto que condu8ce a error.

    La escribo de nuevo, pues creo que lo que estais diciendo no es lo que yo necesito, porque NO TENEMOS DOS WAN

    Frase escrita de nuevo:

    **"Tenemos dos interfaces .
    Una WAN configurada con DHCP connectado a router MIKROTIK (este se encarga de asignar una IP dentro del rango 192.168.2.0/24)
    y la otra a la que llamamos LAN configurada con IP FIJA 192.168.1.101)"

    Nuestro DC (192.168.1.210) es el que hace de DHCP server y asigna a todos los equipos del dominio el gateway 192.168.1.101 para que todos los equipos salgan a traves del PFSsense que está marcada la opcion de proxy transparente.

    Lo que le pedimos al PFSense es que actua de proxy cache, y filtro de contenidos.
    No queremos balanceo de carga, pues solo tenemos un router fibra optica (100Mb/10Mb)

    EL problema como explicaba antes es que si quito el GW de la interface LAN dep PFSense la velocidad disminuye a 30Mbs/10Mbs, mientras que si creo un GW nuevo en PFsense (192.168.1.1 IP del ROuter MIKROTIK) la velocidad se convierte en 100Mb/0Mbs …..es decir, bakamos a la velocidad real de nuestra fibra optica, pero perdemos la capacidad de subida, y en consecuencia dejan de funcionar sercivios como el envio de correos o la conexion Teamviewer de equipos externos.

    A ver si ahora me he explicado mejor !!

    P.D.:

    -192.168.1.1, 192.168.2.1 , 192.168.10.2 (Router MIKROTIK)
    -192.168.10.1 Router FIbra Optica
    -192.168.1.210 Windows 2008 Server DC
    -192.168.1.101 (LAN PFSense IP FIJA)
    -192.168.2.XX (WAN PFSense DHCP asignada por router MIKROTIK)

    Si me decis como habeis hecho ese diagrama lo hago para que podais seguir ayundadome, porque yo realmente voy totsalmente pez y me cuesta seguir algunas cosas que decis**



  • Para una sola interfaz wan en el pfsense la topología:

    red local - siwtch A – interfaz lan pfsense -PFsense --- interfaz wan pfsense --siwtch B- Gateway1
                                                                                                                      --switch B-- Gateway2
    Y pondría direccionamiento estático en la wan de pfsense:

    wan ipv4: 192.168.4.2/23
    máscara 255.255.254.0

    ip red 192.168.4.0
    ip broadcast 192.168.5.255
    1º ip utilizable 192.168.4.1
    última ip utilizable 192.168.5.254

    definiria los 2 gateways en el pfSense

    ( GW1 con ip 192.168.4.1/24, GW2 con ip 192.168.5.1/24)

    gw1 192.168.4.1
    gw2 192.168.5.1

    Crearia un grupo de gateways en system > routing > groups, llamado balanceo1 (com mismo tier tier1 y disparador de evento perdidas de paquetes y alta latencia)

    (En System: Advanced: Miscellaneous > marcaria: Load Balancing    Enable default gateway switching)

    Definiria como gateway balanceo1 en las reglas que lo precisen del firewall en lan

    Y en la LAN

    interfaz lan del pfsense : 192.168.1.101/24

    para clientes lan:

    ip (o por dhcp del pfsense o fijas en la red 192.168.1.0/24)
    gateway 192.168.1.101
    dns 192.168.1.101

    Hola

    Eso es lo que yo haria para una sola interfaz WAN en el pfSense y dos routers con salida a Inet.

    Fijate que hay 2 dominios de Broadcast (2 switches (capa 2), segmentados por un dispositivo de capa 3  el router/firewall pfSense)

    Intenta ubicar tus direccionamientos de red en ese esquema.

    Salu2



  • @javcasta:

    Para una sola interfaz wan en el pfsense la topología:

    red local - siwtch A – interfaz lan pfsense -PFsense --- interfaz wan pfsense --siwtch B- Gateway1
                                                                                                                      --switch B-- Gateway2
    Y pondría direccionamiento estático en la wan de pfsense:

    wan ipv4: 192.168.4.2/23
    máscara 255.255.254.0

    ip red 192.168.4.0
    ip broadcast 192.168.5.255
    1º ip utilizable 192.168.4.1
    última ip utilizable 192.168.5.254

    definiria los 2 gateways en el pfSense

    ( GW1 con ip 192.168.4.1/24, GW2 con ip 192.168.5.1/24)

    gw1 192.168.4.1
    gw2 192.168.5.1

    Crearia un grupo de gateways en system > routing > groups, llamado balanceo1 (com mismo tier tier1 y disparador de evento perdidas de paquetes y alta latencia)

    (En System: Advanced: Miscellaneous > marcaria: Load Balancing    Enable default gateway switching)

    Definiria como gateway balanceo1 en las reglas que lo precisen del firewall en lan

    Y en la LAN

    interfaz lan del pfsense : 192.168.1.101/24

    para clientes lan:

    ip (o por dhcp del pfsense o fijas en la red 192.168.1.0/24)
    gateway 192.168.1.101
    dns 192.168.1.101

    Hola

    Eso es lo que yo haria para una sola interfaz WAN en el pfSense y dos routers con salida a Inet.

    Fijate que hay 2 dominios de Broadcast (2 switches (capa 2), segmentados por un dispositivo de capa 3  el router/firewall pfSense)

    Intenta ubicar tus direccionamientos de red en ese esquema.

    Salu2

    Vale, creo que esto se parece mas a lo que yo tengo, aunque los rangos IP son diferentes y la WAN le asigna IP el router MIKROTIK (aunque siempre es la misma porque esta puesta como reservada)

    Lo que no entiendo lo de los routers y las GW.

    Sería mucho pedir que lo expliques paso a paso como si hablaras con un niño de 5 años ??….  :-[ :-[ :-[



  • Hola.

    Si tienes acceso a administrar tus routers, puedes ponerle el direccionamiento IP en sus interfaces lan que te convenga.

    Lo que te describo es una posible solución para un pfSense con uns sola interfaz wan y dos gateways de salida a Inet (multiwan).

    Al tener uns sola interfaz wan, su ip debe estar en una subred que incluya a las 2 IPs lan de los gateways (routers con salida a Inet)

    GW1 192.168.4.1/24
    pfsense: interfaz wan (192.168.4.2/23) –->  GW2 192.168.5.1/24

    Te recomiendo estos links:
    http://informaticacoslada.com/subnetting-subredes-mascaras-de-red/
    http://www.javcasta.com/blog/calculo-manual-de-subredes/

    Salu2



  • @javcasta:

    Hola.

    Si tienes acceso a administrar tus routers, puedes ponerle el direccionamiento IP en sus interfaces lan que te convenga.

    Lo que te describo es una posible solución para un pfSense con uns sola interfaz wan y dos gateways de salida a Inet (multiwan).

    Al tener uns sola interfaz wan, su ip debe estar en una subred que incluya a las 2 IPs lan de los gateways (routers con salida a Inet)

    GW1 192.168.4.1/24
    pfsense: interfaz wan (192.168.4.2/23) –->  GW2 192.168.5.1/24

    Te recomiendo estos links:
    http://informaticacoslada.com/subnetting-subredes-mascaras-de-red/
    http://www.javcasta.com/blog/calculo-manual-de-subredes/

    Salu2

    Creo que no me he explicado bien (otra vez…...)

    Routers que den acceso a Internet solo hay uno, el de Fibra Optica que es el 192.168.10.1

    El otro, el MIKROTIK, tiene varias IP's (desconozco porque lo hicieron así), creo que era para separar el trafico del dominio del externo.....pero ese no es que que de ningun acceso a Internet

    He hecho un esquema esquema de mi red, a ver si podeis echarme una mano, porque hasta ahora intento seguirte pero no lo consigo (no cabe duda de que es mi culpa, no es que tu te expliques mal, ni nada de eso)



  • Hola.

    jeje, no hay nada como un mapa para no perderse. :)

    Ya lo miro y te digo más adelante (ahora estoy liado)

    Salu2



  • Hola.

    Confirmame si he entendido bien tu topología (ver img):

    Y repasa en el menú: Interfaces: LAN y WAN, si está desmarcado:  Block private networks y Block bogon networks (si estan marcadas, desmarcalas y salva, tanto en la lan como en la wan). Ya que estás trabajando con IPs privadas, tanto en el interfaz WAN como en LAN del pfSense.

    Salu2



  • @javcasta:

    Hola.

    Confirmame si he entendido bien tu topología (ver img):

    Y repasa en el menú: Interfaces: LAN y WAN, si está desmarcado:  Block private networks y Block bogon networks (si estan marcadas, desmarcalas y salva, tanto en la lan como en la wan). Ya que estás trabajando con IPs privadas, tanto en el interfaz WAN como en LAN del pfSense.

    Salu2

    Es casi correcto, salvo que , en tu dibujo , la 192.168.2.93 (IP WAN del PFSense) en lugar de al switch, entiendo que deberia ir directa al mikrotik (Es Este quien le asigna la IP )
    El switch de 24puertos es el que interconecta el ESXi con los equipos, pero no hace nada mas (como si fuera un ladron de corriente)

    otro error que veo es la IP que le has puesto al PFSense, que es 192.168.1.101 en lugar de 192.168.1.10.

    Por lo demas juraria que todo es correcto.

    En cuanto a las opciones que dices (Block private networks y Block bogon networks)  te comento que ya estan desmarcadas en ambas , y siguen así



  • Hola

    Efectivamente, un switch es eso, solo un conmutador (capa 2), he seguido tu esquema, y no veo la interfaz directa desde el mkrotick al pfSense, pero no nos afecta esto.

    Lo que no entiendo es si tienes desmarcadas block private networks, etc y tienes una regla permisiva en la LAN de pasar todo IPv4 desde la lan a la wan, ¿qué es lo que te bloquea?¿Estan asignadas correctamente las interfaces? (a veces pasa que ponemos la lan como wan y viceversa)

    Desde menú Diagnostics: Traceroute: haz un Traceroute a 192.168.10.1, con
    Source Address: WAN

    Y mira si da el salto (pasa por) en 192.168.2.1

    Haz otro traceroute a 192.168.10.1, con
    Source Addres: LAN

    Y mira si da el salto en 192.168.1.1

    Salu2



  • @javcasta:

    Hola

    Efectivamente, un switch es eso, solo un conmutador (capa 2), he seguido tu esquema, y no veo la interfaz directa desde el mkrotick al pfSense, pero no nos afecta esto.

    Lo que no entiendo es si tienes desmarcadas block private networks, etc y tienes una regla permisiva en la LAN de pasar todo IPv4 desde la lan a la wan, ¿qué es lo que te bloquea?¿Estan asignadas correctamente las interfaces? (a veces pasa que ponemos la lan como wan y viceversa)

    Desde menú Diagnostics: Traceroute: haz un Traceroute a 192.168.10.1, con
    Source Address: WAN

    Y mira si da el salto (pasa por) en 192.168.2.1

    Haz otro traceroute a 192.168.10.1, con
    Source Addres: LAN

    Y mira si da el salto en 192.168.1.1

    Salu2

    Si marco la opcion de usar ICMP :

    Quieres conectarte por Teamviewer y lo ves mejor ??



  • Hola.

    Vamos a probar una última cosa.

    Como veo que tienes virtualizado pfSense, puede que un mismo interfaz físico sean 2 virtuales …

    Por lo que en el Menú System: Advanced: Firewall and NAT> Static route filtering

    (Marcar) Bypass firewall rules for traffic on the same interface, y salvar.

    This may be desirable in some situations where multiple subnets are connected to the same interface.

    Y reinicia pfSense.

    Salu2

    (ahora no podria conectarme, en breve tengo que cocinar ;)
    Pero si persiste el problema, esta tarde, a las 18:30 canarias - 17:30 peninsula, podria
    )



  • @javcasta:

    Hola.

    Vamos a probar una última cosa.

    Como veo que tienes virtualizado pfSense, puede que un mismo interfaz físico sean 2 virtuales …

    Por lo que en el Menú System: Advanced: Firewall and NAT> Static route filtering

    (Marcar) Bypass firewall rules for traffic on the same interface, y salvar.

    This may be desirable in some situations where multiple subnets are connected to the same interface.

    Y reinicia pfSense.

    Salu2

    (ahora no podria conectarme, en breve tengo que cocinar ;)
    Pero si persiste el problema, esta tarde, a las 18:30 canarias - 17:30 peninsula, podria
    )

    He hecho ese cambio , y el problema persiste:

    Respecto a las interfacxes, si bien es cierto que PFSense esta virtualizado, el ESXI donde esta alojado tiene dos NIC's fisicas, y le pasa las dos NIC's al PFsense, tal y como puedes ver aquí :



  • Hola.

    ¿El problema no era que te bloqueaba el tráfico de la red local (192.168.1.0/24) a Internet?
    Si ya no te bloquea, perfecto.

    Otra cosa es que no te está pillando el ancho de banda esperado.

    Veo que tus interfaces estan a 1000 y full, perfecto también. (aunque deberias asegurarte en el anfitrión que fisicamente se correspondan a full-duplex 1000)

    ¿Pero y el resto de la cadena?:
    ¿El Switch es gigabitethernet?
    ¿las interfaces de el router mikrotik están configuradas a 1000 full-duplex?
    ¿Has probado con un portatil a conectarte directamente al router de fibra y hacer un test de ancho de banda y te mejora?

    Salu2



  • @javcasta:

    Hola.

    ¿El problema no era que te bloqueaba el tráfico de la red local (192.168.1.0/24) a Internet?
    Si ya no te bloquea, perfecto.
    Otra cosa es que no te está pillando el ancho de banda esperado.

    Si, el problema es que cuando tengo puesta una GW en la interface LAN (ahora solo esta puesta en la WAN) , mejoramos la velocidad de bajada de nuestra fibra y consigue llegar a 100Mb, pero parece que bloquea prácticamente el 99% de nuestra salida.
    Es decir, podemos enviar mails si son dos frases, pero si el mail es por ejemplo de 50Kb , o lleva algun adjunto , aunque sea muy pequeño, el mail ya no sale, dando errores.
    Así como los tests de velocidad, que la bajada es perfecta, pero la subida no puede ni tan siquiera mkedirla, y lanza un error de timeout en la prueba.
    Lo mismo Teamviewer, que pueden conectarse con nosotros, pero las conexiones se cortan.

    Si le quito esa GW a la interface LAN, todo funciona normalmente , nuestro trafico de salida es correcto, pero la velocidad de download no pasa de 30Mbs

    Veo que tus interfaces estan a 1000 y full, perfecto también. (aunque deberias asegurarte en el anfitrión que fisicamente se correspondan a full-duplex 1000)

    ¿Pero y el resto de la cadena?:
    ¿El Switch es gigabitethernet?
    ¿las interfaces de el router mikrotik están configuradas a 1000 full-duplex?
    ¿Has probado con un portatil a conectarte directamente al router de fibra y hacer un test de ancho de banda y te mejora?

    Salu2

    Si a todo.

    El resumen es :

    En PFSense, interface LAN con GW:

    • bajada perfecta de 100Mbs
    • subida hacia internet practicamente nulo, con imposibilidad ni tan siquiera de enviar mail
    • conexiones entrantes de teamviewer se cortan (Establecen conexion, pero no ven nuestros monitores y acaban por cortarse )
    • todo el trafico de subida (de nosotros hacia el extewrior) queda practicamente inutilizado

    En PFSense, interface LAN sin GW:

    Todo funciona correctamente, excepto la velocidad de bajada de fibra optica, que en lugar de 100Mbs entrega solamente 30Mbs



  • Hola.

    En esto estamos ya de acuerdo: se habló que NUNCA se pone Gateway en una interfaz LAN del pfSense …

    Por lo que debes detectar donde está el cuello de botella del ancho de banda.

    Lo que yo haria:

    Con un portatil (o pc) con ip 192.168.2.x/24 y gw 192.168.2.1 (dns al gusto), conectarme al interfaz del microtik con ip 192.168.2.1 y hacer test BW

    Con un portatil (o pc) con ip 192.168.1.x/24 y gw 192.168.1.1 (dns al gusto), conectarme al interfaz lan del microtik (192.168.1.1) y hacer test BW

    Me huelo que el problema puede estar en el mikrotik, más especificamente en su interfaz con ip 192.168.2.1

    Otra cosa, es que configures los interfaces en el pfSense y en mikrotik, sin negociación (forzar el 1000 full duplex) , es decir:

    en el pfsense: Menú interfaz WAN > speed and duplex > advanced > 1000 base T full dupplex, salvar y probar BW

    en el mikrotik, interfaz con ip 192.168.2.1, ni idea como se haria ... pero si no sabeis,enteraros como, y hacerlo, que me huele que es el cuello de botella (comprobad que el cable de red que llega a ese interfaz y al del pfSense es cat6 (mínimo cat 5 pero se recomienda 6)

    Salu2

    (poco a poco, no te agobies, si ya permite el pfSense el tráfico, lo que te queda es un mal menor y con paciencia y pruebas ensayo error localizarás la falla).



  • he probado y en todas las pruebas tengo 100Mbs de bajada y 10Mb de subida, tan solo cuando interviene el PFSense la cosa cambia, y pasamos a 30Mbs de bajada y 9Mbs de subdia.

    Pongo captura del menu interfaces de Mikrotik.

    Las dos primeras son tarjetas de red fisicas del ESXi (las que te he mostrado antes), y va conectadas directamente al Mikrotik.
    La tercera (Wlan) es el propio Mikrotic haciendo de punto de acceso
    Y la ultima es un cable diurecto del mikrotik al router fibra optica

    Todos y cada uno de ellos esta configurado a 1gbs



  • Hola.

    Podrias probar a "tocar" opciones del HW en System: Advanced: Networking > Network Interfaces
    -Disable hardware checksum offload
    -Disable hardware TCP segmentation offload
    -Disable hardware large receive offload

    Pero debes reiniciar pfSense cada vez que cambien (marques o desmarques una de esas opciones).

    También existe la opción Insert a stronger id into IP header of packets passing through the filter. (como medida extra de protección, tb afecta algo a la velocidad, creo)

    Y en System: Advanced: System Tunables hay muchos parámetros que podrian afinar lo del ancho de banda (hay corta fuegos como ipfw que introducen perdida aleatoria de paquetes intencionados para evitar ciertas técnicas de hacking (en detrimento de la velocidad): ipfw -q add prob 0.05 drop ip from any to any in, p.e descarta un 5% de paquetes, lo que no sé si pfSense por defecto activa esto)

    Y como no se me ocurre nada más, te remito a la fuente:

    pfSense dispone de una virtual appliance CERTIFICADA POR VmWare para ESXi, VMware Ready Appliance, está disponible para los suscriptores "gold" (y seguramente comprandola) https://blog.pfsense.org/?p=1716

    Imagino que está optimizada para entornos virtuales y que irá "fina" …

    La doc sobre pfSense en ESXi 5: https://doc.pfsense.org/index.php/PfSense_2_on_VMware_ESXi_5

    Siento no serte de más utilidad (para tu caso, no creo que conectandome en remoto resolviera nada)

    Salu2



  • @javcasta:

    Hola.

    Podrias probar a "tocar" opciones del HW en System: Advanced: Networking > Network Interfaces
    -Disable hardware checksum offload
    -Disable hardware TCP segmentation offload
    -Disable hardware large receive offload

    Pero debes reiniciar pfSense cada vez que cambien (marques o desmarques una de esas opciones).

    También existe la opción Insert a stronger id into IP header of packets passing through the filter. (como medida extra de protección, tb afecta algo a la velocidad, creo)

    Y en System: Advanced: System Tunables hay muchos parámetros que podrian afinar lo del ancho de banda (hay corta fuegos como ipfw que introducen perdida aleatoria de paquetes intencionados para evitar ciertas técnicas de hacking (en detrimento de la velocidad): ipfw -q add prob 0.05 drop ip from any to any in, p.e descarta un 5% de paquetes, lo que no sé si pfSense por defecto activa esto)

    Y como no se me ocurre nada más, te remito a la fuente:

    pfSense dispone de una virtual appliance CERTIFICADA POR VmWare para ESXi, VMware Ready Appliance, está disponible para los suscriptores "gold" (y seguramente comprandola) https://blog.pfsense.org/?p=1716

    Imagino que está optimizada para entornos virtuales y que irá "fina" …

    La doc sobre pfSense en ESXi 5: https://doc.pfsense.org/index.php/PfSense_2_on_VMware_ESXi_5

    Siento no serte de más utilidad (para tu caso, no creo que conectandome en remoto resolviera nada)

    Salu2

    Ya estoy de vuelta …..

    Lo que no entiendo es porque si pongo una GW a la interface LANJ recupero el ancho de banda de bajada, pero a cambio pierdo el Upload



  • Hola

    Cuando usas el GW de la interfaz 192.168.1.1 del mickrotik es cuando va bien
    Cuando usas el GW de la interfaz 192.168.2.1 del mickrotik es cuando va mal …

    (Y recuerda: NUNCA PONER UN GW para la Interfaz lan del pfSense)

    Hipótesis: puede que el meollo esté en el mikrotik. (ACLS? conf?)

    Haz una prueba con tu pfSense virtualizado para que su GW en la wan sea 192.168.1.1 (tienes que poner otro direccionamiento de red en la lan del pfsense temporalmente, p.e 192.168.77.0/24, y configurar un pc o portatil con ip en esa red para hacer la prueba)

    Salu2



  • @javcasta:

    Hola

    Cuando usas el GW de la interfaz 192.168.1.1 del mickrotik = Download Speed 100Mbs pero con problemas en envio de mails, conexiones Teamviewer y los test de velocidad tipicos no pueden probar la velocidad de subida

    Cuando usas el GW de la interfaz 192.168.2.1 del mickrotik = Download Speed 30Mbs y todo parece funcionar bien, tanto los mails, como conexiones de Teamviwer, y los tests de velocidad de ADSL funcionan, dando 30Mbs/10Mbs

    (Y recuerda: NUNCA PONER UN GW para la Interfaz lan del pfSense)

    Hipótesis: puede que el meollo esté en el mikrotik. (ACLS? conf?)

    Haz una prueba con tu pfSense virtualizado para que su GW en la wan sea 1292.168.1.1 (tienes que poner otro direccionamiento de red en la lan del pfsense temporalmente, p.e 102.168.77.0/24, y configurar un pc o portatil con ip en esa red para hacer la prueba)

    Salu2

    Te he corregido tus "apreciaciones" sobre el problema.
    Ahora voy a probar eso que dices a ver



  • Cuando usas el GW de la interfaz 192.168.1.1 del mickrotik es cuando va bien

    la velocidad de bajada, (lo demás ya sabemos que no va con un gw en interfaz lan del pfsense ) queria decir :)

    salu2



  • Hola.

    He instalado pfSense 2.2.6 amd64 en VMware WorkStation 12 player (ver. no comercial). Con las VMware Guest instaladas.

    Efectivamente, con fibra de 100Mbps de bajada, consigo como mucho un tercio de esa velocidad (33Mbps) (la subida es de 10Mbps la consigue al 100%)

    Con VirtualBox, el rendimiento es aún peor (bajadas entre 5Mbps y 15Mbps y subida entre el 50% y el 100%). Por lo que , a pesar del handicap del ancho de banda virtualiznando, migro a VMware.

    Con Cables Cat5 y 6 y NICs del anfitrión y switch: GigabitEthernet, pero …

    Imagino que la appliance CERTIFICADA VMware Ready Appliance de pfSense instaladola sobre ESXI, será otro cantar.

    Habrá que conseguirla :)

    Salu2