2.3 is RC


  • Netgate

    that is all.


  • Moderator

    Upgrade to RC successful here…



  • Smooth upgrade here on SG-2440.



  • Heyo! Nice job all!



  • Woohoo!

    Now to install onto my grouchy router with the >64GB HDD issue, unless I can figure out how to put /boot in the main partition and root in another.

    Is there a way too manually install it via command line and custom partitions?



  • and the latest build also says FreeBSD 10.3-RELEASE even before the FreeBSD.org site has made a release announcement - very pro-active!



  • Error: Error trying to get packages list. Aborting…
    pkg: Repository pfSense-core cannot be opened. 'pkg update' required
    pkg: Repository pfSense cannot be opened. 'pkg update' required

    Never seen this with any of the previous update snapshots.

    This was going from 3/30 beta snapshot to 3/31 RC snapshot using console options 13.
    Restored the VM snaphot and it's repeatable.

    ![pfSense 2.3-RC.png](/public/imported_attachments/1/pfSense 2.3-RC.png)
    ![pfSense 2.3-RC.png_thumb](/public/imported_attachments/1/pfSense 2.3-RC.png_thumb)



  • No issues here on a small form factor PC

    Intel(R) Atom(TM) CPU D2550 @ 1.86GHz
    4 CPUs: 1 package(s) x 2 core(s) x 2 HTT threads

    Carlos



  • Just upgraded.  Ran into issues with IPSEC.  Appears for whatever reason the IPSEC daemons were started twice and so it took me a few reboots to figure this out and kill them off and start up one copy cleanly to restore my IPSEC tunnels.


  • Netgate

    @NOYB:

    Error: Error trying to get packages list. Aborting…
    pkg: Repository pfSense-core cannot be opened. 'pkg update' required
    pkg: Repository pfSense cannot be opened. 'pkg update' required

    Never seen this with any of the previous update snapshots.

    This was going from 3/30 beta snapshot to 3/31 RC snapshot using console options 13.
    Restored the VM snaphot and it's repeatable.

    Please file a bug on redmine.pfsense.org.


  • Netgate

    @phil.davis:

    and the latest build also says FreeBSD 10.3-RELEASE even before the FreeBSD.org site has made a release announcement - very pro-active!

    The changes in the toolchain and the move to pkg(ng) mean that we can generate updates very quickly, and closely follow FreeBSD for both src and ports.

    This is essentially the first time pfSense has released on top of a just-released FreeBSD.

    It will not be the last.



  • @NOYB:

    Error: Error trying to get packages list. Aborting…
    pkg: Repository pfSense-core cannot be opened. 'pkg update' required
    pkg: Repository pfSense cannot be opened. 'pkg update' required

    Same errors observed when I upgraded from 28 March beta to 31 March RC on an amd64 VM.  Everything seems to work OK so not sure how serious it is.



  • @gsiemon:

    Same errors observed when I upgraded from 28 March beta to 31 March RC on an amd64 VM.  Everything seems to work OK so not sure how serious it is.

    Appears to just be cosmetic, but yeah we'll get it fixed.



  • Clean install x64. Nothing is configured yet.

    rc.bootup spams on boot:

    rc.bootup: The command '/usr/bin/nice -n20 /usr/local/bin/rrdtool update /var/db/rrd/lan-traffic.rrd N:U:U:U:U:U:U:U:U' returned exit code '1', the output was 'ERROR: /var/db/rrd/lan-traffic.rrd: illegal attempt to update using time 1459499576 when last update time is 1459509340 (minimum one second step)'

    A block of 10 consecutive msgs. This block sometimes repeats again.

    DNS resolver logs:

    Apr 1 08:32:51 unbound 42511:0 error: Error for server-cert-file: /var/unbound/unbound_server.pem
    Apr 1 08:32:51 unbound 42511:0 error: Error in SSL_CTX use_certificate_chain_file crypto error:02001002:system library:fopen:No such file or directory
    Apr 1 08:32:51 unbound 42511:0 error: and additionally crypto error:20074002:BIO routines:FILE_CTRL:system lib
    Apr 1 08:32:51 unbound 42511:0 error: and additionally crypto error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib
    Apr 1 08:32:51 unbound 42511:0 fatal error: could not set up remote-control


  • Netgate

    @Dmitriy:

    Clean install x64. Nothing is configured yet.

    rc.bootup spams on boot:

    rc.bootup: The command '/usr/bin/nice -n20 /usr/local/bin/rrdtool update /var/db/rrd/lan-traffic.rrd N:U:U:U:U:U:U:U:U' returned exit code '1', the output was 'ERROR: /var/db/rrd/lan-traffic.rrd: illegal attempt to update using time 1459499576 when last update time is 1459509340 (minimum one second step)'

    A block of 10 consecutive msgs. This block sometimes repeats again.

    DNS resolver logs:

    Apr 1 08:32:51 unbound 42511:0 error: Error for server-cert-file: /var/unbound/unbound_server.pem
    Apr 1 08:32:51 unbound 42511:0 error: Error in SSL_CTX use_certificate_chain_file crypto error:02001002:system library:fopen:No such file or directory
    Apr 1 08:32:51 unbound 42511:0 error: and additionally crypto error:20074002:BIO routines:FILE_CTRL:system lib
    Apr 1 08:32:51 unbound 42511:0 error: and additionally crypto error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib
    Apr 1 08:32:51 unbound 42511:0 fatal error: could not set up remote-control

    please file a bug



  • the small bugs you may encounter are due to the date the devs decided to publish this ;)



  • Great !

    What is the Base URL to put in the updater settings for a X64 version ?

    Thank you,
    Gaëtan



  • @jimp:

    The RC images are being tested internally before we publish them, they'll be up before too long.

    There isn't an active "auto-update" URL that 2.2.x or earlier can read from currently, but you can feed a full URL to an update file to a console or ssh session using option 13, then option 1, from a 2.2.x or earlier install.



  • Smooth upgrade on an SG-4860. Only DNSBL did not start automatically. But after manually starting it, it started perfectly. Well done guys!



  • Just upgraded my Nokia IP390 running pfSense. No issues so far.



  • excuse this poor ignorant… but from a stable 2.2.6 how do I do to upgrade to 2.3 RC? And when 2.3 goes stable, it will update automatically to that branch or...?



  • -goto http://snapshots.pfsense.org/
    -pick correct architecture & choose "Update Files (For full installs AND for NanoBSD images) to update from 2.2.x and before to 2.3'
    -download the file if you want to upgrade by GUI / copy link location if you want to upload by console

    console-update
    @jimp:

    The RC images are being tested internally before we publish them, they'll be up before too long.

    There isn't an active "auto-update" URL that 2.2.x or earlier can read from currently, but you can feed a full URL to an update file to a console or ssh session using option 13, then option 1, from a 2.2.x or earlier install.



  • Currently using 2.2.6 production environment on Dual core cpu ,2 x NIC  ,  Snort , Pfblocker NG , bandwidthd , unbound resolver, squid proxy non transparent(Wpad hosted on diff server) , DHCP , and
    SquidGuard . Is it safe to update to RC or should i wait for stable Release

    if upgrading what is the best way ?


Log in to reply