ICAP protocol error



  • I've done a fresh install using 2.3-RELEASE (amd64)
    I'm getting from time to time the "ICAP protocol error"
    I found this page http://squidclamav.darold.net/tuning.html that supposes to have the solution. I just don't know where and what parameters I should use.
    Help? :-[



  • I tried squid + the antivirus that is part of the squid install and got the same error.  The problem for me was actually that the antivirus database was not updated.  It is not updated when you first install the package.  Because of this clamd does not start.  Once I went to the antivirus tab on squid and manually went through the antivirus database update I was able to start clamd and then squid worked for me.  Keep in mind that the antivirus database update took a long time for me.  It was not finished when the GUI returned control back to me.  I also had to start it twice I think.  Once the database does get updated I was set.



  • I decided to force update using the command prompt and got this

    ClamAV update process started at Tue May 24 12:27:06 2016
    WARNING: Your ClamAV installation is OUTDATED!
    WARNING: Local version: 0.99 Recommended version: 0.99.2
    DON'T PANIC! Read http://www.clamav.net/support/faq
    main.cvd is up to date (version: 57, sigs: 4218790, f-level: 60, builder: amishhammer)
    daily.cld is up to date (version: 21602, sigs: 175660, f-level: 63, builder: neo)
    bytecode.cvd is up to date (version: 277, sigs: 47, f-level: 63, builder: neo)

    And the Dashboard shows this
    I suppose the problem must be solved

    Antivirus Scanner   ClamAV: N/A    C-ICAP 0.3.5 +  SquidClamav 6.10
    Antivirus Bases
    Database Date Version Builder
    daily.cld 2016.05.24 21602 neo
    bytecode.cvd 2016.04.15 277 neo
    main.cvd 2016.03.16 57 amishhammer
    Last Update N/A
    Statistics Unknown (no log exists)



  • Even after the latest updates, I got the error again.. Help?



  • Sorry can't any one help? I get at least 3 times a day this error



  • I've disabled the antivirus and have no errors for the last 24 hours. I would like to have another solution, any ideas?



  • Same traffic.

    Fresh squid install, pf 2.3.2, squid 0.4.23_1

    Antivirus breaks the internet with the aforementioned error message on numerous sites (most, actually)

    Tried to run the a/v update, get this in the realtime tab:

    WARNING: Clamd was NOT notified: Can't connect to clamd through /var/run/clamav/clamd.sock: No such file or directory

    a/v disabled for now, which is really too bad…...