Unable to move firewall rules in 2.3.x



  • Hi,

    I run two pfSense 2.3 boxes (installed with 2.3.0 then updated to 2.3.1).

    I have tried to change the order of the firewall rules on the both boxes, without success. I think this is related to the GUI changes which took place in the new version. The drag and drop feature works fine, except my changes are never saved: when I'm done and try to go another page, my browser tells asks me to confirm that my changes will be lost, etc. The same bug also prevents rule separators to be saved: I can create them, name them, move them, but they're gone as soon as I browse to another page.

    This problem appeated in 2.3.0 and is still present in 2.3.1. I'm using Firefox 46.0. Do other people experience the same issues ?

    Thanks,

    Marin.



  • I don't have that problem in my installation of neither 2.30 or the updated 2.3.1 (with FF 46.0.1). You remember to both push "Save" and click "Apply changes" afterwards?

    The only situation I get the same result (the warning message from the browser) is when I forget to push Save and try to browse away from the page after the change.

    If you have remembered to push Save after the rule-move, I would suggest to try to clear browser cache.


  • LAYER 8 Global Moderator

    I did not see this issue in 2.3, nor in 2.3.1

    I am able to move rules just fine, and no issues with separators..  Are you on 46.0 or current 46.0.1, I would look to your browser as source of these sorts of problems.



  • Hi,

    Sorry for the late answer.
    I was on FF 46.0. I just updated to 46.0.1. Still no change.

    What happens is that pfSense fails to detect changes made by drag-and-drop. I suppose that the "apply changes" banner should appear as soon as I move a rule, yet it does not.

    I'm using the Fedora 23 MATE spin-off, which is known to be prone to odd issues as it ships with some pretty old versions of libraries. I'll try with another distro soon.

    Thanks,

    Marin.



  • Is there a save button at the bottom of the page?  If so, after making changes, click it.



  • i have the same problem, except i am unable to edit any aspect of any firewall rule (or any aliases, so far anything under Firewall i cannot edit).

    however this only happens when i log in with an AD login.  if i log in as admin, i can edit as normal.



  • @NOYB:

    Is there a save button at the bottom of the page?  If so, after making changes, click it.

    Thanks NOYB.  Just upgraded all my 2.2 boxes and still not familiar with the 2.3.x interface.  I was having the same issue and missed the 'Save' button lighting up.


Log in to reply