PfSense och Telia ipTV, problem



  • Behöver lite råd i rätt riktning.

    Jag har läst lite olika forums och även peaksie's tråd här. Dock har jag inte blivit mycket klokare av det. Så här det det ut.

    Hårdvara:
    pfSense dator med 4 Ethernet portar, IBG0, IBG1, IBG2, IBG3
    IBG0 = WAN. Tilldelat dhcp ip, dns
    IBG1 0 Sitter kopplad till en L2 switch 2 våningar upp
    IBG3 = Servers
    IBG4 = Cisco labbmiljö

    IBG0, wan har 2 taggade vlan, WAN_Telia_ipTV och WAN_Telia_voip. Dessa har VID 243, 237, har använt 845, 855. Båda är satta att hämta ip, dns via dhpc.
    IBG1, LAN kör otaggade vlan för ipTV och voip, har vlan tagg för Guest nätet, både Ethernet och WiFi samt vlan tagg för Cisco utrustningen. Management nätet är också taggat.
    DHCP poolen satt till 192.168.1.10 - 139. Resten används till drift nätet, där WiFi, server och labbet sitter på. IP nummer .2 - .9 används av switcharna, servers, esxi samt access punkterna (mamagement)

    Har en IGMP proxy Upstream 224.0.0.0/4. Downstream 192.168.1.0/24
    WAN firewall rule UDP allowed, IP options enabled, source 224.0.0./4
    LAN firewall rule IGMP allowed, IP option enabled, source 192.168.1.0/24

    Vlanen har ingen kontakt med Telia noden, dom får inga ip nummer tilldelade, WAN får och fungerar som tänkt. Ingen av boxarna blir tilldelade något ip av LAN DHCP'n.

    Om jag har förstått rätt så när man startar en TV box så skall den svara på IGMP som i sin tur svarar och då aktiveras boxen och skickar en DHCP förfrågan till servern. När detta är klart så skall då UDP strömmen skickas in till boxen.

    Har jag missat något, vad har jag gjort för fel… hjälp  :-[