PfBlockerNG Changing Floating Rule Order



  • Greetings,

    I'm using pfSense 2.3.1 + pfBlockerNG and am running into a weird issue with floating rule ordering. I've enabled some of the ipv4 country blocks (in both directions) and have enabled as floating rules. The floating rules were created no problem and pfBlockerNG is working quite well. Then I realized that TeamViewer seems to want to connect to Germany (DE) which is in the top 20 spammer country list. I decided to just create a floating rule to unblock anything with a destination of TCP/UDP port 5938. I set it as a "quick" rule and put it at the top of the floating rules. It worked as expected - Teamviewer is no longer being blocked. Later that day, I was told by one of my technicians that Teamviewer wasn't connecting again. When I checked my floating rules, the rule I had created was on the bottom of the list. I put it back at the top, saved & applied and it worked for another 10-15 minutes until the same thing happened. The only other floating rules I have are from pfBlockerNG, so is it safe to assume that perhaps when pfBlockerNG periodically updates that it is also somehow changing the order of the floating rules?

    Any assistance or pointers would be much appreciated.

    Regards,

    Nate D.


  • Moderator

    Check the "Rule Order" option in the General tab… You can also create that Permit rule for TeamViewer, in a new pfBlockerNG Alias instead.



  • Thanks BBcan177.. That was it. I changed it to:

    |pfSense Pass/Match | pfB_Pass/Match | pfB_Block/Reject|

    And it works fine now. I'll look at creating aliases within pfB for my overrides.

    Thanks again for your help and for your work on this package!

    Regards,

    Nate D.