Re: SquidGuard and sgerror.php (SOLVED)



  • Hi to all,
    i have SQUID3+SquidGuard on pfsense 2.3.1_1 and all working exept the sgerror.php, because pfsense redirect all :80 url on https, so the sgerror.php is not reacheble.

    Someone have a solution to use internal sgerror.php, but I don't want to switch the webconfigurator on http.

    Sorry for my bad english ;)
    thanks in advance



  • I can not find any solution to view the sgerror page.

    I've the webconfigurator on HTTPS.
    Another lighttpd for the wpad on HTTP ( but don't work with php )
    Someone can point me to adjust this configuration of lighttpd so I can copy the sgerror.php in /usr/local/www/wpad and work with port 80.

    #
    # lighttpd configuration file
    #
    # configured for WPAD/PAC serving
    #
    
    ## set static document-root
    server.document-root        = "/usr/local/www/wpad/"
    
    ## where to send error-messages to
    server.errorlog =       "/var/log/lighty-proxy-wpad.log"
    
    # mimetype mapping
    mimetype.assign             = (
            ".dat"          =>      "application/x-ns-proxy-autoconfig",
            ".da"           =>      "application/x-ns-proxy-autoconfig",
            ".pac"          =>      "application/x-ns-proxy-autoconfig"
     )
    
    ## bind to proxy address and port
    server.bind  = "10.170.60.40"
    server.port  = 80
    
    ## unqiue pid to other lightppd instance
    server.pid-file            = "/var/run/lighty-proxy-wpad.pid"
    


  • I've solved the problem :
    1. enter this configuration on lighty-proxy-wpad.conf

    
    #
    # lighttpd configuration file
    #
    # configured for WPAD/PAC serving
    #
    
    ## set static document-root
    server.document-root        = "/usr/local/www/wpad/"
    server.modules                  = ( "mod_access", "mod_fastcgi", "mod_cgi" )
    
    ## where to send error-messages to
    server.errorlog =       "/var/log/lighty-proxy-wpad.log"
    
    # mimetype mapping
    mimetype.assign             = (
            ".dat"          =>      "application/x-ns-proxy-autoconfig",
            ".da"           =>      "application/x-ns-proxy-autoconfig",
            ".pac"          =>      "application/x-ns-proxy-autoconfig"
     )
    
    ## bind to proxy address and port
    server.bind  = "10.170.60.40"
    server.port  = 80
    
    fastcgi.server                  = ( ".php" => ( "localhost" => ( "socket" => "/var/run/php-fpm.socket", "broken-scriptfilename" => "enable" ) ) )
    cgi.assign                      = ( ".cgi" => "" )
    
    ## unqiue pid to other lightppd instance
    server.pid-file            = "/var/run/lighty-proxy-wpad.pid"
    

    and copy the /usr/local/www/sgerror.php in /usr/local/www/wpad/

    Now all working.  ;)