Openvpn setup on PIA vpn service please help



  • First I want to say I am a retired tech who worked his whole life in computers so I know a little. I have a older alix2d13 board for my project. I initially installed last version 2.3 of pfsense. No problem getting basic router working but have never been able to get it to work with pia vpn service. I have spent 2 days reading several guides with no success. Most of them refer to older versions of pfsense so I installed version 2.1.1 and followed once again the guide. When I got to the final step where it says go to status/openvpn everything looked fine. It showed it as up but I couldn't still get to any website. If I go to the main page in the interface section the pia interface has a down arrow. :(  If I go back and check status again it show up but still can't get to any website. Any suggestions. This old man about ready to give up.


  • Rebel Alliance Global Moderator

    A blind retired tech… JFC that is some HUGE text ;) hehehehe

    Did you read over the HUGE PIA thread?
    https://forum.pfsense.org/index.php?topic=76015.0

    I don't use PIA, but I use my own vps as vpn client that I route traffic through.. If you go to current 2.3.1 and can still not getting it working after working through that tutorial and 19 some pages of discussion.  I will be more than happy to walk you through how to route traffic through vpn service.

    What I can say about guides on other sites on the net is most of them are crap, written by people that don't actually even understand what they are talking about and post up some bits and pieces they got form other places to try and draw traffic to their site ;)

    If you can get your connection up this is big piece of the puzzle.  Your going to want to create an interface, and do not grab routes from from the vpn, and you will need to do an outbound nat to your vpn interface.



  • Yes I read through that a followed it step by step at least 10 times. I guess I will just go back to my Asus rt-a68u. I hate to be defeated but I give up. :(


  • Rebel Alliance Global Moderator

    Dude.. Why don't you post what you did, and what is happening.. Do you get a connection?  Did you create the outbound nat.. Post up what your doing and what is not working and we can fix it for you..  Its really click click..

    My guess is your problem is trying to follow the guide, vs reading the guide understand what they are doing and why and then apply that to your setup.. Trying to click along copy paste what other have done more than likely doesn't match up with your setup.

    So your saying you went over the PIA official support for pfsense guide and not working?
    https://www.privateinternetaccess.com/pages/client-support/pfsense

    What is not working??



  • Ok. I just re-installed 2.3.1 again. As always install goes fine. I followed your procedure you noted step by step. When finished my computer shows being connected to the internet but I can't get anywhere. I have attached 2 screen shots. the one show connected and the other doesn't. I guess I don't know enough to ask anything else at the moment. I have gone through the procedure several times always with the same results. I used both pia's instructions and also the one mentioned in this thread.

    ![PFSENSE 1.jpg](/public/imported_attachments/1/PFSENSE 1.jpg)
    ![PFSENSE 1.jpg_thumb](/public/imported_attachments/1/PFSENSE 1.jpg_thumb)
    ![PFSENSE 2.jpg](/public/imported_attachments/1/PFSENSE 2.jpg)
    ![PFSENSE 2.jpg_thumb](/public/imported_attachments/1/PFSENSE 2.jpg_thumb)


  • Rebel Alliance Global Moderator

    Ok you can get the connection up.. That is good sign, did you assign it a interface?  See for example my settings for interfaces, for the vpn client and the gateway.  Can you post those?

    I would have to look over the instructions, maybe they missed that part, maybe you did?

    I don't like/no why your interface widget says NONE.. Like you created an interface but didn't attach anything to it?  But its not really possible to do that, did you assign it to a physical interface and that is why it show none for the connection?

    But yeah if your interface doesn't have an IP its not going to be possible to route traffic through it.






  • I guess I am totally lost. I have redone all the steps to setup vpn and always end up with the same results as before. I guess this must be beyond my skills. On the status page is sys openvpn running but when ever I go to the main page widget is still missing. My setting match exactly what the guide said to use. So frustrating. I really don't even need all the features of what pfsense provides but I am retired and have nothing but time and really enjoy this stuff. I am just not making any progress. :(


  • Rebel Alliance Global Moderator

    You know what is frustrating is someone going through instructions without understanding them, and thinking that if they do the same thing over and over and over again that the outcome will change.

    How about you post up your config after you have followed the guide.  What interface did you assign to your vpn client connection.  As I posted in my screenshot, this is not going to be exactly like your setup, because its one of my vps for my vpn connection that doesn't use a freaking username/password just uses a cert to auth.

    But the connection is exactly the same.  Its all of couple of minutes to setup.  You have shown that you can get the connection up, so lets move to what is not right/working in the rest of it.. But without seeing your configs.  Your not doing something in the steps, you did something wrong - or quite possible something else is wrong??  But without knowing what you did or didn't do, just guessing and would guess your just doing it wrong..  Maybe the type is too small for you to read from your first post font selection ;)

    You mention another router, is pfsense behind another router?  Or does it have a public IP on its wan.



  • I had it hooked to another router but also tried it hooked directly to my cable modem. I really do appreciate the help and I did look at the photos you posted but it really is beyond my skills I believe. I would be glad to post my configuration but not sure exactly what pages to post. If you can tell  me exactly where to go to get the config I will screen shot it and post it. Sorry I am being such a pain.



  • I finally got it working but unfortunately I have worked on it for 2 days and now have no idea what I did. I just restarted from scratch using the same guide and it now works. PFM I guess. Thanks for your support.


  • Rebel Alliance Global Moderator

    No not PFM.. simple networking..  Again without you posting what you did, its impossible to know what you had missed..  Maybe the guide font was too small and you were missing half of the steps?

    Glad you got it sorted, but how are you retired tech and don't know how to ask a support question and post what you did?  What pages to post - how about the pages you edited via the guide?

    Good luck with your router and vpn that you believe if PFM… that is not a good sign of success when you don't understand how the tech your using and managing works.. Its ok if the users think its PFM, but the person with the hand on the controls needs to have a little more understanding than I clicked on some shit and now its working..