Prevent webui from issuing a cached 301 redirect?



  • Hello,
    I have an issue where if I am configuring the webui and I am browsing by the firewalls IP rather than domain it caches the 301 redirect to https. If I later go onto a different network with the same IP scheme, ie. 192.168.1.1/24 but with a non https webui then on firefox the connection is refused.

    I have created a ticket on bugzilla (https://bugzilla.mozilla.org/show_bug.cgi?id=1274691) but it's not getting an traction, if you have powers over there I'd appreciate it.

    I am looking for a temporary workaround on the pfSense side. Is there any way I can disable the caching of the 301 redirect?

    Thanks
    dpsi


  • Rebel Alliance Developer Netgate

    That's up to the client, but you can disable the port 80 redirect on pfSense, which would also stop that from being a problem. Though you'll have to remember to go to https://x.x.x.x manually and not rely on the redirect in that case.

    The option is under System > Advanced on the Admin Access tab