Openvpn client unable to ping remote internal network



  • Dear All,

    I have configured OpenVpn in pfsense 2.1.5 with Ldap authentication and client connected successfully but i am unable to ping and access remote internal servers and host.

    Global IP of VPN Server          = 185.190.–----          ( this is example only for understanding )
    Remote Internal Network        =  172.16.0.0/24
    Home DSL Internet network    192.168.1.0/24

    I am connected from Home DSL to Pfsense OpenVpn and got IP= 192.168.168.3/24  but i am unable to ping 10.0.0.0/24  network servers and all hosts.

    what is going wrong why i am still unable to communicate as i have allowed in firewall to any any and also disabled firewall in remote internal hosts.



  • Do you have a firewall rule at pfSense on OpenVPN interface which allow access?
    Can you ping the pfSense internal IP?



  • Could you check if your client has a route to the subnet (server side) ?
    You can use the command route print on Windows (just guessing your SO).
    If it hasn't, just check you OpenVPN Configuration (Ipv4 local networks - 10.0.0.0/24)
    If it's correct probably you have to add some rules to the VPN interface on your firewall.



  • I've just reading some docs and notice that if you are using Windows and a non admin user, maybe it wont work:

    f such a user needs to establish an OpenVPN connection (OpenVPN and OpenVPN-GUI are already installed) the connection will be established but the necessary routes are not set.

    https://community.openvpn.net/openvpn/wiki/Nonprivileged



  • Dear All,

    yes i have enabled firewall allow rule on open vpn instance and wan instance but i am unable to communicate with internal host and servers.

    and i am connecting through admin user on local windows 7 operating system.

    please advise what is the issue.

    Regards,



  • So check the routing table on your Windows client as suggested above by trekkiebr.



  • yes after connected through VPN i can ping to pfsense firewall but cannot ping to internal network. routes are ok but missing default gateway.

    it can be due to default gateway missing am i right..? if yes then what is the solution

    Regards,



  • No way to help if we can't see the routing table. Sorry.



  • ok i am configuring again whole setup and will share routing table here soon.



  • Dear All,

    I have troubleshoot the issue with my self and SSL VPN working very perfect now i can access remote internet and internal network through internet with high speed it is working with same speed as i getting in local LAN i did not feel any difference. this is great thing in pfsense i salute to their Developers.

    Regards,
    Noor.


Log in to reply