Completely unable to setup wifi properly.



  • Ive tried so many configurations im just wasting time and need to ask for help now.

    My desired setup is:

    WAN-> Internet
    LAN->eth0
    wifi->ath0

    I just want a simple 4 or so computers on a lan connection that can talk to the wan.
    I have < 10 wireless devices that need internet and well… originally wanted it all on one network but decided against that so keeping them on their own network isolated but able to get internet is fine.

    So my hardware is a pfSense box, it has internet into a dedicated NIC and another NIC going to a switch.  (WAN and LAN connections are made here). It now has a Wireless card also installed into it (for WIFI)

    The Lan switch has a access point wireless router upstairs. Originally it just passed all data to the LAN and left it as that.

    My goal is to have Wifi upstairs, downstairs on one network, and of course any hardwired connections on their own.

    (Everything is 192.168 so im just going to use ... to shorten the text)

    I have setup the wireless as follows:

    Lan with enabled dhcp with ...2.10 as its address with a range from ...2.50 to ...2.99

    I setup the wireless card to have an ip of ...3.10 with a range from ...3.50 to ...3.99
    I enabled DHCP on the wireless as well.
    I then went to bridge and setup LAN/WIFI as a bridge.
    I setup filtering to allow all in and out for wifi (for now)

    At this point any wifi device can connect and get a ...3.50 whatever IP and internet just fine.
    My LAN devices are now getting ...3.50 ip addresses as well and not pulling ...2.50 addresses.

    Have I set it up correctly so far? I thought after what I did that each would have be isolated properly and working. Is there a filter I need to prevent the ...2.50 computer from getting DHCP from the wireless DHCP server?

    So confused at this point and just need some direction.



  • You bridged the two different subnets 192.168.2.0/24 and 192.168.3.0/24. Don't do that.

    Remove the bridge or remove the subnet (IPv4 Configuration Type: None) and DHCP server for WIFI.



  • Thanks, I had to ignore it for a few days but my very first attempt what was you mentioned but I had my proxy setup (which of course didnt work when on a different subnet) so I immediately thought that was wrong.

    After reading your post and doing it properly it all worked within minutes and seems so logical. Cant believe I didnt figure that out. Thanks!


Log in to reply