Log di navigazione utenti in remoto su server syslog



  • ciao a tutti  :) spero possiate darmi una mano….  attualmente i log di navigazioni degli utenti li faccio sparare dal cisco al syslog server (debian con syslog ng) vorrei che fosse  pfsense a fare i log di navigazione .... attualmente funge da ppoe server  con istallato squid e squid guard (che mi restituisce  un errore
    LigthSquid diagnostic.
    Error : report folder '/var/lightsquid/report' not contain any valid data! Please run lightparser.pl (and check 'report' folder content)
    Please check config file !

    ho letto che il proxi fa un bel log della navigazione...... come posso fare???



  • Hai provato a lanciare quel comando da Shell ?
    Sei andato a controllare i log tramite shell per vedere se è tutto ok ?

    Che ver. di pf usi ?

    Attendo nuove.

    Ciaoz.-
    Matteo



  • ho lanciato lightparser.pl  ma non fa niente…...
    uso la 1.2 ... grazie mille delle risposte..
    quali sono i log piu completi per la navigazione??



  • Dipende cosa vuoi sapre.
    Direi che sicuramente squid e squid guard danno ottimi risultati (soprattutto se supportato da un autentificazione) per quanto concerne la navigazione WEB pura.
    Anche pacchetti come come ntop e darkstat danno una mano, questi soprattutto per il traffico non web tipo SIP o Altri protocolli.
    Poi ci sono pacchetti come imspector per tenere sotto controllo i messenger …

    Che altro dire ... per l'errore prova a forzare un reinstallazione dei pacchetti.

    Ciaoz.-
    Matteo



  • credo che il problema sia la configurazione del proxi server….
    come faccio a vedere se effettivamente qualcosa va in cache ???   ORA E SETTATO  cosi:

    trasparent proxy  abilitato
    interfaccia lan  chelta
    Allow users on interface  selezionato
    cache da 50 gb ...
    Enabled logging selezionato

    sembra quasi che non salvi roba nella cache....    come posso fare a controllare ...? di spazio su disco n on mi pare che ne stia accupando.
    come posso testare se funge ???  vorrei che mi facesse da proxi di navigazione !!! grazie matteo per le tue dritte !!!



  • Non ho un pf sotto mano ma se non mi ricordo male in /var/squid/log/cache.log dovreti trovare qualcosa info … e poi in /var/squid/cache/ dovrebbe fisicamente cerare i file di cache (mi pare.)

    Ciaoz.-
    Matteo

    PS: con pf in alcuni casi fai prima a fare un bk e reinstallare tutto (no bk anche i pacchi mi da quasi sempre rogni in fase di reinstallazione !)



  • azzo qui non salva niente…..



  • Vuoi un consiglio … fai un bk. e reinstalli tutto. (o provi a reinstallare solo squid).

    Ciaoz.-



  • risolto:  il proxi era in  ascolto su una altra subnet e non mi cacheva niente… tutto ok!


Log in to reply