- SOLVED- CP redirecting to blank page instead of webserver (CentOS6)



  • I managed to make the redirection work with a standard uri, but when i try to use the IP address of my locally hosted website (192.168.0.20:8080 or adding at the end /joomla), it doesn't get redirected.
    The website its hosted on a machine running on CentOS 6.8, i disabled the firewall (Selinux), i can get to that address if i used it directly of that machine, edited the httpd.conf of Apache to make sure i am allowed to connect (maybe i missed something here, not 100% sure), allowed that IP under the allowed IP on the captive portal, inserted that address on both the html file of the CP and on the redirection's field on the main menu….what else should i do??



  • Anyone?



  • @OOOpf:

    Anyone?

    Hi,

    Answers are easy to come, but probably readers have question about your network setup.
    Your question will only …. produce more question (on our side).
    Can you give a design , Where is this web server ? LAN, OPT1 ? elsewhere ?
    Where is your portal, on OPT1 (where it belongs) or on LAN ?
    Firewall rules ?
    Does the portal works after authenticating - does it let you surf on the net ?



  • Okay i will try to explain.
    The internet came from a modem-router(TP-Link), which connects to the WAN(192.168.0.6) port of an IBM where PFSense it's installed.
    Then on the LAN(192.168.1.1) port of the IBM, there is another wire going to an AirLive machine which provide the wi-fi signal for whoever wants to connect to the wi-fi (the Airlive its set on WISP-Universal Repeater mode).
    Then there is another pc, an Asus, using CentOS 6.8 as O/S, downloaded and installed Bitnami-Joomla and created a website (Bitnami came with its own Apache2, Php).
    So far, this configuration has worked just fine to redirect people on the wifi, to any internet website after they have clicked on a splash page which works just as an authorization button for the captive portal, but whenever i try to redirect people on the Joomla website hosted locally on the Asus, they just land on a white page showing an error, at the beginning was an "Error 403- You don't have permission to access /joomla on this server", then i modified the "htaccess.conf" and the error changed into a "Error 404- Not Found. The requested URL /joomla was not found on this server. "
    I previously edited the "httpd_vhost.conf" to match the same IP of the network interface (192.168.0.33), then i realize that the subnet was not matching the one on the LAN of the other machine, so i modified that to 192.168.1.133, but now i cannot even access my website from the same machine where i have it installed, not even 127.0.0.1 works anymore.
    The Asus connect with a wire to a port of the Airlive.
    Selinux (firewall) it's complitely disabled on CentOs, i also did not create any new rules into the firewall of PFSense, i only allowed the IP of the Asus to pass through, i can't remember under which menu but i can double check if it's really necessary, right now i am trying to find back my lost joomla's site (binding).



  • @OOOpf:

    ….
    Then there is another pc, an Asus, using CentOS 6.8 as O/S, downloaded and installed Bitnami-Joomla and created a website (Bitnami came with its own Apache2, Php).
    ....

    Connected where - to what - IP -etc ?

    edit : on the WAN segment ?



  • [Asus@localhost ~]$ ifconfig
    eth0 Link encap:Ethernet HWaddr 00:11:D8:41:69:5D
    inet addr:192.168.1.133 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::211:d8ff:fe41:695d/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:47918 errors:0 dropped:0 overruns:0 frame:0
    TX packets:67205 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:4590005 (4.3 MiB) TX bytes:17382221 (16.5 MiB)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:81321 errors:0 dropped:0 overruns:0 frame:0
    TX packets:81321 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:37344207 (35.6 MiB) TX bytes:37344207 (35.6 MiB)

    [Asus@localhost ~]$

    in the dns i put 127.0.0.1,8.8.8.8

    Right now i connected the Asus on a port of the Airlive, so that would be the LAN.
    Should be better to put it back on a different address as it was before (192.168.0…)??
    I changed that as i saw that i could not get access to it from the other machines on the LAN (192.168.1...), so i thought that maybe this was the problem, but by doing so, now i can no longer access the same even when i type "localhost" on that machine (before this was possible).



  • @Gertjan:

    Answers are easy to come,

    Really? Where?  It doesn't look that way to me, at all, maybe you can point me out toward the right direction as i didn't really noticed anyone else pushing up to write a reply….
    If anything, adding more details seems to just scare away people somehow.
    However that gave me plenty of time to delete the entire OS, then reinstall and update, rebuild an entire website and now i am back to the original problem where i can't get redirected to the server, hopefully someone with just a little more knowledge will be able to help me with this?



  • Ok i fixed it.
    The problem was depending from the fact that i thought the only firewall was "Selinux" (which i disabled), but there was another default firewall still on, so as soon i realize that, i disabled it and now it works, good job OOPF, thank you for helping yourself…. ;D


Log in to reply