Squid not installable on 2.3.1_1



  • Have fully reinstalled my pf box with 2.3.1_1 and now i can't install squid…

    >>> Installing pfSense-pkg-squid... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    Checking integrity... done (0 conflicting)
    The following 15 package(s) will be affected (of 0 checked):
    
    New packages to be INSTALLED:
    	pfSense-pkg-squid: 0.4.17 [pfSense]
    	squid_radius_auth: 1.10 [pfSense]
    	squid: 3.5.19 [pfSense]
    	krb5: 1.14.1 [pfSense]
    	pkgconf: 0.9.12_1 [pfSense]
    	cyrus-sasl: 2.1.26_12 [pfSense]
    	squidclamav: 6.14 [pfSense]
    	c-icap: 0.4.2,2 [pfSense]
    	c-icap-modules: 0.4.2_1 [pfSense]
    	clamav: 0.99.1 [pfSense]
    	unzoo: 4.4_2 [pfSense]
    	arc: 5.21p [pfSense]
    	lha: 1.14i_6 [pfSense]
    	arj: 3.10.22_4 [pfSense]
    	json-c: 0.12_2 [pfSense]
    
    The process will require 27 MiB more space.
    [1/15] Installing pkgconf-0.9.12_1...
    [1/15] Extracting pkgconf-0.9.12_1: ....... done
    [2/15] Installing unzoo-4.4_2...
    [2/15] Extracting unzoo-4.4_2: .. done
    [3/15] Installing arc-5.21p...
    [3/15] Extracting arc-5.21p: ...... done
    [4/15] Installing lha-1.14i_6...
    [4/15] Extracting lha-1.14i_6: .. done
    [5/15] Installing arj-3.10.22_4...
    [5/15] Extracting arj-3.10.22_4: .......... done
    [6/15] Installing json-c-0.12_2...
    [6/15] Extracting json-c-0.12_2: .......... done
    [7/15] Installing krb5-1.14.1...
    [7/15] Extracting krb5-1.14.1: .......... done
    [8/15] Installing cyrus-sasl-2.1.26_12...
    *** Updated user `cyrus'.
    [8/15] Extracting cyrus-sasl-2.1.26_12: .......... done
    [9/15] Installing c-icap-0.4.2,2...
    ===> Creating users and/or groups.
    Using existing group 'c_icap'.
    Using existing user 'c_icap'.
    [9/15] Extracting c-icap-0.4.2,2: .......... done
    [10/15] Installing clamav-0.99.1...
    ===> Creating users and/or groups.
    Using existing group 'clamav'.
    Using existing group 'mail'.
    Using existing user 'clamav'.
    [10/15] Extracting clamav-0.99.1: .......... done
    [11/15] Installing squid_radius_auth-1.10...
    [11/15] Extracting squid_radius_auth-1.10: .... done
    [12/15] Installing squid-3.5.19...
    ===> Creating users and/or groups.
    Using existing group 'squid'.
    Using existing user 'squid'.
    ===> Pre-installation configuration for squid-3.5.19
    [12/15] Extracting squid-3.5.19: .......... done
    [13/15] Installing squidclamav-6.14...
    [13/15] Extracting squidclamav-6.14: .......... done
    [14/15] Installing c-icap-modules-0.4.2_1...
    [14/15] Extracting c-icap-modules-0.4.2_1: .......... done
    [15/15] Installing pfSense-pkg-squid-0.4.17...
    [15/15] Extracting pfSense-pkg-squid-0.4.17: .......... done
    Saving updated package information...
    done.
    Loading package configuration... done.
    Configuring package components...
    Loading package instructions...
    Custom commands...
    Executing custom_php_install_command()...done.
    Executing custom_php_resync_config_command()...
    

    after that i'm getting fully logged out of the webinterface.
    i'm also getting logged out if i do simple save the config page..

    Update: Seems more like SquidGuard is broken.
    If Squid is installed there is also a menu option for "Proxy filter"
    But it leads to nowhere.
    If I install Squidguard and try to access the config menu then the logout happens every time

    Update: Got it sorted out. Some old config was still there which the webinterface didn't like. deleted it by hand and it works now



  • Can you tell us how did you cleared up those old installation's files and possibly how do you find them out too?
    I resetted to factory default the whole PFSense countless times, it always fail to install once it reach 12/15….

    Update:
                    FIXED, Jimp made it work  :D  https://forum.pfsense.org/index.php?topic=113092.msg631132#msg631132


Log in to reply