Modification du CronTab



  • Netgate SG-4860

    2.3-RELEASE (amd64)
    built on Mon Apr 11 18:28:29 CDT 2016
    FreeBSD 10.3-RELEASE

    Bonjour messieurs,

    Une rapide question à laquelle vous saurez peut-être me répondre :

    J'ai dans mon crontab des restes de Sarg (qui c'est automatiquement désinstallé pendant la migration vers la 2.3)
    C'est lignes me génèrent des erreurs dans mes log, et ça m'ennuie …

    Lorsque je modifie ce Crontab (Loggué en admin, puis "8" pour le shell) la modification se passe bien (à coup de VI : ajout d'un # devant les 3 lignes "sarg")

    Le contrôle semble ok mais après quelques minutes mes modifications sont annulé et je reviens au Crontab d'origine.

    Est-ce que vous sauriez m'expliquer ce qui se passe ?

    Merci de votre aide.

    [2.3-RELEASE][admin@pfSense.prodirect.com]/root: vi /etc/crontab
    SHELL=/bin/sh
    PATH=/etc:/bin:/sbin:/usr/bin:/usr/sbin
    HOME=/var/log
    #minute hour    mday    month  wday    who      command

    pfSense specific crontab entries

    Created: June 9, 2016, 12:02 pm

    1,31    0-5    *      *      *      root    /usr/bin/nice -n20 adjkerntz -a
    1      3      1      *      *      root    /usr/bin/nice -n20 /etc/rc.update_bogons.sh
    */60    *      *      *      *      root    /usr/bin/nice -n20 /usr/local/sbin/expiretable -v -t 3600 sshlockout
    */60    *      *      *      *      root    /usr/bin/nice -n20 /usr/local/sbin/expiretable -v -t 3600 webConfiguratorlockout
    1      1      *      *      *      root    /usr/bin/nice -n20 /etc/rc.dyndns.update
    */60    *      *      *      *      root    /usr/bin/nice -n20 /usr/local/sbin/expiretable -v -t 3600 virusprot
    30      12      *      *      *      root    /usr/bin/nice -n20 /etc/rc.update_urltables
    0      0      *      *      *      root    /usr/bin/nice -n20 /usr/pbi/squidguard-amd64/etc/rc.d/squidGuard_logrotate
    0      */23    *      *      *      root    /usr/local/bin/php –no-header /usr/local/www/sarg.php 0
    0      0      */7    *      *      root    /usr/local/bin/php --no-header /usr/local/www/sarg.php 1
    0      */1    *      *      *      root    /usr/local/bin/php --no-header /usr/local/www/sarg.php 2
    0      0      *      *      *      root    /usr/bin/nice -n20 /usr/local/etc/rc.d/squidGuard_logrotate
    0      0      *      *      *      root    /usr/local/sbin/squid -k rotate -f /usr/local/etc/squid/squid.conf
    15      0      *      *      *      root    /usr/local/pkg/swapstate_check.php
    */60    *      *      *      *      root    /usr/local/bin/perl /usr/local/www/lightsquid/lightparser.pl today
    15      0      *      *      *      root    /usr/local/bin/perl /usr/local/www/lightsquid/lightparser.pl yesterday

    If possible do not add items to this file manually.

    If done so, this file must be terminated with a blank line (e.g. new line)

    Jun 9 11:00:00 php /usr/local/www/sarg.php: The command 'export LC_ALL=C && /usr/local/bin/sarg ' returned exit code '127', the output was '/usr/local/bin/sarg: not found'



  • As-tu regardé si ces options ne sont pas toujours présentent dans la sauvegarde (XML) de la conf pfSense (ce qui signifierait que la désinstallation due au passage en 2.3 ne serait pas complète) ?



  • Effectivement !!!

    Un cat /cf/conf/config.xml m'affiche plein de trace de cochonneries testées par le passé, en particulier Sarg et Squidgard …
    Clairement, la désinstallation c'est  mal passé ...

    Une question complémentaire :

    Si je réalise un "Factory Default" je retombe avec les paramètres de base, mais quid des packages installés ?

    • Les fichiers restent mais la conf saute : je ré-installe le package et tout fonctionne après re-configuration.
    • Les fichiers des packages sont désinstallés. (ou en tout cas, ceux qui sont correctement installés)
    • Les packages ne bougent pas (mais ça n'est pas un Factory Default...

    Bon, en fait j'ai ma réponse ici :

    NOTE: This does not remove any changes made to the file system, it only changes the configuration. Installed package binaries would be left in place.

    https://doc.pfsense.org/index.php/Factory_Defaults

    Merci.



  • Pour clôturer :

    Plutôt qu'un reset usine j'ai  :

    • effacé les binaires non utilisés
    • modifié le XML de sauvegarde
    • modifié le CronTab à la main

    Rebooté le serveur : tout fonctionne sans message d'erreur.

    Squid est op, sauf quand j'active le SSL, il faut que je creuse de ce coté.


Log in to reply