OPENVPN DONT SEE LAN



  • Please I need help…

    Hello Guys, sorry my english.

    My scenario is this:

    OpenVPN: Range 10.0.8.0/24

    Lan: 192.168.0.0/24

    I can connect to OpenVPN, however I can not access any other server on my LAN Network. Ja created a rule "any to any" but without success. Should I create a gateway for this connection? some tutorial ?

    Thank you very much.



  • you need to create the rules on the openvpn as well
    go to firewall / rules / openvpn and create the rules you want " like any /any "



  • The rules were created in openvpn but not working . " Any to Any"



  • Is this a site-to-site or an access server?
    I assume an access server. So the interface or the gateway isn't needed until you are running multiple OpenVPN instances (client or server).

    These few points have to be given for the connection to function:

    • pfSense has to be the default gateway in the LAN you want to access. Otherwise you have to set routes at the LAN hosts or do NAT at pfSense.

    • The traffic has to be permitted by firewall rules. As you said above, that's given.

    • The client has to have set a route to the LAN over the VPN. That is done by entering your LAN network in "Locale Network(s)" box in the server config. But ensure that the route is set correctly at the client. Check this with route or route print command.

    • The LAN subnet must not overlap the clients local network.

    Check these points, please.



  • Post your server1.conf.



  • See the description of the 'server additional config' text box. Add the push route command: push "route 10.0.8.0 255.255.255.0"


  • LAYER 8 Netgate

    Can you ping the LAN IP address? Presumably 192.168.0.1? If so check the local firewalls of the servers you're trying to connect to.

    Are you connecting from a network that is also 192.168.0.0/24? That would be a problem.



  • @Derelict:

    Can you ping the LAN IP address? Presumably 192.168.0.1? If so check the local firewalls of the servers you're trying to connect to.

    Are you connecting from a network that is also 192.168.0.0/24? That would be a problem.

    in your openvpn server configuration page, you either have to rout the traffic through the gateway or assign your lan network there

    192.168.11.0/24
    https://pfsenseIP/vpn_openvpn_server.php?act=edit&id=0



  • The OP hasn't posted his config and responded in 5 days.  I guess we'll assume he figured it out.


Log in to reply