Squid + Clamav



  • I found that on my box, when I turn on Squid with Clamav CPU is running 100% and upload is very slow. I have a 1000/100 link but I get  ~100/10 when Squid and Clamav is on. Without it I can easy get 700/120.

    Any optimizations? Better HW?



  • Yep - turning it off speeds things up abit…



  • Try without Clamav



  • Ive turned Calmav off. No significant change in speed.
    Ive turned SquidGuard off. No significant change in speed.

    Hard disk cache is set to:
    Hard Disk Cache Size = 0
    Hard Disk Cache System = null

    For mem cache:
    Memory Replacement Policy = Heap GDSF
    Maximum Object Size in RAM = 256
    Memory Cache Size = 1024

    I only get 150 down and 5 up. Without Squid proxy I get 700/120.

    I also run pfBlockerNG and Snort.

    pfSense version = 3.2.1 - RELEASE p1 (amd64)

    Any suggestions?



  • Check CPU load when doing the speed test,

    Hard Disk Cache Size = 0
    Hard Disk Cache System = null

    Not sure about this, try setting something small like 256kB and 1mB

    Maximum Object Size in RAM = 256
    Memory Cache Size = 1024

    See this issue for ram cache https://forum.pfsense.org/index.php?topic=96472.0



  • Ive tried many possible configurations regarding HD and Mem caching, even setting sizes to 0 and/or disable totally.

    But whatever I do, I still end up with speeds ~150/5.

    CPU is around 50-100% when I speed test.

    It doesnt seem to apply 1-1 to this issue https://redmine.pfsense.org/issues/6485, because it happens immediately when squid restarts after configurations.