WAN-Gateways nach Reboot down



  • Liebe Forenmitglieder!

    Ich verwende pfSense mittlerweile seit einigen Jahren und konnte bis jetzt alle Probleme und Fragen unter anderem mit Hilfe dieses Forums klären. Herzlichen Dank dafür! Nun stehe ich vor einem Problem, dass ich so leider nicht lösen kann.

    Ich verwende ein PC Engines APU1D4 Board mit zwei Internetanbindungen und einer Gatewaygroup für Loadbalancing und Failover. Diese beiden Anbindungen liegen auf einer gemeinsamen NIC (re2) und sind in verschiedenen VLANs. Das Ganze funktioniert auch wunderbar.
    re0 ist das LAN und re1 das WLAN Netz.

    Leider habe ich seit dem Update auf 2.3.1 einen sehr unangenehmen Effekt: Nach einem Reboot sind zwar alle Interfaces up, jedoch die beiden WAN-Gateways bleiben down.

    Im Systemlog steht dann folgendes:

    
    Jun 14 17:17:19 pfSense kernel: arpresolve: can't allocate llinfo for 192.168.8.254 on re2_vlan2
    Jun 14 17:17:19 pfSense kernel: arpresolve: can't allocate llinfo for 192.168.18.254 on re2_vlan3
    
    

    Sobald ich in den jeweiligen Interfaceeinstellungen (ohne etwas zu ändern) auf "Save" und danach auf "Apply" klicke funktioniert wieder alles.
    Ich habe versucht herauszufinden, was das "Save" in den Interfaceeinstellungen bewirkt und habe die "Config.xml" davor und danach verglichen. Ausser dem Zeitstempel ändert sich jedoch nichts.

    Eine Neuinstallation mit dem aktuellen pfSense Image und Einspielen des Backups brachte keinen Erfolg.
    Alle Interfaces haben eine statische IP und DHCP ist auf den GW Modems deaktiviert.

    Ich habe noch zwei virtuelle pfSense Installationen mit ähnlicher Konfiguration. Dort tritt dieses Problem nicht auf. Der große Unterschied besteht darin, dass dort virtuelle NICs eingerichtet sind und ich keine VLANs benötige.

    Über Ideen und Hinweise zur Lösung dieses Problems wäre ich sehr dankbar!

    Gruß Martin


  • Moderator

    Hallo Martin,

    wie sind denn die beiden WANs auf den VLANs konfiguriert? Sind das DHCP Interfaces? Gibts sonst noch Infos zu den Gateways? Sind die statisch? dynamisch? etc.

    Wenn das Problem nach einem Neustart auftritt, kannst du dann mal auf der Console folgendes ausführen?

    
    ifconfig re2 down
    ifconfig re2 up
    
    

    um das Interface zu "resetten"?

    Grüße



  • Hallo,

    danke für deine Antwort!
    Wie gesagt, sind alle Interfaces static - hier die Ausgabe von ifconfig:

    
    re0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=82098 <vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic,linkstate>ether 00:0d:b9:40:03:b8
            inet6 fe80::20d:b9ff:fe40:3b8%re0 prefixlen 64 scopeid 0x1
            inet 172.16.11.254 netmask 0xffffff00 broadcast 172.16.11.255
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active
    re1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=82098 <vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic,linkstate>ether 00:0d:b9:40:03:b9
            inet6 fe80::20d:b9ff:fe40:3b9%re1 prefixlen 64 scopeid 0x2
            inet 192.168.0.254 netmask 0xffffff00 broadcast 192.168.0.255
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active
    re2: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=82098 <vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic,linkstate>ether 00:0d:b9:40:03:ba
            inet6 fe80::20d:b9ff:fe40:3ba%re2 prefixlen 64 scopeid 0x3
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active
    pflog0: flags=100 <promisc>metric 0 mtu 33160
    pfsync0: flags=0<> metric 0 mtu 1500
            syncpeer: 224.0.0.240 maxupd: 128 defer: on
            syncok: 1
    enc0: flags=0<> metric 0 mtu 1536
            nd6 options=21 <performnud,auto_linklocal>lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
            options=600003 <rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6>inet 127.0.0.1 netmask 0xff000000
            inet6 ::1 prefixlen 128
            inet6 fe80::1%lo0 prefixlen 64 scopeid 0x7
            nd6 options=21 <performnud,auto_linklocal>re2_vlan2: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            ether 00:0d:b9:40:03:ba
            inet6 fe80::20d:b9ff:fe40:3ba%re2_vlan2 prefixlen 64 scopeid 0x8
            inet 192.168.8.1 netmask 0xffffff00 broadcast 192.168.8.255
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active
            vlan: 2 vlanpcp: 0 parent interface: re2
    re2_vlan3: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            ether 00:0d:b9:40:03:ba
            inet6 fe80::20d:b9ff:fe40:3ba%re2_vlan3 prefixlen 64 scopeid 0x9
            inet 192.168.18.1 netmask 0xffffff00 broadcast 192.168.18.255
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active
            vlan: 3 vlanpcp: 0 parent interface: re2</full-duplex></performnud,auto_linklocal></up,broadcast,running,simplex,multicast></full-duplex></performnud,auto_linklocal></up,broadcast,running,simplex,multicast></performnud,auto_linklocal></rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6></up,loopback,running,multicast></performnud,auto_linklocal></promisc></full-duplex></performnud,auto_linklocal></vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic,linkstate></up,broadcast,running,simplex,multicast></full-duplex></performnud,auto_linklocal></vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic,linkstate></up,broadcast,running,simplex,multicast></full-duplex></performnud,auto_linklocal></vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic,linkstate></up,broadcast,running,simplex,multicast> 
    

    Den Interface Reset kann ich heute Abend gerne versuchen (bin gerade remote drauf und würde mich sonst selbst rauskicken) . Bin mir nicht ganz sicher, aber ich glaube, dass habe ich schon mal ohne Erfolg versucht.

    sg Martin


  • Moderator

    Wenn es mit re2 als Träger nicht funktioniert, versuch mal direkt re2_vlan3 und re2_vlan2 zu downen und uppen ;)



  • Hi,

    Danke für den Tipp!

    Die Interfaces gehen laut GUI down und auch wieder up. Die GWs sind jedoch trotzdem nicht erreichbar.

    Ein Ping liefert nur:

    
    PING 192.168.18.254 (192.168.18.254): 56 data bytes
    ping: sendto: Invalid argument
    ...
    
    

    Im Systemlog:

    
    Jun 16 20:01:04 	kernel 		arpresolve: can't allocate llinfo for 192.168.18.254 on re2_vlan3 
    

    Sofort nach einem "Save & Apply" in der GUI der WAN-Interfaces läuft alles wie geschmiert. Keine Ahnung was beim Aktivieren des "Save" oder "Apply" Buttons ausgelöst wird, aber scheinbar wird es bei einem  Reboot nicht ausgelöst.

    Im Systemlog findet sich dann folgendes:

    
    Jun 16 20:09:13 	xinetd 	16906 	Reconfigured: new=0 old=1 dropped=0 (services)
    Jun 16 20:09:13 	xinetd 	16906 	readjusting service 6969-udp
    Jun 16 20:09:13 	xinetd 	16906 	Swapping defaults
    Jun 16 20:09:13 	xinetd 	16906 	Starting reconfiguration
    Jun 16 20:09:12 	php-fpm 	70446 	/interfaces.php: Creating rrd update script
    Jun 16 20:09:12 	check_reload_status 		Reloading filter
    Jun 16 20:09:12 	php-fpm 	70446 	/interfaces.php: Removing static route for monitor 8.8.4.4 and adding a new route through 192.168.18.254
    Jun 16 20:09:12 	php-fpm 	70446 	/interfaces.php: Removing static route for monitor 8.8.8.8 and adding a new route through 192.168.8.254
    Jun 16 20:09:11 	php-fpm 	73673 	/rc.dyndns.update: MONITOR: AndomTecGW is down, omitting from routing group Loadbalance
    Jun 16 20:09:11 	php-fpm 	73673 	/rc.dyndns.update: MONITOR: AndomTecGW is down, omitting from routing group Loadbalance
    Jun 16 20:09:10 	check_reload_status 		updating dyndns opt3
    Jun 16 20:09:10 	php-fpm 	70446 	/interfaces.php: The command '/usr/local/sbin/dhcpd -user dhcpd -group _dhcp -chroot /var/dhcpd -cf /etc/dhcpd.conf -pf /var/run/dhcpd.pid re0 re1' returned exit code '1', the output was 'Internet Systems Consortium DHCP Server 4.3.3-P1 Copyright 2004-2016 Internet Systems Consortium. All rights reserved. For info, please visit https://www.isc.org/software/dhcp/ Config file: /etc/dhcpd.conf Database file: /var/db/dhcpd.leases PID file: /var/run/dhcpd.pid Wrote 0 deleted host decls to leases file. Wrote 0 new dynamic host decls to leases file. Wrote 9 leases to leases file. Listening on BPF/re1/00:0d:b9:40:03:b9/192.168.0.0/24 Sending on BPF/re1/00:0d:b9:40:03:b9/192.168.0.0/24 Listening on BPF/re0/00:0d:b9:40:03:b8/172.16.11.0/24 Sending on BPF/re0/00:0d:b9:40:03:b8/172.16.11.0/24 Can't bind to dhcp address: Address already in use Please make sure there is no other dhcp server running and that there's no entry for dhcp or bootp in /etc/inetd.conf. Also make sure you a
    Jun 16 20:09:09 	php-fpm 	70446 	/interfaces.php: MONITOR: AndomTecGW is down, omitting from routing group Loadbalance
    Jun 16 20:09:09 	php-fpm 	70446 	/interfaces.php: MONITOR: AndomTecGW is down, omitting from routing group Loadbalance
    Jun 16 20:09:07 	check_reload_status 		Restarting ipsec tunnels
    Jun 16 20:09:07 	kernel 		arpresolve: can't allocate llinfo for 192.168.18.254 on re2_vlan3 
    
    

    Spannend ist das "…Can't bind to dhcp address: Address already in use..."

    sg Martin