Bridge does not work



  • Hello,

    I have installed beta 3 on a vmware workstation and it is working flawlessly when firewalling but when I tried setting up a transparent firewall following the instruction on the document I run into the following problem:

    1-  After bridging LAN with WAN I can NOT access the web even when changing my local IP to the match the WAN subnet. ???

    2- Assuming I have managed to setup the enable bridge filter in the advanced page and then bridging Lan with Wan. I still can NOT access the internet. From my linux experience when setting up a bridge; eth0 and eth1 should have no IP address and the bridge is assigned and IP address. But after I setup the bridge with pfSense,I see that lnc1 and lnc0 still have there IP addresses and Bridge0 have no IP address.  It seems that Lan interface is not passing the data over to the Wan intereface.

    I wonder if anyone would be kind enough to guide me through the right path into setting up the bridge.

    All the help is appreciated.

    Al



  • Try this on real hardware.  I have a brdige right now with ATH0 -> WAN which works fine.  I suspect bridging on VMWare is not the best of a test environment.



  • I will give it a shot tomorrow morning and post the results.

    Thanx

    Al



  • I'm have working bridge in real hardware. Bridge work outside of protocol but FBSD can filter IP/TCP/other protocols.

    Hm I test bridge in windows - this big dark hole. Any external firewall can't filter that (only buil-in Windows filters)



  • FWIW, I have yet to get bridging working in VMWare, for whatever reason FreeBSD will not send out the STP packets.  I'm betting something to do with the lnc interface driver, but I haven't looked.

    –Bill



  • Hello Guys,

    I tried it on a hardware and  it partially worked. this what I have noticed;

    1- All the interfaces has no IP address so I had to set the IP for the bridge interface manually.
    2- For testing sake, Out bound/In bound was allowed but the client still did not get the IP address through dhcp so I set it manually and was able to surf.
    3- For unknown reason I was only able to surf for a few minutes then it goes dowan and up again in a matter of 30 seconds more or less.
    4- I could not access the mangement interface from the LAN side  but I was able to access it from the WAN side
    5- When a reboot was made, the LAN , WAN interface has an IP address and the Bridge did not have an IP.

    I will give it a thorough test over the weekend and post the results.
    I guess I should learn about FreeBSD.  ;)

    Al


Log in to reply