Error al instalar packetes(squid) - Error de certificado



  • Alguien me puede ayudar con este error?. Estoy usando la version 2.3.1

    The process will require 27 MiB more space.
    7 MiB to be downloaded.
    Certificate verification failed for /C=GB/ST=Greater Manchester/L=Salford/O=COMODO CA Limited/CN=COMODO RSA Domain Validation Secure Server CA
    34401131016:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed:/builder/pfsense-231/tmp/FreeBSD-src/secure/lib/libssl/../../../crypto/openssl/ssl/s3_clnt.c:1185:
    Certificate verification failed for /C=GB/ST=Greater Manchester/L=Salford/O=COMODO CA Limited/CN=COMODO RSA Domain Validation Secure Server CA
    34401131016:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed:/builder/pfsense-231/tmp/FreeBSD-src/secure/lib/libssl/../../../crypto/openssl/ssl/s3_clnt.c:1185:
    pkg: https://pkg.pfsense.org/pfSense_v2_3_1_amd64-pfSense_v2_3_1/All/pfSense-pkg-squid-0.4.16_2.txz: Authentication error
    ailed



  • I had the same problem.

    type the command:

    cat /usr/local/etc/pkg/repos/pfSense.conf

    the file should read as below:

    FreeBSD: { enabled: no }
    
    pfSense-core: {
      url: "pkg+http://pkg.pfsense.org/pfSense_v2_3_1_i386-core",
      mirror_type: "srv",
      signature_type: "fingerprints",
      fingerprints: "/usr/local/share/pfSense/keys/pkg",
      enabled: yes
    }
    
    pfSense: {
      url: "pkg+http://pkg.pfsense.org/pfSense_v2_3_1_i386-pfSense_v2_3_1",
      mirror_type: "srv",
      signature_type: "fingerprints",
      fingerprints: "/usr/local/share/pfSense/keys/pkg",
      enabled: yes
    }
    
    

    if you find it to have https as below:

    url: "pkg+https://pkg.pfsense.org/pfSense_v2_3_1_i386-core",

    change all ocurrences of https to http editing the file with vi

    save it and try installing the packages again.